<!DOCTYPE html>
<html xmlns="http://www.w3.org/1999/xhtml" lang="en">
<head>
<meta http-equiv="Content-Type" content="text/html; charset=utf-8">
<meta name="viewport" content="width=device-width, initial-scale=1.0" />
<meta property="fb:pages" content="21535456940" />
<meta property="fb:app_id" content="1775326929407925" />
<link rel="shortcut icon" type="image/x-icon" href="/ui/images/icons/Icon-Small@2x.png">
<link rel="apple-touch-icon" href="/ui/images/icons/Icon-60@2x.png" />
<link rel="apple-touch-icon" sizes="58x58" href="/ui/images/icons/Icon-Small@2x.png" />
<link rel="apple-touch-icon" sizes="76x76" href="/ui/images/icons/Icon-76.png" />
<link rel="apple-touch-icon" sizes="152x152" href="/ui/images/icons/Icon-76@2x.png" />
<link rel="apple-touch-icon" sizes="180x180" href="/ui/images/icons/Icon-60@3x.png" />
<link rel="icon" sizes="192x192" href="/ui/images/icons/icon-192x192.png" />
<link rel="stylesheet" href="/dist/css/desktop.min.css?v=91.2021" />
<link rel="canonical" href="https://www.maltatoday.com.mt/news/court_and_police/110075/judge_calls_for_body_of_specialised_inquiring_magistrates_to_be_created">
<meta property="og:site_name" content="MaltaToday.com.mt" />
<meta property="og:url" content="http://www.maltatoday.com.mt/news/court_and_police/110075/judge_calls_for_body_of_specialised_inquiring_magistrates_to_be_created" />
<meta property="og:title" content="Judge calls for body of specialised inquiring magistrates to be created" />
<meta property="og:description" content="Newly-appointed Judge Neville Camilleri says times has come for magistrates specialised only on inquiries because these have increased in number and complexity" />
<meta property="og:type" content="article" />
<meta property="article:publisher" content="https://www.facebook.com/maltatoday" />
<meta property="og:image" content="http://cdn.maltatoday.com.mt/ui_frontend/thumbnail/684/400/judge_neville_camilleri.jpg" />
<meta name="description" content="Newly-appointed Judge Neville Camilleri says times has come for magistrates specialised only on inquiries because these have increased in number and complexity" />
<script type="text/javascript">
        var cdn_url = "//content.maltatoday.com.mt";
    </script>
<title>Judge calls for body of specialised inquiring magistrates to be created</title>

<script async='async' src='https://www.googletagservices.com/tag/js/gpt.js'></script>
<script>
        var googletag = googletag || {};
        googletag.cmd = googletag.cmd || [];
    </script>

<script>
    !function(f,b,e,v,n,t,s)
    {if(f.fbq)return;n=f.fbq=function(){n.callMethod?
    n.callMethod.apply(n,arguments):n.queue.push(arguments)};
    if(!f._fbq)f._fbq=n;n.push=n;n.loaded=!0;n.version='2.0';
    n.queue=[];t=b.createElement(e);t.async=!0;
    t.src=v;s=b.getElementsByTagName(e)[0];
    s.parentNode.insertBefore(t,s)}(window, document,'script',
    'https://connect.facebook.net/en_US/fbevents.js');
    fbq('init', '213704729706889');
    fbq('track', 'PageView');
    </script>
<noscript><img height="1" width="1" style="display:none"
    src="https://www.facebook.com/tr?id=213704729706889&ev=PageView&noscript=1"
    /></noscript>

<script type="text/javascript">
    window._taboola = window._taboola || [];
    _taboola.push({article:'auto'});
    !function (e, f, u, i) {
    if (!document.getElementById(i)){
    e.async = 1;
    e.src = u;
    e.id = i;
    f.parentNode.insertBefore(e, f);
    }
    }(document.createElement('script'),
    document.getElementsByTagName('script')[0],
    '//cdn.taboola.com/libtrc/maltatoday/loader.js',
    'tb_loader_script');
    if(window.performance && typeof window.performance.mark == 'function')
    {window.performance.mark('tbl_ic');}
</script>
</head>
<body class="page-article">
<header>
<div class="zone" data-zone-name="TOPMOST" data-zone-id="TOPMOST"><div class='mt_module' data-module-name='code' data-update-frequency='0' data-module-settings-code='PGRpdiBjbGFzcz0idG9wLXNsYXNoIGRmcC1zbG90IiAKICAgICAgICAgICAgZGF0YS1wYXRoPSIvMTM0NzQ1NDUvTWFsdGFUb2RheV9bY2F0ZWdvcnldX0xlYWRlcmJvYXJkXzcyOHg5MCIKICAgICAgICAgICAgZGF0YS1zaXplPSJbWzcyOCwgOTBdLCBbOTcwLCA5MF0sIFs5NzAsIDI1MF0sIFszMjAsIDEwMF0sIFsxMzIwLCAyNTBdLCBbMTE1MCwgMjUwXV0iPgogICAgICAgIDwvZGl2Pg=='><div class="code_module">
<div class="top-slash dfp-slot" data-path="/13474545/MaltaToday_news_Leaderboard_728x90" data-size="[[728, 90], [970, 90], [970, 250], [320, 100], [1320, 250], [1150, 250]]">
</div></div></div></div> <div class="main-nav">
<div class="main-nav-bg">
<div class="container">
<div class="row">
<div class="col-md-12">
<div class="row">
<div class="menu-bar news">
<div class="logo col-xs-7 col-md-2">
<a href="/"><img class="img-responsive" src="/ui/images/frontend/maltatoday_logo_news.png" alt="maltatoday" /></a>
</div>
<div class="col-xs-5 visible-sm visible-xs text-right">
<div id="more-menu">
menu
<button type="button" class="navbar-toggle" aria-expanded="false">
<span class="sr-only">Toggle navigation</span>
<span class="icon-bar"></span>
<span class="icon-bar"></span>
<span class="icon-bar"></span>
</button>
</div>
</div>
<ul class="main-menu">
<li class="menu-inline-search visible-xs">
<form action="/search-mt/" method="get">
<div class="col-xs-12">
<input type="text" name="q" class="form-control" placeholder="Search maltatoday.." />
</div>
</form>
</li>
<li class="menu_item home has-sub-menu">
<a href="/">
Home </a>
<div class="menu-item-detail-box">
<ul class="sub-menu">
<li><a href="/vacancies">Jobs in Malta</a></li>
<li><a href="/yellow">Yellow</a></li>
<li><a href="/pharmacies">Pharmacies</a></li>
<li><a href="/sponsored">Sponsored</a></li>
<li><a href="/announcements">Announcements</a></li>
<li><a href="/advertising">Advertise</a></li>
<li><a href="/contact">Contact</a></li>
<li><a href="/maltatodaydigitaledition">Digital Edition</a></li>
<li><a href="/subscribe_sms">SMS Alerts</a></li>
</ul>
</div>
</li>
<li class="menu_item news active has-sub-menu">
<a href="/news">
News </a>
<div class="menu-item-detail-box">
<ul class="sub-menu">
<li><a href="/news/national">National</a></li>
<li><a href="/covid19">Covid-19</a></li>
<li><a href="/news/ewropej">#EWROPEJ</a></li>
<li><a href="/news/court_and_police">Court &amp; Police</a></li>
<li><a href="/news/interview">Interview</a></li>
<li><a href="/news/data_and_surveys">Data &amp; Survey</a></li>
<li><a href="/news/skinny">The Skinny</a></li>
<li><a href="/news/xtra">Xtra</a></li>
<li><a href="/news/budget-2021">Budget 2021</a></li>
</ul>
<div class="detail-content-box hidden-sm hidden-xs">
<div class="sub-menu-latest-stories">
<div class="row">
<div class="col-md-6">
<div class="left-section">
<div class="top-story-container">
<div class="photo">
<a href="/news/xtra/110074/watch_marlene_farrugia_inspired_by_her_children_to_propose_abortion_decriminalisation_bill"><img src="//content.maltatoday.com.mt/ui_frontend/thumbnail/400/220/marlene_farrugia_mp.jpg" /></a>
</div>
<div class="title">
<span class="category">Xtra</span> <a href="/news/xtra/110074/watch_marlene_farrugia_inspired_by_her_children_to_propose_abortion_decriminalisation_bill">
[WATCH] ‘My kids changed my mind’: Farrugia will take abortion Bill further</a>
</div>
</div>
</div>
</div>
<div class="col-md-6">
<div class="right-section">
<ul class="stories">
<li class="story">
<div class="story-content">
<div class="image">
<a href="/news/national/110076/jason_micallef_now_dubs_enemies_activists_calling_out_maltas_concrete_paradise"><img src="//content.maltatoday.com.mt/ui_frontend/thumbnail/62/62/claire_bonello.jpg" /></a>
</div>
<div class="text">
<a href="/news/national/110076/jason_micallef_now_dubs_enemies_activists_calling_out_maltas_concrete_paradise">
<span class="category">National</span>
<span class="title"> Jason Micallef now dubs ‘enemies’ activists calling out Malta’s concrete paradise</span>
</a>
</div>
</div>
</li>
<li class="story">
<div class="story-content">
<div class="image">
<a href="/news/court_and_police/110075/judge_calls_for_body_of_specialised_inquiring_magistrates_to_be_created"><img src="//content.maltatoday.com.mt/ui_frontend/thumbnail/62/62/judge_neville_camilleri.jpg" /></a>
</div>
<div class="text">
<a href="/news/court_and_police/110075/judge_calls_for_body_of_specialised_inquiring_magistrates_to_be_created">
<span class="category">Court & Police</span>
<span class="title"> Judge calls for body of specialised inquiring magistrates to be created</span>
</a>
</div>
</div>
</li>
<li class="story">
<div class="story-content">
<div class="image">
<a href="/news/court_and_police/110073/property_owners_awarded_31000_in_case_over_protected_lease"><img src="//content.maltatoday.com.mt/ui_frontend/thumbnail/62/62/court.jpg" /></a>
</div>
<div class="text">
<a href="/news/court_and_police/110073/property_owners_awarded_31000_in_case_over_protected_lease">
<span class="category">Court & Police</span>
<span class="title"> Property owners awarded €31,000 in case over protected lease</span>
</a>
</div>
</div>
</li>
</ul>
<a href="/news">More in News <i class="fa fa-angle-right"></i></a>
</div>
</div>
</div>
</div>
</div>
</div>
</li>
<li class="menu_item business has-sub-menu">
<a href="/business">
Business </a>
<div class="menu-item-detail-box">
<ul class="sub-menu">
<li><a href="/business/business_news">Business News</a></li>
<li><a href="/business/business_comment">Business Comment</a></li>
<li><a href="/business/tech">Tech & Gaming</a></li>
<li><a href="/business/law_report">Law Report</a></li>
</ul>
<div class="detail-content-box hidden-sm hidden-xs">
<div class="sub-menu-latest-stories">
<div class="row">
<div class="col-md-6">
<div class="left-section">
<div class="top-story-container">
<div class="photo">
<a href="/business/business_comment/110072/rs2_software_plc_reaping_the_benefits_of_prior_investments__calamatta_cuschieri"><img src="//content.maltatoday.com.mt/ui_frontend/thumbnail/400/220/rs2-software-plc.jpeg" /></a>
</div>
<div class="title">
<span class="category">Business Comment</span> <a href="/business/business_comment/110072/rs2_software_plc_reaping_the_benefits_of_prior_investments__calamatta_cuschieri">
RS2 Software plc reaping the benefits of prior investments | Calamatta Cuschieri</a>
</div>
</div>
</div>
</div>
<div class="col-md-6">
<div class="right-section">
<ul class="stories">
<li class="story">
<div class="story-content">
<div class="image">
<a href="/business/business_news/109834/from_scrutiny_to_example_setting_hefty_investment_in_the_fiau_ushers_in_a_paradigm_shift"><img src="//content.maltatoday.com.mt/ui_frontend/thumbnail/62/62/dsc07254.jpg" /></a>
</div>
<div class="text">
<a href="/business/business_news/109834/from_scrutiny_to_example_setting_hefty_investment_in_the_fiau_ushers_in_a_paradigm_shift">
<span class="category">Business News</span>
<span class="title"> From scrutiny to example setting: hefty investment in the FIAU ushers in a paradigm shift</span>
</a>
</div>
</div>
</li>
<li class="story">
<div class="story-content">
<div class="image">
<a href="/business/business_comment/110051/india_records_q1_gdp_growth__calamatta_cuschieri"><img src="//content.maltatoday.com.mt/ui_frontend/thumbnail/62/62/for-india-economic-growth-is-no-substitute-for-grand-strategy.jpeg" /></a>
</div>
<div class="text">
<a href="/business/business_comment/110051/india_records_q1_gdp_growth__calamatta_cuschieri">
<span class="category">Business Comment</span>
<span class="title"> India records Q1 GDP growth | Calamatta Cuschieri</span>
</a>
</div>
</div>
</li>
<li class="story">
<div class="story-content">
<div class="image">
<a href="/business/business_news/109833/transformational_overhaul_takes_the_fiau_out_of_the_red_and_into_the_black"><img src="//content.maltatoday.com.mt/ui_frontend/thumbnail/62/62/alfred_zammit_kenneth_farrugia_fiau.png" /></a>
</div>
<div class="text">
<a href="/business/business_news/109833/transformational_overhaul_takes_the_fiau_out_of_the_red_and_into_the_black">
<span class="category">Business News</span>
<span class="title"> Transformational overhaul takes the FIAU out of the red and into the black</span>
</a>
</div>
</div>
</li>
</ul>
<a href="/business">More in Business <i class="fa fa-angle-right"></i></a>
</div>
</div>
</div>
</div>
</div>
</div>
</li>
<li class="menu_item sports has-sub-menu">
<a href="/sports">
Sports </a>
<div class="menu-item-detail-box">
<ul class="sub-menu">
<li><a href="/worldcup2018">World Cup 2018</a></li>
<li><a href="/sports/football">Football</a></li>
<li><a href="/sports/rugby">Rugby</a></li>
<li><a href="/sports/motorsports">Motor Sports</a></li>
<li><a href="/sports/boxing">Boxing</a></li>
<li><a href="/sports/tennis">Tennis</a></li>
<li><a href="/sports/cricket">Cricket</a></li>
</ul>
<div class="detail-content-box hidden-sm hidden-xs">
<div class="sub-menu-latest-stories">
<div class="row">
<div class="col-md-6">
<div class="left-section">
<div class="top-story-container">
<div class="photo">
<a href="/sports/football/110013/experienced_football_talentspotter_for_mediterranean_college_of_sport"><img src="//content.maltatoday.com.mt/ui_frontend/thumbnail/400/220/sports_college_pic.jpeg" /></a>
</div>
<div class="title">
<span class="category">Football</span> <a href="/sports/football/110013/experienced_football_talentspotter_for_mediterranean_college_of_sport">
Experienced football talent-spotter for Mediterranean College of Sport</a>
</div>
</div>
</div>
</div>
<div class="col-md-6">
<div class="right-section">
<ul class="stories">
<li class="story">
<div class="story-content">
<div class="image">
<a href="/sports/football/109988/mfa_fines_attard_fc_deducts_points_after_bribery_case"><img src="//content.maltatoday.com.mt/ui_frontend/thumbnail/62/62/red_card_football.png" /></a>
</div>
<div class="text">
<a href="/sports/football/109988/mfa_fines_attard_fc_deducts_points_after_bribery_case">
<span class="category">Football</span>
<span class="title"> MFA fines Attard FC, deducts points after bribery case</span>
</a>
</div>
</div>
</li>
<li class="story">
<div class="story-content">
<div class="image">
<a href="/sports/football/109908/preparing_for_an_allenglish_champions_league_final_with_meridianbet"><img src="//content.maltatoday.com.mt/ui_frontend/thumbnail/62/62/man-city-chelsea-684x454.jpg" /></a>
</div>
<div class="text">
<a href="/sports/football/109908/preparing_for_an_allenglish_champions_league_final_with_meridianbet">
<span class="category">Football</span>
<span class="title"> Preparing for an all-English Champions League final with Meridianbet</span>
</a>
</div>
</div>
</li>
<li class="story">
<div class="story-content">
<div class="image">
<a href="/sports/othersports/109881/olympian_neil_agius_to_swim_from_tunisia_to_sicily_in_second_wave_of_change_challenge"><img src="//content.maltatoday.com.mt/ui_frontend/thumbnail/62/62/neil_agius.jpeg" /></a>
</div>
<div class="text">
<a href="/sports/othersports/109881/olympian_neil_agius_to_swim_from_tunisia_to_sicily_in_second_wave_of_change_challenge">
<span class="category">Other Sports</span>
<span class="title"> Olympian Neil Agius to swim from Tunisia to Sicily in second Wave of Change challenge</span>
</a>
</div>
</div>
</li>
</ul>
<a href="/sports">More in Sports <i class="fa fa-angle-right"></i></a>
</div>
</div>
</div>
</div>
</div>
</div>
</li>
<li class="menu_item arts has-sub-menu">
<a href="/arts">
Arts </a>
<div class="menu-item-detail-box">
<ul class="sub-menu">
<li><a href="/arts/art">Art</a></li>
<li><a href="/arts/books">Books</a></li>
<li><a href="/arts/entertainment">Entertainment</a></li>
<li><a href="/arts/music">Music</a></li>
<li><a href="/arts/theatre_and_dance">Theatre &amp; Dance</a></li>
<li><a href="/arts/film">Film</a></li>
<li><a href="/arts/cultural_diary">Cultural Diary</a></li>
<li><a href="/arts/kwartaktieb/">KwartaKtieb</a></li>
<li><a href="/arts/valletta_2018">Valletta 2018</a></li>
</ul>
<div class="detail-content-box hidden-sm hidden-xs">
<div class="sub-menu-latest-stories">
<div class="row">
<div class="col-md-6">
<div class="left-section">
<div class="top-story-container">
<div class="photo">
<a href="/arts/music/110062/enya_magris_electro_pop_single_feelin_fits_the_seasons_vibe"><img src="//content.maltatoday.com.mt/ui_frontend/thumbnail/400/220/enya_magri_3.jpg" /></a>
</div>
<div class="title">
<span class="category">Music</span> <a href="/arts/music/110062/enya_magris_electro_pop_single_feelin_fits_the_seasons_vibe">
Enya Magri’s electro pop single Feelin’ fits the season’s vibe</a>
</div>
</div>
</div>
</div>
<div class="col-md-6">
<div class="right-section">
<ul class="stories">
<li class="story">
<div class="story-content">
<div class="image">
<a href="/lifestyle/question_and_answer/109831/joon_be_kind_everyone_is_going_through_their_own_struggles"><img src="//content.maltatoday.com.mt/ui_frontend/thumbnail/62/62/screen_shot_2021-05-24_at_11.16.02.png" /></a>
</div>
<div class="text">
<a href="/lifestyle/question_and_answer/109831/joon_be_kind_everyone_is_going_through_their_own_struggles">
<span class="category">Music</span>
<span class="title"> JOON: ‘Be kind, everyone is going through their own struggles’</span>
</a>
</div>
</div>
</li>
<li class="story">
<div class="story-content">
<div class="image">
<a href="/arts/music/109795/destiny_finishes_seventh_eurovision"><img src="//content.maltatoday.com.mt/ui_frontend/thumbnail/62/62/destiny_waiting_for_votes.jpg" /></a>
</div>
<div class="text">
<a href="/arts/music/109795/destiny_finishes_seventh_eurovision">
<span class="category">Music</span>
<span class="title"> Eurovision 2021: Italy wins, Destiny finishes 7th</span>
</a>
</div>
</div>
</li>
<li class="story">
<div class="story-content">
<div class="image">
<a href="/arts/music/109781/eurovision_2021_nachos_beer_and_impressing_your_guests"><img src="//content.maltatoday.com.mt/ui_frontend/thumbnail/62/62/destiny_rehearsal_ebu_andres_putting.jpg" /></a>
</div>
<div class="text">
<a href="/arts/music/109781/eurovision_2021_nachos_beer_and_impressing_your_guests">
<span class="category">Music</span>
<span class="title"> Eurovision 2021: Nachos, beer and impressing your guests</span>
</a>
</div>
</div>
</li>
</ul>
<a href="/arts">More in Arts <i class="fa fa-angle-right"></i></a>
</div>
</div>
</div>
</div>
</div>
</div>
</li>
<li class="menu_item comment has-sub-menu">
<a href="/comment">
Comment </a>
<div class="menu-item-detail-box">
<ul class="sub-menu">
<li><a href="/comment/blogs">Blogs</a></li>
<li><a href="/comment/editorial">Editorial</a></li>
<li><a href="/comment/letters">Letters</a></li>
<li><a href="/comment/cartoons">Cartoons</a></li>
</ul>
<div class="detail-content-box hidden-sm hidden-xs">
<div class="sub-menu-latest-stories">
<div class="row">
<div class="col-md-6">
<div class="left-section">
<div class="top-story-container">
<div class="photo">
<a href="/comment/blogs/109969/why_malta_needs_a_humane_prison_policy_for_a_better_society"><img src="//content.maltatoday.com.mt/ui_frontend/thumbnail/400/220/6005_1.png" /></a>
</div>
<div class="title">
<span class="category">Blogs</span> <a href="/comment/blogs/109969/why_malta_needs_a_humane_prison_policy_for_a_better_society">
Why Malta needs a humane prison policy for a better society</a>
</div>
</div>
</div>
</div>
<div class="col-md-6">
<div class="right-section">
<ul class="stories">
<li class="story">
<div class="story-content">
<div class="image">
<a href="/comment/blogs/110017/maybe_theres_something_psychologically_missing_from_maltese_politics_too"><img src="//content.maltatoday.com.mt/ui_frontend/thumbnail/62/62/opinion_raphael_vassallo.png" /></a>
</div>
<div class="text">
<a href="/comment/blogs/110017/maybe_theres_something_psychologically_missing_from_maltese_politics_too">
<span class="category">Blogs</span>
<span class="title"> Maybe there’s ‘something psychologically missing’ from Maltese politics, too...</span>
</a>
</div>
</div>
</li>
<li class="story">
<div class="story-content">
<div class="image">
<a href="/comment/blogs/109968/the_maltese_climate_emergency_is_a_joke"><img src="//content.maltatoday.com.mt/ui_frontend/thumbnail/62/62/7_climate.jpg" /></a>
</div>
<div class="text">
<a href="/comment/blogs/109968/the_maltese_climate_emergency_is_a_joke">
<span class="category">Blogs</span>
<span class="title"> The Maltese climate emergency is a joke</span>
</a>
</div>
</div>
</li>
<li class="story">
<div class="story-content">
<div class="image">
<a href="/comment/blogs/109970/criminalising_abortion_creates_chilling_effect_on_healthcare_providers"><img src="//content.maltatoday.com.mt/ui_frontend/thumbnail/62/62/2_14_abortion.jpg" /></a>
</div>
<div class="text">
<a href="/comment/blogs/109970/criminalising_abortion_creates_chilling_effect_on_healthcare_providers">
<span class="category">Blogs</span>
<span class="title"> Criminalising abortion creates ‘chilling effect’ on healthcare providers</span>
</a>
</div>
</div>
</li>
</ul>
<a href="/comment">More in Comment <i class="fa fa-angle-right"></i></a>
</div>
</div>
</div>
</div>
</div>
</div>
</li>
<li class="menu_item videos">
<a href="/videos/">
Video </a>
</li>
<li class="menu_item archives">
<a href="http://archive.maltatoday.com.mt" target="_blank">
Archives </a>
</li>
<li class="menu_item sponsored visible-xs visible-sm">
<a href="/sponsored">
Sponsored </a>
</li>
<li class="menu_item gourmet-today has-sub-menu">
<a href="/gourmet/">
<img src="/ui/images/frontend/maltatoday_logo_gourmet.png" alt="Gourmet" />
</a>
<div class="menu-item-detail-box">
<ul class="sub-menu">
<li><a href="/gourmet/recipes/">Recipes</a></li>
<li><a href="/gourmet/restaurants/">Restaurants</a></li>
<li><a href="/gourmet/gourmet_today/">Magazines</a></li>
<li><a href="/gourmet/gourmettv/">TV</a></li>
<li><a href="/gourmet/videos/">Videos</a></li>
</ul>
</div>
</li>
<li class="menu_item deal-today visible-xs visible-sm">
<a href="/yellow">
Yellow </a>
</li>
<li class="menu_item login visible-xs visible-sm login-menu-item">
<a href="/maltatodaydigitaledition/">
Digital Paper </a>
</li>
</ul>
<div class="menu-icons hidden-xs hidden-sm">
<div class="menu-icons-icon search-icon" onclick="$(this).addClass('active').find('input').focus()">
<span class="fa fa-search"></span>
<div class="searchbox">
<form action="/search-mt/" method="get">
<input type="text" name="q" placeholder="Search" onblur="$(this).parents('.search-icon').removeClass('active');" onkeyup="if (event.keyCode === 27) { $(this).blur(); }" />
<button type="submit">
<i class="fa fa-search search_now"></i>
</button>
</form>
</div>
</div>
<div class="menu-icons-icon login-icon digital-paper">
<a href="/maltatodaydigitaledition/" class="btn btn-red">Digital Paper</a>
<div id="login-sub-menu">
<a target="_blank" href="https://maltatoday.uberflip.com/t/73329-mediatoday-newspapers-latest-editions">My Account</a>
<a href="/maltatodaydigitaledition/">Subscribe</a>
<a href="/subscribe_sms/">SMS Alerts</a>
<a href="/maltatodaydigitaledition/#previous">Previous Editions</a>
</div>
</div>
</div>
</div>
</div>
<div id="small-menu-placeholder" class="row visible-xs visible-sm news">
<div id="small-menu">
<a href="/">home</a>
<a href="/news">news</a>
<a class="highlight" href="/maltatodaydigitaledition">Digital Paper</a>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
<div class="sub-nav">
<div class="container">
<ul class="hidden-xs outer-sub-menu sub-menu news">
<li><a href="/news/national">National</a></li>
<li><a href="/covid19">Covid-19</a></li>
<li><a href="/news/ewropej">#EWROPEJ</a></li>
<li><a href="/news/court_and_police">Court &amp; Police</a></li>
<li><a href="/news/interview">Interview</a></li>
<li><a href="/news/data_and_surveys">Data &amp; Survey</a></li>
<li><a href="/news/skinny">The Skinny</a></li>
<li><a href="/news/xtra">Xtra</a></li>
<li><a href="/news/budget-2021">Budget 2021</a></li>
</ul>
</div>
</div>
</header>
<div id="content">
<section>
<div class="container">
<div class="row">
<div class="col-lg-12 col-md-12">
<div class="zone" data-zone-name="Top" data-zone-id="top"><div class='mt_module' data-module-name='article_breadcrumb' data-update-frequency='0'><ul class="breadcrumb">
<li class="breadcrumb-item news"><a href="/news/">News</a></li>
<li class="breadcrumb-item news"><a href="/news/court_and_police/">Court & Police</a></li>
</ul></div><div class='mt_module' data-module-name='article_heading' data-update-frequency='0'><div class="article-heading">
<div class="row">
<div class="col-md-12">
<h1>Judge calls for body of specialised inquiring magistrates to be created</h1>
<h2><p>Newly-appointed Judge Neville Camilleri says times has come for magistrates specialised only on inquiries because these have increased in number and complexity</p></h2>
</div>
</div>
</div>
</div></div> </div>
</div>
<div class="row">
<div class="col-lg-2 col-md-2">
<div class="zone" data-zone-name="Left" data-zone-id="left"><div class='mt_module' data-module-name='article_meta' data-update-frequency='0'><div class="article-meta">
<div class="author-photos"> <img src="//content.maltatoday.com.mt/ui_frontend/profile_thumbnail/300/300/matthew_agius_1519462042.jpg" alt="matthew_agius" />
</div>
<div class="date-text">
<span class="date">4 June 2021, 3:27pm</span>
<br />by <span class="name">Matthew Agius </span>
</div>
</div></div><div class='mt_module' data-module-name='addthis' data-update-frequency='0'> <script type="text/javascript" src="//s7.addthis.com/js/300/addthis_widget.js#pubid=ra-5a7023510fcc04af"></script>
</div></div> </div>
<div class="col-lg-8 col-md-8">
<div class="zone" data-zone-name="Main" data-zone-id="content"><div class='mt_module' data-module-name='article_cover' data-update-frequency='0'><div class="full-article article-cover">
<div class="photo_collection_cover article-cover-media single-cover" data-slick='{"slidesToShow": 1, "slidesToScroll": 1}'>
<div class="media-item show ">
<div class="cover-photo" title="Judge Neville Camilleri" style="background-image: url('//content.maltatoday.com.mt/ui/images/photos/judge_neville_camilleri.jpg')">
<img src="//content.maltatoday.com.mt/ui_frontend/thumbnail/684/0/judge_neville_camilleri.jpg" alt="Judge Neville Camilleri" />
</div>
<div class="caption">
<div class="inner">Judge Neville Camilleri</div>
</div>
</div>
</div>
</div></div><div class='mt_module' data-module-name='small_share_buttons' data-update-frequency='0'><div class="row">
<div class="col-md-6">
</div>
<div class="col-md-6">
<div class="small_share_buttons text-right">
<a class="addthis_button_facebook_like" fb:like:layout="button_count" style="position:relative; top: 4px; padding: 0px; right: -10px;"></a>
<script type="text/javascript">var addthis_config = {"data_track_addressbar":true};</script>
<script type="text/javascript" src="//s7.addthis.com/js/300/addthis_widget.js#pubid=seekopia"></script>
<a class="twitter" href="https://twitter.com/share?url=https://www.maltatoday.com.mt/news/court_and_police/110075/judge_calls_for_body_of_specialised_inquiring_magistrates_to_be_created&text=Judge calls for body of specialised inquiring magistrates to be created" target="_blank">
<i class="fa fa-twitter"></i> TWEET
</a>
<a class="facebook" href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.maltatoday.com.mt%2Fnews%2Fcourt_and_police%2F110075%2Fjudge_calls_for_body_of_specialised_inquiring_magistrates_to_be_created" target="_blank">
<i class="fa fa-facebook"></i> SHARE
</a>
</div>
</div>
</div></div><div class='mt_module' data-module-name='full_article' data-update-frequency='0'><div class="full-article">
<div class="content content-news"> <div class="dfp-slot" data-path="/13474545/MaltaToday_news_Inline_300x250" data-size="[[300, 250]]" style="float:right; margin:8px 0 8px 25px">
</div>
<p>Judge Neville Camilleri has called for specialised inquiring magistrates to be appointed alongside magistrates who deal with the normal caseload in his first court sitting.
</p><p>Camilleri, 47, had served for 10 years as a magistrate before being selected as a judge of the superior courts.
</p><p>In his inaugural sitting this afternoon, Camilleri promised that his ethos would not change from his days in the lower courts: &ldquo;Be on time and be prepared.&rdquo;
</p><p>Coping with the ever-increasing workload in court was not easy for court staff, lawyers and also for the judiciary, he said.
</p><p>Despite the addition of new faces to the bench, he appealed to the authorities to appoint more members of the judiciary. Staff problems also need to be addressed, he said.
</p><p>Pointing out that the role of magistrates had changed a lot over the years, he said the time had come for magistrates specialised only on magisterial inquiries to be appointed as these inquiries have increased in number and complexity. It was not easy to keep up with the work of judging and investigating, he said.
</p><p>Lawyer Louis De Gabriele, as president of Chamber of Advocates, wished the new judge well in his post and praised his seriousness and courage. Camilleri had always carried out his responsibilities with integrity and there was a consensus amongst the legal profession on this point.
</p><p>De Gabriele urged a rethink of the court&rsquo;s systems from the ground up. &ldquo;We must ask ourselves if what we see around ourselves is still relevant. We have systems which were excellent when the volume of cases was less, but which now must be updated.&rdquo;
</p><p>The legal profession must restructure itself in the light of external challenges, added the veteran lawyer.
</p><p>De Gabriele expressed solidarity with his Gozitan colleagues, who are on strike due to administrative problems at the Gozo courts. He pointed out that &ldquo;two years ago in this hall, there was a call for addressing the issues in Gozo. These have not been met&rdquo;.</p><p></p> </div>
</div></div><div class='mt_module' data-module-name='code' data-update-frequency='0' data-module-settings-code='PGRpdiBjbGFzcz0ic3BsaXQtYWR2ZXJ0IGRmcC1zbG90IiAKICAgICAgICAgICAgZGF0YS1wYXRoPSIvMTM0NzQ1NDUvTWFsdGFUb2RheV9bY2F0ZWdvcnldX0FydGljbGVMZWFkZXJib2FyZCIKICAgICAgICAgICAgZGF0YS1zaXplPSJbWzcyOCwgOTBdLCBbMzIwLCA1MF1dIj4KICAgICAgICA8L2Rpdj4='><div class="code_module">
<div class="split-advert dfp-slot" data-path="/13474545/MaltaToday_news_ArticleLeaderboard" data-size="[[728, 90], [320, 50]]">
</div></div></div><div class='mt_module' data-module-name='article_author_bios' data-update-frequency='0'> <div class="article-author-bio">
<div class="bio">
<div class="row">
<div class="col-xs-1">
<div class="image">
<img src="//content.maltatoday.com.mt/ui_frontend/profile_thumbnail/40/40/matthew_agius_1517918791_zoom.jpg" />
</div>
</div>
<div class="col-xs-11">
<div class="text">
Matthew Agius is Senior Reporter on Law and Court Affairs at MaltaToday.
He is also a Leg... </div>
<div class="socialmedia">
<span class="link readmore"> <a href="/author/matthew_agius/">More from Matthew Agius</a></span>
<span class="link twitter"><i class="fa fa-twitter twitter"></i> <a href="https://twitter.com/mattagius" target="_blank">Matthew on Twitter</a></span> </div>
</div>
</div>
</div>
</div>
</div><div class='mt_module' data-module-name='comments' data-update-frequency='0'><div id="taboola-below-article-thumbnails"></div>
<script type="text/javascript">window._taboola = window._taboola || [];_taboola.push({mode: 'thumbnails-a',container: 'taboola-below-article-thumbnails',placement: 'Below Article Thumbnails',target_type: 'mix'});</script>
<div id="disqus_thread"></div>
<script type="text/javascript">

    var disqus_config = function () {

        
            // The generated payload which authenticates users with Disqus
            this.page.remote_auth_s3 = 'eyJpZCI6InVzZXJfIiwidXNlcm5hbWUiOiIgIiwiZW1haWwiOm51bGx9 beaf319d1241ad27f93ae9b99124df07e2178fd6 1622820415';
            this.page.api_key = 'KKsrhxY6LSXy3nbzit54YG6MHLFaxrOJ42o6hFm3W1sUtwGMqjEzqyO5HBu9sxTW';

                this.page.identifier = 'article_110075';
        this.sso = {
            name:   "MaltaToday.com.mt",
            button:  "https://www.maltatoday.com.mt/ui/images/frontend/disqus_button.png",
            icon:     "https://www.maltatoday.com.mt/ui/images/icons/Icon-Small@2x.png",
            url:      "https://www.maltatoday.com.mt/ui_frontend/login/",
            logout:  "https://www.maltatoday.com.mt/ui_frontend/disquslogout/",
            width:   "867",
            height:  "152"
        };
    };

    var disqus_shortname = 'malta-today';

    (function() {
        var dsq = document.createElement('script'); dsq.type = 'text/javascript'; dsq.async = true;
        dsq.src = '//' + disqus_shortname + '.disqus.com/embed.js';
        (document.getElementsByTagName('head')[0] || document.getElementsByTagName('body')[0]).appendChild(dsq);
    })();
</script>
<div id="taboola-below-article-thumbnails1"></div>
<script type="text/javascript">window._taboola = window._taboola || [];_taboola.push({mode: 'thumbnails-a1',container: 'taboola-below-article-thumbnails1',placement: 'Below Article Thumbnails1',target_type: 'mix'});</script></div></div> </div>
<div class="col-lg-2 col-md-2">
<div class="zone" data-zone-name="Right" data-zone-id="right"></div> </div>
</div>
<div class="row">
<div class="col-lg-12 col-md-12">
<div class="zone" data-zone-name="Bottom" data-zone-id="bottom"></div> </div>
</div>
</div>
</section></div>
<footer class="hidden-xs">
<div class="container">
<div class="row">
<div class="col-xs-12 col-sm-6">
<div class="footer-logo">
<a href="/"> <img src="/ui/images/frontend/maltatoday_logo_white.png" /></a>
</div>
</div>
<div class="col-xs-12 col-sm-6">
<div class="social-icons">
<div class="icon facebook">
<a href="//facebook.com/maltatoday" target="_blank"><i class="fa fa-facebook"></i></a>
</div>
<div class="icon twitter">
<a href="//twitter.com/maltatoday" target="_blank"><i class="fa fa-twitter"></i></a>
</div>
<div class="icon instagram">
<a href="//www.instagram.com/maltatoday" target="_blank"><i class="fa fa-instagram"></i></a>
</div>
<div class="icon youtube">
<a href="//www.youtube.com/user/ReporterMediaToday" target="_blank"><i class="fa fa-youtube"></i></a>
</div>
<div class="icon googleplus">
<a href="//plus.google.com/113527506098764625850" target="_blank"><i class="fa fa-google-plus"></i></a>
</div>
</div>
</div>
</div>
<div class="row">
<div class="col-xs-12">
<ul class="bottom-nav">
<li><a href="/about-us/">About Us</a></li>
<li><a href="/advertising/">Advertise</a> </li>
<li><a href="/contact/">Contact</a> </li>
<li><a href="/maltatodaydigitaledition/">Digital Edition</a></li>
<li><a href="/subscribe_sms/">SMS Alerts</a></li>
</ul>
<ul class="bottom-links">
<li><a href="/terms-and-conditions/">Terms and Conditions</a> </li>
<li><a href="/privacy-policy/">Privacy Policy</a> </li>
<li><a href="/privacy-policy/">Cookie Policy</a> </li>
<li><a target="_blank" href="http://archive.maltatoday.com.mt/archive.html">Archives</a></li>
</ul>
</div>
</div>
<div class="row">
<div class="col-md-12">
<div class="copyright">
MediaToday is an independent media house based in Malta. Copyright © MediaToday Co. Ltd, Vjal ir-Rihan, San Gwann SGN 9016, Malta, Europe <br />
Reproduction of material from this website without written permission is strictly prohibited.
</div>
</div>
</div>
</div>
</footer>
<div class="floating-bar" data-cookie-name="cookie_notice">
<div class="container">
<div class="message-inner">
<a href="https://www.maltatoday.com.mt/privacy-policy/" target="_blank" class="set-close">
By using this site, you agree to our Privacy Policy including the use of cookies to enhance your experience. </a>
<button class="message-close-btn set-close">
<i class="fa fa-times close"></i>
</button>
</div>
</div>
</div>
<script type="text/javascript" src="//imasdk.googleapis.com/js/sdkloader/ima3.js"></script>
<script type="text/javascript" src="/dist/js/packages.min.js?v=91.2021"></script>
<script>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</script>

<script type="text/javascript">
_atrk_opts = { atrk_acct:"io5hj1aAkN00oK", domain:"maltatoday.com.mt",dynamic: true};
(function() { var as = document.createElement('script'); as.type = 'text/javascript'; as.async = true; as.src = "https://certify-js.alexametrics.com/atrk.js"; var s = document.getElementsByTagName('script')[0];s.parentNode.insertBefore(as, s); })();
</script>
<noscript><img src="https://certify.alexametrics.com/atrk.gif?account=io5hj1aAkN00oK" style="display:none" height="1" width="1" alt="" /></noscript>

<script type="text/javascript" src="/dist/js/app.min.js?v=91.2021"></script>
<script type="text/javascript">
    var _gaq = _gaq || [];
    _gaq.push(['_setAccount', 'UA-16977049-1']);
    _gaq.push(['_trackPageview']);

    (function () {
        var ga = document.createElement('script'); ga.type =
            'text/javascript'; ga.async = true;
        ga.src = ('https:' == document.location.protocol ? 'https://ssl' :
            'http://www') + '.google-analytics.com/ga.js';
        var s = document.getElementsByTagName('script')[0];
        s.parentNode.insertBefore(ga, s);
    })();
</script>
<script id="dsq-count-scr" src="//malta-today.disqus.com/count.js" async></script>
<script type="text/javascript">
    window._taboola = window._taboola || [];
    _taboola.push({flush: true});
</script>
</body>
</html>
