<!DOCTYPE html>
<html xmlns="http://www.w3.org/1999/xhtml" lang="en">
<head>
<meta http-equiv="Content-Type" content="text/html; charset=utf-8">
<meta name="viewport" content="width=device-width, initial-scale=1.0" />
<meta property="fb:pages" content="21535456940" />
<meta property="fb:app_id" content="1775326929407925" />
<link rel="shortcut icon" type="image/x-icon" href="/ui/images/icons/Icon-Small@2x.png">
<link rel="apple-touch-icon" href="/ui/images/icons/Icon-60@2x.png" />
<link rel="apple-touch-icon" sizes="58x58" href="/ui/images/icons/Icon-Small@2x.png" />
<link rel="apple-touch-icon" sizes="76x76" href="/ui/images/icons/Icon-76.png" />
<link rel="apple-touch-icon" sizes="152x152" href="/ui/images/icons/Icon-76@2x.png" />
<link rel="apple-touch-icon" sizes="180x180" href="/ui/images/icons/Icon-60@3x.png" />
<link rel="icon" sizes="192x192" href="/ui/images/icons/icon-192x192.png" />
<link rel="stylesheet" href="/dist/css/desktop.min.css?v=1.9991" />
<link rel="canonical" href="https://www.maltatoday.com.mt/news/national/106794/robert_abela_aims_for_full_economic_recovery_by_may_this_year">
<meta property="og:site_name" content="MaltaToday.com.mt" />
<meta property="og:url" content="http://www.maltatoday.com.mt/news/national/106794/robert_abela_aims_for_full_economic_recovery_by_may_this_year" />
<meta property="og:title" content="Robert Abela aims for full economic recovery by May this year" />
<meta property="og:description" content="Reflecting on the year behind us, the PM is aiming for a full economic recovery within the next five months, with business as usual starting as of May this year" />
<meta property="og:type" content="article" />
<meta property="article:publisher" content="https://www.facebook.com/maltatoday" />
<meta property="og:image" content="http://cdn.maltatoday.com.mt/ui_frontend/thumbnail/684/400/robert_abela_budget_2021.jpg" />
<meta name="description" content="Reflecting on the year behind us, the PM is aiming for a full economic recovery within the next five months, with business as usual starting as of May this year" />
<script type="text/javascript">
        var cdn_url = "//content.maltatoday.com.mt";
    </script>
<title>Robert Abela aims for full economic recovery by May this year</title>

<script async='async' src='https://www.googletagservices.com/tag/js/gpt.js'></script>
<script>
        var googletag = googletag || {};
        googletag.cmd = googletag.cmd || [];
    </script>

<script>
    !function(f,b,e,v,n,t,s)
    {if(f.fbq)return;n=f.fbq=function(){n.callMethod?
    n.callMethod.apply(n,arguments):n.queue.push(arguments)};
    if(!f._fbq)f._fbq=n;n.push=n;n.loaded=!0;n.version='2.0';
    n.queue=[];t=b.createElement(e);t.async=!0;
    t.src=v;s=b.getElementsByTagName(e)[0];
    s.parentNode.insertBefore(t,s)}(window, document,'script',
    'https://connect.facebook.net/en_US/fbevents.js');
    fbq('init', '213704729706889');
    fbq('track', 'PageView');
    </script>
<noscript><img height="1" width="1" style="display:none"
    src="https://www.facebook.com/tr?id=213704729706889&ev=PageView&noscript=1"
    /></noscript>

<script type="text/javascript">
    window._taboola = window._taboola || [];
    _taboola.push({article:'auto'});
    !function (e, f, u, i) {
    if (!document.getElementById(i)){
    e.async = 1;
    e.src = u;
    e.id = i;
    f.parentNode.insertBefore(e, f);
    }
    }(document.createElement('script'),
    document.getElementsByTagName('script')[0],
    '//cdn.taboola.com/libtrc/maltatoday/loader.js',
    'tb_loader_script');
    if(window.performance && typeof window.performance.mark == 'function')
    {window.performance.mark('tbl_ic');}
</script>
</head>
<body class="page-article">
<header>
<div class="zone" data-zone-name="TOPMOST" data-zone-id="TOPMOST"><div class='mt_module' data-module-name='code' data-update-frequency='0' data-module-settings-code='PGRpdiBjbGFzcz0idG9wLXNsYXNoIGRmcC1zbG90IiAKICAgICAgICAgICAgZGF0YS1wYXRoPSIvMTM0NzQ1NDUvTWFsdGFUb2RheV9bY2F0ZWdvcnldX0xlYWRlcmJvYXJkXzcyOHg5MCIKICAgICAgICAgICAgZGF0YS1zaXplPSJbWzcyOCwgOTBdLCBbOTcwLCA5MF0sIFs5NzAsIDI1MF0sIFszMjAsIDEwMF0sIFsxMzIwLCAyNTBdLCBbMTE1MCwgMjUwXV0iPgogICAgICAgIDwvZGl2Pg=='><div class="code_module">
<div class="top-slash dfp-slot" data-path="/13474545/MaltaToday_news_Leaderboard_728x90" data-size="[[728, 90], [970, 90], [970, 250], [320, 100], [1320, 250], [1150, 250]]">
</div></div></div></div> <div class="main-nav">
<div class="main-nav-bg">
<div class="container">
<div class="row">
<div class="col-md-12">
<div class="row">
<div class="menu-bar news">
<div class="logo col-xs-7 col-md-2">
<a href="/"><img class="img-responsive" src="/ui/images/frontend/maltatoday_logo_news.png" alt="maltatoday" /></a>
</div>
<div class="col-xs-5 visible-sm visible-xs text-right">
<div id="more-menu">
menu
<button type="button" class="navbar-toggle" aria-expanded="false">
<span class="sr-only">Toggle navigation</span>
<span class="icon-bar"></span>
<span class="icon-bar"></span>
<span class="icon-bar"></span>
</button>
</div>
</div>
<ul class="main-menu">
<li class="menu-inline-search visible-xs">
<form action="/search-mt/" method="get">
<div class="col-xs-12">
<input type="text" name="q" class="form-control" placeholder="Search maltatoday.." />
</div>
</form>
</li>
<li class="menu_item home has-sub-menu">
<a href="/">
Home </a>
<div class="menu-item-detail-box">
<ul class="sub-menu">
<li><a href="http://frontpages.maltatoday.com.mt/">Today's Newspapers</a></li>
<li><a href="/vacancies">Jobs in Malta</a></li>
<li><a href="/yellow">Yellow</a></li>
<li><a href="/pharmacies">Pharmacies</a></li>
<li><a href="/sponsored">Sponsored</a></li>
<li><a href="/announcements">Announcements</a></li>
<li><a href="/advertising">Advertise</a></li>
<li><a href="/contact">Contact</a></li>
<li><a href="/maltatodaydigitaledition">Digital Edition</a></li>
<li><a href="/subscribe_sms">SMS Alerts</a></li>
</ul>
</div>
</li>
<li class="menu_item news active has-sub-menu">
<a href="/news">
News </a>
<div class="menu-item-detail-box">
<ul class="sub-menu">
<li><a href="/news/national">National</a></li>
<li><a href="/news/europe">Europe</a></li>
<li><a href="/news/world">World</a></li>
<li><a href="/news/court_and_police">Court &amp; Police</a></li>
<li><a href="/news/interview">Interview</a></li>
<li><a href="/news/data_and_surveys">Data &amp; Survey</a></li>
<li><a href="/news/skinny">The Skinny</a></li>
<li><a href="/news/xtra">Xtra</a></li>
<li><a href="/news/budget-2021">Budget 2021</a></li>
</ul>
<div class="detail-content-box hidden-sm hidden-xs">
<div class="sub-menu-latest-stories">
<div class="row">
<div class="col-md-6">
<div class="left-section">
<div class="top-story-container">
<div class="photo">
<a href="/news/national/106800/pn_lambasts_outdated_energy_policy_after_government_fails_to_secure_eu_funds_for_gas_pipeline"><img src="//content.maltatoday.com.mt/ui_frontend/thumbnail/400/220/gas-pipeline-is-still-a-proposal-to-europe-and-was-made-this-year-opm.png" /></a>
</div>
<div class="title">
<span class="category">National</span> <a href="/news/national/106800/pn_lambasts_outdated_energy_policy_after_government_fails_to_secure_eu_funds_for_gas_pipeline">
PN lambasts 'outdated' energy policy after government fails to secure EU funds for gas pipeline</a>
</div>
</div>
</div>
</div>
<div class="col-md-6">
<div class="right-section">
<ul class="stories">
<li class="story">
<div class="story-content">
<div class="image">
<a href="/news/court_and_police/106799/motorcyclist_grievously_injured_in_gozo_traffic_accident"><img src="//content.maltatoday.com.mt/ui_frontend/thumbnail/62/62/dsc_8704.jpg" /></a>
</div>
<div class="text">
<a href="/news/court_and_police/106799/motorcyclist_grievously_injured_in_gozo_traffic_accident">
<span class="category">Court & Police</span>
<span class="title"> Motorcyclist grievously injured in Gozo traffic accident</span>
</a>
</div>
</div>
</li>
<li class="story">
<div class="story-content">
<div class="image">
<a href="/news/national/106798/bernard_grech_warns_against_backtobusiness_approach"><img src="//content.maltatoday.com.mt/ui_frontend/thumbnail/62/62/20202211_pn_photo_bg_dc_2.jpg" /></a>
</div>
<div class="text">
<a href="/news/national/106798/bernard_grech_warns_against_backtobusiness_approach">
<span class="category">National</span>
<span class="title"> Bernard Grech warns against back-to-business approach if people end up left behind</span>
</a>
</div>
</div>
</li>
<li class="story">
<div class="story-content">
<div class="image">
<a href="/news/court_and_police/106797/man_released_on_bail_over_abbar_stabbing"><img src="//content.maltatoday.com.mt/ui_frontend/thumbnail/62/62/6_courts.jpg" /></a>
</div>
<div class="text">
<a href="/news/court_and_police/106797/man_released_on_bail_over_abbar_stabbing">
<span class="category">Court & Police</span>
<span class="title"> Man released on bail over Żabbar knife attack</span>
</a>
</div>
</div>
</li>
</ul>
<a href="/news">More in News <i class="fa fa-angle-right"></i></a>
</div>
</div>
</div>
</div>
</div>
</div>
</li>
<li class="menu_item business has-sub-menu">
<a href="/business">
Business </a>
<div class="menu-item-detail-box">
<ul class="sub-menu">
 <li><a href="/business/business_news">Business News</a></li>
<li><a href="/business/business_comment">Business Comment</a></li>
<li><a href="/business/technology">Technology</a></li>
<li><a href="/business/law_report">Law Report</a></li>
</ul>
<div class="detail-content-box hidden-sm hidden-xs">
<div class="sub-menu-latest-stories">
<div class="row">
<div class="col-md-6">
<div class="left-section">
<div class="top-story-container">
<div class="photo">
<a href="/business/business_comment/106745/fintech_ceo_rati_tchelidze_on_why_europe_is_dominating_the_fintech_sector"><img src="//content.maltatoday.com.mt/ui_frontend/thumbnail/400/220/rati_tchelidze.jpg" /></a>
</div>
<div class="title">
<span class="category">Business Comment</span> <a href="/business/business_comment/106745/fintech_ceo_rati_tchelidze_on_why_europe_is_dominating_the_fintech_sector">
FinTech CEO Rati Tchelidze on why Europe is dominating the Fintech sector</a>
</div>
</div>
</div>
</div>
<div class="col-md-6">
<div class="right-section">
<ul class="stories">
<li class="story">
<div class="story-content">
<div class="image">
<a href="/business/law_report/106691/evaluation_of_appeal_is_required_to_determine_which_declarations_are_res_judicata_"><img src="//content.maltatoday.com.mt/ui_frontend/thumbnail/62/62/2_law_report.png" /></a>
</div>
<div class="text">
<a href="/business/law_report/106691/evaluation_of_appeal_is_required_to_determine_which_declarations_are_res_judicata_">
<span class="category">Law Report</span>
<span class="title"> Evaluation of appeal is required to determine which declarations are res judicata</span>
</a>
</div>
</div>
</li>
<li class="story">
<div class="story-content">
<div class="image">
<a href="/business/law_report/106628/constitutional_proceedings_can_be_initiated_if_theres_no_effective_and_adequate_remedy"><img src="//content.maltatoday.com.mt/ui_frontend/thumbnail/62/62/2_law_report.png" /></a>
</div>
<div class="text">
<a href="/business/law_report/106628/constitutional_proceedings_can_be_initiated_if_theres_no_effective_and_adequate_remedy">
<span class="category">Law Report</span>
<span class="title"> Constitutional proceedings can be initiated if there’s no effective and adequate remedy</span>
</a>
</div>
</div>
</li>
<li class="story">
<div class="story-content">
<div class="image">
<a href="/business/business_comment/106673/global_stocks_end_mixed__calamatta_cuschieri"><img src="//content.maltatoday.com.mt/ui_frontend/thumbnail/62/62/74_picture1.png" /></a>
</div>
<div class="text">
<a href="/business/business_comment/106673/global_stocks_end_mixed__calamatta_cuschieri">
<span class="category">Business Comment</span>
<span class="title"> Global stocks end mixed | Calamatta Cuschieri</span>
</a>
</div>
</div>
</li>
</ul>
<a href="/business">More in Business <i class="fa fa-angle-right"></i></a>
</div>
</div>
</div>
</div>
</div>
</div>
</li>
<li class="menu_item sports has-sub-menu">
<a href="/sports">
Sports </a>
<div class="menu-item-detail-box">
<ul class="sub-menu">
<li><a href="/worldcup2018">World Cup 2018</a></li>
<li><a href="/sports/football">Football</a></li>
<li><a href="/sports/rugby">Rugby</a></li>
<li><a href="/sports/motorsports">Motor Sports</a></li>
<li><a href="/sports/boxing">Boxing</a></li>
<li><a href="/sports/tennis">Tennis</a></li>
<li><a href="/sports/cricket">Cricket</a></li>
</ul>
<div class="detail-content-box hidden-sm hidden-xs">
<div class="sub-menu-latest-stories">
<div class="row">
<div class="col-md-6">
<div class="left-section">
<div class="top-story-container">
<div class="photo">
<a href="/sports/football/106775/devis_mangias_era_heralds_new_hope_for_malta_national_football_team"><img src="//content.maltatoday.com.mt/ui_frontend/thumbnail/400/220/malta_football_team.png" /></a>
</div>
<div class="title">
<span class="category">Football</span> <a href="/sports/football/106775/devis_mangias_era_heralds_new_hope_for_malta_national_football_team">
Devis Mangia’s era heralds new hope for Malta national football team</a>
</div>
</div>
</div>
</div>
<div class="col-md-6">
<div class="right-section">
<ul class="stories">
<li class="story">
<div class="story-content">
<div class="image">
<a href="/sports/football/106552/premier_league_stakes_are_high_aston_villa_burnley_match"><img src="//content.maltatoday.com.mt/ui_frontend/thumbnail/62/62/aston-villa-burnley-684x455.jpg" /></a>
</div>
<div class="text">
<a href="/sports/football/106552/premier_league_stakes_are_high_aston_villa_burnley_match">
<span class="category">Football</span>
<span class="title"> Premier League | Stakes are high for Villa-Burnley encounter</span>
</a>
</div>
</div>
</li>
<li class="story">
<div class="story-content">
<div class="image">
<a href="/sports/football/106455/europes_big_five_leagues_offer_thrilling_weekend_clashes"><img src="//content.maltatoday.com.mt/ui_frontend/thumbnail/62/62/football_leagues_big_five.jpg" /></a>
</div>
<div class="text">
<a href="/sports/football/106455/europes_big_five_leagues_offer_thrilling_weekend_clashes">
<span class="category">Football</span>
<span class="title"> Europe’s big five leagues offer thrilling weekend clashes</span>
</a>
</div>
</div>
</li>
<li class="story">
<div class="story-content">
<div class="image">
<a href="/sports/football/106422/midtable_battle_looms_as_stakes_climb_even_higher"><img src="//content.maltatoday.com.mt/ui_frontend/thumbnail/62/62/crvena-zvezda-olympiacos-684x455.jpg" /></a>
</div>
<div class="text">
<a href="/sports/football/106422/midtable_battle_looms_as_stakes_climb_even_higher">
<span class="category">Football</span>
<span class="title"> Mid-table battle looms as stakes climb even higher</span>
</a>
</div>
</div>
</li>
</ul>
<a href="/sports">More in Sports <i class="fa fa-angle-right"></i></a>
</div>
</div>
</div>
</div>
</div>
</div>
</li>
<li class="menu_item arts has-sub-menu">
<a href="/arts">
Arts </a>
<div class="menu-item-detail-box">
<ul class="sub-menu">
<li><a href="/arts/art">Art</a></li>
<li><a href="/arts/books">Books</a></li>
<li><a href="/arts/entertainment">Entertainment</a></li>
<li><a href="/arts/music">Music</a></li>
<li><a href="/arts/theatre_and_dance">Theatre &amp; Dance</a></li>
<li><a href="/arts/film">Film</a></li>
<li><a href="/arts/cultural_diary">Cultural Diary</a></li>
<li><a href="/arts/kwartaktieb/">KwartaKtieb</a></li>
<li><a href="/arts/valletta_2018">Valletta 2018</a></li>
</ul>
<div class="detail-content-box hidden-sm hidden-xs">
<div class="sub-menu-latest-stories">
<div class="row">
<div class="col-md-6">
<div class="left-section">
<div class="top-story-container">
<div class="photo">
<a href="/arts/books/106717/watch_the_national_book_prize_winners_performed_by_maltas_best_actors"><img src="//content.maltatoday.com.mt/ui_frontend/thumbnail/400/220/national_book_prize_2020.png" /></a>
</div>
<div class="title">
<span class="category">Books</span> <a href="/arts/books/106717/watch_the_national_book_prize_winners_performed_by_maltas_best_actors">
[WATCH] The National Book Prize winners performed by Malta’s best actors</a>
</div>
</div>
</div>
</div>
<div class="col-md-6">
<div class="right-section">
<ul class="stories">
<li class="story">
<div class="story-content">
<div class="image">
<a href="/arts/books/106588/national_book_prize_2020_trevor_zahra_conferred_lifetime_achievement_award"><img src="//content.maltatoday.com.mt/ui_frontend/thumbnail/62/62/national_book_prize.jpg" /></a>
</div>
<div class="text">
<a href="/arts/books/106588/national_book_prize_2020_trevor_zahra_conferred_lifetime_achievement_award">
<span class="category">Books</span>
<span class="title"> National Book Prize 2020: Trevor Zahra conferred lifetime achievement award</span>
</a>
</div>
</div>
</li>
<li class="story">
<div class="story-content">
<div class="image">
<a href="/arts/film/106543/malta_film_luzzu_to_compete_at_the_sundance_film_festival_in_the_us"><img src="//content.maltatoday.com.mt/ui_frontend/thumbnail/62/62/luzzu_sundance.jpg" /></a>
</div>
<div class="text">
<a href="/arts/film/106543/malta_film_luzzu_to_compete_at_the_sundance_film_festival_in_the_us">
<span class="category">Film</span>
<span class="title"> Malta film Luzzu to compete at the Sundance Film Festival in the US</span>
</a>
</div>
</div>
</li>
<li class="story">
<div class="story-content">
<div class="image">
<a href="/arts/art/106511/emerging_artist_anna_calleja_plans_first_solo_show_for_march_2021"><img src="//content.maltatoday.com.mt/ui_frontend/thumbnail/62/62/_e9a0020.jpg" /></a>
</div>
<div class="text">
<a href="/arts/art/106511/emerging_artist_anna_calleja_plans_first_solo_show_for_march_2021">
<span class="category">Art</span>
<span class="title"> Emerging artist Anna Calleja plans first solo show for March 2021</span>
</a>
</div>
</div>
</li>
</ul>
<a href="/arts">More in Arts <i class="fa fa-angle-right"></i></a>
</div>
</div>
</div>
</div>
</div>
</div>
</li>
<li class="menu_item comment has-sub-menu">
<a href="/comment">
Comment </a>
<div class="menu-item-detail-box">
<ul class="sub-menu">
<li><a href="/comment/blogs">Blogs</a></li>
<li><a href="/comment/editorial">Editorial</a></li>
<li><a href="/comment/letters">Letters</a></li>
<li><a href="/comment/cartoons">Cartoons</a></li>
</ul>
<div class="detail-content-box hidden-sm hidden-xs">
<div class="sub-menu-latest-stories">
<div class="row">
<div class="col-md-6">
<div class="left-section">
<div class="top-story-container">
<div class="photo">
<a href="/comment/editorial/106793/there_is_no_vaccine_for_corruption_"><img src="//content.maltatoday.com.mt/ui_frontend/thumbnail/400/220/maltatoday_editorial.png" /></a>
</div>
<div class="title">
<span class="category">Editorial</span> <a href="/comment/editorial/106793/there_is_no_vaccine_for_corruption_">
There is no ‘vaccine’ for corruption</a>
</div>
</div>
</div>
</div>
<div class="col-md-6">
<div class="right-section">
<ul class="stories">
<li class="story">
<div class="story-content">
<div class="image">
<a href="/comment/blogs/106772/2020_a_lot_of_positive_work_overshadowed_by_covid19__josianne_cutajar"><img src="//content.maltatoday.com.mt/ui_frontend/thumbnail/62/62/josianne_cutajar_2.jpg" /></a>
</div>
<div class="text">
<a href="/comment/blogs/106772/2020_a_lot_of_positive_work_overshadowed_by_covid19__josianne_cutajar">
<span class="category">Blogs</span>
<span class="title"> 2020: A lot of positive work overshadowed by COVID-19 | Josianne Cutajar</span>
</a>
</div>
</div>
</li>
<li class="story">
<div class="story-content">
<div class="image">
<a href="/comment/blogs/106767/raising_a_glass_to_our_children"><img src="//content.maltatoday.com.mt/ui_frontend/thumbnail/62/62/ela_rainbow.jpg" /></a>
</div>
<div class="text">
<a href="/comment/blogs/106767/raising_a_glass_to_our_children">
<span class="category">Blogs</span>
<span class="title"> Raising a glass to our children</span>
</a>
</div>
</div>
</li>
<li class="story">
<div class="story-content">
<div class="image">
<a href="/comment/blogs/106698/carbonneutrality_no_small_feat_aaron_farrugia"><img src="//content.maltatoday.com.mt/ui_frontend/thumbnail/62/62/20180123pht92311_original.jpg" /></a>
</div>
<div class="text">
<a href="/comment/blogs/106698/carbonneutrality_no_small_feat_aaron_farrugia">
<span class="category">Blogs</span>
<span class="title"> Carbon-neutrality: no small feat | Aaron Farrugia</span>
</a>
</div>
</div>
</li>
</ul>
<a href="/comment">More in Comment <i class="fa fa-angle-right"></i></a>
</div>
</div>
</div>
</div>
</div>
</div>
</li>
<li class="menu_item videos">
<a href="/videos/">
Video </a>
</li>
<li class="menu_item archives">
<a href="http://archive.maltatoday.com.mt" target="_blank">
Archives </a>
</li>
<li class="menu_item sponsored visible-xs visible-sm">
<a href="/sponsored">
Sponsored </a>
</li>
<li class="menu_item gourmet-today has-sub-menu">
<a href="/gourmet/">
<img src="/ui/images/frontend/maltatoday_logo_gourmet.png" alt="Gourmet" />
</a>
<div class="menu-item-detail-box">
<ul class="sub-menu">
<li><a href="/gourmet/recipes/">Recipes</a></li>
<li><a href="/gourmet/restaurants/">Restaurants</a></li>
 <li><a href="/gourmet/gourmet_today/">Magazines</a></li>
<li><a href="/gourmet/gourmettv/">TV</a></li>
<li><a href="/gourmet/videos/">Videos</a></li>
</ul>
</div>
</li>
<li class="menu_item frontpages visible-xs">
<a href="http://frontpages.maltatoday.com.mt">
Frontpages </a>
</li>
<li class="menu_item deal-today visible-xs visible-sm">
<a href="/yellow">
Yellow </a>
</li>
<li class="menu_item login visible-xs visible-sm login-menu-item">
<a href="/maltatodaydigitaledition/">
Login to Digital Edition </a>
</li>
</ul>
<div class="menu-icons hidden-xs hidden-sm">
<div class="menu-icons-icon search-icon" onclick="$(this).addClass('active').find('input').focus()">
<span class="fa fa-search"></span>
<div class="searchbox">
<form action="/search-mt/" method="get">
<input type="text" name="q" placeholder="Search" onblur="$(this).parents('.search-icon').removeClass('active');" onkeyup="if (event.keyCode === 27) { $(this).blur(); }" />
<button type="submit">
<i class="fa fa-search search_now"></i>
</button>
</form>
</div>
</div>
<div class="menu-icons-icon login-icon">
<a href="/maltatodaydigitaledition/" class="btn btn-red">Login</a>
</div>
</div>
</div>
</div>
<div id="small-menu-placeholder" class="row visible-xs visible-sm news">
<div id="small-menu">
<a href="/">home</a>
<a href="/news">news</a>
<a class="highlight" href="/maltatodaydigitaledition">login</a>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
<div class="sub-nav">
<div class="container">
<ul class="hidden-xs outer-sub-menu sub-menu news">
<li><a href="/news/national">National</a></li>
<li><a href="/news/europe">Europe</a></li>
<li><a href="/news/world">World</a></li>
<li><a href="/news/court_and_police">Court &amp; Police</a></li>
<li><a href="/news/interview">Interview</a></li>
<li><a href="/news/data_and_surveys">Data &amp; Survey</a></li>
<li><a href="/news/skinny">The Skinny</a></li>
<li><a href="/news/xtra">Xtra</a></li>
<li><a href="/news/budget-2021">Budget 2021</a></li>
</ul>
</div>
</div>
</header>
<div id="content">
<section>
<div class="container">
<div class="row">
<div class="col-lg-12 col-md-12">
<div class="zone" data-zone-name="Top" data-zone-id="top"><div class='mt_module' data-module-name='article_breadcrumb' data-update-frequency='0'><ul class="breadcrumb">
<li class="breadcrumb-item news"><a href="/news/">News</a></li>
<li class="breadcrumb-item news"><a href="/news/national/">National</a></li>
</ul></div><div class='mt_module' data-module-name='article_heading' data-update-frequency='0'><div class="article-heading">
<div class="row">
<div class="col-md-12">
<h1>Robert Abela aims for full economic recovery by May this year</h1>
<h2><p>Reflecting on the year behind us, the PM is aiming for a full economic recovery within the next five months, with business as usual starting as of May this year</p></h2>
</div>
</div>
</div>
</div></div> </div>
</div>
<div class="row">
<div class="col-lg-2 col-md-2">
<div class="zone" data-zone-name="Left" data-zone-id="left"><div class='mt_module' data-module-name='article_meta' data-update-frequency='0'><div class="article-meta">
<div class="author-photos"> <img src="//content.maltatoday.com.mt/ui_frontend/profile_thumbnail/300/300/nicole_meilak_1598949851.jpg" alt="nicole_meilak" />
</div>
<div class="date-text">
<span class="date">3 January 2021, 11:41am</span>
<br />by <span class="name">Nicole Meilak </span>
</div>
</div></div><div class='mt_module' data-module-name='addthis' data-update-frequency='0'> <script type="text/javascript" src="//s7.addthis.com/js/300/addthis_widget.js#pubid=ra-5a7023510fcc04af"></script>
</div></div> </div>
<div class="col-lg-8 col-md-8">
<div class="zone" data-zone-name="Main" data-zone-id="content"><div class='mt_module' data-module-name='article_cover' data-update-frequency='0'><div class="full-article article-cover">
<div class="photo_collection_cover article-cover-media single-cover" data-slick='{"slidesToShow": 1, "slidesToScroll": 1}'>
<div class="media-item show ">
<div class="cover-photo" title="" style="background-image: url('//content.maltatoday.com.mt/ui/images/photos/robert_abela_budget_2021.jpg')">
<img src="//content.maltatoday.com.mt/ui_frontend/thumbnail/684/0/robert_abela_budget_2021.jpg" alt="" />
</div>
</div>
</div>
</div></div><div class='mt_module' data-module-name='small_share_buttons' data-update-frequency='0'><div class="row">
<div class="col-md-6">
</div>
<div class="col-md-6">
<div class="small_share_buttons text-right">
<a class="addthis_button_facebook_like" fb:like:layout="button_count" style="position:relative; top: 4px; padding: 0px; right: -10px;"></a>
<script type="text/javascript">var addthis_config = {"data_track_addressbar":true};</script>
<script type="text/javascript" src="//s7.addthis.com/js/300/addthis_widget.js#pubid=seekopia"></script>
<a class="twitter" href="https://twitter.com/share?url=https://www.maltatoday.com.mt/news/national/106794/robert_abela_aims_for_full_economic_recovery_by_may_this_year&text=Robert Abela aims for full economic recovery by May this year" target="_blank">
<i class="fa fa-twitter"></i> TWEET
</a>
<a class="facebook" href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.maltatoday.com.mt%2Fnews%2Fnational%2F106794%2Frobert_abela_aims_for_full_economic_recovery_by_may_this_year" target="_blank">
<i class="fa fa-facebook"></i> SHARE
</a>
</div>
</div>
</div></div><div class='mt_module' data-module-name='full_article' data-update-frequency='0'><div class="full-article">
<div class="content content-news"> <div class="dfp-slot" data-path="/13474545/MaltaToday_news_Inline_300x250" data-size="[[300, 250]]" style="float:right; margin:8px 0 8px 25px">
</div>
<p>A week after the COVID-19 vaccine roll-out began in Malta, Prime Minister Robert Abela hopes to have a recovering economy by March this year, and complete business-as-usual in May.
</p><p>In today&#39;s radio appearance on the Labour party-owned media station, Abela said that&nbsp;for the country to go back to business within the next five months it&#39;s crucial for people receive the COVID-19 jab as soon as possible.
</p><p>&quot;By next may we want an economy that&#39;s back to business - but we also want a country with working institutions and strong governance,&quot; he said.&nbsp;
</p><p>Earlier in the interview Abela remarked that the current administration implemented all recommendations put forward by Moneyval and Greco reports, and made substantial changes within the police force, including the appointment of&nbsp;a new police commissioner and attorney general.
</p><p>&quot;Next May I want a recovered&nbsp;economy complemented by a country with strong institutions, good governance, functioning law enforcement institutions, and authorities that work as they should,&quot; Abela stated.
</p><p><strong>Immigration challenges</strong>
</p><p>The PM reflected on the decisions taken over the year on the handling of immigration arrivals, taking particular aim at a <a href="https://www.maltatoday.com.mt/news/court_and_police/105719/52_asylum_seekers_take_government_to_court_over_delayed_rescue_and_pushback">court application</a> funded by the NGO Repubblika which saw a group of 52 asylum-seekers take Abela, Home Affairs Minister Byron Camilleri, and AFM brigadier Jeffrey Curmi to court after allegedly being pushed back to Libya while in Malta&#39;s Search-And-Rescue&nbsp;zone.
</p><p>&quot;While some were trying to put the soldiers in jail, we not only registered success in controlling immigration but we also made a collective agreement for our soldiers,&quot; he said, in reference to a <a href="https://www.maltatoday.com.mt/news/national/105967/soldiers_get_pay_boost_in_82_million_collective_agreement">sectoral agreement</a> between government and the General Worker&#39;s Union which now sees soldiers receiving higher allowances and compensation for all work carried out above a stipulated 40 hours per week.&nbsp;
</p><p>&quot;We currently have an immigration problem, but we are working to curb the arrival of more boats. This is a problem that you have to work on all year round, not just in summer,&quot; he said.
</p><p>&nbsp;</p><p></p> </div>
</div></div><div class='mt_module' data-module-name='code' data-update-frequency='0' data-module-settings-code='PGRpdiBjbGFzcz0ic3BsaXQtYWR2ZXJ0IGRmcC1zbG90IiAKICAgICAgICAgICAgZGF0YS1wYXRoPSIvMTM0NzQ1NDUvTWFsdGFUb2RheV9bY2F0ZWdvcnldX0FydGljbGVMZWFkZXJib2FyZCIKICAgICAgICAgICAgZGF0YS1zaXplPSJbWzcyOCwgOTBdLCBbMzIwLCA1MF1dIj4KICAgICAgICA8L2Rpdj4='><div class="code_module">
<div class="split-advert dfp-slot" data-path="/13474545/MaltaToday_news_ArticleLeaderboard" data-size="[[728, 90], [320, 50]]">
</div></div></div><div class='mt_module' data-module-name='article_author_bios' data-update-frequency='0'> <div class="article-author-bio">
<div class="bio">
<div class="row">
<div class="col-xs-1">
<div class="image">
<img src="//content.maltatoday.com.mt/ui_frontend/profile_thumbnail/40/40/nicole_meilak_1598949846_zoom.jpg" />
</div>
</div>
<div class="col-xs-11">
<div class="text">
Nicole Meilak is a staff reporter </div>
<div class="socialmedia">
<span class="link readmore"> <a href="/author/nicole_meilak/">More from Nicole Meilak</a></span>
</div>
</div>
</div>
</div>
</div>
</div><div class='mt_module' data-module-name='boxed_title' data-update-frequency='0' data-module-settings-text='More in {subcategory}'> <div class="boxed-title">
<span class="title-text">
More in National </span>
</div>
</div><div class='mt_module' data-module-name='small_article' data-update-frequency='0' data-module-settings-amount='4' data-module-settings-show_photo='1' data-module-settings-show_author='1' data-module-settings-show_category='1' data-module-settings-show_inset_category='0' data-module-settings-show_standfirst='1'><div class="responsive-articles small-articles">
<div class="article small-article open_url news-article" data-url="/news/national/106800/pn_lambasts_outdated_energy_policy_after_government_fails_to_secure_eu_funds_for_gas_pipeline">
<div class="image" style="background-image: url('//content.maltatoday.com.mt/ui_frontend/thumbnail/684/0/gas-pipeline-is-still-a-proposal-to-europe-and-was-made-this-year-opm.png');">
<img src="//content.maltatoday.com.mt/ui_frontend/thumbnail/684/0/gas-pipeline-is-still-a-proposal-to-europe-and-was-made-this-year-opm.png" alt="PN lambasts 'outdated' energy policy after government fails to secure EU funds for gas pipeline" />
</div>
<div class="details" style="padding-right: 25px;">
<div class="extra-info">
<span class="category news">National</span>
</div>
<div class="title">
<a href="/news/national/106800/pn_lambasts_outdated_energy_policy_after_government_fails_to_secure_eu_funds_for_gas_pipeline"><h3>PN lambasts 'outdated' energy policy after government fails to secure EU funds for gas pipeline</h3></a>
</div>
<div class="extra-info">
<span class="author news">Nicole Meilak </span>
</div>
</div>
</div>
<div class="article small-article open_url news-article" data-url="/news/national/106798/bernard_grech_warns_against_backtobusiness_approach">
<div class="image" style="background-image: url('//content.maltatoday.com.mt/ui_frontend/thumbnail/684/0/20202211_pn_photo_bg_dc_2.jpg');">
<img src="//content.maltatoday.com.mt/ui_frontend/thumbnail/684/0/20202211_pn_photo_bg_dc_2.jpg" alt="Bernard Grech warns against back-to-business approach if people end up left behind" />
</div>
<div class="details" style="padding-right: 25px;">
<div class="extra-info">
<span class="category news">National</span>
</div>
<div class="title">
<a href="/news/national/106798/bernard_grech_warns_against_backtobusiness_approach"><h3>Bernard Grech warns against back-to-business approach if people end up left behind</h3></a>
</div>
<div class="extra-info">
<span class="author news">Nicole Meilak </span>
</div>
</div>
</div>
<div class="article small-article open_url news-article" data-url="/news/national/106796/85_new_cases_no_new_deaths">
<div class="image" style="background-image: url('//content.maltatoday.com.mt/ui_frontend/thumbnail/684/0/valletta_masks.jpg');">
<img src="//content.maltatoday.com.mt/ui_frontend/thumbnail/684/0/valletta_masks.jpg" alt="COVID-19 Update: 85 new cases, no new deaths" />
</div>
<div class="details" style="padding-right: 25px;">
<div class="extra-info">
<span class="category news">National</span>
</div>
<div class="title">
<a href="/news/national/106796/85_new_cases_no_new_deaths"><h3>COVID-19 Update: 85 new cases, no new deaths</h3></a>
</div>
<div class="extra-info">
<span class="author news">Nicole Meilak </span>
</div>
</div>
</div>
<div class="article small-article open_url news-article" data-url="/news/national/106794/robert_abela_aims_for_full_economic_recovery_by_may_this_year">
<div class="image" style="background-image: url('//content.maltatoday.com.mt/ui_frontend/thumbnail/684/0/robert_abela_budget_2021.jpg');">
<img src="//content.maltatoday.com.mt/ui_frontend/thumbnail/684/0/robert_abela_budget_2021.jpg" alt="Robert Abela aims for full economic recovery by May this year" />
</div>
<div class="details" style="padding-right: 25px;">
<div class="extra-info">
<span class="category news">National</span>
</div>
<div class="title">
<a href="/news/national/106794/robert_abela_aims_for_full_economic_recovery_by_may_this_year"><h3>Robert Abela aims for full economic recovery by May this year</h3></a>
</div>
<div class="extra-info">
<span class="author news">Nicole Meilak </span>
</div>
</div>
</div>
</div>
</div><div class='mt_module' data-module-name='comments' data-update-frequency='0'><div id="taboola-below-article-thumbnails"></div>
<script type="text/javascript">window._taboola = window._taboola || [];_taboola.push({mode: 'thumbnails-a',container: 'taboola-below-article-thumbnails',placement: 'Below Article Thumbnails',target_type: 'mix'});</script>
<div id="disqus_thread"></div>
<script type="text/javascript">

    var disqus_config = function () {

        
            // The generated payload which authenticates users with Disqus
            this.page.remote_auth_s3 = 'eyJpZCI6InVzZXJfIiwidXNlcm5hbWUiOiIgIiwiZW1haWwiOm51bGx9 2c92bc71b5c0f690728101ae6c610a1d93fe0c5d 1609693117';
            this.page.api_key = 'KKsrhxY6LSXy3nbzit54YG6MHLFaxrOJ42o6hFm3W1sUtwGMqjEzqyO5HBu9sxTW';

                this.page.identifier = 'article_106794';
        this.sso = {
            name:   "MaltaToday.com.mt",
            button:  "https://www.maltatoday.com.mt/ui/images/frontend/disqus_button.png",
            icon:     "https://www.maltatoday.com.mt/ui/images/icons/Icon-Small@2x.png",
            url:      "https://www.maltatoday.com.mt/ui_frontend/login/",
            logout:  "https://www.maltatoday.com.mt/ui_frontend/disquslogout/",
            width:   "867",
            height:  "152"
        };
    };

    var disqus_shortname = 'malta-today';

    (function() {
        var dsq = document.createElement('script'); dsq.type = 'text/javascript'; dsq.async = true;
        dsq.src = '//' + disqus_shortname + '.disqus.com/embed.js';
        (document.getElementsByTagName('head')[0] || document.getElementsByTagName('body')[0]).appendChild(dsq);
    })();
</script>
<div id="taboola-below-article-thumbnails1"></div>
<script type="text/javascript">window._taboola = window._taboola || [];_taboola.push({mode: 'thumbnails-a1',container: 'taboola-below-article-thumbnails1',placement: 'Below Article Thumbnails1',target_type: 'mix'});</script></div></div> </div>
<div class="col-lg-2 col-md-2">
<div class="zone" data-zone-name="Right" data-zone-id="right"></div> </div>
</div>
<div class="row">
<div class="col-lg-12 col-md-12">
<div class="zone" data-zone-name="Bottom" data-zone-id="bottom"></div> </div>
</div>
</div>
</section></div>
<footer class="hidden-xs">
<div class="container">
<div class="row">
<div class="col-xs-12 col-sm-6">
<div class="footer-logo">
<a href="/"> <img src="/ui/images/frontend/maltatoday_logo_white.png" /></a>
</div>
</div>
<div class="col-xs-12 col-sm-6">
<div class="social-icons">
<div class="icon facebook">
<a href="//facebook.com/maltatoday" target="_blank"><i class="fa fa-facebook"></i></a>
</div>
<div class="icon twitter">
<a href="//twitter.com/maltatoday" target="_blank"><i class="fa fa-twitter"></i></a>
</div>
<div class="icon instagram">
<a href="//www.instagram.com/maltatoday" target="_blank"><i class="fa fa-instagram"></i></a>
</div>
<div class="icon youtube">
<a href="//www.youtube.com/user/ReporterMediaToday" target="_blank"><i class="fa fa-youtube"></i></a>
</div>
<div class="icon googleplus">
<a href="//plus.google.com/113527506098764625850" target="_blank"><i class="fa fa-google-plus"></i></a>
</div>
</div>
</div>
</div>
<div class="row">
<div class="col-xs-12">
<ul class="bottom-nav">
<li><a href="/about-us/">About Us</a></li>
<li><a href="/advertising/">Advertise</a> </li>
<li><a href="/contact/">Contact</a> </li>
<li><a href="/maltatodaydigitaledition/">Digital Edition</a></li>
<li><a href="http://frontpages.maltatoday.com.mt/">Today's Newspapers</a></li>
<li><a href="/subscribe_sms/">SMS Alerts</a></li>
</ul>
<ul class="bottom-links">
<li><a href="/terms-and-conditions/">Terms and Conditions</a> </li>
<li><a href="/privacy-policy/">Privacy Policy</a> </li>
<li><a href="/privacy-policy/">Cookie Policy</a> </li>
<li><a target="_blank" href="http://archive.maltatoday.com.mt/archive.html">Archives</a></li>
</ul>
</div>
</div>
<div class="row">
<div class="col-md-12">
<div class="copyright">
MediaToday is an independent media house based in Malta. Copyright © MediaToday Co. Ltd, Vjal ir-Rihan, San Gwann SGN 9016, Malta, Europe <br />
Reproduction of material from this website without written permission is strictly prohibited.
</div>
</div>
</div>
</div>
</footer>
<div class="floating-bar" data-cookie-name="cookie_notice">
<div class="container">
<div class="message-inner">
<a href="https://www.maltatoday.com.mt/privacy-policy/" target="_blank" class="set-close">
By using this site, you agree to our Privacy Policy including the use of cookies to enhance your experience. </a>
<button class="message-close-btn set-close">
<i class="fa fa-times close"></i>
</button>
</div>
</div>
</div>
<script type="text/javascript" src="//imasdk.googleapis.com/js/sdkloader/ima3.js"></script>
<script type="text/javascript" src="/dist/js/packages.min.js?v=1.9991"></script>
<script>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</script>

<script type="text/javascript">
_atrk_opts = { atrk_acct:"io5hj1aAkN00oK", domain:"maltatoday.com.mt",dynamic: true};
(function() { var as = document.createElement('script'); as.type = 'text/javascript'; as.async = true; as.src = "https://certify-js.alexametrics.com/atrk.js"; var s = document.getElementsByTagName('script')[0];s.parentNode.insertBefore(as, s); })();
</script>
<noscript><img src="https://certify.alexametrics.com/atrk.gif?account=io5hj1aAkN00oK" style="display:none" height="1" width="1" alt="" /></noscript>

<script type="text/javascript" src="/dist/js/app.min.js?v=1.9991"></script>
<script type="text/javascript">
    var _gaq = _gaq || [];
    _gaq.push(['_setAccount', 'UA-16977049-1']);
    _gaq.push(['_trackPageview']);

    (function () {
        var ga = document.createElement('script'); ga.type =
            'text/javascript'; ga.async = true;
        ga.src = ('https:' == document.location.protocol ? 'https://ssl' :
            'http://www') + '.google-analytics.com/ga.js';
        var s = document.getElementsByTagName('script')[0];
        s.parentNode.insertBefore(ga, s);
    })();
</script>
<script id="dsq-count-scr" src="//malta-today.disqus.com/count.js" async></script>
<script type="text/javascript">
    window._taboola = window._taboola || [];
    _taboola.push({flush: true});
</script>
</body>
</html>
