<!DOCTYPE html>
<html xmlns="http://www.w3.org/1999/xhtml" lang="en">
<head>
<meta http-equiv="Content-Type" content="text/html; charset=utf-8">
<meta name="viewport" content="width=device-width, initial-scale=1.0" />
<meta property="fb:pages" content="21535456940" />
<meta property="fb:app_id" content="1775326929407925" />
<link rel="shortcut icon" type="image/x-icon" href="/ui/images/icons/Icon-Small@2x.png">
<link rel="apple-touch-icon" href="/ui/images/icons/Icon-60@2x.png" />
<link rel="apple-touch-icon" sizes="58x58" href="/ui/images/icons/Icon-Small@2x.png" />
<link rel="apple-touch-icon" sizes="76x76" href="/ui/images/icons/Icon-76.png" />
<link rel="apple-touch-icon" sizes="152x152" href="/ui/images/icons/Icon-76@2x.png" />
<link rel="apple-touch-icon" sizes="180x180" href="/ui/images/icons/Icon-60@3x.png" />
<link rel="icon" sizes="192x192" href="/ui/images/icons/icon-192x192.png" />
<link rel="stylesheet" href="/dist/css/desktop.min.css?v=15.2022" />
<link rel="canonical" href="https://www.maltatoday.com.mt/news/national/119269/us_subpoenas_get_green_light_in_malta_probe_on_fenech_dark_web_purchase">
<meta property="og:site_name" content="MaltaToday.com.mt" />
<meta property="og:url" content="http://www.maltatoday.com.mt/news/national/119269/us_subpoenas_get_green_light_in_malta_probe_on_fenech_dark_web_purchase" />
<meta property="og:title" content="U.S. subpoenas get green light in Malta probe on Fenech ‘Dark Web’ purchase" />
<meta property="og:description" content="A US district court in Delaware has authorised a delegate from the Office of the US Attorney, to serve subpoenas as required in a request by Maltese police investigating Yorgen Fenech&amp;rsquo;s alleged bid to purchase firearms on the dark web using cryptocurrency" />
<meta property="og:type" content="article" />
<meta property="article:publisher" content="https://www.facebook.com/maltatoday" />
<meta property="og:image" content="http://cdn.maltatoday.com.mt/ui_frontend/thumbnail/684/400/2_yorgen_fenech_1.jpeg" />
<meta name="description" content="A US district court in Delaware has authorised a delegate from the Office of the US Attorney, to serve subpoenas as required in a request by Maltese police investigating Yorgen Fenech&amp;rsquo;s alleged bid to purchase firearms on the dark web using cryptocurrency" />
<script type="text/javascript">
        var cdn_url = "//content.maltatoday.com.mt";
    </script>
<title>US subpoenas get green light in Malta probe on Fenech ‘Dark Web’ purchase</title>

<script async='async' src='https://www.googletagservices.com/tag/js/gpt.js'></script>
<script>
        var googletag = googletag || {};
        googletag.cmd = googletag.cmd || [];
    </script>

<script>
    !function(f,b,e,v,n,t,s)
    {if(f.fbq)return;n=f.fbq=function(){n.callMethod?
    n.callMethod.apply(n,arguments):n.queue.push(arguments)};
    if(!f._fbq)f._fbq=n;n.push=n;n.loaded=!0;n.version='2.0';
    n.queue=[];t=b.createElement(e);t.async=!0;
    t.src=v;s=b.getElementsByTagName(e)[0];
    s.parentNode.insertBefore(t,s)}(window, document,'script',
    'https://connect.facebook.net/en_US/fbevents.js');
    fbq('init', '213704729706889');
    fbq('track', 'PageView');
    </script>
<noscript><img height="1" width="1" style="display:none"
    src="https://www.facebook.com/tr?id=213704729706889&ev=PageView&noscript=1"
    /></noscript>

</head>
<body class="page-article">
<header>
<div class="zone" data-zone-name="TOPMOST" data-zone-id="TOPMOST"><div class='mt_module' data-module-name='code' data-update-frequency='0' data-module-settings-code='PGRpdiBjbGFzcz0idG9wLXNsYXNoIGRmcC1zbG90IiAKICAgICAgICAgICAgZGF0YS1wYXRoPSIvMTM0NzQ1NDUvTWFsdGFUb2RheV9bY2F0ZWdvcnldX0xlYWRlcmJvYXJkXzcyOHg5MCIKICAgICAgICAgICAgZGF0YS1zaXplPSJbWzcyOCwgOTBdLCBbOTcwLCA5MF0sIFs5NzAsIDI1MF0sIFszMjAsIDEwMF0sIFsxMzIwLCAyNTBdLCBbMTE1MCwgMjUwXV0iPgogICAgICAgIDwvZGl2Pg=='><div class="code_module">
<div class="top-slash dfp-slot" data-path="/13474545/MaltaToday_news_Leaderboard_728x90" data-size="[[728, 90], [970, 90], [970, 250], [320, 100], [1320, 250], [1150, 250]]">
</div></div></div></div> <div class="main-nav">
<div class="main-nav-bg">
<div class="container">
<div class="row">
<div class="col-md-12">
<div class="row">
<div class="menu-bar news">
<div class="logo col-xs-7 col-md-2">
<a href="/"><img class="img-responsive" src="/ui/images/frontend/maltatoday_logo_news.png" alt="maltatoday" /></a>
</div>
<div class="col-xs-5 visible-sm visible-xs text-right">
<div id="more-menu">
menu
<button type="button" class="navbar-toggle" aria-expanded="false">
<span class="sr-only">Toggle navigation</span>
<span class="icon-bar"></span>
<span class="icon-bar"></span>
<span class="icon-bar"></span>
</button>
</div>
</div>
<ul class="main-menu">
<li class="menu-inline-search visible-xs">
<form action="/search-mt/" method="get">
<div class="col-xs-12">
<input type="text" name="q" class="form-control" placeholder="Search maltatoday.." />
</div>
</form>
</li>
<li class="menu_item home has-sub-menu">
<a href="/">
Home </a>
<div class="menu-item-detail-box">
<ul class="sub-menu">
<li><a href="/vacancies">Jobs in Malta</a></li>
<li><a href="/yellow">Yellow</a></li>
<li><a href="/pharmacies">Pharmacies</a></li>
<li><a href="/sponsored">Sponsored</a></li>
<li><a href="/announcements">Announcements</a></li>
<li><a href="/advertising">Advertise</a></li>
<li><a href="/contact">Contact</a></li>
<li><a href="/maltatodaydigitaledition">Digital Edition</a></li>
<li><a href="/subscribe_sms">SMS Alerts</a></li>
</ul>
</div>
</li>
<li class="menu_item news active has-sub-menu">
<a href="/news">
News </a>
<div class="menu-item-detail-box">
<ul class="sub-menu">
<li><a href="/news/national">National</a></li>
<li><a href="/news/budget-2023">Budget 2023</a></li>
<li><a href="/covid19">Covid-19</a></li>
<li><a href="/news/ewropej">#EWROPEJ</a></li>
 <li><a href="/news/court_and_police">Court &amp; Police</a></li>
<li><a href="/news/interview">Interview</a></li>
<li><a href="/news/data_and_surveys">Data &amp; Survey</a></li>
<li><a href="/news/skinny">The Skinny</a></li>
<li><a href="/news/xtra">Xtra</a></li>
<li><a href="/news/election-2022">Election 2022</a></li>
</ul>
<div class="detail-content-box hidden-sm hidden-xs">
<div class="sub-menu-latest-stories">
<div class="row">
<div class="col-md-6">
<div class="left-section">
<div class="top-story-container">
<div class="photo">
<a href="/news/interview/119279/response_violence_racism_police_crime_aditus_neil_falzon"><img src="//content.maltatoday.com.mt/ui_frontend/thumbnail/400/220/8-9_neil_falzon.jpg" /></a>
</div>
<div class="title">
<span class="category">Interview</span> <a href="/news/interview/119279/response_violence_racism_police_crime_aditus_neil_falzon">
Our response to violence cannot be ‘more violence’ | Neil Falzon</a>
</div>
</div>
</div>
</div>
<div class="col-md-6">
<div class="right-section">
<ul class="stories">
<li class="story">
<div class="story-content">
<div class="image">
<a href="/news/national/119269/us_subpoenas_get_green_light_in_malta_probe_on_fenech_dark_web_purchase"><img src="//content.maltatoday.com.mt/ui_frontend/thumbnail/62/62/2_yorgen_fenech_1.jpeg" /></a>
</div>
<div class="text">
<a href="/news/national/119269/us_subpoenas_get_green_light_in_malta_probe_on_fenech_dark_web_purchase">
<span class="category">National</span>
<span class="title"> U.S. subpoenas get green light in Malta probe on Fenech ‘Dark Web’ purchase</span>
</a>
</div>
</div>
</li>
<li class="story">
<div class="story-content">
<div class="image">
<a href="/news/europe/119304/malta_rule_of_law_debated_in_strasbourg_labour_mounts_defence_of_slow_pace_of_reform"><img src="//content.maltatoday.com.mt/ui_frontend/thumbnail/62/62/alex_agius_saliba_didier_reynders.jpg" /></a>
</div>
<div class="text">
<a href="/news/europe/119304/malta_rule_of_law_debated_in_strasbourg_labour_mounts_defence_of_slow_pace_of_reform">
<span class="category">Europe</span>
<span class="title"> Malta rule of law debated in Strasbourg, Labour mounts defence of slow pace of reform</span>
</a>
</div>
</div>
</li>
<li class="story">
<div class="story-content">
<div class="image">
<a href="/news/europe/119302/metsola_european_parliament_will_always_stand_on_the_side_of_truthseekers"><img src="//content.maltatoday.com.mt/ui_frontend/thumbnail/62/62/screenshot_2022-10-17_at_19.39.21.png" /></a>
</div>
<div class="text">
<a href="/news/europe/119302/metsola_european_parliament_will_always_stand_on_the_side_of_truthseekers">
<span class="category">Europe</span>
<span class="title"> Metsola: European Parliament will always stand on the side of truth-seekers</span>
</a>
</div>
</div>
</li>
</ul>
<a href="/news">More in News <i class="fa fa-angle-right"></i></a>
</div>
</div>
</div>
</div>
</div>
</div>
</li>
<li class="menu_item business has-sub-menu">
<a href="/business">
Business </a>
<div class="menu-item-detail-box">
<ul class="sub-menu">
<li><a href="/business/business_news">Business News</a></li>
<li><a href="/business/business_comment">Business Comment</a></li>
<li><a href="/business/tech">Tech & Gaming</a></li>
<li><a href="/business/law_report">Law Report</a></li>
<li><a href="/business/property">Property</a></li>
</ul>
<div class="detail-content-box hidden-sm hidden-xs">
<div class="sub-menu-latest-stories">
<div class="row">
<div class="col-md-6">
<div class="left-section">
<div class="top-story-container">
<div class="photo">
<a href="/business/business_news/119303/greylist_reversal_lifts_investors_mood_now_concerned_about_tax_wages_and_labour_supply"><img src="//content.maltatoday.com.mt/ui_frontend/thumbnail/400/220/fatf_plenary.jpg" /></a>
</div>
<div class="title">
<span class="category">Business News</span> <a href="/business/business_news/119303/greylist_reversal_lifts_investors_mood_now_concerned_about_tax_wages_and_labour_supply">
Greylist reversal lifts investors’ mood, now concerned about tax, wages and labour supply</a>
</div>
</div>
</div>
</div>
<div class="col-md-6">
<div class="right-section">
<ul class="stories">
<li class="story">
<div class="story-content">
<div class="image">
<a href="/business/business_comment/119278/quality_growth_as_a_shield_against_inflation"><img src="//content.maltatoday.com.mt/ui_frontend/thumbnail/62/62/computersfinance.jpg" /></a>
</div>
<div class="text">
<a href="/business/business_comment/119278/quality_growth_as_a_shield_against_inflation">
<span class="category">Business Comment</span>
<span class="title"> Quality growth as a shield against inflation</span>
</a>
</div>
</div>
</li>
<li class="story">
<div class="story-content">
<div class="image">
<a href="/business/tech/119199/blazing_in_malta"><img src="//content.maltatoday.com.mt/ui_frontend/thumbnail/62/62/blazing_in_malta__684x455_no_text.jpg" /></a>
</div>
<div class="text">
<a href="/business/tech/119199/blazing_in_malta">
<span class="category">Tech & Gaming</span>
<span class="title"> Blazing in Malta</span>
</a>
</div>
</div>
</li>
<li class="story">
<div class="story-content">
<div class="image">
<a href="/business/business_comment/119194/equity_investors_may_seek_shelter_in_defensive_sectors"><img src="//content.maltatoday.com.mt/ui_frontend/thumbnail/62/62/workingcoverphoto.jpg" /></a>
</div>
<div class="text">
<a href="/business/business_comment/119194/equity_investors_may_seek_shelter_in_defensive_sectors">
<span class="category">Business Comment</span>
<span class="title"> Equity investors may seek shelter in defensive sectors</span>
</a>
</div>
</div>
</li>
</ul>
<a href="/business">More in Business <i class="fa fa-angle-right"></i></a>
</div>
</div>
</div>
</div>
</div>
</div>
</li>
<li class="menu_item sports has-sub-menu">
<a href="/sports">
Sports </a>
<div class="menu-item-detail-box">
<ul class="sub-menu">
<li><a href="/worldcup2018">World Cup 2018</a></li>
<li><a href="/sports/football">Football</a></li>
<li><a href="/sports/rugby">Rugby</a></li>
<li><a href="/sports/motorsports">Motor Sports</a></li>
<li><a href="/sports/boxing">Boxing</a></li>
<li><a href="/sports/tennis">Tennis</a></li>
<li><a href="/sports/cricket">Cricket</a></li>
</ul>
</div>
</li>
<li class="menu_item arts has-sub-menu">
<a href="/arts">
Arts </a>
<div class="menu-item-detail-box">
<ul class="sub-menu">
<li><a href="/arts/art">Art</a></li>
<li><a href="/arts/books">Books</a></li>
<li><a href="/arts/entertainment">Entertainment</a></li>
<li><a href="/arts/music">Music</a></li>
<li><a href="/arts/theatre_and_dance">Theatre &amp; Dance</a></li>
<li><a href="/arts/film">Film</a></li>
<li><a href="/arts/cultural_diary">Cultural Diary</a></li>
<li><a href="/arts/markapagna/">Markapaġna</a></li>
<li><a href="/arts/kwartaktieb/">KwartaKtieb</a></li>
<li><a href="/arts/valletta_2018">Valletta 2018</a></li>
</ul>
<div class="detail-content-box hidden-sm hidden-xs">
<div class="sub-menu-latest-stories">
<div class="row">
<div class="col-md-6">
<div class="left-section">
<div class="top-story-container">
<div class="photo">
<a href="/arts/cultural_diary/119148/my_essentials_joseph_depasquales_cultural_picks"><img src="//content.maltatoday.com.mt/ui_frontend/thumbnail/400/220/joe_depasquale2.png" /></a>
</div>
<div class="title">
<span class="category">Cultural Diary</span> <a href="/arts/cultural_diary/119148/my_essentials_joseph_depasquales_cultural_picks">
My essentials: Joseph DePasquale’s cultural picks</a>
</div>
</div>
</div>
</div>
<div class="col-md-6">
<div class="right-section">
<ul class="stories">
<li class="story">
<div class="story-content">
<div class="image">
<a href="/arts/cultural_diary/119027/my_essentials_bettina_zammits_cultural_picks"><img src="//content.maltatoday.com.mt/ui_frontend/thumbnail/62/62/screenshot_2022-10-03_at_08.52.55.png" /></a>
</div>
<div class="text">
<a href="/arts/cultural_diary/119027/my_essentials_bettina_zammits_cultural_picks">
<span class="category">Cultural Diary</span>
<span class="title"> My essentials: Bettina Zammit’s cultural picks</span>
</a>
</div>
</div>
</li>
<li class="story">
<div class="story-content">
<div class="image">
<a href="/arts/books/119201/watch_markapagna_francesco_grech"><img src="//content.maltatoday.com.mt/ui_frontend/thumbnail/62/62/5._francesco_grech_1920_x_1080.jpeg" /></a>
</div>
<div class="text">
<a href="/arts/books/119201/watch_markapagna_francesco_grech">
<span class="category">Books</span>
<span class="title"> [WATCH] Markapaġna | Francesco Grech</span>
</a>
</div>
</div>
</li>
<li class="story">
<div class="story-content">
<div class="image">
<a href="/arts/books/119192/from_illustration_to_book_the_exhibition_at_the_malta_book_festival_2022"><img src="//content.maltatoday.com.mt/ui_frontend/thumbnail/62/62/national_book_council_2022.jpg" /></a>
</div>
<div class="text">
<a href="/arts/books/119192/from_illustration_to_book_the_exhibition_at_the_malta_book_festival_2022">
<span class="category">Books</span>
<span class="title"> ‘From Illustration to Book’: the exhibition at the Malta Book Festival 2022</span>
</a>
</div>
</div>
</li>
</ul>
<a href="/arts">More in Arts <i class="fa fa-angle-right"></i></a>
</div>
</div>
</div>
</div>
</div>
</div>
</li>
<li class="menu_item comment has-sub-menu">
<a href="/comment">
Comment </a>
<div class="menu-item-detail-box">
<ul class="sub-menu">
<li><a href="/comment/blogs">Blogs</a></li>
<li><a href="/comment/editorial">Editorial</a></li>
<li><a href="/comment/letters">Letters</a></li>
<li><a href="/comment/cartoons">Cartoons</a></li>
</ul>
<div class="detail-content-box hidden-sm hidden-xs">
<div class="sub-menu-latest-stories">
<div class="row">
<div class="col-md-6">
<div class="left-section">
<div class="top-story-container">
<div class="photo">
<a href="/comment/blogs/119280/were_all_human_but_some_of_us_are_more_human_than_others"><img src="//content.maltatoday.com.mt/ui_frontend/thumbnail/400/220/8_robert_abela.jpeg" /></a>
</div>
<div class="title">
<span class="category">Blogs</span> <a href="/comment/blogs/119280/were_all_human_but_some_of_us_are_more_human_than_others">
‘We’re all human’ (but some of us are more human than others)</a>
</div>
</div>
</div>
</div>
<div class="col-md-6">
<div class="right-section">
<ul class="stories">
<li class="story">
<div class="story-content">
<div class="image">
<a href="/comment/blogs/119277/the_end_of_the_plpn_duopoly"><img src="//content.maltatoday.com.mt/ui_frontend/thumbnail/62/62/election_2017.jpg" /></a>
</div>
<div class="text">
<a href="/comment/blogs/119277/the_end_of_the_plpn_duopoly">
<span class="category">Blogs</span>
<span class="title"> The end of the PL-PN duopoly?</span>
</a>
</div>
</div>
</li>
<li class="story">
<div class="story-content">
<div class="image">
<a href="/comment/blogs/119261/our_mental_health_problems_require_more_than_just_helplines"><img src="//content.maltatoday.com.mt/ui_frontend/thumbnail/62/62/home_telephone.png" /></a>
</div>
<div class="text">
<a href="/comment/blogs/119261/our_mental_health_problems_require_more_than_just_helplines">
<span class="category">Blogs</span>
<span class="title"> Our mental health problems require more than just helplines</span>
</a>
</div>
</div>
</li>
<li class="story">
<div class="story-content">
<div class="image">
<a href="/comment/blogs/119260/innocent_until_proven_guilty"><img src="//content.maltatoday.com.mt/ui_frontend/thumbnail/62/62/dsc03621.jpg" /></a>
</div>
<div class="text">
<a href="/comment/blogs/119260/innocent_until_proven_guilty">
<span class="category">Blogs</span>
<span class="title"> 'Innocent until proven guilty'</span>
</a>
</div>
</div>
</li>
</ul>
<a href="/comment">More in Comment <i class="fa fa-angle-right"></i></a>
</div>
</div>
</div>
</div>
</div>
</div>
</li>
<li class="menu_item videos">
<a href="/videos/">
Video </a>
</li>
<li class="menu_item archives">
<a href="http://archive.maltatoday.com.mt" target="_blank">
Archives </a>
</li>
<li class="menu_item sponsored visible-xs visible-sm">
<a href="/sponsored">
Sponsored </a>
</li>
<li class="menu_item gourmet-today has-sub-menu">
<a href="/gourmet/">
<img src="/ui/images/frontend/maltatoday_logo_gourmet.png" alt="Gourmet" />
</a>
<div class="menu-item-detail-box">
<ul class="sub-menu">
<li><a href="/gourmet/recipes/">Recipes</a></li>
<li><a href="/gourmet/restaurants/">Restaurants</a></li>
<li><a href="/gourmet/gourmet_today/">Magazines</a></li>
<li><a href="/gourmet/gourmettv/">TV</a></li>
<li><a href="/gourmet/videos/">Videos</a></li>
</ul>
</div>
</li>
<li class="menu_item deal-today visible-xs visible-sm">
<a href="/yellow">
Yellow </a>
</li>
<li class="menu_item login visible-xs visible-sm login-menu-item">
<a href="/maltatodaydigitaledition/">
Digital Paper </a>
</li>
</ul>
<div class="menu-icons hidden-xs hidden-sm">
<div class="menu-icons-icon search-icon" onclick="$(this).addClass('active').find('input').focus()">
<span class="fa fa-search"></span>
<div class="searchbox">
<form action="/search-mt/" method="get">
<input type="text" name="q" placeholder="Search" onblur="$(this).parents('.search-icon').removeClass('active');" onkeyup="if (event.keyCode === 27) { $(this).blur(); }" />
<button type="submit">
<i class="fa fa-search search_now"></i>
</button>
</form>
</div>
</div>
<div class="menu-icons-icon login-icon digital-paper">
<a href="/maltatodaydigitaledition/" class="btn btn-red">Digital Paper</a>
<div id="login-sub-menu">
<a target="_blank" href="https://maltatoday.uberflip.com/t/73329-mediatoday-newspapers-latest-editions">My Account</a>
<a href="/maltatodaydigitaledition/">Subscribe</a>
<a href="/subscribe_sms/">SMS Alerts</a>
<a href="/maltatodaydigitaledition/#previous">Previous Editions</a>
</div>
</div>
</div>
</div>
</div>
<div id="small-menu-placeholder" class="row visible-xs visible-sm news">
<div id="small-menu">
<a href="/">home</a>
<a href="/news">news</a>
<a class="highlight" href="/maltatodaydigitaledition">Digital Paper</a>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
<div class="sub-nav">
<div class="container">
<ul class="hidden-xs outer-sub-menu sub-menu news">
<li><a href="/news/national">National</a></li>
<li><a href="/news/budget-2023">Budget 2023</a></li>
<li><a href="/covid19">Covid-19</a></li>
<li><a href="/news/ewropej">#EWROPEJ</a></li>
<li><a href="/news/court_and_police">Court &amp; Police</a></li>
<li><a href="/news/interview">Interview</a></li>
<li><a href="/news/data_and_surveys">Data &amp; Survey</a></li>
<li><a href="/news/skinny">The Skinny</a></li>
<li><a href="/news/xtra">Xtra</a></li>
<li><a href="/news/election-2022">Election 2022</a></li>
</ul>
</div>
</div>
</header>
<div id="content">
<section>
<div class="container">
<div class="row">
<div class="col-lg-12 col-md-12">
<div class="zone" data-zone-name="Top" data-zone-id="top"><div class='mt_module' data-module-name='article_breadcrumb' data-update-frequency='0'><ul class="breadcrumb">
<li class="breadcrumb-item news"><a href="/news/">News</a></li>
<li class="breadcrumb-item news"><a href="/news/national/">National</a></li>
</ul></div><div class='mt_module' data-module-name='article_heading' data-update-frequency='0'><div class="article-heading">
<div class="row">
<div class="col-md-12">
<h1>U.S. subpoenas get green light in Malta probe on Fenech ‘Dark Web’ purchase</h1>
<h2><p>A US district court in Delaware has authorised a delegate from the Office of the US Attorney, to serve subpoenas as required in a request by Maltese police investigating Yorgen Fenech&rsquo;s alleged bid to purchase firearms on the dark web using cryptocurrency</p></h2>
</div>
</div>
</div>
</div></div> </div>
</div>
<div class="row">
<div class="col-lg-2 col-md-2">
<div class="zone" data-zone-name="Left" data-zone-id="left"><div class='mt_module' data-module-name='article_meta' data-update-frequency='0'><div class="article-meta">
<div class="author-photos"> <img src="//content.maltatoday.com.mt/ui_frontend/profile_thumbnail/300/300/matthew_vella_1645462502.jpg" alt="matthew_vella" />
</div>
<div class="date-text">
<span class="date">18 October 2022, 8:52am</span>
<br />by <span class="name">Matthew Vella </span>
</div>
</div></div><div class='mt_module' data-module-name='addthis' data-update-frequency='0'> <script type="text/javascript" src="//s7.addthis.com/js/300/addthis_widget.js#pubid=ra-5a7023510fcc04af"></script>
</div></div> </div>
<div class="col-lg-8 col-md-8">
<div class="zone" data-zone-name="Main" data-zone-id="content"><div class='mt_module' data-module-name='article_cover' data-update-frequency='0'><div class="full-article article-cover">
<div class="photo_collection_cover article-cover-media single-cover" data-slick='{"slidesToShow": 1, "slidesToScroll": 1}'>
<div class="media-item show ">
<div class="cover-photo" title="Malta issued a request for information from the United States back in September 2021, as part of a magisterial inquiry conducted by Magistrate Nadine Lia into Yorgen Fenech, over the unlawful acquisition of firearms on the “Dark Web” using Bitcoin" style="background-image: url('//content.maltatoday.com.mt/ui/images/photos/2_yorgen_fenech_1.jpeg')">
<img src="//content.maltatoday.com.mt/ui_frontend/thumbnail/684/0/2_yorgen_fenech_1.jpeg" alt="Malta issued a request for information from the United States back in September 2021, as part of a magisterial inquiry conducted by Magistrate Nadine Lia into Yorgen Fenech, over the unlawful acquisition of firearms on the “Dark Web” using Bitcoin" />
</div>
<div class="caption">
<div class="inner">Malta issued a request for information from the United States back in September 2021, as part of a magisterial inquiry conducted by Magistrate Nadine Lia into Yorgen Fenech, over the unlawful acquisition of firearms on the “Dark Web” using Bitcoin</div>
</div>
</div>
</div>
</div></div><div class='mt_module' data-module-name='small_share_buttons' data-update-frequency='0'><div class="row">
<div class="col-md-6">
</div>
<div class="col-md-6">
<div class="small_share_buttons text-right">
<a class="addthis_button_facebook_like" fb:like:layout="button_count" style="position:relative; top: 4px; padding: 0px; right: -10px;"></a>
<script type="text/javascript">var addthis_config = {"data_track_addressbar":true};</script>
<script type="text/javascript" src="//s7.addthis.com/js/300/addthis_widget.js#pubid=seekopia"></script>
<a class="twitter" href="https://twitter.com/share?url=https://www.maltatoday.com.mt/news/national/119269/us_subpoenas_get_green_light_in_malta_probe_on_fenech_dark_web_purchase&text=U.S. subpoenas get green light in Malta probe on Fenech ‘Dark Web’ purchase" target="_blank">
<i class="fa fa-twitter"></i> TWEET
</a>
<a class="facebook" href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.maltatoday.com.mt%2Fnews%2Fnational%2F119269%2Fus_subpoenas_get_green_light_in_malta_probe_on_fenech_dark_web_purchase" target="_blank">
<i class="fa fa-facebook"></i> SHARE
</a>
</div>
</div>
</div></div><div class='mt_module' data-module-name='full_article' data-update-frequency='0'><div class="full-article">
<div class="content content-news"> <div class="dfp-slot" data-path="/13474545/MaltaToday_news_Inline_300x250" data-size="[[300, 250]]" style="float:right; margin:8px 0 8px 25px">
</div>
<p>A United States district court in Delaware has authorised a delegate from the Office of the US Attorney, to serve subpoenas as required in a request by Maltese police investigating Yorgen Fenech&rsquo;s alleged bid to purchase firearms on the dark web using cryptocurrency.
</p><p>The Maltese request has targeted lawyer Aron Mifsud Bonnici, a lawyer whose services were availed by Fenech to transfer an amount of Bitcoin to a wallet controlled by Fenech, for the purchase of weapons.
</p><p>The decision by the American court authorises the US attorney to collect the evidence requested by the Maltese police, if necessary with the force of FBI officers.
</p><p>Malta issued a request for information from the United States back in September 2021, as part of a magisterial inquiry conducted by Magistrate Nadine Lia into Fenech, over the unlawful acquisition of firearms on the &ldquo;Dark Web&rdquo; using Bitcoin.
</p><p>Details in an application by the United States Office of International Affairs, filed 12 months after the request &ndash; 21 September 2022 &ndash; seeks evidence from cryptocurrency exchanges Poloniex and Coinbase.
</p><p>&ldquo;As Malta&rsquo;s Office of the Attorney General stated in the Request, the Maltese police are investigating the unlawful acquisition of firearms by Yorgen Fenech, via the dark web, on or about December 13, 2017 and November 25, 2018, in violation of the criminal law of Malta...
</p><p>&ldquo;&hellip; According to authorities in Malta, on November 25, 2018, Fenech inquired into the purchase of a Glock firearm and a Scorpion CZ automatic rifle for 0.9 Bitcoin. On the same day, another individual, Aron Mifsud Bonnici, sent from his accounts at Coinbase and Poloniex 1 Bitcoin to Fenech, 0.9 Bitcoin of which Fenech then used for the weapons purchase.
</p><p>&ldquo;One of the transactions that Mifsud Bonnici made that day to Fenech was in the amount of 0.46221 Bitcoin from his Coinbase account to wallet address [xxx]. Moreover, on December 13, 2017, Mifsud Bonnici made a transaction of 1.3999 Bitcoin from his Poloniex platform account to BTC wallet [xxx].&rdquo;
</p><p>The Maltese authorities said they are requesting pertinent business records from Coinbase and Poloniex for both Mifsud Bonnici and Fenech. Poloniex and Coinbase are both Delaware corporations.
</p><p>Fenech was arrested in November 2019 while trying to leave Malta on his yacht and is indicted for complicity and conspiracy in the murder of journalist Daphne Caruana Galizia, who was killed in a car bombing near her home in 2017. He is currently in custody awaiting trial.
</p><p>Mifsud Bonnici has denied being the subject of an investigation. &ldquo;In August and September 2021, I assisted the Malta Police in an open investigation regarding Mr Yorgen Fenech. I was subsequently asked by the Police to help further by giving evidence, once Mr Fenech was charged with the attempted importation of a firearm from the dark web. Given the ongoing investigation, the case was heard behind closed doors, and I have thus refrained from making any public comment in regard thereto until today.
</p><p>&ldquo;The Police confirmed that there is no suggestion of wrongdoing in my regard. I ask that you verify this directly with the Police.&rdquo;
</p><p>A source connected to the probe told MaltaToday that the related investigations are still ongoing.
</p><p>Mifsud Bonnici runs his own law firm. He previously enjoyed the trust of Labour Party leadership. Apart from acting as legal counsel to the General Workers Union, his father was also a party candidate and deputy mayor of San Gwann.
</p><p>During the first Muscat administration, Mifsud Bonnici had represented embattled minister Konrad Mizzi, when his name emerged in the Panama Papers, in various litigation cases.
</p><p>Afterwards, the three partners of Mifsud Bonnici Advocates all found themselves occupying various posts in public companies, mostly falling under Mizzi&rsquo;s political remit when he was appointed tourism minister in 2017 in the second Muscat administration.
</p><p>At that point Mifsud Bonnici was acting as board secretary of at least nine public entities, among them Enemalta plc and Engineering Resources, and billing company ARMS, as well as Projects Malta and Projects Plus.</p><p></p> </div>
</div></div><div class='mt_module' data-module-name='code' data-update-frequency='0' data-module-settings-code='PGRpdiBjbGFzcz0ic3BsaXQtYWR2ZXJ0IGRmcC1zbG90IiAKICAgICAgICAgICAgZGF0YS1wYXRoPSIvMTM0NzQ1NDUvTWFsdGFUb2RheV9bY2F0ZWdvcnldX0FydGljbGVMZWFkZXJib2FyZCIKICAgICAgICAgICAgZGF0YS1zaXplPSJbWzcyOCwgOTBdLCBbMzIwLCA1MF1dIj4KICAgICAgICA8L2Rpdj4='><div class="code_module">
<div class="split-advert dfp-slot" data-path="/13474545/MaltaToday_news_ArticleLeaderboard" data-size="[[728, 90], [320, 50]]">
</div></div></div><div class='mt_module' data-module-name='article_author_bios' data-update-frequency='0'> <div class="article-author-bio">
<div class="bio">
<div class="row">
<div class="col-xs-1">
<div class="image">
<img src="//content.maltatoday.com.mt/ui_frontend/profile_thumbnail/40/40/matthew_vella_1645462508_zoom.jpg" />
</div>
</div>
<div class="col-xs-11">
<div class="text">
Matthew Vella is executive editor at MaltaToday. </div>
<div class="socialmedia">
<span class="link readmore"> <a href="/author/matthew_vella/">More from Matthew Vella</a></span>
<span class="link twitter"><i class="fa fa-twitter twitter"></i> <a href="http://www.twitter.com/matt_vella" target="_blank">Matthew on Twitter</a></span> </div>
</div>
</div>
</div>
</div>
</div><div class='mt_module' data-module-name='comments' data-update-frequency='0'><div class="OUTBRAIN" data-widget-id="GS_5"></div>
<script type="text/javascript" async="async" src="//widgets.outbrain.com/outbrain.js"></script>
<div id="disqus_thread"></div>
<script type="text/javascript">

    var disqus_config = function () {

        
            // The generated payload which authenticates users with Disqus
            this.page.remote_auth_s3 = 'eyJpZCI6InVzZXJfIiwidXNlcm5hbWUiOiIgIiwiZW1haWwiOm51bGx9 1c5c6321115041112617809e8e83bf2b40df47d6 1666080057';
            this.page.api_key = 'KKsrhxY6LSXy3nbzit54YG6MHLFaxrOJ42o6hFm3W1sUtwGMqjEzqyO5HBu9sxTW';

                this.page.identifier = 'article_119269';
        this.sso = {
            name:   "MaltaToday.com.mt",
            button:  "https://www.maltatoday.com.mt/ui/images/frontend/disqus_button.png",
            icon:     "https://www.maltatoday.com.mt/ui/images/icons/Icon-Small@2x.png",
            url:      "https://www.maltatoday.com.mt/ui_frontend/login/",
            logout:  "https://www.maltatoday.com.mt/ui_frontend/disquslogout/",
            width:   "867",
            height:  "152"
        };
    };

    var disqus_shortname = 'malta-today';

    (function() {
        var dsq = document.createElement('script'); dsq.type = 'text/javascript'; dsq.async = true;
        dsq.src = '//' + disqus_shortname + '.disqus.com/embed.js';
        (document.getElementsByTagName('head')[0] || document.getElementsByTagName('body')[0]).appendChild(dsq);
    })();
</script>
</div></div> </div>
<div class="col-lg-2 col-md-2">
<div class="zone" data-zone-name="Right" data-zone-id="right"></div> </div>
</div>
<div class="row">
<div class="col-lg-12 col-md-12">
<div class="zone" data-zone-name="Bottom" data-zone-id="bottom"></div> </div>
</div>
</div>
</section></div>
<footer class="hidden-xs">
<div class="container">
<div class="row">
<div class="col-xs-12 col-sm-6">
<div class="footer-logo">
<a href="/"> <img src="/ui/images/frontend/maltatoday_logo_white.png" /></a>
</div>
</div>
<div class="col-xs-12 col-sm-6">
<div class="social-icons">
<div class="icon facebook">
<a href="//facebook.com/maltatoday" target="_blank"><i class="fa fa-facebook"></i></a>
</div>
<div class="icon twitter">
<a href="//twitter.com/maltatoday" target="_blank"><i class="fa fa-twitter"></i></a>
</div>
<div class="icon instagram">
<a href="//www.instagram.com/maltatoday" target="_blank"><i class="fa fa-instagram"></i></a>
</div>
<div class="icon youtube">
<a href="//www.youtube.com/user/ReporterMediaToday" target="_blank"><i class="fa fa-youtube"></i></a>
</div>
<div class="icon googleplus">
<a href="//plus.google.com/113527506098764625850" target="_blank"><i class="fa fa-google-plus"></i></a>
</div>
</div>
</div>
</div>
<div class="row">
<div class="col-xs-12">
<ul class="bottom-nav">
<li><a href="/about-us/">About Us</a></li>
<li><a href="/advertising/">Advertise</a> </li>
<li><a href="/contact/">Contact</a> </li>
<li><a href="/maltatodaydigitaledition/">Digital Edition</a></li>
<li><a href="/subscribe_sms/">SMS Alerts</a></li>
</ul>
<ul class="bottom-links">
<li><a href="/terms-and-conditions/">Terms and Conditions</a> </li>
<li><a href="/privacy-policy/">Privacy Policy</a> </li>
<li><a href="/privacy-policy/">Cookie Policy</a> </li>
<li><a target="_blank" href="http://archive.maltatoday.com.mt/archive.html">Archives</a></li>
</ul>
</div>
</div>
<div class="row">
<div class="col-md-12">
<div class="copyright">
MediaToday is an independent media house based in Malta. Copyright © MediaToday Co. Ltd, Vjal ir-Rihan, San Gwann SGN 9016, Malta, Europe <br />
Reproduction of material from this website without written permission is strictly prohibited.
</div>
</div>
</div>
</div>
</footer>
<div class="floating-bar" data-cookie-name="cookie_notice">
<div class="container">
<div class="message-inner">
<a href="https://www.maltatoday.com.mt/privacy-policy/" target="_blank" class="set-close">
By using this site, you agree to our Privacy Policy including the use of cookies to enhance your experience. </a>
<button class="message-close-btn set-close">
<i class="fa fa-times close"></i>
</button>
</div>
</div>
</div>
<script type="text/javascript" src="//imasdk.googleapis.com/js/sdkloader/ima3.js"></script>
<script type="text/javascript" src="/dist/js/packages.min.js?v=15.2022"></script>
<script>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</script>

<script type="text/javascript">
_atrk_opts = { atrk_acct:"io5hj1aAkN00oK", domain:"maltatoday.com.mt",dynamic: true};
(function() { var as = document.createElement('script'); as.type = 'text/javascript'; as.async = true; as.src = "https://certify-js.alexametrics.com/atrk.js"; var s = document.getElementsByTagName('script')[0];s.parentNode.insertBefore(as, s); })();
</script>
<noscript><img src="https://certify.alexametrics.com/atrk.gif?account=io5hj1aAkN00oK" style="display:none" height="1" width="1" alt="" /></noscript>

<script type="text/javascript" src="/dist/js/app.min.js?v=15.2022"></script>
<script type="text/javascript">
    var _gaq = _gaq || [];
    _gaq.push(['_setAccount', 'UA-16977049-1']);
    _gaq.push(['_trackPageview']);

    (function () {
        var ga = document.createElement('script'); ga.type =
            'text/javascript'; ga.async = true;
        ga.src = ('https:' == document.location.protocol ? 'https://ssl' :
            'http://www') + '.google-analytics.com/ga.js';
        var s = document.getElementsByTagName('script')[0];
        s.parentNode.insertBefore(ga, s);
    })();
</script>
<script id="dsq-count-scr" src="//malta-today.disqus.com/count.js" async></script>
</body>
</html>
