<!DOCTYPE html>
<html xmlns="http://www.w3.org/1999/xhtml" lang="en">
<head>
<meta http-equiv="Content-Type" content="text/html; charset=utf-8">
<meta name="viewport" content="width=device-width, initial-scale=1.0" />
<meta property="fb:pages" content="21535456940" />
<meta property="fb:app_id" content="1775326929407925" />
<link rel="shortcut icon" type="image/x-icon" href="/ui/images/icons/Icon-Small@2x.png">
<link rel="apple-touch-icon" href="/ui/images/icons/Icon-60@2x.png" />
<link rel="apple-touch-icon" sizes="58x58" href="/ui/images/icons/Icon-Small@2x.png" />
<link rel="apple-touch-icon" sizes="76x76" href="/ui/images/icons/Icon-76.png" />
<link rel="apple-touch-icon" sizes="152x152" href="/ui/images/icons/Icon-76@2x.png" />
<link rel="apple-touch-icon" sizes="180x180" href="/ui/images/icons/Icon-60@3x.png" />
<link rel="icon" sizes="192x192" href="/ui/images/icons/icon-192x192.png" />
<link rel="stylesheet" href="/dist/css/desktop.min.css?v=1571911336" />
<link rel="canonical" href="https://www.maltatoday.com.mt/news/skinny/98193/an_event_loaded_with_political_cultural_social_and_emotional_resonance_that_cannot_be_ignored">
<meta property="og:site_name" content="MaltaToday.com.mt" />
<meta property="og:url" content="http://www.maltatoday.com.mt/news/skinny/98193/an_event_loaded_with_political_cultural_social_and_emotional_resonance_that_cannot_be_ignored" />
<meta property="og:title" content="An event loaded with political, cultural, social and emotional resonance that cannot be ignored" />
<meta property="og:description" content="No 6 &amp;bull;&amp;nbsp;The Daphne vigil" />
<meta property="og:type" content="article" />
<meta property="article:publisher" content="https://www.facebook.com/maltatoday" />
<meta property="og:image" content="http://cdn.maltatoday.com.mt/ui_frontend/thumbnail/684/400/who_killed_daphne.jpg" />
<meta name="description" content="No 6 &amp;bull;&amp;nbsp;The Daphne vigil" />
<script type="text/javascript">
        var cdn_url = "//content.maltatoday.com.mt";
    </script>
<title>An event loaded with political, cultural, social and emotional resonance that cannot be ignored</title>

<script async='async' src='https://www.googletagservices.com/tag/js/gpt.js'></script>
<script>
        var googletag = googletag || {};
        googletag.cmd = googletag.cmd || [];
    </script>
</head>
<body class="page-article">
<header>
<div class="zone" data-zone-name="TOPMOST" data-zone-id="TOPMOST"><div class='mt_module' data-module-name='code' data-update-frequency='0' data-module-settings-code='PGRpdiBjbGFzcz0idG9wLXNsYXNoIGRmcC1zbG90IiAKICAgICAgICAgICAgZGF0YS1wYXRoPSIvMTM0NzQ1NDUvTWFsdGFUb2RheV9bY2F0ZWdvcnldX0xlYWRlcmJvYXJkXzcyOHg5MCIKICAgICAgICAgICAgZGF0YS1zaXplPSJbWzcyOCwgOTBdLCBbOTcwLCA5MF0sIFs5NzAsIDI1MF0sIFszMjAsIDUwXSwgWzEzMjAsIDI1MF0sIFsxMTUwLCAyNTBdXSI+CiAgICAgICAgPC9kaXY+'><div class="code_module">
<div class="top-slash dfp-slot" data-path="/13474545/MaltaToday_news_Leaderboard_728x90" data-size="[[728, 90], [970, 90], [970, 250], [320, 50], [1320, 250], [1150, 250]]">
</div></div></div></div> <div class="main-nav">
<div class="main-nav-bg">
<div class="container">
<div class="row">
<div class="col-md-12">
<div class="row">
<div class="menu-bar news">
<div class="logo col-xs-7 col-md-2">
<a href="/"><img class="img-responsive" src="/ui/images/frontend/maltatoday_logo_news.png" alt="maltatoday" /></a>
</div>
<div class="col-xs-5 visible-sm visible-xs text-right">
<div id="more-menu">
menu
<button type="button" class="navbar-toggle" aria-expanded="false">
<span class="sr-only">Toggle navigation</span>
<span class="icon-bar"></span>
<span class="icon-bar"></span>
<span class="icon-bar"></span>
</button>
</div>
</div>
<ul class="main-menu">
<li class="menu-inline-search visible-xs">
<form action="/search-mt/" method="get">
<div class="col-xs-12">
<input type="text" name="q" class="form-control" placeholder="Search maltatoday.." />
</div>
</form>
</li>
<li class="menu_item home has-sub-menu">
<a href="/">
Home </a>
<div class="menu-item-detail-box">
<ul class="sub-menu">
<li><a href="http://frontpages.maltatoday.com.mt/">Today's Newspapers</a></li>
<li><a href="/vacancies">Jobs in Malta</a></li>
<li><a href="/deals">DealToday</a></li>
<li><a href="/pharmacies">Pharmacies</a></li>
<li><a href="/sponsored">Sponsored</a></li>
<li><a href="/announcements">Announcements</a></li>
<li><a href="/advertising">Advertise</a></li>
<li><a href="/contact">Contact</a></li>
<li><a href="/maltatodaydigitaledition">Digital Edition</a></li>
<li><a href="/subscribe_sms">SMS Alerts</a></li>
</ul>
</div>
</li>
<li class="menu_item news active has-sub-menu">
<a href="/news">
News </a>
<div class="menu-item-detail-box">
<ul class="sub-menu">
<li><a href="/news/national">National</a></li>
<li><a href="/news/europe">Europe</a></li>
<li><a href="/news/world">World</a></li>
<li><a href="/news/court_and_police">Court &amp; Police</a></li>
<li><a href="/news/interview">Interview</a></li>
<li><a href="/news/data_and_surveys">Data &amp; Survey</a></li>
<li><a href="/news/skinny">The Skinny</a></li>
<li><a href="/news/xtra">Xtra</a></li>
<li><a href="/news/budget-2020">Budget 2020</a></li>
</ul>
<div class="detail-content-box hidden-sm hidden-xs">
<div class="sub-menu-latest-stories">
<div class="row">
<div class="col-md-6">
<div class="left-section">
<div class="top-story-container">
<div class="photo">
<a href="/news/skinny/98193/an_event_loaded_with_political_cultural_social_and_emotional_resonance_that_cannot_be_ignored"><img src="//content.maltatoday.com.mt/ui_frontend/thumbnail/400/220/who_killed_daphne.jpg" /></a>
</div>
<div class="title">
<span class="category">The Skinny</span> <a href="/news/skinny/98193/an_event_loaded_with_political_cultural_social_and_emotional_resonance_that_cannot_be_ignored">
An event loaded with political, cultural, social and emotional resonance that cannot be ignored</a>
</div>
</div>
</div>
</div>
<div class="col-md-6">
<div class="right-section">
<ul class="stories">
<li class="story">
<div class="story-content">
<div class="image">
<a href="/news/xtra/98229/watch_malta_can_be_the_flagbearer_for_climate_change_in_the_mediterranean_jason_azzopardi_says"><img src="//content.maltatoday.com.mt/ui_frontend/thumbnail/62/62/2_screen_shot_2019-10-24_at_17.34.29.png" /></a>
</div>
<div class="text">
<a href="/news/xtra/98229/watch_malta_can_be_the_flagbearer_for_climate_change_in_the_mediterranean_jason_azzopardi_says">
<span class="category">Xtra</span>
<span class="title"> [WATCH] Malta can be the flag-bearer for climate change in the Mediterranean, Jason Azzopardi says</span>
</a>
</div>
</div>
</li>
<li class="story">
<div class="story-content">
<div class="image">
<a href="/news/national/98152/where_will_it_all_dovetail_revisiting_the_criminal_landscape_preceding_the_caruana_galizia_assassination"><img src="//content.maltatoday.com.mt/ui_frontend/thumbnail/62/62/14_jpb_8299.jpg" /></a>
</div>
<div class="text">
<a href="/news/national/98152/where_will_it_all_dovetail_revisiting_the_criminal_landscape_preceding_the_caruana_galizia_assassination">
<span class="category">National</span>
<span class="title"> ‘Where will it all dovetail?’ Revisiting the criminal landscape preceding the Caruana Galizia assassination</span>
</a>
</div>
</div>
</li>
<li class="story">
<div class="story-content">
 <div class="image">
<a href="/news/xtra/98230/government_brought_migrant_crisis_on_itself_beppe_fenech_adami_says"><img src="//content.maltatoday.com.mt/ui_frontend/thumbnail/62/62/screen_shot_2019-10-24_at_19.35.20.png" /></a>
</div>
<div class="text">
<a href="/news/xtra/98230/government_brought_migrant_crisis_on_itself_beppe_fenech_adami_says">
<span class="category">Xtra</span>
<span class="title"> Government brought migrant crisis on itself, Beppe Fenech Adami says</span>
</a>
</div>
</div>
</li>
</ul>
<a href="/news">More in News <i class="fa fa-angle-right"></i></a>
</div>
</div>
</div>
</div>
</div>
</div>
</li>
<li class="menu_item business has-sub-menu">
<a href="/business">
Business </a>
<div class="menu-item-detail-box">
<ul class="sub-menu">
<li><a href="/business/business_news">Business News</a></li>
<li><a href="/business/business_comment">Business Comment</a></li>
<li><a href="/business/technology">Technology</a></li>
<li><a href="/business/law_report">Law Report</a></li>
</ul>
<div class="detail-content-box hidden-sm hidden-xs">
<div class="sub-menu-latest-stories">
<div class="row">
<div class="col-md-6">
<div class="left-section">
<div class="top-story-container">
<div class="photo">
<a href="/business/law_report/98158/bills_of_exchange_will_not_be_enforced__is_they_are_a_result_of_usury"><img src="//content.maltatoday.com.mt/ui_frontend/thumbnail/400/220/2_law_report.png" /></a>
</div>
<div class="title">
<span class="category">Law Report</span> <a href="/business/law_report/98158/bills_of_exchange_will_not_be_enforced__is_they_are_a_result_of_usury">
Bills of Exchange will not be enforced if they are a result of usury</a>
</div>
</div>
</div>
</div>
<div class="col-md-6">
<div class="right-section">
<ul class="stories">
<li class="story">
<div class="story-content">
<div class="image">
<a href="/business/business_news/98218/lufthansa_technik_to_build_hangar_create_90_new_jobs"><img src="//content.maltatoday.com.mt/ui_frontend/thumbnail/62/62/new-hangar-inaugurated-at-lufthansa-technik-malta-20131121.png" /></a>
</div>
<div class="text">
<a href="/business/business_news/98218/lufthansa_technik_to_build_hangar_create_90_new_jobs">
<span class="category">Business News</span>
<span class="title"> Lufthansa Technik to build hangar, create 90 new jobs</span>
</a>
</div>
</div>
</li>
<li class="story">
<div class="story-content">
<div class="image">
<a href="/business/business_news/98214/venezuela_dirty_money_probe_mfsa_ordered_to_finalise_portmann_review"><img src="//content.maltatoday.com.mt/ui_frontend/thumbnail/62/62/4_nicolas_maduro.jpg" /></a>
</div>
<div class="text">
<a href="/business/business_news/98214/venezuela_dirty_money_probe_mfsa_ordered_to_finalise_portmann_review">
<span class="category">Business News</span>
<span class="title"> Venezuela dirty money probe: MFSA ordered to finalise Portmann review</span>
</a>
</div>
</div>
</li>
<li class="story">
<div class="story-content">
<div class="image">
<a href="/business/business_comment/98209/justin_trudeau_wins_second_term_in_canada_election__calamatta_cuschieri"><img src="//content.maltatoday.com.mt/ui_frontend/thumbnail/62/62/27_picture1.png" /></a>
</div>
<div class="text">
<a href="/business/business_comment/98209/justin_trudeau_wins_second_term_in_canada_election__calamatta_cuschieri">
<span class="category">Business Comment</span>
<span class="title"> Justin Trudeau wins second term in Canada election | Calamatta Cuschieri</span>
</a>
</div>
</div>
</li>
</ul>
<a href="/business">More in Business <i class="fa fa-angle-right"></i></a>
</div>
</div>
</div>
</div>
</div>
</div>
</li>
<li class="menu_item sports has-sub-menu">
<a href="/sports">
Sports </a>
<div class="menu-item-detail-box">
<ul class="sub-menu">
<li><a href="/worldcup2018">World Cup 2018</a></li>
<li><a href="/sports/football">Football</a></li>
<li><a href="/sports/rugby">Rugby</a></li>
<li><a href="/sports/motorsports">Motor Sports</a></li>
<li><a href="/sports/boxing">Boxing</a></li>
<li><a href="/sports/tennis">Tennis</a></li>
<li><a href="/sports/cricket">Cricket</a></li>
</ul>
<div class="detail-content-box hidden-sm hidden-xs">
<div class="sub-menu-latest-stories">
<div class="row">
<div class="col-md-6">
<div class="left-section">
<div class="top-story-container">
<div class="photo">
<a href="/sports/football/98170/bov_premier_league__hibernians_1__hamrun_spartans_2"><img src="//content.maltatoday.com.mt/ui_frontend/thumbnail/400/220/img_3916.jpg" /></a>
</div>
<div class="title">
<span class="category">Football</span> <a href="/sports/football/98170/bov_premier_league__hibernians_1__hamrun_spartans_2">
BOV Premier League | Hibernians 1 – Hamrun Spartans 2</a>
</div>
</div>
</div>
</div>
<div class="col-md-6">
<div class="right-section">
<ul class="stories">
<li class="story">
<div class="story-content">
<div class="image">
<a href="/sports/football/98132/bov_premier_league__balzan_3__tarxien_rainbows_1"><img src="//content.maltatoday.com.mt/ui_frontend/thumbnail/62/62/at0i7211.jpg" /></a>
</div>
<div class="text">
<a href="/sports/football/98132/bov_premier_league__balzan_3__tarxien_rainbows_1">
<span class="category">Football</span>
<span class="title"> BOV Premier League | Balzan 3 – Tarxien Rainbows 1</span>
</a>
</div>
</div>
</li>
<li class="story">
<div class="story-content">
<div class="image">
<a href="/sports/football/98131/bov_premier_league__gudja_united_0__valletta_1"><img src="//content.maltatoday.com.mt/ui_frontend/thumbnail/62/62/at0i6920.jpg" /></a>
</div>
<div class="text">
<a href="/sports/football/98131/bov_premier_league__gudja_united_0__valletta_1">
<span class="category">Football</span>
<span class="title"> BOV Premier League | Gudja United 0 – Valletta 1</span>
</a>
</div>
</div>
</li>
<li class="story">
<div class="story-content">
<div class="image">
<a href="/sports/othersports/98129/rolex_middle_sea_race_heads_into_the_second_day_of_the_competition_"><img src="//content.maltatoday.com.mt/ui_frontend/thumbnail/62/62/72789523_2979430752071548_4856003631037546496_o.jpg" /></a>
</div>
<div class="text">
<a href="/sports/othersports/98129/rolex_middle_sea_race_heads_into_the_second_day_of_the_competition_">
<span class="category">Other Sports</span>
<span class="title"> Rolex Middle Sea Race heads into the second day of the competition</span>
</a>
</div>
</div>
</li>
</ul>
<a href="/sports">More in Sports <i class="fa fa-angle-right"></i></a>
</div>
</div>
</div>
</div>
</div>
</div>
</li>
<li class="menu_item arts has-sub-menu">
<a href="/arts">
Arts </a>
<div class="menu-item-detail-box">
<ul class="sub-menu">
<li><a href="/arts/art">Art</a></li>
<li><a href="/arts/books">Books</a></li>
<li><a href="/arts/entertainment">Entertainment</a></li>
<li><a href="/arts/music">Music</a></li>
<li><a href="/arts/theatre_and_dance">Theatre &amp; Dance</a></li>
<li><a href="/arts/film">Film</a></li>
<li><a href="/arts/cultural_diary">Cultural Diary</a></li>
<li><a href="/arts/valletta_2018">Valletta 2018</a></li>
</ul>
<div class="detail-content-box hidden-sm hidden-xs">
<div class="sub-menu-latest-stories">
<div class="row">
<div class="col-md-6">
<div class="left-section">
<div class="top-story-container">
<div class="photo">
<a href="/arts/music/98156/remembering_piazzola__fiorella_camilleri"><img src="//content.maltatoday.com.mt/ui_frontend/thumbnail/400/220/ef7b1147-1.jpg" /></a>
</div>
<div class="title">
<span class="category">Music</span> <a href="/arts/music/98156/remembering_piazzola__fiorella_camilleri">
Remembering Piazzola | Fiorella Camilleri</a>
</div>
</div>
</div>
</div>
<div class="col-md-6">
<div class="right-section">
<ul class="stories">
 <li class="story">
<div class="story-content">
<div class="image">
<a href="/arts/film/98157/film_review_joker_the_burning_powder_keg_of_our_modern_times"><img src="//content.maltatoday.com.mt/ui_frontend/thumbnail/62/62/film_review_overlay(17).png" /></a>
</div>
<div class="text">
<a href="/arts/film/98157/film_review_joker_the_burning_powder_keg_of_our_modern_times">
<span class="category">Film</span>
<span class="title"> Film Review | Joker: The burning powder keg of our modern times</span>
</a>
</div>
</div>
</li>
<li class="story">
<div class="story-content">
<div class="image">
<a href="/arts/books/98154/i_am_not_afraid_to_speak__rosemarie_aquilina"><img src="//content.maltatoday.com.mt/ui_frontend/thumbnail/62/62/2_rosemarie_aquilina_cropped.jpg" /></a>
</div>
<div class="text">
<a href="/arts/books/98154/i_am_not_afraid_to_speak__rosemarie_aquilina">
<span class="category">Books</span>
<span class="title"> ‘I am not afraid to speak’ | Rosemarie Aquilina</span>
</a>
</div>
</div>
</li>
<li class="story">
<div class="story-content">
<div class="image">
<a href="/arts/theatre_and_dance/98088/come_un_granello_di_sabbia_the_story_of_the_alcamo_marina_massacre_for_malta_staging"><img src="//content.maltatoday.com.mt/ui_frontend/thumbnail/62/62/massimo-barilla-salvatore-arena-1024x686.jpg" /></a>
</div>
<div class="text">
<a href="/arts/theatre_and_dance/98088/come_un_granello_di_sabbia_the_story_of_the_alcamo_marina_massacre_for_malta_staging">
<span class="category">Theatre & Dance</span>
<span class="title"> ‘Come un granello di sabbia’, the story of the Alcamo Marina Massacre, for Malta staging</span>
</a>
</div>
</div>
</li>
</ul>
<a href="/arts">More in Arts <i class="fa fa-angle-right"></i></a>
</div>
</div>
</div>
</div>
</div>
</div>
</li>
<li class="menu_item comment has-sub-menu">
<a href="/comment">
Comment </a>
<div class="menu-item-detail-box">
<ul class="sub-menu">
<li><a href="/comment/blogs">Blogs</a></li>
<li><a href="/comment/editorial">Editorial</a></li>
<li><a href="/comment/letters">Letters</a></li>
<li><a href="/comment/cartoons">Cartoons</a></li>
</ul>
<div class="detail-content-box hidden-sm hidden-xs">
<div class="sub-menu-latest-stories">
<div class="row">
<div class="col-md-6">
<div class="left-section">
<div class="top-story-container">
<div class="photo">
<a href="/comment/blogs/98215/only_the_lonely"><img src="//content.maltatoday.com.mt/ui_frontend/thumbnail/400/220/istock_000007951394medium-1237a54f46a726596a671126b7998511e1e9324b-s800-c85.jpg" /></a>
</div>
<div class="title">
<span class="category">Blogs</span> <a href="/comment/blogs/98215/only_the_lonely">
Only the lonely</a>
</div>
</div>
</div>
</div>
<div class="col-md-6">
<div class="right-section">
<ul class="stories">
<li class="story">
<div class="story-content">
<div class="image">
<a href="/comment/blogs/98198/chronicle_of_a_riot_foretold"><img src="//content.maltatoday.com.mt/ui_frontend/thumbnail/62/62/opinion_raphael_vassallo.png" /></a>
</div>
<div class="text">
<a href="/comment/blogs/98198/chronicle_of_a_riot_foretold">
<span class="category">Blogs</span>
<span class="title"> Chronicle of a riot foretold</span>
</a>
</div>
</div>
</li>
<li class="story">
<div class="story-content">
<div class="image">
<a href="/comment/blogs/98190/climate_change__beyond_the_empty_rhetoric"><img src="//content.maltatoday.com.mt/ui_frontend/thumbnail/62/62/screen_shot_2019-10-23_at_07.50.27.png" /></a>
</div>
<div class="text">
<a href="/comment/blogs/98190/climate_change__beyond_the_empty_rhetoric">
<span class="category">Blogs</span>
<span class="title"> Climate change - beyond the empty rhetoric</span>
</a>
</div>
</div>
</li>
<li class="story">
<div class="story-content">
<div class="image">
<a href="/comment/editorial/98189/an_explosive_powderkeg_that_must_be_defused"><img src="//content.maltatoday.com.mt/ui_frontend/thumbnail/62/62/maltatoday_editorial.png" /></a>
</div>
<div class="text">
<a href="/comment/editorial/98189/an_explosive_powderkeg_that_must_be_defused">
<span class="category">Editorial</span>
<span class="title"> An explosive powder-keg that must be defused</span>
</a>
</div>
</div>
</li>
</ul>
<a href="/comment">More in Comment <i class="fa fa-angle-right"></i></a>
</div>
</div>
</div>
</div>
</div>
</div>
</li>
<li class="menu_item videos">
<a href="/videos">
Video </a>
</li>
<li class="menu_item archives">
<a href="http://archive.maltatoday.com.mt" target="_blank">
Archives </a>
</li>
<li class="menu_item gourmet-today">
<a href="/lifestyle/food">
<img src="/ui/images/frontend/maltatoday_logo_gourmet.png" alt="Gourmet" />
</a>
</li>
<li class="menu_item frontpages visible-xs">
<a href="http://frontpages.maltatoday.com.mt">
Frontpages </a>
</li>
<li class="menu_item deal-today visible-xs visible-sm">
<a href="/deals">
DealToday </a>
</li>
<li class="menu_item login visible-xs visible-sm login-menu-item">
<a href="/maltatodaydigitaledition/">
Login to Digital Edition </a>
</li>
</ul>
<div class="menu-icons hidden-xs hidden-sm">
<div class="menu-icons-icon search-icon" onclick="$(this).addClass('active').find('input').focus()">
<span class="fa fa-search"></span>
<div class="searchbox">
<form action="/search-mt/" method="get">
<input type="text" name="q" placeholder="Search" onblur="$(this).parents('.search-icon').removeClass('active');" onkeyup="if (event.keyCode === 27) { $(this).blur(); }" />
<button type="submit">
<i class="fa fa-search search_now"></i>
</button>
</form>
</div>
</div>
<div class="menu-icons-icon login-icon">
<a href="/maltatodaydigitaledition/" class="btn btn-red">Login</a>
</div>
</div>
</div>
</div>
<div id="small-menu-placeholder" class="row visible-xs visible-sm news">
<div id="small-menu">
<a href="/">home</a>
<a href="/news">news</a>
<a class="highlight" href="/maltatodaydigitaledition">login</a>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
<div class="sub-nav">
<div class="container">
<ul class="hidden-xs outer-sub-menu sub-menu news">
<li><a href="/news/national">National</a></li>
<li><a href="/news/europe">Europe</a></li>
<li><a href="/news/world">World</a></li>
<li><a href="/news/court_and_police">Court &amp; Police</a></li>
<li><a href="/news/interview">Interview</a></li>
<li><a href="/news/data_and_surveys">Data &amp; Survey</a></li>
<li><a href="/news/skinny">The Skinny</a></li>
<li><a href="/news/xtra">Xtra</a></li>
<li><a href="/news/budget-2020">Budget 2020</a></li>
</ul>
</div>
</div>
</header>
<div id="content">
<section>
<div class="container">
<div class="row">
<div class="col-lg-12 col-md-12">
<div class="zone" data-zone-name="Top" data-zone-id="top"><div class='mt_module' data-module-name='article_breadcrumb' data-update-frequency='0'><ul class="breadcrumb">
<li class="breadcrumb-item news"><a href="/news/">News</a></li>
<li class="breadcrumb-item news"><a href="/news/skinny/">The Skinny</a></li>
</ul></div><div class='mt_module' data-module-name='article_heading' data-update-frequency='0'><div class="article-heading">
<div class="row">
<div class="col-md-12">
<h1>An event loaded with political, cultural, social and emotional resonance that cannot be ignored</h1>
<h2><p>No 6 &bull;&nbsp;The Daphne vigil</p></h2>
</div>
</div>
</div>
</div></div> </div>
</div>
<div class="row">
<div class="col-lg-2 col-md-2">
<div class="zone" data-zone-name="Left" data-zone-id="left"><div class='mt_module' data-module-name='article_meta' data-update-frequency='0'><div class="article-meta">
<div class="date-text">
<span class="date">25 October 2019, 7:34am</span>
</div>
</div></div><div class='mt_module' data-module-name='addthis' data-update-frequency='0'> <script type="text/javascript" src="//s7.addthis.com/js/300/addthis_widget.js#pubid=ra-5a7023510fcc04af"></script>
</div></div> </div>
<div class="col-lg-8 col-md-8">
<div class="zone" data-zone-name="Main" data-zone-id="content"><div class='mt_module' data-module-name='article_cover' data-update-frequency='0'><div class="full-article article-cover">
<div class="photo_collection_cover article-cover-media single-cover" data-slick='{"slidesToShow": 1, "slidesToScroll": 1}'>
<div class="media-item show ">
<div class="cover-photo" title="" style="background-image: url('//content.maltatoday.com.mt/ui/images/photos/who_killed_daphne.jpg')">
<img src="//content.maltatoday.com.mt/ui_frontend/thumbnail/684/0/who_killed_daphne.jpg" alt="" />
</div>
</div>
</div>
</div></div><div class='mt_module' data-module-name='small_share_buttons' data-update-frequency='0'><div class="row">
<div class="col-md-6">
</div>
<div class="col-md-6">
<div class="small_share_buttons text-right">
<a class="addthis_button_facebook_like" fb:like:layout="button_count" style="position:relative; top: 4px; padding: 0px; right: -10px;"></a>
<script type="text/javascript">var addthis_config = {"data_track_addressbar":true};</script>
<script type="text/javascript" src="//s7.addthis.com/js/300/addthis_widget.js#pubid=seekopia"></script>
<a class="twitter" href="https://twitter.com/share?url=https://www.maltatoday.com.mt/news/skinny/98193/an_event_loaded_with_political_cultural_social_and_emotional_resonance_that_cannot_be_ignored&text=An event loaded with political, cultural, social and emotional resonance that cannot be ignored" target="_blank">
<i class="fa fa-twitter"></i> TWEET
</a>
<a class="facebook" href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.maltatoday.com.mt%2Fnews%2Fskinny%2F98193%2Fan_event_loaded_with_political_cultural_social_and_emotional_resonance_that_cannot_be_ignored" target="_blank">
<i class="fa fa-facebook"></i> SHARE
</a>
</div>
</div>
</div></div><div class='mt_module' data-module-name='full_article' data-update-frequency='0'><div class="full-article">
<div class="content content-news"> <div class="dfp-slot" data-path="/13474545/MaltaToday_news_Inline_300x250" data-size="[[300, 250]]" style="float:right; margin:8px 0 8px 25px">
</div>
<p><strong>What are we skinning?</strong> The commemorative vigil in honour of slain journalist Daphne Caruana Galizia, who was murdered by car bomb on October 16, 2017.
</p><p><strong>Why are we skinning it?</strong> It&rsquo;s an event loaded with political, cultural, social and emotional resonance that simply cannot be ignored, not least because of the international speakers addressing the enormous crowd in Valletta.
</p><p><strong>So you&rsquo;re gonna make fun of it? </strong>Not at all. The murder of a journalist, however complex, controversial and misunderstood her legacy may be, is no laughing matter. But there&rsquo;&rsquo; a lot that can be explored between the interstices of the narratives forming around all of that, and last Thursday&rsquo;s vigil was another example of just how true that is.
</p><p><strong>How do you mean?</strong> Well, for starters we had former MEP Ana Gomez come up to speak, and one of her rallying cries was, &ldquo;I am a socialist, and I&rsquo;m proud to be a socialist!&rdquo; &ndash; a puzzling bit of political positioning given Caruana Galizia&rsquo;s own discomfort, if not outright disdain, of socialist principles...
</p><p><strong>But surely an act as shocking as Daphne&rsquo;s murder should force us to step aside from comparatively petty &ndash; even &lsquo;academic&rsquo; &ndash; political semantics, and just focus on healing and prevention?</strong> Yes, but with a figure as strongly etched into the Maltese psyche as Caruana Galizia was, it is difficult for politics not to worm its way through.
</p><p><strong>An international perspective always helps though, right?</strong> Getting the Mayor of Palermo and a Sicilian anti-mafia priest to speak should focus our mind on the issues at hand, surely? In theory, yes, and their impassioned speeches were adequately rousing calls for social justice. But these performances also point towards the danger of generalising Daphne&rsquo;s legacy far too much.
</p><p><strong>Generalising? </strong>To put it plainly, their speeches could have been copy/pasted commemorations to any fallen figure who died in circumstances that suggest institutional corruption may have had a hand in the assassination. As ever, international attention on the Daphne case appears to hinge on a lack of specificity, which has the unfortunate &ndash; even if it may be unwitting &ndash; side-effect of intellectual dishonesty. &nbsp;
</p><p><strong>Do say:</strong> &ldquo;The murder of Daphne Caruana Galizia was both a viscerally horrific and nationally traumatising tragedy, and we should all give ourselves the space to process it with goodwill and a calm mind, while remaining vigilant over the powers-to-be, ensuring that such a thing never happens again in an EU member state that claims to hold freedom of speech as sacred.&rdquo;
</p><p><strong>Don&rsquo;t say: </strong>&ldquo;Daphne is a martyr and deserves unquestioning and unreconstructed adulation/Daphne was a Labour-bashing propagandist and a gossip blogger with classist tendencies so her legacy is hopelessly tarnished. Nuance and complexity is banned from the discussion on pain of social ostracism.&rdquo;</p><p></p> </div>
</div></div><div class='mt_module' data-module-name='code' data-update-frequency='0' data-module-settings-code='PGRpdiBjbGFzcz0ic3BsaXQtYWR2ZXJ0IGRmcC1zbG90IiAKICAgICAgICAgICAgZGF0YS1wYXRoPSIvMTM0NzQ1NDUvTWFsdGFUb2RheV9bY2F0ZWdvcnldX0FydGljbGVMZWFkZXJib2FyZCIKICAgICAgICAgICAgZGF0YS1zaXplPSJbWzcyOCwgOTBdLCBbMzIwLCA1MF1dIj4KICAgICAgICA8L2Rpdj4='><div class="code_module">
<div class="split-advert dfp-slot" data-path="/13474545/MaltaToday_news_ArticleLeaderboard" data-size="[[728, 90], [320, 50]]">
</div></div></div><div class='mt_module' data-module-name='article_author_bios' data-update-frequency='0'> <div class="article-author-bio">
</div>
</div><div class='mt_module' data-module-name='boxed_title' data-update-frequency='0' data-module-settings-text='More in {subcategory}'> <div class="boxed-title">
<span class="title-text">
More in The Skinny </span>
</div>
</div><div class='mt_module' data-module-name='small_article' data-update-frequency='0' data-module-settings-amount='4' data-module-settings-show_photo='1' data-module-settings-show_author='1' data-module-settings-show_category='1' data-module-settings-show_inset_category='0' data-module-settings-show_standfirst='1'><div class="responsive-articles small-articles">
<div class="article small-article open_url news-article" data-url="/news/skinny/98193/an_event_loaded_with_political_cultural_social_and_emotional_resonance_that_cannot_be_ignored">
<div class="image" style="background-image: url('//content.maltatoday.com.mt/ui_frontend/thumbnail/684/0/who_killed_daphne.jpg');">
<img src="//content.maltatoday.com.mt/ui_frontend/thumbnail/684/0/who_killed_daphne.jpg" alt="An event loaded with political, cultural, social and emotional resonance that cannot be ignored" />
</div>
<div class="details" style="padding-right: 25px;">
<div class="extra-info">
<span class="category news">The Skinny</span>
</div>
<div class="title">
<a href="/news/skinny/98193/an_event_loaded_with_political_cultural_social_and_emotional_resonance_that_cannot_be_ignored"><h3>An event loaded with political, cultural, social and emotional resonance that cannot be ignored</h3></a>
</div>
</div>
</div>
<div class="article small-article open_url news-article" data-url="/news/skinny/98001/weepy_ballads_strummy_guitars_and_the_occasional_outoftune_dud_but_where_are_the_buzzers">
<div class="image" style="background-image: url('//content.maltatoday.com.mt/ui_frontend/thumbnail/684/0/x_factor_presenters.png');">
<img src="//content.maltatoday.com.mt/ui_frontend/thumbnail/684/0/x_factor_presenters.png" alt="Weepy ballads, strummy guitars and the occasional out-of-tune dud. But where are the buzzers?" />
</div>
<div class="details" style="padding-right: 25px;">
<div class="extra-info">
<span class="category news">The Skinny</span>
</div>
<div class="title">
<a href="/news/skinny/98001/weepy_ballads_strummy_guitars_and_the_occasional_outoftune_dud_but_where_are_the_buzzers"><h3>Weepy ballads, strummy guitars and the occasional out-of-tune dud. But where are the buzzers?</h3></a>
</div>
</div>
</div>
<div class="article small-article open_url news-article" data-url="/news/skinny/97876/corporate_peddling_partisan_politics_and_a_small_and_apparently_dangerous_smidgen_of_student_activism">
<div class="image" style="background-image: url('//content.maltatoday.com.mt/ui_frontend/thumbnail/684/0/graffitti_freshers_week_2019.jpeg');">
<img src="//content.maltatoday.com.mt/ui_frontend/thumbnail/684/0/graffitti_freshers_week_2019.jpeg" alt="Corporate peddling, partisan politics and a small, and apparently dangerous, smidgen of student activism" />
</div>
<div class="details" style="padding-right: 25px;">
<div class="extra-info">
<span class="category news">The Skinny</span>
</div>
<div class="title">
<a href="/news/skinny/97876/corporate_peddling_partisan_politics_and_a_small_and_apparently_dangerous_smidgen_of_student_activism"><h3>Corporate peddling, partisan politics and a small, and apparently dangerous, smidgen of student activism</h3></a>
</div>
</div>
</div>
<div class="article small-article open_url news-article" data-url="/news/skinny/97777/freshers_week_reduced_to_showcase_for_commercial_and_business_institutions">
<div class="image" style="background-image: url('//content.maltatoday.com.mt/ui_frontend/thumbnail/684/0/graffitti_freshers_week_2019.jpeg');">
<img src="//content.maltatoday.com.mt/ui_frontend/thumbnail/684/0/graffitti_freshers_week_2019.jpeg" alt="Freshers’ Week reduced to ‘showcase for commercial and business institutions’" />
</div>
<div class="details" style="padding-right: 25px;">
<div class="extra-info">
<span class="category news">The Skinny</span>
</div>
<div class="title">
<a href="/news/skinny/97777/freshers_week_reduced_to_showcase_for_commercial_and_business_institutions"><h3>Freshers’ Week reduced to ‘showcase for commercial and business institutions’</h3></a>
</div>
<div class="extra-info">
<span class="author news">MaltaToday Staff </span>
</div>
</div>
</div>
</div>
</div><div class='mt_module' data-module-name='code' data-update-frequency='0' data-module-settings-code='PGRpdiBpZD0icmMtd2lkZ2V0LTllZWU1OSIgZGF0YS1yYy13aWRnZXQgZGF0YS13aWRnZXQtaG9zdD0iaGFiaXRhdCIgZGF0YS1lbmRwb2ludD0iLy90cmVuZHMucmV2Y29udGVudC5jb20iIGRhdGEtd2lkZ2V0LWlkPSI4MzQ1MSI+PC9kaXY+CjxzY3JpcHQgdHlwZT0idGV4dC9qYXZhc2NyaXB0IiBzcmM9Ii8vYXNzZXRzLnJldmNvbnRlbnQuY29tL21hc3Rlci9kZWxpdmVyeS5qcyIgZGVmZXI9ImRlZmVyIj48L3NjcmlwdD4='><div class="code_module">
<div id="rc-widget-9eee59" data-rc-widget data-widget-host="habitat" data-endpoint="//trends.revcontent.com" data-widget-id="83451"></div>
<script type="text/javascript" src="//assets.revcontent.com/master/delivery.js" defer="defer"></script></div></div><div class='mt_module' data-module-name='comments' data-update-frequency='0'><div id="disqus_thread"></div>
<script type="text/javascript">

    var disqus_config = function () {

        
            // The generated payload which authenticates users with Disqus
            this.page.remote_auth_s3 = 'eyJpZCI6InVzZXJfIiwidXNlcm5hbWUiOiIgIiwiZW1haWwiOm51bGx9 ba41dd7fe23be5b190e255571aadddd670077c9f 1571991416';
            this.page.api_key = 'KKsrhxY6LSXy3nbzit54YG6MHLFaxrOJ42o6hFm3W1sUtwGMqjEzqyO5HBu9sxTW';

                this.page.identifier = 'article_98193';
        this.sso = {
            name:   "MaltaToday.com.mt",
            button:  "https://www.maltatoday.com.mt/ui/images/frontend/disqus_button.png",
            icon:     "https://www.maltatoday.com.mt/ui/images/icons/Icon-Small@2x.png",
            url:      "https://www.maltatoday.com.mt/ui_frontend/login/",
            logout:  "https://www.maltatoday.com.mt/ui_frontend/disquslogout/",
            width:   "867",
            height:  "152"
        };
    };

    var disqus_shortname = 'malta-today';

    (function() {
        var dsq = document.createElement('script'); dsq.type = 'text/javascript'; dsq.async = true;
        dsq.src = '//' + disqus_shortname + '.disqus.com/embed.js';
        (document.getElementsByTagName('head')[0] || document.getElementsByTagName('body')[0]).appendChild(dsq);
    })();
</script>
</div></div> </div>
<div class="col-lg-2 col-md-2">
<div class="zone" data-zone-name="Right" data-zone-id="right"></div> </div>
</div>
<div class="row">
<div class="col-lg-12 col-md-12">
<div class="zone" data-zone-name="Bottom" data-zone-id="bottom"></div> </div>
</div>
</div>
</section></div>
<footer class="hidden-xs">
<div class="container">
<div class="row">
<div class="col-xs-12 col-sm-6">
<div class="footer-logo">
<a href="/"> <img src="/ui/images/frontend/maltatoday_logo_white.png" /></a>
</div>
</div>
<div class="col-xs-12 col-sm-6">
<div class="social-icons">
<div class="icon facebook">
<a href="//facebook.com/maltatoday" target="_blank"><i class="fa fa-facebook"></i></a>
</div>
<div class="icon twitter">
<a href="//twitter.com/maltatoday" target="_blank"><i class="fa fa-twitter"></i></a>
</div>
<div class="icon instagram">
<a href="//www.instagram.com/maltatoday" target="_blank"><i class="fa fa-instagram"></i></a>
</div>
<div class="icon youtube">
<a href="//www.youtube.com/user/ReporterMediaToday" target="_blank"><i class="fa fa-youtube"></i></a>
</div>
<div class="icon googleplus">
<a href="//plus.google.com/113527506098764625850" target="_blank"><i class="fa fa-google-plus"></i></a>
</div>
</div>
</div>
</div>
<div class="row">
<div class="col-xs-12">
<ul class="bottom-nav">
<li><a href="/about-us/">About Us</a></li>
<li><a href="/advertising/">Advertise</a> </li>
<li><a href="/contact/">Contact</a> </li>
<li><a href="/maltatodaydigitaledition/">Digital Edition</a></li>
<li><a href="http://frontpages.maltatoday.com.mt/">Today's Newspapers</a></li>
<li><a href="/subscribe_sms/">SMS Alerts</a></li>
</ul>
<ul class="bottom-links">
<li><a href="/terms-and-conditions/">Terms and Conditions</a> </li>
<li><a href="/privacy-policy/">Privacy Policy</a> </li>
<li><a href="/privacy-policy/">Cookie Policy</a> </li>
<li><a target="_blank" href="http://archive.maltatoday.com.mt/archive.html">Archives</a></li>
</ul>
</div>
</div>
<div class="row">
<div class="col-md-12">
<div class="copyright">
MediaToday is an independent media house based in Malta. Copyright © MediaToday Co. Ltd, Vjal ir-Rihan, San Gwann SGN 9016, Malta, Europe <br />
Reproduction of material from this website without written permission is strictly prohibited.
</div>
</div>
</div>
</div>
</footer>
<div class="floating-bar" data-cookie-name="cookie_notice">
<div class="container">
<div class="message-inner">
<a href="https://www.maltatoday.com.mt/privacy-policy/" target="_blank" class="set-close">
By using this site, you agree to our Privacy Policy including the use of cookies to enhance your experience. </a>
<button class="message-close-btn set-close">
<i class="fa fa-times close"></i>
</button>
</div>
</div>
</div>
<script type="text/javascript" src="//imasdk.googleapis.com/js/sdkloader/ima3.js"></script>
<script type="text/javascript" src="/dist/js/packages.min.js?v=1571911336"></script>
<script>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</script>

<script type="text/javascript">
_atrk_opts = { atrk_acct:"io5hj1aAkN00oK", domain:"maltatoday.com.mt",dynamic: true};
(function() { var as = document.createElement('script'); as.type = 'text/javascript'; as.async = true; as.src = "https://certify-js.alexametrics.com/atrk.js"; var s = document.getElementsByTagName('script')[0];s.parentNode.insertBefore(as, s); })();
</script>
<noscript><img src="https://certify.alexametrics.com/atrk.gif?account=io5hj1aAkN00oK" style="display:none" height="1" width="1" alt="" /></noscript>

<script type="text/javascript" src="/dist/js/app.min.js?v=1571911336"></script>
<script type="text/javascript">
    var _gaq = _gaq || [];
    _gaq.push(['_setAccount', 'UA-16977049-1']);
    _gaq.push(['_trackPageview']);

    (function () {
        var ga = document.createElement('script'); ga.type =
            'text/javascript'; ga.async = true;
        ga.src = ('https:' == document.location.protocol ? 'https://ssl' :
            'http://www') + '.google-analytics.com/ga.js';
        var s = document.getElementsByTagName('script')[0];
        s.parentNode.insertBefore(ga, s);
    })();
</script>
<script id="dsq-count-scr" src="//malta-today.disqus.com/count.js" async></script>
</body>
</html>
