<!DOCTYPE html>
<html xmlns="http://www.w3.org/1999/xhtml" lang="en">
<head>
<meta http-equiv="Content-Type" content="text/html; charset=utf-8">
<meta name="viewport" content="width=device-width, initial-scale=1.0" />
<meta property="fb:pages" content="21535456940" />
<meta property="fb:app_id" content="1775326929407925" />
<link rel="shortcut icon" type="image/x-icon" href="/ui/images/icons/Icon-Small@2x.png">
<link rel="apple-touch-icon" href="/ui/images/icons/Icon-60@2x.png" />
<link rel="apple-touch-icon" sizes="58x58" href="/ui/images/icons/Icon-Small@2x.png" />
<link rel="apple-touch-icon" sizes="76x76" href="/ui/images/icons/Icon-76.png" />
<link rel="apple-touch-icon" sizes="152x152" href="/ui/images/icons/Icon-76@2x.png" />
<link rel="apple-touch-icon" sizes="180x180" href="/ui/images/icons/Icon-60@3x.png" />
<link rel="icon" sizes="192x192" href="/ui/images/icons/icon-192x192.png" />
<link rel="stylesheet" href="/dist/css/desktop.min.css?v=1580122566" />
<link rel="canonical" href="https://www.maltatoday.com.mt/comment/blogs/100540/is_the_public_inquiry_working">
<meta property="og:site_name" content="MaltaToday.com.mt" />
<meta property="og:url" content="http://www.maltatoday.com.mt/comment/blogs/100540/is_the_public_inquiry_working" />
<meta property="og:title" content="Is the Caruana Galizia public inquiry really working?" />
<meta property="og:description" content="The public inquiry seems to be a show of na&amp;iuml;vet&amp;eacute; about what has been happening in the political world in Malta, on the powers of our political leaders, and on the great deception the former prime minister and his chief-of-staff managed to put up inside and out of Castille" />
<meta property="og:type" content="article" />
<meta property="article:publisher" content="https://www.facebook.com/maltatoday" />
<meta property="og:image" content="http://cdn.maltatoday.com.mt/ui_frontend/thumbnail/684/400/who_killed_daphne.jpg" />
<meta name="description" content="The public inquiry seems to be a show of na&amp;iuml;vet&amp;eacute; about what has been happening in the political world in Malta, on the powers of our political leaders, and on the great deception the former prime minister and his chief-of-staff managed to put up inside and out of Castille" />
<script type="text/javascript">
        var cdn_url = "//content.maltatoday.com.mt";
    </script>
<title>Is the Caruana Galizia public inquiry really working? | Saviour Balzan, 23 February 2020</title>

<script async='async' src='https://www.googletagservices.com/tag/js/gpt.js'></script>
<script>
        var googletag = googletag || {};
        googletag.cmd = googletag.cmd || [];
    </script>
</head>
<body class="page-article">
<header>
<div class="zone" data-zone-name="TOPMOST" data-zone-id="TOPMOST"><div class='mt_module' data-module-name='code' data-update-frequency='0' data-module-settings-code='PGRpdiBjbGFzcz0idG9wLXNsYXNoIGRmcC1zbG90IiAKICAgICAgICAgICAgZGF0YS1wYXRoPSIvMTM0NzQ1NDUvTWFsdGFUb2RheV9bY2F0ZWdvcnldX0xlYWRlcmJvYXJkXzcyOHg5MCIKICAgICAgICAgICAgZGF0YS1zaXplPSJbWzcyOCwgOTBdLCBbOTcwLCA5MF0sIFs5NzAsIDI1MF0sIFszMjAsIDUwXSwgWzEzMjAsIDI1MF0sIFsxMTUwLCAyNTBdXSI+CiAgICAgICAgPC9kaXY+'><div class="code_module">
<div class="top-slash dfp-slot" data-path="/13474545/MaltaToday_comment_Leaderboard_728x90" data-size="[[728, 90], [970, 90], [970, 250], [320, 50], [1320, 250], [1150, 250]]">
</div></div></div></div> <div class="main-nav">
<div class="main-nav-bg">
<div class="container">
<div class="row">
<div class="col-md-12">
<div class="row">
<div class="menu-bar comment">
<div class="logo col-xs-7 col-md-2">
<a href="/"><img class="img-responsive" src="/ui/images/frontend/maltatoday_logo_comment.png" alt="maltatoday" /></a>
</div>
<div class="col-xs-5 visible-sm visible-xs text-right">
<div id="more-menu">
menu
<button type="button" class="navbar-toggle" aria-expanded="false">
<span class="sr-only">Toggle navigation</span>
<span class="icon-bar"></span>
<span class="icon-bar"></span>
<span class="icon-bar"></span>
</button>
</div>
</div>
<ul class="main-menu">
<li class="menu-inline-search visible-xs">
<form action="/search-mt/" method="get">
<div class="col-xs-12">
<input type="text" name="q" class="form-control" placeholder="Search maltatoday.." />
</div>
</form>
</li>
<li class="menu_item home has-sub-menu">
<a href="/">
Home </a>
<div class="menu-item-detail-box">
<ul class="sub-menu">
<li><a href="http://frontpages.maltatoday.com.mt/">Today's Newspapers</a></li>
<li><a href="/vacancies">Jobs in Malta</a></li>
<li><a href="/deals">DealToday</a></li>
<li><a href="/pharmacies">Pharmacies</a></li>
<li><a href="/sponsored">Sponsored</a></li>
<li><a href="/announcements">Announcements</a></li>
<li><a href="/advertising">Advertise</a></li>
<li><a href="/contact">Contact</a></li>
<li><a href="/maltatodaydigitaledition">Digital Edition</a></li>
<li><a href="/subscribe_sms">SMS Alerts</a></li>
</ul>
</div>
</li>
<li class="menu_item news has-sub-menu">
<a href="/news">
News </a>
<div class="menu-item-detail-box">
<ul class="sub-menu">
<li><a href="/news/national">National</a></li>
<li><a href="/news/europe">Europe</a></li>
<li><a href="/news/world">World</a></li>
<li><a href="/news/court_and_police">Court &amp; Police</a></li>
<li><a href="/news/interview">Interview</a></li>
<li><a href="/news/data_and_surveys">Data &amp; Survey</a></li>
<li><a href="/news/skinny">The Skinny</a></li>
<li><a href="/news/xtra">Xtra</a></li>
<li><a href="/news/budget-2020">Budget 2020</a></li>
</ul>
<div class="detail-content-box hidden-sm hidden-xs">
<div class="sub-menu-latest-stories">
<div class="row">
<div class="col-md-6">
<div class="left-section">
<div class="top-story-container">
<div class="photo">
<a href="/news/national/100549/libya_pact_malta_facilitated_return_of_migrants_to_ghastly_and_horrific_situation_ngos_says"><img src="//content.maltatoday.com.mt/ui_frontend/thumbnail/400/220/migrants_on_rescue_boat.jpeg" /></a>
</div>
<div class="title">
<span class="category">National</span> <a href="/news/national/100549/libya_pact_malta_facilitated_return_of_migrants_to_ghastly_and_horrific_situation_ngos_says">
Libya ‘pact’: Malta facilitated return of migrants to ‘ghastly and horrific’ situation, NGOs says</a>
</div>
</div>
</div>
</div>
<div class="col-md-6">
<div class="right-section">
<ul class="stories">
<li class="story">
<div class="story-content">
<div class="image">
<a href="/news/national/100545/social_justice_activists_mourn_passing_of_joe_bartolo_issloopy"><img src="//content.maltatoday.com.mt/ui_frontend/thumbnail/62/62/joseph_bartolo_sloopy.jpg" /></a>
</div>
<div class="text">
 <a href="/news/national/100545/social_justice_activists_mourn_passing_of_joe_bartolo_issloopy">
<span class="category">National</span>
<span class="title"> Social justice activists mourn passing of Joe Bartolo 'is-Sloopy'</span>
</a>
</div>
</div>
</li>
<li class="story">
<div class="story-content">
<div class="image">
<a href="/news/world/100544/venice_carnival_closes_as_italy_imposes_lockdown_over_coronavirus_"><img src="//content.maltatoday.com.mt/ui_frontend/thumbnail/62/62/1582515174_293_coronavirus-italy-imposes-extreme-measures-puts-fine-on-travellers-caught.jpeg" /></a>
</div>
<div class="text">
<a href="/news/world/100544/venice_carnival_closes_as_italy_imposes_lockdown_over_coronavirus_">
<span class="category">World</span>
<span class="title"> Venice Carnival closes as Italy imposes lockdown over coronavirus</span>
</a>
</div>
</div>
</li>
<li class="story">
<div class="story-content">
<div class="image">
<a href="/news/court_and_police/100543/inmate_found_dead_at_corradino_prison_"><img src="//content.maltatoday.com.mt/ui_frontend/thumbnail/62/62/2737_corradino_prison.png" /></a>
</div>
<div class="text">
<a href="/news/court_and_police/100543/inmate_found_dead_at_corradino_prison_">
<span class="category">Court & Police</span>
<span class="title"> Inmate found dead at Corradino prison</span>
</a>
</div>
</div>
</li>
</ul>
<a href="/news">More in News <i class="fa fa-angle-right"></i></a>
</div>
</div>
</div>
</div>
</div>
</div>
</li>
<li class="menu_item business has-sub-menu">
<a href="/business">
Business </a>
<div class="menu-item-detail-box">
<ul class="sub-menu">
<li><a href="/business/business_news">Business News</a></li>
<li><a href="/business/business_comment">Business Comment</a></li>
<li><a href="/business/technology">Technology</a></li>
<li><a href="/business/law_report">Law Report</a></li>
</ul>
<div class="detail-content-box hidden-sm hidden-xs">
<div class="sub-menu-latest-stories">
<div class="row">
<div class="col-md-6">
<div class="left-section">
<div class="top-story-container">
<div class="photo">
<a href="/business/business_comment/100509/morgan_stanley_to_buy_etrade__calamatta_cuschieri"><img src="//content.maltatoday.com.mt/ui_frontend/thumbnail/400/220/431_untitled.png" /></a>
</div>
<div class="title">
<span class="category">Business Comment</span> <a href="/business/business_comment/100509/morgan_stanley_to_buy_etrade__calamatta_cuschieri">
Morgan Stanley to buy E-Trade | Calamatta Cuschieri</a>
</div>
</div>
</div>
</div>
<div class="col-md-6">
<div class="right-section">
<ul class="stories">
<li class="story">
<div class="story-content">
<div class="image">
<a href="/business/law_report/100428/any_administrative_act_may_be_scrutinised_by_the_administrative_review_tribunal"><img src="//content.maltatoday.com.mt/ui_frontend/thumbnail/62/62/2_law_report.png" /></a>
</div>
<div class="text">
<a href="/business/law_report/100428/any_administrative_act_may_be_scrutinised_by_the_administrative_review_tribunal">
<span class="category">Law Report</span>
<span class="title"> Any administrative act may be scrutinised by the Administrative Review Tribunal</span>
</a>
</div>
</div>
</li>
<li class="story">
<div class="story-content">
<div class="image">
<a href="/business/business_comment/100468/franklin_templeton_to_acquire_legg_mason__calamatta_cuschieri"><img src="//content.maltatoday.com.mt/ui_frontend/thumbnail/62/62/32_picture1.png" /></a>
</div>
<div class="text">
<a href="/business/business_comment/100468/franklin_templeton_to_acquire_legg_mason__calamatta_cuschieri">
<span class="category">Business Comment</span>
<span class="title"> Franklin Templeton to acquire Legg Mason | Calamatta Cuschieri</span>
</a>
</div>
</div>
</li>
<li class="story">
<div class="story-content">
<div class="image">
<a href="/business/business_news/100464/italian_cruise_ship_company_to_buy_50_stake_in_palumbo_shipyard"><img src="//content.maltatoday.com.mt/ui_frontend/thumbnail/62/62/palumbo_shipyard.jpg" /></a>
</div>
<div class="text">
<a href="/business/business_news/100464/italian_cruise_ship_company_to_buy_50_stake_in_palumbo_shipyard">
<span class="category">Business News</span>
<span class="title"> Italian cruise ship company to buy 50% stake in Palumbo shipyard</span>
</a>
</div>
</div>
</li>
</ul>
<a href="/business">More in Business <i class="fa fa-angle-right"></i></a>
</div>
</div>
</div>
</div>
</div>
</div>
</li>
<li class="menu_item sports has-sub-menu">
<a href="/sports">
Sports </a>
<div class="menu-item-detail-box">
<ul class="sub-menu">
<li><a href="/worldcup2018">World Cup 2018</a></li>
<li><a href="/sports/football">Football</a></li>
<li><a href="/sports/rugby">Rugby</a></li>
<li><a href="/sports/motorsports">Motor Sports</a></li>
<li><a href="/sports/boxing">Boxing</a></li>
<li><a href="/sports/tennis">Tennis</a></li>
<li><a href="/sports/cricket">Cricket</a></li>
</ul>
<div class="detail-content-box hidden-sm hidden-xs">
<div class="sub-menu-latest-stories">
<div class="row">
<div class="col-md-6">
<div class="left-section">
<div class="top-story-container">
<div class="photo">
<a href="/sports/football/100437/bov_premier_league__hamrun_spartans_1__senglea_0"><img src="//content.maltatoday.com.mt/ui_frontend/thumbnail/400/220/at0i3523_-_copy.jpg" /></a>
</div>
<div class="title">
<span class="category">Football</span> <a href="/sports/football/100437/bov_premier_league__hamrun_spartans_1__senglea_0">
BOV Premier League | Hamrun Spartans 1 – Senglea 0</a>
</div>
</div>
</div>
</div>
<div class="col-md-6">
<div class="right-section">
<ul class="stories">
<li class="story">
<div class="story-content">
<div class="image">
<a href="/sports/football/100402/bov_premier_league__valletta_1__birkirkara_4"><img src="//content.maltatoday.com.mt/ui_frontend/thumbnail/62/62/at0i3376.jpg" /></a>
</div>
<div class="text">
<a href="/sports/football/100402/bov_premier_league__valletta_1__birkirkara_4">
<span class="category">Football</span>
<span class="title"> BOV Premier League | Valletta 1 – Birkirkara 4</span>
</a>
</div>
</div>
</li>
<li class="story">
<div class="story-content">
<div class="image">
<a href="/sports/football/100401/bov_premier_league__balzan_1__gzira_united_3"><img src="//content.maltatoday.com.mt/ui_frontend/thumbnail/62/62/at0i3023.jpg" /></a>
</div>
<div class="text">
<a href="/sports/football/100401/bov_premier_league__balzan_1__gzira_united_3">
<span class="category">Football</span>
<span class="title"> BOV Premier League | Balzan 1 – Gzira United 3</span>
</a>
</div>
</div>
</li>
<li class="story">
<div class="story-content">
<div class="image">
<a href="/sports/football/100394/bov_premier_league__floriana_1__gudja_united_2"><img src="//content.maltatoday.com.mt/ui_frontend/thumbnail/62/62/at0i2823.jpg" /></a>
</div>
<div class="text">
<a href="/sports/football/100394/bov_premier_league__floriana_1__gudja_united_2">
<span class="category">Football</span>
<span class="title"> BOV Premier League | Floriana 1 – Gudja United 2</span>
</a>
</div>
</div>
</li>
</ul>
<a href="/sports">More in Sports <i class="fa fa-angle-right"></i></a>
</div>
</div>
</div>
</div>
</div>
</div>
</li>
<li class="menu_item arts has-sub-menu">
<a href="/arts">
Arts </a>
<div class="menu-item-detail-box">
<ul class="sub-menu">
<li><a href="/arts/art">Art</a></li>
<li><a href="/arts/books">Books</a></li>
<li><a href="/arts/entertainment">Entertainment</a></li>
<li><a href="/arts/music">Music</a></li>
<li><a href="/arts/theatre_and_dance">Theatre &amp; Dance</a></li>
<li><a href="/arts/film">Film</a></li>
<li><a href="/arts/cultural_diary">Cultural Diary</a></li>
<li><a href="/arts/valletta_2018">Valletta 2018</a></li>
</ul>
<div class="detail-content-box hidden-sm hidden-xs">
<div class="sub-menu-latest-stories">
<div class="row">
<div class="col-md-6">
<div class="left-section">
<div class="top-story-container">
<div class="photo">
<a href="/arts/cultural_diary/100498/seven_years_with_the_marsaxlokk_lampara_fishing_crew_of_the_talglawdu_family"><img src="//content.maltatoday.com.mt/ui_frontend/thumbnail/400/220/n_dsc8868_copy.jpg" /></a>
</div>
<div class="title">
<span class="category">Cultural Diary</span> <a href="/arts/cultural_diary/100498/seven_years_with_the_marsaxlokk_lampara_fishing_crew_of_the_talglawdu_family">
Seven years with the Marsaxlokk lampara fishing crew of the Tal-Glawdu family</a>
</div>
</div>
</div>
</div>
<div class="col-md-6">
<div class="right-section">
<ul class="stories">
<li class="story">
<div class="story-content">
<div class="image">
<a href="/arts/cultural_diary/100527/coronavirus_haunts_gozos_spontaneously_grotesque_carnival_in_nadur"><img src="//content.maltatoday.com.mt/ui_frontend/thumbnail/62/62/jpb_3779.jpg" /></a>
</div>
<div class="text">
<a href="/arts/cultural_diary/100527/coronavirus_haunts_gozos_spontaneously_grotesque_carnival_in_nadur">
<span class="category">Cultural Diary</span>
<span class="title"> Coronavirus ‘haunts’ Gozo’s spontaneously grotesque carnival in Nadur</span>
</a>
</div>
</div>
</li>
<li class="story">
<div class="story-content">
<div class="image">
<a href="/arts/film/100427/film_review__birds_of_prey_keep_it_crazy_but_stay_light"><img src="//content.maltatoday.com.mt/ui_frontend/thumbnail/62/62/2_film_review_overlay_(5).png" /></a>
</div>
<div class="text">
<a href="/arts/film/100427/film_review__birds_of_prey_keep_it_crazy_but_stay_light">
<span class="category">Film</span>
<span class="title"> Film Review | Birds of Prey: Keep it crazy but stay light</span>
</a>
</div>
</div>
</li>
<li class="story">
<div class="story-content">
<div class="image">
<a href="/arts/music/100426/rattling_your_inner_self__kill_the_action"><img src="//content.maltatoday.com.mt/ui_frontend/thumbnail/62/62/kta_6971-4.jpg" /></a>
</div>
<div class="text">
<a href="/arts/music/100426/rattling_your_inner_self__kill_the_action">
<span class="category">Music</span>
<span class="title"> Rattling your inner self | Kill the Action</span>
</a>
</div>
</div>
</li>
</ul>
<a href="/arts">More in Arts <i class="fa fa-angle-right"></i></a>
</div>
</div>
</div>
</div>
</div>
</div>
</li>
<li class="menu_item comment active has-sub-menu">
<a href="/comment">
Comment </a>
<div class="menu-item-detail-box">
<ul class="sub-menu">
<li><a href="/comment/blogs">Blogs</a></li>
<li><a href="/comment/editorial">Editorial</a></li>
<li><a href="/comment/letters">Letters</a></li>
<li><a href="/comment/cartoons">Cartoons</a></li>
</ul>
<div class="detail-content-box hidden-sm hidden-xs">
<div class="sub-menu-latest-stories">
<div class="row">
<div class="col-md-6">
<div class="left-section">
<div class="top-story-container">
<div class="photo">
<a href="/comment/blogs/100540/is_the_public_inquiry_working"><img src="//content.maltatoday.com.mt/ui_frontend/thumbnail/400/220/who_killed_daphne.jpg" /></a>
</div>
<div class="title">
<span class="category">Blogs</span> <a href="/comment/blogs/100540/is_the_public_inquiry_working">
Is the Caruana Galizia public inquiry really working?</a>
</div>
</div>
</div>
</div>
<div class="col-md-6">
<div class="right-section">
<ul class="stories">
<li class="story">
<div class="story-content">
<div class="image">
<a href="/comment/blogs/100539/public_sentiment_vacum_grow"><img src="//content.maltatoday.com.mt/ui_frontend/thumbnail/62/62/dcg_march_banner.jpg" /></a>
</div>
<div class="text">
<a href="/comment/blogs/100539/public_sentiment_vacum_grow">
<span class="category">Blogs</span>
<span class="title"> Public sentiment does not grow in a vacuum</span>
</a>
</div>
</div>
</li>
<li class="story">
<div class="story-content">
<div class="image">
<a href="/comment/editorial/100528/at_100_some_selfreflection"><img src="//content.maltatoday.com.mt/ui_frontend/thumbnail/62/62/maltatoday_editorial.png" /></a>
</div>
<div class="text">
<a href="/comment/editorial/100528/at_100_some_selfreflection">
<span class="category">Editorial</span>
<span class="title"> Labour at 100: the need for self-reflection</span>
</a>
</div>
</div>
</li>
<li class="story">
<div class="story-content">
<div class="image">
<a href="/comment/blogs/100490/whats_35_to_you"><img src="//content.maltatoday.com.mt/ui_frontend/thumbnail/62/62/europe-minimum-wage2.jpg" /></a>
</div>
<div class="text">
<a href="/comment/blogs/100490/whats_35_to_you">
<span class="category">Blogs</span>
<span class="title"> What's €35 to you?</span>
</a>
</div>
</div>
</li>
</ul>
<a href="/comment">More in Comment <i class="fa fa-angle-right"></i></a>
</div>
</div>
</div>
</div>
</div>
</div>
</li>
<li class="menu_item videos">
<a href="/videos/">
Video </a>
</li>
<li class="menu_item archives">
<a href="http://archive.maltatoday.com.mt" target="_blank">
Archives </a>
</li>
<li class="menu_item gourmet-today has-sub-menu">
<a href="/gourmet/">
<img src="/ui/images/frontend/maltatoday_logo_gourmet.png" alt="Gourmet" />
</a>
<div class="menu-item-detail-box">
<ul class="sub-menu">
<li><a href="/gourmet/recipes/">Recipes</a></li>
<li><a href="/gourmet/restaurants/">Restaurants</a></li>
<li><a href="/gourmet/gourmet_today/">Magazines</a></li>
<li><a href="/gourmet/gourmettv/">TV</a></li>
<li><a href="/gourmet/videos/">Videos</a></li>
</ul>
</div>
</li>
<li class="menu_item frontpages visible-xs">
<a href="http://frontpages.maltatoday.com.mt">
Frontpages </a>
</li>
<li class="menu_item deal-today visible-xs visible-sm">
<a href="/deals">
DealToday </a>
</li>
<li class="menu_item login visible-xs visible-sm login-menu-item">
<a href="/maltatodaydigitaledition/">
Login to Digital Edition </a>
</li>
</ul>
<div class="menu-icons hidden-xs hidden-sm">
<div class="menu-icons-icon search-icon" onclick="$(this).addClass('active').find('input').focus()">
<span class="fa fa-search"></span>
<div class="searchbox">
<form action="/search-mt/" method="get">
<input type="text" name="q" placeholder="Search" onblur="$(this).parents('.search-icon').removeClass('active');" onkeyup="if (event.keyCode === 27) { $(this).blur(); }" />
<button type="submit">
<i class="fa fa-search search_now"></i>
</button>
</form>
</div>
</div>
<div class="menu-icons-icon login-icon">
<a href="/maltatodaydigitaledition/" class="btn btn-red">Login</a>
</div>
</div>
</div>
</div>
<div id="small-menu-placeholder" class="row visible-xs visible-sm comment">
<div id="small-menu">
<a href="/">home</a>
<a href="/news">news</a>
<a class="highlight" href="/maltatodaydigitaledition">login</a>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
<div class="sub-nav">
<div class="container">
<ul class="hidden-xs outer-sub-menu sub-menu comment">
<li><a href="/comment/blogs">Blogs</a></li>
<li><a href="/comment/editorial">Editorial</a></li>
<li><a href="/comment/letters">Letters</a></li>
<li><a href="/comment/cartoons">Cartoons</a></li>
</ul>
</div>
</div>
</header>
<div id="content">
<section>
<div class="container">
<div class="row">
<div class="col-lg-12 col-md-12">
<div class="zone" data-zone-name="Top" data-zone-id="top"><div class='mt_module' data-module-name='article_breadcrumb' data-update-frequency='0'><ul class="breadcrumb">
<li class="breadcrumb-item comment"><a href="/comment/">Comment</a></li>
<li class="breadcrumb-item comment"><a href="/comment/blogs/">Blogs</a></li>
</ul></div><div class='mt_module' data-module-name='article_heading' data-update-frequency='0'><div class="article-heading">
<div class="row">
<div class="col-md-12">
<h1>Is the Caruana Galizia public inquiry really working?</h1>
<h2><p>The public inquiry seems to be a show of na&iuml;vet&eacute; about what has been happening in the political world in Malta, on the powers of our political leaders, and on the great deception the former prime minister and his chief-of-staff managed to put up inside and out of Castille</p></h2>
</div>
</div>
</div>
</div></div> </div>
</div>
<div class="row">
<div class="col-lg-2 col-md-2">
<div class="zone" data-zone-name="Left" data-zone-id="left"><div class='mt_module' data-module-name='article_meta' data-update-frequency='0'><div class="article-meta comment-meta">
<div class="author-photos"> <img src="//content.maltatoday.com.mt/ui_frontend/profile_thumbnail/300/300/saviour_balzan_1502114349.jpg" alt="saviour_balzan" />
</div>
<div class="date-text">
<span class="name">Saviour Balzan </span>
<span class="date">24 February 2020, 7:14am</span>
</div>
</div></div><div class='mt_module' data-module-name='addthis' data-update-frequency='0'>  <script type="text/javascript" src="//s7.addthis.com/js/300/addthis_widget.js#pubid=ra-5a7023510fcc04af"></script>
</div></div> </div>
<div class="col-lg-8 col-md-8">
<div class="zone" data-zone-name="Main" data-zone-id="content"><div class='mt_module' data-module-name='article_cover' data-update-frequency='0'><div class="full-article article-cover">
<div class="photo_collection_cover article-cover-media single-cover" data-slick='{"slidesToShow": 1, "slidesToScroll": 1}'>
<div class="media-item show ">
<div class="cover-photo" title="" style="background-image: url('//content.maltatoday.com.mt/ui/images/photos/who_killed_daphne.jpg')">
<img src="//content.maltatoday.com.mt/ui_frontend/thumbnail/684/0/who_killed_daphne.jpg" alt="" />
</div>
</div>
</div>
</div></div><div class='mt_module' data-module-name='small_share_buttons' data-update-frequency='0'><div class="row">
<div class="col-md-6">
</div>
<div class="col-md-6">
<div class="small_share_buttons text-right">
<a class="addthis_button_facebook_like" fb:like:layout="button_count" style="position:relative; top: 4px; padding: 0px; right: -10px;"></a>
<script type="text/javascript">var addthis_config = {"data_track_addressbar":true};</script>
<script type="text/javascript" src="//s7.addthis.com/js/300/addthis_widget.js#pubid=seekopia"></script>
<a class="twitter" href="https://twitter.com/share?url=https://www.maltatoday.com.mt/comment/blogs/100540/is_the_public_inquiry_working&text=Is the Caruana Galizia public inquiry really working?" target="_blank">
<i class="fa fa-twitter"></i> TWEET
</a>
<a class="facebook" href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.maltatoday.com.mt%2Fcomment%2Fblogs%2F100540%2Fis_the_public_inquiry_working" target="_blank">
<i class="fa fa-facebook"></i> SHARE
</a>
</div>
</div>
</div></div><div class='mt_module' data-module-name='full_article' data-update-frequency='0'><div class="full-article">
<div class="content content-comment"> <div class="dfp-slot" data-path="/13474545/MaltaToday_comment_Inline_300x250" data-size="[[300, 250]]" style="float:right; margin:8px 0 8px 25px">
</div>
<p>It is over and out for the Nationalist party. Attempts to shake the party leadership and get it to realise that a change at the top would give it a fighting chance have failed. Adrian Delia has clearly shown that he has only his personal interest at heart.
</p><p>When the country clearly needs a strong and vibrant Opposition, we have none. None of the contenders have come forward, unwilling to get out of their comfort zone to take on Delia and face Robert Abela and Labour in the next general elections, with all the risks that entails. They only have themselves to blame.
</p><p>I interviewed former PN leader Simon Busuttil this week and when I asked him why he thought he had lost the 2017 election, he admitted that it had been &ldquo;too early&rdquo; to take on the Labour government. He, of course, also attributed the landslide victory for Muscat to other factors, namely, the power with which it could curry favour with so many pockets of voters. To the victors the spoils, I guess.
</p><p>But if 2017 was too early to take on Labour, the events that followed after the 16 October 2017 and more recently the 28 November 2019, should have galvanised the Opposition and raised its political relevance. Instead the PN nosedived into more irrelevance and the new PL line-up sky-rocketed (as Godfrey Baldacchino noted in MaltaToday last week, it seems Joseph Muscat has drawn out the poison and took it away with him).
</p><p>I ask myself how this could have happened. The answers could be various.
</p><p>For starters, and I think most will agree about this, the Nationalist party&rsquo;s infighting coupled with the positive economic momentum in Malta, has left the public somewhat desensitised to the big democratic conundrum we face. As the surveys have shown, people want the &ldquo;stability&rdquo; that the Labour government has preserved in terms of economic and infrastructural investment; so long as the alternative is a divided PN, voters will not sacrifice the &lsquo;national interest&rsquo; for anything the PN espouses.
</p><p>But I have to add the fact that Labour&rsquo;s popularity and ability to remain united in the face of all that has happened, also seems to be, partly, a reaction to what is happening in the wake of the Caruana Galizia assassination.
</p><p>The protests we witnessed in the last three months did not bring the nation together. They definitely caused change, but they also added to the political and tribal divide. It has sharpened the us-and-them divide, even when non-partisan Labour and Nationalist voters would have loved to be part of this outcry. But still, they feel disenfranchised even though they support the protest in spirit as the actions of people of good will.
</p><p>And yet, the protests have still &ndash; indirectly &ndash; consolidated the electoral strength of the Labour party, more so because the PN has been officially excluded from this show of force. And, whether one agrees or not, the incessant attacks from MEPs on Malta has hardened a native suspicion here that Brussels has been excessively preoccupied with Malta; that even minute financial institutions like Pilatus Bank seem to be more important to MEPs than Deutsche Bank&rsquo;s own wrongdoings and peccadilloes. However justified the criticism has been, a good deal of Maltese have been unwilling to be shaken by what they read, hear and see. And certainly enough, the vast majority do not read the English-language press or share the angst of Occupy Justice and Repubblika activists.
</p><p>So finally, we come to the Caruana Galizia public inquiry, which I am afraid, has only turned out to be a sad show of questions-and-answers concerned with the culture of a blog, rather than into the murder itself.
</p><p>I, for one, cannot accept that impunity or the political culture that encourages it, was suddenly brought about by a social media circus where one side was pitted against the other. The first salvoes of abuse on the budding blogosphere &ndash; pre-Facebook and all that &ndash; did not start with those who have been called for questioning before the inquiry. For a very long time, the word on the web was controlled by those who wrote the columns and the news, and readers&rsquo; voices lacked a proper platform to hit back. When the unwarranted attacks from blogs started picking out people by shaming their personal lives, they were never questioned by the political class.
</p><p>The murder of Caruana Galizia was not &lsquo;facilitated&rsquo; in the arena of social media. Had that been the case, I for one would be culpable of having been such a critic of Caruana Galizia&rsquo;s style and writing.
</p><p>The murder was committed by the criminal minds of &lsquo;oligarchs&rsquo; who wanted to silence a person who was effectively close to uncovering a web of corruption.
</p><p>Instead this public inquiry by its independent judges seems to be a show of na&iuml;vet&eacute; about what has been happening in the political world in Malta, on the powers of our political leaders, and on the great deception the former prime minister and his chief-of-staff managed to put up inside and out of Castille.
</p><p>I hoped such a public inquiry could bring people to their senses by exposing the toxicity of both sides of the political divide and embracing a spirit of reconciliation. Instead, the opposite seems to be happening. How could the inquiry&rsquo;s obsession with the Castille &lsquo;incident&rsquo; &ndash; when journalists were kept locked in while the Cabinet made its exit &ndash; overshadow the more salient considerations that led to the fatal and horrendous event that murdered Caruana Galizia?
</p><p>Why are we not asking questions about the message of fear that was designed to be sent out when Caruana Galizia was assassinated?
</p><p>In my 32 years of journalism, being locked out, manhandled, thrown out, arrested and abused by government staffers &ndash; including former ministerial aides such as Manuel Delia &ndash; was part of the experience of being a working journalist. Being killed is not.
</p><p>I hit back at Caruana Galizia when she lambasted me, or my family and friends, unfairly. That does not make me complicit in what happened. Her murderers were those who believed they were above the law and omnipotent. They believed they could determine who lives or dies. That their money laundering or kickbacks should not be questioned or queried. That they had a divine right to do what they wanted without question.
</p><p>What we must determine is when and why this happened. But in doing so, we must think of the bigger picture. We need to bring this country and its citizens together, and understand that what happened should never happen again. To bring about this change, we would need to stop imagining that everyone on the other side of the border is to blame. We must stop this hatred, now.</p><p></p> </div>
</div></div><div class='mt_module' data-module-name='code' data-update-frequency='0' data-module-settings-code='PGRpdiBjbGFzcz0ic3BsaXQtYWR2ZXJ0IGRmcC1zbG90IiAKICAgICAgICAgICAgZGF0YS1wYXRoPSIvMTM0NzQ1NDUvTWFsdGFUb2RheV9bY2F0ZWdvcnldX0FydGljbGVMZWFkZXJib2FyZCIKICAgICAgICAgICAgZGF0YS1zaXplPSJbWzcyOCwgOTBdLCBbMzIwLCA1MF1dIj4KICAgICAgICA8L2Rpdj4='><div class="code_module">
<div class="split-advert dfp-slot" data-path="/13474545/MaltaToday_comment_ArticleLeaderboard" data-size="[[728, 90], [320, 50]]">
</div></div></div><div class='mt_module' data-module-name='article_author_bios' data-update-frequency='0'> <div class="article-author-bio">
<div class="bio">
<div class="row">
<div class="col-xs-1">
<div class="image">
<img src="//content.maltatoday.com.mt/ui_frontend/profile_thumbnail/40/40/saviour_balzan_1502114355_zoom.jpg" />
</div>
</div>
<div class="col-xs-11">
<div class="text">
Saviour Balzan is the founder and co-owner of MaltaToday. He has reported on Maltese poli... </div>
<div class="socialmedia">
<span class="link readmore"> <a href="/author/saviour_balzan/">More from Saviour Balzan</a></span>
<span class="link twitter"><i class="fa fa-twitter twitter"></i> <a href="twitter.com/saviourbalzan" target="_blank">Saviour on Twitter</a></span> <span class="link googleplus"><i class="fa fa-google-plus googleplus"></i> <a href="plus.google.com/110943896945537039530/posts" target="_blank"> Saviour on Google+</a></span> </div>
</div>
</div>
</div>
</div>
</div><div class='mt_module' data-module-name='boxed_title' data-update-frequency='0' data-module-settings-text='More in {subcategory}'> <div class="boxed-title">
<span class="title-text">
More in Blogs </span>
</div>
</div><div class='mt_module' data-module-name='small_article' data-update-frequency='0' data-module-settings-amount='4' data-module-settings-show_photo='1' data-module-settings-show_author='1' data-module-settings-show_category='1' data-module-settings-show_inset_category='0' data-module-settings-show_standfirst='1'><div class="responsive-articles small-articles">
<div class="article small-article open_url comment-article" data-url="/comment/blogs/100540/is_the_public_inquiry_working">
<div class="image" style="background-image: url('//content.maltatoday.com.mt/ui_frontend/thumbnail/684/0/who_killed_daphne.jpg');">
<img src="//content.maltatoday.com.mt/ui_frontend/thumbnail/684/0/who_killed_daphne.jpg" alt="Is the Caruana Galizia public inquiry really working?" />
</div>
<div class="details" style="padding-right: 25px;">
<div class="extra-info">
<span class="category comment">Blogs</span>
</div>
<div class="title">
<a href="/comment/blogs/100540/is_the_public_inquiry_working"><h3>Is the Caruana Galizia public inquiry really working?</h3></a>
</div>
<div class="extra-info">
<span class="author comment">Saviour Balzan </span>
</div>
</div>
</div>
<div class="article small-article open_url comment-article" data-url="/comment/blogs/100539/public_sentiment_vacum_grow">
<div class="image" style="background-image: url('//content.maltatoday.com.mt/ui_frontend/thumbnail/684/0/dcg_march_banner.jpg');">
<img src="//content.maltatoday.com.mt/ui_frontend/thumbnail/684/0/dcg_march_banner.jpg" alt="Public sentiment does not grow in a vacuum" />
</div>
<div class="details" style="padding-right: 25px;">
<div class="extra-info">
<span class="category comment">Blogs</span>
</div>
<div class="title">
<a href="/comment/blogs/100539/public_sentiment_vacum_grow"><h3>Public sentiment does not grow in a vacuum</h3></a>
</div>
<div class="extra-info">
<span class="author comment">Josanne Cassar </span>
</div>
</div>
</div>
<div class="article small-article open_url comment-article" data-url="/comment/blogs/100490/whats_35_to_you">
<div class="image" style="background-image: url('//content.maltatoday.com.mt/ui_frontend/thumbnail/684/0/europe-minimum-wage2.jpg');">
<img src="//content.maltatoday.com.mt/ui_frontend/thumbnail/684/0/europe-minimum-wage2.jpg" alt="What's €35 to you?" />
</div>
<div class="details" style="padding-right: 25px;">
<div class="extra-info">
<span class="category comment">Blogs</span>
</div>
<div class="title">
<a href="/comment/blogs/100490/whats_35_to_you"><h3>What's €35 to you?</h3></a>
</div>
<div class="extra-info">
<span class="author comment">Josanne Cassar </span>
</div>
</div>
</div>
<div class="article small-article open_url comment-article" data-url="/comment/blogs/100335/maltas_medical_doctors_no_to_total_ban_on_abortion">
<div class="image" style="background-image: url('//content.maltatoday.com.mt/ui_frontend/thumbnail/684/0/pro_choice_20190929_4.jpeg');">
<img src="//content.maltatoday.com.mt/ui_frontend/thumbnail/684/0/pro_choice_20190929_4.jpeg" alt="Malta’s medical doctors: No to total ban on abortion" />
</div>
<div class="details" style="padding-right: 25px;">
<div class="extra-info">
<span class="category comment">Blogs</span>
</div>
<div class="title">
<a href="/comment/blogs/100335/maltas_medical_doctors_no_to_total_ban_on_abortion"><h3>Malta’s medical doctors: No to total ban on abortion</h3></a>
</div>
</div>
</div>
</div>
</div><div class='mt_module' data-module-name='code' data-update-frequency='0' data-module-settings-code='PGRpdiBpZD0icmMtd2lkZ2V0LTllZWU1OSIgZGF0YS1yYy13aWRnZXQgZGF0YS13aWRnZXQtaG9zdD0iaGFiaXRhdCIgZGF0YS1lbmRwb2ludD0iLy90cmVuZHMucmV2Y29udGVudC5jb20iIGRhdGEtd2lkZ2V0LWlkPSI4MzQ1MSI+PC9kaXY+CjxzY3JpcHQgdHlwZT0idGV4dC9qYXZhc2NyaXB0IiBzcmM9Ii8vYXNzZXRzLnJldmNvbnRlbnQuY29tL21hc3Rlci9kZWxpdmVyeS5qcyIgZGVmZXI9ImRlZmVyIj48L3NjcmlwdD4='><div class="code_module">
<div id="rc-widget-9eee59" data-rc-widget data-widget-host="habitat" data-endpoint="//trends.revcontent.com" data-widget-id="83451"></div>
<script type="text/javascript" src="//assets.revcontent.com/master/delivery.js" defer="defer"></script></div></div><div class='mt_module' data-module-name='comments' data-update-frequency='0'><div id="disqus_thread"></div>
<script type="text/javascript">

    var disqus_config = function () {

        
            // The generated payload which authenticates users with Disqus
            this.page.remote_auth_s3 = 'eyJpZCI6InVzZXJfIiwidXNlcm5hbWUiOiIgIiwiZW1haWwiOm51bGx9 e5eefa1a040c20a7bd302a2cee6d5ba36ff8475b 1582533749';
            this.page.api_key = 'KKsrhxY6LSXy3nbzit54YG6MHLFaxrOJ42o6hFm3W1sUtwGMqjEzqyO5HBu9sxTW';

                this.page.identifier = 'article_100540';
        this.sso = {
            name:   "MaltaToday.com.mt",
            button:  "https://www.maltatoday.com.mt/ui/images/frontend/disqus_button.png",
            icon:     "https://www.maltatoday.com.mt/ui/images/icons/Icon-Small@2x.png",
            url:      "https://www.maltatoday.com.mt/ui_frontend/login/",
            logout:  "https://www.maltatoday.com.mt/ui_frontend/disquslogout/",
            width:   "867",
            height:  "152"
        };
    };

    var disqus_shortname = 'malta-today';

    (function() {
        var dsq = document.createElement('script'); dsq.type = 'text/javascript'; dsq.async = true;
        dsq.src = '//' + disqus_shortname + '.disqus.com/embed.js';
        (document.getElementsByTagName('head')[0] || document.getElementsByTagName('body')[0]).appendChild(dsq);
    })();
</script>
</div></div> </div>
<div class="col-lg-2 col-md-2">
<div class="zone" data-zone-name="Right" data-zone-id="right"></div> </div>
</div>
<div class="row">
<div class="col-lg-12 col-md-12">
<div class="zone" data-zone-name="Bottom" data-zone-id="bottom"></div> </div>
</div>
</div>
</section></div>
<footer class="hidden-xs">
<div class="container">
<div class="row">
<div class="col-xs-12 col-sm-6">
<div class="footer-logo">
<a href="/"> <img src="/ui/images/frontend/maltatoday_logo_white.png" /></a>
</div>
</div>
<div class="col-xs-12 col-sm-6">
<div class="social-icons">
<div class="icon facebook">
<a href="//facebook.com/maltatoday" target="_blank"><i class="fa fa-facebook"></i></a>
</div>
<div class="icon twitter">
<a href="//twitter.com/maltatoday" target="_blank"><i class="fa fa-twitter"></i></a>
</div>
<div class="icon instagram">
<a href="//www.instagram.com/maltatoday" target="_blank"><i class="fa fa-instagram"></i></a>
</div>
<div class="icon youtube">
<a href="//www.youtube.com/user/ReporterMediaToday" target="_blank"><i class="fa fa-youtube"></i></a>
</div>
<div class="icon googleplus">
<a href="//plus.google.com/113527506098764625850" target="_blank"><i class="fa fa-google-plus"></i></a>
</div>
</div>
</div>
</div>
<div class="row">
<div class="col-xs-12">
<ul class="bottom-nav">
<li><a href="/about-us/">About Us</a></li>
<li><a href="/advertising/">Advertise</a> </li>
<li><a href="/contact/">Contact</a> </li>
<li><a href="/maltatodaydigitaledition/">Digital Edition</a></li>
<li><a href="http://frontpages.maltatoday.com.mt/">Today's Newspapers</a></li>
<li><a href="/subscribe_sms/">SMS Alerts</a></li>
</ul>
<ul class="bottom-links">
<li><a href="/terms-and-conditions/">Terms and Conditions</a> </li>
<li><a href="/privacy-policy/">Privacy Policy</a> </li>
<li><a href="/privacy-policy/">Cookie Policy</a> </li>
<li><a target="_blank" href="http://archive.maltatoday.com.mt/archive.html">Archives</a></li>
</ul>
</div>
</div>
<div class="row">
<div class="col-md-12">
<div class="copyright">
MediaToday is an independent media house based in Malta. Copyright © MediaToday Co. Ltd, Vjal ir-Rihan, San Gwann SGN 9016, Malta, Europe <br />
Reproduction of material from this website without written permission is strictly prohibited.
</div>
</div>
</div>
</div>
</footer>
<div class="floating-bar" data-cookie-name="cookie_notice">
<div class="container">
<div class="message-inner">
<a href="https://www.maltatoday.com.mt/privacy-policy/" target="_blank" class="set-close">
By using this site, you agree to our Privacy Policy including the use of cookies to enhance your experience. </a>
<button class="message-close-btn set-close">
<i class="fa fa-times close"></i>
</button>
</div>
</div>
</div>
<script type="text/javascript" src="//imasdk.googleapis.com/js/sdkloader/ima3.js"></script>
<script type="text/javascript" src="/dist/js/packages.min.js?v=1580122566"></script>
<script>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</script>

<script type="text/javascript">
_atrk_opts = { atrk_acct:"io5hj1aAkN00oK", domain:"maltatoday.com.mt",dynamic: true};
(function() { var as = document.createElement('script'); as.type = 'text/javascript'; as.async = true; as.src = "https://certify-js.alexametrics.com/atrk.js"; var s = document.getElementsByTagName('script')[0];s.parentNode.insertBefore(as, s); })();
</script>
<noscript><img src="https://certify.alexametrics.com/atrk.gif?account=io5hj1aAkN00oK" style="display:none" height="1" width="1" alt="" /></noscript>

<script type="text/javascript" src="/dist/js/app.min.js?v=1580122566"></script>
<script type="text/javascript">
    var _gaq = _gaq || [];
    _gaq.push(['_setAccount', 'UA-16977049-1']);
    _gaq.push(['_trackPageview']);

    (function () {
        var ga = document.createElement('script'); ga.type =
            'text/javascript'; ga.async = true;
        ga.src = ('https:' == document.location.protocol ? 'https://ssl' :
            'http://www') + '.google-analytics.com/ga.js';
        var s = document.getElementsByTagName('script')[0];
        s.parentNode.insertBefore(ga, s);
    })();
</script>
<script id="dsq-count-scr" src="//malta-today.disqus.com/count.js" async></script>
</body>
</html>
