<!DOCTYPE html>
<html xmlns="http://www.w3.org/1999/xhtml" lang="en">
<head>
<meta http-equiv="Content-Type" content="text/html; charset=utf-8">
<meta name="viewport" content="width=device-width, initial-scale=1.0" />
<meta property="fb:pages" content="21535456940" />
<meta property="fb:app_id" content="1775326929407925" />
<link rel="shortcut icon" type="image/x-icon" href="/ui/images/icons/Icon-Small@2x.png">
<link rel="apple-touch-icon" href="/ui/images/icons/Icon-60@2x.png" />
<link rel="apple-touch-icon" sizes="58x58" href="/ui/images/icons/Icon-Small@2x.png" />
<link rel="apple-touch-icon" sizes="76x76" href="/ui/images/icons/Icon-76.png" />
<link rel="apple-touch-icon" sizes="152x152" href="/ui/images/icons/Icon-76@2x.png" />
<link rel="apple-touch-icon" sizes="180x180" href="/ui/images/icons/Icon-60@3x.png" />
<link rel="icon" sizes="192x192" href="/ui/images/icons/icon-192x192.png" />
<link rel="stylesheet" href="/dist/css/desktop.min.css?v=9.2021" />
<link rel="canonical" href="https://www.maltatoday.com.mt/news/court_and_police/113357/judge_shoots_down_yorgen_fenechs_request_to_reveal_identities_of_secret_service_agents">
<meta property="og:site_name" content="MaltaToday.com.mt" />
<meta property="og:url" content="http://www.maltatoday.com.mt/news/court_and_police/113357/judge_shoots_down_yorgen_fenechs_request_to_reveal_identities_of_secret_service_agents" />
<meta property="og:title" content="Judge shoots down Yorgen Fenech's request to reveal identities of secret service agents" />
<meta property="og:description" content="The defence argued that the agents acted outside of their remit when they passed on information that led to Fenech&amp;#39;s arrest on 19 November 2019" />
<meta property="og:type" content="article" />
<meta property="article:publisher" content="https://www.facebook.com/maltatoday" />
<meta property="og:image" content="http://cdn.maltatoday.com.mt/ui_frontend/thumbnail/684/400/yorgen_fenech_2.jpg" />
<meta name="description" content="The defence argued that the agents acted outside of their remit when they passed on information that led to Fenech&amp;#39;s arrest on 19 November 2019" />
<script type="text/javascript">
        var cdn_url = "//content.maltatoday.com.mt";
    </script>
<title>Judge shoots down Yorgen Fenech's request to reveal identities of secret service agents</title>

<script async='async' src='https://www.googletagservices.com/tag/js/gpt.js'></script>
<script>
        var googletag = googletag || {};
        googletag.cmd = googletag.cmd || [];
    </script>

<script>
    !function(f,b,e,v,n,t,s)
    {if(f.fbq)return;n=f.fbq=function(){n.callMethod?
    n.callMethod.apply(n,arguments):n.queue.push(arguments)};
    if(!f._fbq)f._fbq=n;n.push=n;n.loaded=!0;n.version='2.0';
    n.queue=[];t=b.createElement(e);t.async=!0;
    t.src=v;s=b.getElementsByTagName(e)[0];
    s.parentNode.insertBefore(t,s)}(window, document,'script',
    'https://connect.facebook.net/en_US/fbevents.js');
    fbq('init', '213704729706889');
    fbq('track', 'PageView');
    </script>
<noscript><img height="1" width="1" style="display:none"
    src="https://www.facebook.com/tr?id=213704729706889&ev=PageView&noscript=1"
    /></noscript>

<script type="text/javascript">
    window._taboola = window._taboola || [];
    _taboola.push({article:'auto'});
    !function (e, f, u, i) {
    if (!document.getElementById(i)){
    e.async = 1;
    e.src = u;
    e.id = i;
    f.parentNode.insertBefore(e, f);
    }
    }(document.createElement('script'),
    document.getElementsByTagName('script')[0],
    '//cdn.taboola.com/libtrc/maltatoday/loader.js',
    'tb_loader_script');
    if(window.performance && typeof window.performance.mark == 'function')
    {window.performance.mark('tbl_ic');}
</script>
</head>
<body class="page-article">
<header>
<div class="zone" data-zone-name="TOPMOST" data-zone-id="TOPMOST"><div class='mt_module' data-module-name='code' data-update-frequency='0' data-module-settings-code='PGRpdiBjbGFzcz0idG9wLXNsYXNoIGRmcC1zbG90IiAKICAgICAgICAgICAgZGF0YS1wYXRoPSIvMTM0NzQ1NDUvTWFsdGFUb2RheV9bY2F0ZWdvcnldX0xlYWRlcmJvYXJkXzcyOHg5MCIKICAgICAgICAgICAgZGF0YS1zaXplPSJbWzcyOCwgOTBdLCBbOTcwLCA5MF0sIFs5NzAsIDI1MF0sIFszMjAsIDEwMF0sIFsxMzIwLCAyNTBdLCBbMTE1MCwgMjUwXV0iPgogICAgICAgIDwvZGl2Pg=='><div class="code_module">
<div class="top-slash dfp-slot" data-path="/13474545/MaltaToday_news_Leaderboard_728x90" data-size="[[728, 90], [970, 90], [970, 250], [320, 100], [1320, 250], [1150, 250]]">
</div></div></div></div> <div class="main-nav">
<div class="main-nav-bg">
<div class="container">
<div class="row">
<div class="col-md-12">
<div class="row">
<div class="menu-bar news">
<div class="logo col-xs-7 col-md-2">
<a href="/"><img class="img-responsive" src="/ui/images/frontend/maltatoday_logo_news.png" alt="maltatoday" /></a>
</div>
<div class="col-xs-5 visible-sm visible-xs text-right">
<div id="more-menu">
menu
<button type="button" class="navbar-toggle" aria-expanded="false">
<span class="sr-only">Toggle navigation</span>
<span class="icon-bar"></span>
<span class="icon-bar"></span>
<span class="icon-bar"></span>
</button>
</div>
</div>
<ul class="main-menu">
<li class="menu-inline-search visible-xs">
<form action="/search-mt/" method="get">
<div class="col-xs-12">
<input type="text" name="q" class="form-control" placeholder="Search maltatoday.." />
</div>
</form>
</li>
<li class="menu_item home has-sub-menu">
<a href="/">
Home </a>
<div class="menu-item-detail-box">
<ul class="sub-menu">
<li><a href="/vacancies">Jobs in Malta</a></li>
<li><a href="/yellow">Yellow</a></li>
<li><a href="/pharmacies">Pharmacies</a></li>
<li><a href="/sponsored">Sponsored</a></li>
<li><a href="/announcements">Announcements</a></li>
<li><a href="/advertising">Advertise</a></li>
<li><a href="/contact">Contact</a></li>
<li><a href="/maltatodaydigitaledition">Digital Edition</a></li>
<li><a href="/subscribe_sms">SMS Alerts</a></li>
</ul>
</div>
</li>
<li class="menu_item news active has-sub-menu">
<a href="/news">
News </a>
<div class="menu-item-detail-box">
<ul class="sub-menu">
<li><a href="/news/national">National</a></li>
<li><a href="/covid19">Covid-19</a></li>
<li><a href="/news/ewropej">#EWROPEJ</a></li>
<li><a href="/news/court_and_police">Court &amp; Police</a></li>
<li><a href="/news/interview">Interview</a></li>
<li><a href="/news/data_and_surveys">Data &amp; Survey</a></li>
<li><a href="/news/skinny">The Skinny</a></li>
<li><a href="/news/xtra">Xtra</a></li>
<li><a href="/news/budget-2022">Budget 2022</a></li>
</ul>
<div class="detail-content-box hidden-sm hidden-xs">
<div class="sub-menu-latest-stories">
<div class="row">
<div class="col-md-6">
<div class="left-section">
<div class="top-story-container">
<div class="photo">
<a href="/news/court_and_police/113360/court_upholds_yorgen_fenechs_request_for_keith_schembris_mobile_data_to_be_presented_in_court_"><img src="//content.maltatoday.com.mt/ui_frontend/thumbnail/400/220/keith_schembri_arriving_in_court_2.jpg" /></a>
</div>
<div class="title">
<span class="category">Court & Police</span> <a href="/news/court_and_police/113360/court_upholds_yorgen_fenechs_request_for_keith_schembris_mobile_data_to_be_presented_in_court_">
Court upholds Yorgen Fenech’s request for Keith Schembri’s mobile data to be presented in court</a>
</div>
</div>
</div>
</div>
<div class="col-md-6">
<div class="right-section">
<ul class="stories">
<li class="story">
<div class="story-content">
<div class="image">
<a href="/news/court_and_police/113359/director_acquitted_of_involuntary_homicide_of_his_brother_in_quarry_accident"><img src="//content.maltatoday.com.mt/ui_frontend/thumbnail/62/62/6_courts.jpg" /></a>
</div>
<div class="text">
<a href="/news/court_and_police/113359/director_acquitted_of_involuntary_homicide_of_his_brother_in_quarry_accident">
<span class="category">Court & Police</span>
<span class="title"> Director acquitted of involuntary homicide of his brother in quarry accident</span>
</a>
</div>
</div>
</li>
<li class="story">
<div class="story-content">
<div class="image">
<a href="/news/national/113358/new_covid_cases_in_malta_surge_to_79_hospitalisations_drop__austria_goes_into_lockdown"><img src="//content.maltatoday.com.mt/ui_frontend/thumbnail/62/62/2_12-13_coronavirus_1.jpg" /></a>
</div>
<div class="text">
<a href="/news/national/113358/new_covid_cases_in_malta_surge_to_79_hospitalisations_drop__austria_goes_into_lockdown">
<span class="category">National</span>
<span class="title"> New COVID cases in Malta surge to 79, hospitalisations drop • Austria to go into full lockdown</span>
</a>
</div>
</div>
</li>
<li class="story">
<div class="story-content">
<div class="image">
<a href="/news/court_and_police/113357/judge_shoots_down_yorgen_fenechs_request_to_reveal_identities_of_secret_service_agents"><img src="//content.maltatoday.com.mt/ui_frontend/thumbnail/62/62/yorgen_fenech_2.jpg" /></a>
</div>
<div class="text">
<a href="/news/court_and_police/113357/judge_shoots_down_yorgen_fenechs_request_to_reveal_identities_of_secret_service_agents">
<span class="category">Court & Police</span>
<span class="title"> Judge shoots down Yorgen Fenech's request to reveal identities of secret service agents</span>
</a>
</div>
</div>
</li>
</ul>
<a href="/news">More in News <i class="fa fa-angle-right"></i></a>
</div>
</div>
</div>
</div>
</div>
</div>
</li>
<li class="menu_item business has-sub-menu">
<a href="/business">
Business </a>
<div class="menu-item-detail-box">
<ul class="sub-menu">
<li><a href="/business/business_news">Business News</a></li>
<li><a href="/business/business_comment">Business Comment</a></li>
<li><a href="/business/tech">Tech & Gaming</a></li>
<li><a href="/business/law_report">Law Report</a></li>
<li><a href="/business/property">Property</a></li>
</ul>
<div class="detail-content-box hidden-sm hidden-xs">
<div class="sub-menu-latest-stories">
<div class="row">
<div class="col-md-6">
<div class="left-section">
<div class="top-story-container">
<div class="photo">
<a href="/business/business_comment/113338/shipping_outlook_remains_positive_despite_operational_challenges"><img src="//content.maltatoday.com.mt/ui_frontend/thumbnail/400/220/4q68kwxy0r3hc9w_pg3wuqncdpqqplhl-yt8ysw4trq.jpeg" /></a>
</div>
<div class="title">
<span class="category">Business Comment</span> <a href="/business/business_comment/113338/shipping_outlook_remains_positive_despite_operational_challenges">
Shipping: outlook remains positive despite operational challenges</a>
 </div>
</div>
</div>
</div>
<div class="col-md-6">
<div class="right-section">
<ul class="stories">
<li class="story">
<div class="story-content">
<div class="image">
<a href="/business/business_news/113331/ej_busuttil_ltd_supports_cancer_research_through_ridt_at_university_of_malta"><img src="//content.maltatoday.com.mt/ui_frontend/thumbnail/62/62/whatsapp_image_2021-11-17_at_5.45.55_pm.jpeg" /></a>
</div>
<div class="text">
<a href="/business/business_news/113331/ej_busuttil_ltd_supports_cancer_research_through_ridt_at_university_of_malta">
<span class="category">Business News</span>
<span class="title"> E.J. Busuttil Ltd supports cancer research through RIDT at University of Malta</span>
</a>
</div>
</div>
</li>
<li class="story">
<div class="story-content">
<div class="image">
<a href="/business/business_comment/113323/cc_funds_announced_3_annualised_distribution_for_the_malta_high_income_fund"><img src="//content.maltatoday.com.mt/ui_frontend/thumbnail/62/62/calamatta_cuschieri_head_office.jpg" /></a>
</div>
<div class="text">
<a href="/business/business_comment/113323/cc_funds_announced_3_annualised_distribution_for_the_malta_high_income_fund">
<span class="category">Business Comment</span>
<span class="title"> CC Funds announced 3% annualised distribution for the Malta High Income Fund</span>
</a>
</div>
</div>
</li>
<li class="story">
<div class="story-content">
<div class="image">
<a href="/business/business_news/113305/new_controller_appointed_to_nemea_bank_for_liquidation"><img src="//content.maltatoday.com.mt/ui_frontend/thumbnail/62/62/nemea_bank_logo.png" /></a>
</div>
<div class="text">
<a href="/business/business_news/113305/new_controller_appointed_to_nemea_bank_for_liquidation">
<span class="category">Business News</span>
<span class="title"> New controller appointed to Nemea Bank for liquidation</span>
</a>
</div>
</div>
</li>
</ul>
<a href="/business">More in Business <i class="fa fa-angle-right"></i></a>
</div>
</div>
</div>
</div>
</div>
</div>
</li>
<li class="menu_item sports has-sub-menu">
<a href="/sports">
Sports </a>
<div class="menu-item-detail-box">
<ul class="sub-menu">
<li><a href="/worldcup2018">World Cup 2018</a></li>
<li><a href="/sports/football">Football</a></li>
<li><a href="/sports/rugby">Rugby</a></li>
<li><a href="/sports/motorsports">Motor Sports</a></li>
<li><a href="/sports/boxing">Boxing</a></li>
<li><a href="/sports/tennis">Tennis</a></li>
<li><a href="/sports/cricket">Cricket</a></li>
</ul>
<div class="detail-content-box hidden-sm hidden-xs">
<div class="sub-menu-latest-stories">
<div class="row">
<div class="col-md-6">
<div class="left-section">
<div class="top-story-container">
<div class="photo">
<a href="/sports/sailing/112989/rolex_middle_sea_race_2021_comanche_confirmed_overall_winner"><img src="//content.maltatoday.com.mt/ui_frontend/thumbnail/400/220/comanche_middle_sea_2021_1.jpg" /></a>
</div>
<div class="title">
<span class="category">Sailing</span> <a href="/sports/sailing/112989/rolex_middle_sea_race_2021_comanche_confirmed_overall_winner">
Rolex Middle Sea Race 2021: Comanche confirmed overall winner</a>
</div>
</div>
</div>
</div>
<div class="col-md-6">
<div class="right-section">
<ul class="stories">
<li class="story">
<div class="story-content">
<div class="image">
<a href="/news/ewropej/112945/states_who_breach_human_rights_should_not_host_major_sporting_events_meps_say"><img src="//content.maltatoday.com.mt/ui_frontend/thumbnail/62/62/kakudmi-jo19k0hddxi-unsplash.jpg" /></a>
</div>
<div class="text">
<a href="/news/ewropej/112945/states_who_breach_human_rights_should_not_host_major_sporting_events_meps_say">
<span class="category">Football</span>
<span class="title"> States who breach human rights should not host major sporting events, MEPs say</span>
</a>
</div>
</div>
</li>
<li class="story">
<div class="story-content">
<div class="image">
<a href="/sports/sailing/112926/mediterranean_storm_belts_rolex_middle_sea_yachts_on_return_to_malta"><img src="//content.maltatoday.com.mt/ui_frontend/thumbnail/62/62/artie_iii_rolex_middle_sea.jpg" /></a>
</div>
<div class="text">
<a href="/sports/sailing/112926/mediterranean_storm_belts_rolex_middle_sea_yachts_on_return_to_malta">
<span class="category">Sailing</span>
<span class="title"> Mediterranean storm belts Rolex Middle Sea yachts on return to Malta</span>
</a>
</div>
</div>
</li>
<li class="story">
<div class="story-content">
<div class="image">
<a href="/sports/football/112844/longtime_rivals_valletta_and_hibernians_come_facetoface_this_weekend"><img src="//content.maltatoday.com.mt/ui_frontend/thumbnail/62/62/684_x_455.jpg" /></a>
</div>
<div class="text">
<a href="/sports/football/112844/longtime_rivals_valletta_and_hibernians_come_facetoface_this_weekend">
<span class="category">Football</span>
<span class="title"> Long-time rivals Valletta and Hibernians come face-to-face this weekend</span>
</a>
</div>
</div>
</li>
</ul>
<a href="/sports">More in Sports <i class="fa fa-angle-right"></i></a>
</div>
</div>
</div>
</div>
</div>
</div>
</li>
<li class="menu_item arts has-sub-menu">
<a href="/arts">
Arts </a>
<div class="menu-item-detail-box">
<ul class="sub-menu">
<li><a href="/arts/art">Art</a></li>
<li><a href="/arts/books">Books</a></li>
<li><a href="/arts/entertainment">Entertainment</a></li>
<li><a href="/arts/music">Music</a></li>
<li><a href="/arts/theatre_and_dance">Theatre &amp; Dance</a></li>
<li><a href="/arts/film">Film</a></li>
<li><a href="/arts/cultural_diary">Cultural Diary</a></li>
<li><a href="/arts/kwartaktieb/">KwartaKtieb</a></li>
<li><a href="/arts/valletta_2018">Valletta 2018</a></li>
</ul>
<div class="detail-content-box hidden-sm hidden-xs">
<div class="sub-menu-latest-stories">
<div class="row">
<div class="col-md-6">
<div class="left-section">
<div class="top-story-container">
<div class="photo">
<a href="/arts/cultural_diary/113282/my_essentials_chris_dinglis_cultural_picks"><img src="//content.maltatoday.com.mt/ui_frontend/thumbnail/400/220/tw_front_christopher_dingli_jonathan_dunn_stephen_oliver_as_you_like_it_photo_jacob_sammut.jpg" /></a>
</div>
<div class="title">
<span class="category">Cultural Diary</span> <a href="/arts/cultural_diary/113282/my_essentials_chris_dinglis_cultural_picks">
My essentials: Chris Dingli’s cultural picks</a>
</div>
</div>
</div>
</div>
<div class="col-md-6">
<div class="right-section">
<ul class="stories">
<li class="story">
<div class="story-content">
<div class="image">
<a href="/arts/cultural_diary/113156/my_essentials_catherine_cavallos_cultural_picks"><img src="//content.maltatoday.com.mt/ui_frontend/thumbnail/62/62/1_cover_mt3.jpg" /></a>
</div>
<div class="text">
<a href="/arts/cultural_diary/113156/my_essentials_catherine_cavallos_cultural_picks">
<span class="category">Cultural Diary</span>
<span class="title"> My essentials: Catherine Cavallo’s cultural picks</span>
</a>
</div>
</div>
</li>
<li class="story">
<div class="story-content">
<div class="image">
<a href="/arts/music/113226/rock_band_bring_me_the_horizon_to_curate_fourday_festival_in_malta"><img src="//content.maltatoday.com.mt/ui_frontend/thumbnail/62/62/screenshot_2021-11-11_at_19.26.25.png" /></a>
</div>
<div class="text">
<a href="/arts/music/113226/rock_band_bring_me_the_horizon_to_curate_fourday_festival_in_malta">
<span class="category">Music</span>
<span class="title"> Rock band Bring Me The Horizon to curate four-day festival in Malta</span>
</a>
</div>
</div>
</li>
<li class="story">
<div class="story-content">
<div class="image">
<a href="/arts/cultural_diary/113168/prime_minister_greets_russel_crowe_on_set_of_prizefighter"><img src="//content.maltatoday.com.mt/ui_frontend/thumbnail/62/62/opm0811202102.jpg" /></a>
</div>
<div class="text">
<a href="/arts/cultural_diary/113168/prime_minister_greets_russel_crowe_on_set_of_prizefighter">
<span class="category">Cultural Diary</span>
<span class="title"> Prime Minister greets Russell Crowe on set of ‘Prizefighter’</span>
</a>
</div>
</div>
</li>
</ul>
<a href="/arts">More in Arts <i class="fa fa-angle-right"></i></a>
</div>
</div>
</div>
</div>
 </div>
</div>
</li>
<li class="menu_item comment has-sub-menu">
<a href="/comment">
Comment </a>
<div class="menu-item-detail-box">
<ul class="sub-menu">
<li><a href="/comment/blogs">Blogs</a></li>
<li><a href="/comment/editorial">Editorial</a></li>
<li><a href="/comment/letters">Letters</a></li>
<li><a href="/comment/cartoons">Cartoons</a></li>
</ul>
<div class="detail-content-box hidden-sm hidden-xs">
<div class="sub-menu-latest-stories">
<div class="row">
<div class="col-md-6">
<div class="left-section">
<div class="top-story-container">
<div class="photo">
<a href="/comment/blogs/113280/cop_26_a_global_attempt_at_preventing_climate_disaster"><img src="//content.maltatoday.com.mt/ui_frontend/thumbnail/400/220/13_op_cyrus_engerer.jpg" /></a>
</div>
<div class="title">
<span class="category">Blogs</span> <a href="/comment/blogs/113280/cop_26_a_global_attempt_at_preventing_climate_disaster">
COP 26: A global attempt at preventing climate disaster</a>
</div>
</div>
</div>
</div>
<div class="col-md-6">
<div class="right-section">
<ul class="stories">
<li class="story">
<div class="story-content">
<div class="image">
<a href="/comment/blogs/113154/wuthering_heights_on_a_nascent_sea_of_green"><img src="//content.maltatoday.com.mt/ui_frontend/thumbnail/62/62/cannabis_and_resin.png" /></a>
</div>
<div class="text">
<a href="/comment/blogs/113154/wuthering_heights_on_a_nascent_sea_of_green">
<span class="category">Blogs</span>
<span class="title"> Wuthering heights on a nascent sea of green | Andrew Bonello</span>
</a>
</div>
</div>
</li>
<li class="story">
<div class="story-content">
<div class="image">
<a href="/comment/blogs/113318/nothing_is_certain_except_death_and_uturns"><img src="//content.maltatoday.com.mt/ui_frontend/thumbnail/62/62/opinion_raphael_vassallo.png" /></a>
</div>
<div class="text">
<a href="/comment/blogs/113318/nothing_is_certain_except_death_and_uturns">
<span class="category">Blogs</span>
<span class="title"> Nothing is certain, except death and… U-turns</span>
</a>
</div>
</div>
</li>
<li class="story">
<div class="story-content">
<div class="image">
<a href="/comment/editorial/113317/fairness_can_only_be_achieved_through_social_reform"><img src="//content.maltatoday.com.mt/ui_frontend/thumbnail/62/62/maltatoday_editorial.png" /></a>
</div>
<div class="text">
<a href="/comment/editorial/113317/fairness_can_only_be_achieved_through_social_reform">
<span class="category">Editorial</span>
<span class="title"> ‘Fairness’ can only be achieved through social reform</span>
</a>
</div>
</div>
</li>
</ul>
<a href="/comment">More in Comment <i class="fa fa-angle-right"></i></a>
</div>
</div>
</div>
</div>
</div>
</div>
</li>
<li class="menu_item videos">
<a href="/videos/">
Video </a>
</li>
<li class="menu_item archives">
<a href="http://archive.maltatoday.com.mt" target="_blank">
Archives </a>
</li>
<li class="menu_item sponsored visible-xs visible-sm">
<a href="/sponsored">
Sponsored </a>
</li>
<li class="menu_item gourmet-today has-sub-menu">
<a href="/gourmet/">
<img src="/ui/images/frontend/maltatoday_logo_gourmet.png" alt="Gourmet" />
</a>
<div class="menu-item-detail-box">
<ul class="sub-menu">
<li><a href="/gourmet/recipes/">Recipes</a></li>
<li><a href="/gourmet/restaurants/">Restaurants</a></li>
<li><a href="/gourmet/gourmet_today/">Magazines</a></li>
<li><a href="/gourmet/gourmettv/">TV</a></li>
<li><a href="/gourmet/videos/">Videos</a></li>
</ul>
</div>
</li>
<li class="menu_item deal-today visible-xs visible-sm">
<a href="/yellow">
Yellow </a>
</li>
<li class="menu_item login visible-xs visible-sm login-menu-item">
<a href="/maltatodaydigitaledition/">
Digital Paper </a>
</li>
</ul>
<div class="menu-icons hidden-xs hidden-sm">
<div class="menu-icons-icon search-icon" onclick="$(this).addClass('active').find('input').focus()">
<span class="fa fa-search"></span>
<div class="searchbox">
<form action="/search-mt/" method="get">
<input type="text" name="q" placeholder="Search" onblur="$(this).parents('.search-icon').removeClass('active');" onkeyup="if (event.keyCode === 27) { $(this).blur(); }" />
<button type="submit">
<i class="fa fa-search search_now"></i>
</button>
</form>
</div>
</div>
<div class="menu-icons-icon login-icon digital-paper">
<a href="/maltatodaydigitaledition/" class="btn btn-red">Digital Paper</a>
<div id="login-sub-menu">
<a target="_blank" href="https://maltatoday.uberflip.com/t/73329-mediatoday-newspapers-latest-editions">My Account</a>
<a href="/maltatodaydigitaledition/">Subscribe</a>
<a href="/subscribe_sms/">SMS Alerts</a>
<a href="/maltatodaydigitaledition/#previous">Previous Editions</a>
</div>
</div>
</div>
</div>
</div>
<div id="small-menu-placeholder" class="row visible-xs visible-sm news">
<div id="small-menu">
<a href="/">home</a>
<a href="/news">news</a>
<a class="highlight" href="/maltatodaydigitaledition">Digital Paper</a>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
<div class="sub-nav">
<div class="container">
<ul class="hidden-xs outer-sub-menu sub-menu news">
<li><a href="/news/national">National</a></li>
<li><a href="/covid19">Covid-19</a></li>
<li><a href="/news/ewropej">#EWROPEJ</a></li>
<li><a href="/news/court_and_police">Court &amp; Police</a></li>
<li><a href="/news/interview">Interview</a></li>
<li><a href="/news/data_and_surveys">Data &amp; Survey</a></li>
<li><a href="/news/skinny">The Skinny</a></li>
<li><a href="/news/xtra">Xtra</a></li>
<li><a href="/news/budget-2022">Budget 2022</a></li>
</ul>
</div>
</div>
</header>
<div id="content">
<section>
<div class="container">
<div class="row">
<div class="col-lg-12 col-md-12">
<div class="zone" data-zone-name="Top" data-zone-id="top"><div class='mt_module' data-module-name='article_breadcrumb' data-update-frequency='0'><ul class="breadcrumb">
<li class="breadcrumb-item news"><a href="/news/">News</a></li>
<li class="breadcrumb-item news"><a href="/news/court_and_police/">Court & Police</a></li>
</ul></div><div class='mt_module' data-module-name='article_heading' data-update-frequency='0'><div class="article-heading">
<div class="row">
<div class="col-md-12">
<h1>Judge shoots down Yorgen Fenech's request to reveal identities of secret service agents</h1>
<h2><p>The defence argued that the agents acted outside of their remit when they passed on information that led to Fenech&#39;s arrest on 19 November 2019</p></h2>
</div>
</div>
</div>
</div></div> </div>
</div>
<div class="row">
<div class="col-lg-2 col-md-2">
<div class="zone" data-zone-name="Left" data-zone-id="left"><div class='mt_module' data-module-name='article_meta' data-update-frequency='0'><div class="article-meta">
<div class="author-photos"> <img src="//content.maltatoday.com.mt/ui_frontend/profile_thumbnail/300/300/maltatoday_1547202840.jpg" alt="maltatoday" />
</div>
<div class="date-text">
<span class="date">19 November 2021, 11:48am</span>
<br />by <span class="name">Staff Reporter </span>
</div>
</div></div><div class='mt_module' data-module-name='addthis' data-update-frequency='0'> <script type="text/javascript" src="//s7.addthis.com/js/300/addthis_widget.js#pubid=ra-5a7023510fcc04af"></script>
</div></div> </div>
<div class="col-lg-8 col-md-8">
<div class="zone" data-zone-name="Main" data-zone-id="content"><div class='mt_module' data-module-name='article_cover' data-update-frequency='0'><div class="full-article article-cover">
<div class="photo_collection_cover article-cover-media single-cover" data-slick='{"slidesToShow": 1, "slidesToScroll": 1}'>
<div class="media-item show ">
<div class="cover-photo" title="" style="background-image: url('//content.maltatoday.com.mt/ui/images/photos/yorgen_fenech_2.jpg')">
<img src="//content.maltatoday.com.mt/ui_frontend/thumbnail/684/0/yorgen_fenech_2.jpg" alt="" />
</div>
</div>
</div>
</div></div><div class='mt_module' data-module-name='small_share_buttons' data-update-frequency='0'><div class="row">
<div class="col-md-6">
</div>
<div class="col-md-6">
<div class="small_share_buttons text-right">
<a class="addthis_button_facebook_like" fb:like:layout="button_count" style="position:relative; top: 4px; padding: 0px; right: -10px;"></a>
<script type="text/javascript">var addthis_config = {"data_track_addressbar":true};</script>
<script type="text/javascript" src="//s7.addthis.com/js/300/addthis_widget.js#pubid=seekopia"></script>
<a class="twitter" href="https://twitter.com/share?url=https://www.maltatoday.com.mt/news/court_and_police/113357/judge_shoots_down_yorgen_fenechs_request_to_reveal_identities_of_secret_service_agents&text=Judge shoots down Yorgen Fenech's request to reveal identities of secret service agents" target="_blank">
<i class="fa fa-twitter"></i> TWEET
</a>
<a class="facebook" href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.maltatoday.com.mt%2Fnews%2Fcourt_and_police%2F113357%2Fjudge_shoots_down_yorgen_fenechs_request_to_reveal_identities_of_secret_service_agents" target="_blank">
<i class="fa fa-facebook"></i> SHARE
</a>
</div>
</div>
</div></div><div class='mt_module' data-module-name='full_article' data-update-frequency='0'><div class="full-article">
<div class="content content-news"> <div class="dfp-slot" data-path="/13474545/MaltaToday_news_Inline_300x250" data-size="[[300, 250]]" style="float:right; margin:8px 0 8px 25px">
</div>
<p>Judge Miriam Hayman has denied a request by Yorgen Fenech&rsquo;s lawyers to divulge the names of officials from the Malta Secret Service who passed on information that led to Fenech&rsquo;s arrest on 19 November 2019 as he was leaving the Portomaso marina.
</p><p>The ruling comes two years to the day since Fenech was arrested.
</p><p>His lawyers made the request on the argument that the operation was unlawful. However, given that Fenech was ultimately intercepted when trying to flee Malta before his arrest, whether or not the names are divulged is irrelevant to the case, the judge argued.
</p><p>The court also denied a request by the State Advocate, Attorney General and parte civile to have Fenech&rsquo;s pending money laundering case presented as evidence in his murder compilation.
</p><p>This request was met with heavy objection from Fenech&rsquo;s lawyer Charles Mercieca. &ldquo;God forbid that a person be denied bail because of other pending cases before them,&rdquo; he said.
</p><p>Mercieca argued that the two cases are separate. In Fenech&rsquo;s case relating to the murder of Daphne Caruana Galizia, the prosecution can only work with his criminal conduct at the time of the charges. &ldquo;And it wasn&rsquo;t tainted,&rdquo; Mercieca remarked.
</p><p>Both requests by the prosecution and defence were thrown out by the judge.
</p><p>These requests were put forward in the constitutional case opened by Fenech over his repeated denial of bail throughout the murder compilation.
</p><p>The compilation was spurred by charges that Fenech was complicit in the assassination of journalist Daphne Caruana Galizia.
</p><p>Last summer, Fenech was also accused of money laundering and misappropriation from his company Glimmer Ltd, which he jointly owned with his uncle Ray Fenech.
</p><p>He is alleged to have misappropriated around &euro;40,000.
</p><p>Lawyers Charles Mercieca, Gianluca Caruana Curran and Marion Camilleri appeared for Yorgen Fenech. Lawyers Jason Azzopardi and Therese Comodini represented the Caruana Galizia family.
</p><p>The case will continue on December 15 at 1pm</p><p></p> </div>
</div></div><div class='mt_module' data-module-name='code' data-update-frequency='0' data-module-settings-code='PGRpdiBjbGFzcz0ic3BsaXQtYWR2ZXJ0IGRmcC1zbG90IiAKICAgICAgICAgICAgZGF0YS1wYXRoPSIvMTM0NzQ1NDUvTWFsdGFUb2RheV9bY2F0ZWdvcnldX0FydGljbGVMZWFkZXJib2FyZCIKICAgICAgICAgICAgZGF0YS1zaXplPSJbWzcyOCwgOTBdLCBbMzIwLCA1MF1dIj4KICAgICAgICA8L2Rpdj4='><div class="code_module">
<div class="split-advert dfp-slot" data-path="/13474545/MaltaToday_news_ArticleLeaderboard" data-size="[[728, 90], [320, 50]]">
</div></div></div><div class='mt_module' data-module-name='article_author_bios' data-update-frequency='0'> <div class="article-author-bio">
<div class="bio">
<div class="row">
<div class="col-xs-1">
<div class="image">
<img src="//content.maltatoday.com.mt/ui_frontend/profile_thumbnail/40/40/maltatoday_1547202845_zoom.jpg" />
</div>
</div>
<div class="col-xs-11">
<div class="socialmedia">
<span class="link readmore"> <a href="/author/maltatoday/">More from Staff Reporter</a></span>
</div>
</div>
</div>
</div>
</div>
</div><div class='mt_module' data-module-name='comments' data-update-frequency='0'><div id="taboola-below-article-thumbnails"></div>
<script type="text/javascript">window._taboola = window._taboola || [];_taboola.push({mode: 'thumbnails-a',container: 'taboola-below-article-thumbnails',placement: 'Below Article Thumbnails',target_type: 'mix'});</script>
<div id="disqus_thread"></div>
<script type="text/javascript">

    var disqus_config = function () {

        
            // The generated payload which authenticates users with Disqus
            this.page.remote_auth_s3 = 'eyJpZCI6InVzZXJfIiwidXNlcm5hbWUiOiIgIiwiZW1haWwiOm51bGx9 753c56fd4b09094ffed30c1243de01266dea9463 1637332087';
            this.page.api_key = 'KKsrhxY6LSXy3nbzit54YG6MHLFaxrOJ42o6hFm3W1sUtwGMqjEzqyO5HBu9sxTW';

                this.page.identifier = 'article_113357';
        this.sso = {
            name:   "MaltaToday.com.mt",
            button:  "https://www.maltatoday.com.mt/ui/images/frontend/disqus_button.png",
            icon:     "https://www.maltatoday.com.mt/ui/images/icons/Icon-Small@2x.png",
            url:      "https://www.maltatoday.com.mt/ui_frontend/login/",
            logout:  "https://www.maltatoday.com.mt/ui_frontend/disquslogout/",
            width:   "867",
            height:  "152"
        };
    };

    var disqus_shortname = 'malta-today';

    (function() {
        var dsq = document.createElement('script'); dsq.type = 'text/javascript'; dsq.async = true;
        dsq.src = '//' + disqus_shortname + '.disqus.com/embed.js';
        (document.getElementsByTagName('head')[0] || document.getElementsByTagName('body')[0]).appendChild(dsq);
    })();
</script>
<div id="taboola-below-article-thumbnails1"></div>
<script type="text/javascript">window._taboola = window._taboola || [];_taboola.push({mode: 'thumbnails-a1',container: 'taboola-below-article-thumbnails1',placement: 'Below Article Thumbnails1',target_type: 'mix'});</script></div></div> </div>
<div class="col-lg-2 col-md-2">
<div class="zone" data-zone-name="Right" data-zone-id="right"></div> </div>
</div>
<div class="row">
<div class="col-lg-12 col-md-12">
<div class="zone" data-zone-name="Bottom" data-zone-id="bottom"></div> </div>
</div>
</div>
</section></div>
<footer class="hidden-xs">
<div class="container">
<div class="row">
<div class="col-xs-12 col-sm-6">
<div class="footer-logo">
<a href="/"> <img src="/ui/images/frontend/maltatoday_logo_white.png" /></a>
</div>
</div>
<div class="col-xs-12 col-sm-6">
<div class="social-icons">
<div class="icon facebook">
<a href="//facebook.com/maltatoday" target="_blank"><i class="fa fa-facebook"></i></a>
</div>
<div class="icon twitter">
<a href="//twitter.com/maltatoday" target="_blank"><i class="fa fa-twitter"></i></a>
</div>
<div class="icon instagram">
<a href="//www.instagram.com/maltatoday" target="_blank"><i class="fa fa-instagram"></i></a>
</div>
<div class="icon youtube">
<a href="//www.youtube.com/user/ReporterMediaToday" target="_blank"><i class="fa fa-youtube"></i></a>
</div>
<div class="icon googleplus">
<a href="//plus.google.com/113527506098764625850" target="_blank"><i class="fa fa-google-plus"></i></a>
</div>
</div>
</div>
</div>
<div class="row">
<div class="col-xs-12">
<ul class="bottom-nav">
<li><a href="/about-us/">About Us</a></li>
<li><a href="/advertising/">Advertise</a> </li>
<li><a href="/contact/">Contact</a> </li>
<li><a href="/maltatodaydigitaledition/">Digital Edition</a></li>
<li><a href="/subscribe_sms/">SMS Alerts</a></li>
</ul>
<ul class="bottom-links">
<li><a href="/terms-and-conditions/">Terms and Conditions</a> </li>
<li><a href="/privacy-policy/">Privacy Policy</a> </li>
<li><a href="/privacy-policy/">Cookie Policy</a> </li>
<li><a target="_blank" href="http://archive.maltatoday.com.mt/archive.html">Archives</a></li>
</ul>
</div>
</div>
<div class="row">
<div class="col-md-12">
<div class="copyright">
MediaToday is an independent media house based in Malta. Copyright © MediaToday Co. Ltd, Vjal ir-Rihan, San Gwann SGN 9016, Malta, Europe <br />
Reproduction of material from this website without written permission is strictly prohibited.
</div>
</div>
</div>
</div>
</footer>
<div class="floating-bar" data-cookie-name="cookie_notice">
<div class="container">
<div class="message-inner">
<a href="https://www.maltatoday.com.mt/privacy-policy/" target="_blank" class="set-close">
By using this site, you agree to our Privacy Policy including the use of cookies to enhance your experience. </a>
<button class="message-close-btn set-close">
<i class="fa fa-times close"></i>
</button>
</div>
</div>
</div>
<script type="text/javascript" src="//imasdk.googleapis.com/js/sdkloader/ima3.js"></script>
<script type="text/javascript" src="/dist/js/packages.min.js?v=9.2021"></script>
<script>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</script>

<script type="text/javascript">
_atrk_opts = { atrk_acct:"io5hj1aAkN00oK", domain:"maltatoday.com.mt",dynamic: true};
(function() { var as = document.createElement('script'); as.type = 'text/javascript'; as.async = true; as.src = "https://certify-js.alexametrics.com/atrk.js"; var s = document.getElementsByTagName('script')[0];s.parentNode.insertBefore(as, s); })();
</script>
<noscript><img src="https://certify.alexametrics.com/atrk.gif?account=io5hj1aAkN00oK" style="display:none" height="1" width="1" alt="" /></noscript>

<script type="text/javascript" src="/dist/js/app.min.js?v=9.2021"></script>
<script type="text/javascript">
    var _gaq = _gaq || [];
    _gaq.push(['_setAccount', 'UA-16977049-1']);
    _gaq.push(['_trackPageview']);

    (function () {
        var ga = document.createElement('script'); ga.type =
            'text/javascript'; ga.async = true;
        ga.src = ('https:' == document.location.protocol ? 'https://ssl' :
            'http://www') + '.google-analytics.com/ga.js';
        var s = document.getElementsByTagName('script')[0];
        s.parentNode.insertBefore(ga, s);
    })();
</script>
<script id="dsq-count-scr" src="//malta-today.disqus.com/count.js" async></script>
<script type="text/javascript">
    window._taboola = window._taboola || [];
    _taboola.push({flush: true});
</script>
</body>
</html>
