<!DOCTYPE html>
<html xmlns="http://www.w3.org/1999/xhtml" lang="en">
<head>
<meta http-equiv="Content-Type" content="text/html; charset=utf-8">
<meta name="viewport" content="width=device-width, initial-scale=1.0" />
<meta property="fb:pages" content="21535456940" />
<meta property="fb:app_id" content="1775326929407925" />
<link rel="shortcut icon" type="image/x-icon" href="/ui/images/icons/Icon-Small@2x.png">
<link rel="apple-touch-icon" href="/ui/images/icons/Icon-60@2x.png" />
<link rel="apple-touch-icon" sizes="58x58" href="/ui/images/icons/Icon-Small@2x.png" />
<link rel="apple-touch-icon" sizes="76x76" href="/ui/images/icons/Icon-76.png" />
<link rel="apple-touch-icon" sizes="152x152" href="/ui/images/icons/Icon-76@2x.png" />
<link rel="apple-touch-icon" sizes="180x180" href="/ui/images/icons/Icon-60@3x.png" />
<link rel="icon" sizes="192x192" href="/ui/images/icons/icon-192x192.png" />
<link rel="stylesheet" href="/dist/css/desktop.min.css?v=2.1" />
<link rel="canonical" href="http://www.maltatoday.com.mt/news/national/88459/casa_challenges_labour_meps_on_fiau_report">
<meta property="og:site_name" content="MaltaToday.com.mt" />
<meta property="og:url" content="http://www.maltatoday.com.mt/news/national/88459/casa_challenges_labour_meps_on_fiau_report" />
<meta property="og:title" content="Casa challenges Labour MEPs on FIAU report" />
<meta property="og:description" content="The Nationalist MEP said Marlene Mizzi and Miriam Dalli should say they do not believe the FIAU report and clarify their positions on&amp;nbsp;Konrad Mizzi and Keith Schembri" />
<meta property="og:type" content="article" />
<meta property="article:publisher" content="https://www.facebook.com/maltatoday" />
<meta property="og:image" content="http://cdn.maltatoday.com.mt/ui_frontend/thumbnail/684/400/david_casa_1.png" />
<meta name="description" content="The Nationalist MEP said Marlene Mizzi and Miriam Dalli should say they do not believe the FIAU report and clarify their positions on&amp;nbsp;Konrad Mizzi and Keith Schembri" />
<script type="text/javascript">
        var cdn_url = "//content.maltatoday.com.mt";
    </script>
<title>Casa challenges Labour MEPs on FIAU report</title>

<script async='async' src='https://www.googletagservices.com/tag/js/gpt.js'></script>
<script>
        var googletag = googletag || {};
        googletag.cmd = googletag.cmd || [];
    </script>
</head>
<body class="page-article">
<header>
<div class="zone" data-zone-name="TOPMOST" data-zone-id="TOPMOST"><div class='mt_module' data-module-name='code' data-update-frequency='0' data-module-settings-code='PGRpdiBjbGFzcz0idG9wLXNsYXNoIGRmcC1zbG90IiAKICAgICAgICAgICAgZGF0YS1wYXRoPSIvMTM0NzQ1NDUvTWFsdGFUb2RheV9bY2F0ZWdvcnldX0xlYWRlcmJvYXJkXzcyOHg5MCIKICAgICAgICAgICAgZGF0YS1zaXplPSJbWzcyOCwgOTBdLCBbOTcwLCA5MF0sIFs5NzAsIDI1MF0sIFszMjAsIDUwXSwgWzEzMjAsIDI1MF0sIFsxMTUwLCAyNTBdXSI+CiAgICAgICAgPC9kaXY+'><div class="code_module">
<div class="top-slash dfp-slot" data-path="/13474545/MaltaToday_news_Leaderboard_728x90" data-size="[[728, 90], [970, 90], [970, 250], [320, 50], [1320, 250], [1150, 250]]">
</div></div></div></div> <div class="main-nav">
<div class="main-nav-bg">
<div class="container">
<div class="row">
<div class="col-md-12">
<div class="row">
<div class="menu-bar news">
<div class="logo col-xs-7 col-md-2">
<a href="/"><img class="img-responsive" src="/ui/images/frontend/maltatoday_logo_news.png" alt="maltatoday" /></a>
</div>
<div class="col-xs-5 visible-sm visible-xs text-right">
<div id="more-menu">
menu
<button type="button" class="navbar-toggle" aria-expanded="false">
<span class="sr-only">Toggle navigation</span>
<span class="icon-bar"></span>
<span class="icon-bar"></span>
<span class="icon-bar"></span>
</button>
</div>
</div>
<ul class="main-menu">
<li class="menu-inline-search visible-xs">
<form action="/search-mt/" method="get">
<div class="col-xs-12">
<input type="text" name="q" class="form-control" placeholder="Search maltatoday.." />
</div>
</form>
</li>
<li class="menu_item home has-sub-menu">
<a href="/">
Home </a>
<div class="menu-item-detail-box">
<ul class="sub-menu">
<li><a href="http://frontpages.maltatoday.com.mt/">Today's Newspapers</a></li>
<li><a href="/vacancies">Vacancies</a></li>
<li><a href="/deals">DealToday</a></li>
<li><a href="/pharmacies">Pharmacies</a></li>
<li><a href="/sponsored">Sponsored</a></li>
<li><a href="/announcements">Announcements</a></li>
<li><a href="/advertising">Advertise</a></li>
<li><a href="/contact">Contact</a></li>
<li><a href="/maltatodaydigitaledition">Digital Edition</a></li>
<li><a href="/subscribe_sms">SMS Alerts</a></li>
</ul>
</div>
</li>
<li class="menu_item news active has-sub-menu">
<a href="/news">
News </a>
<div class="menu-item-detail-box">
<ul class="sub-menu">
<li><a href="/news/national">National</a></li>
<li><a href="/news/europe">Europe</a></li>
<li><a href="/news/world">World</a></li>
<li><a href="/news/court_and_police">Court &amp; Police</a></li>
<li><a href="/news/interview">Interview</a></li>
<li><a href="/news/data_and_surveys">Data &amp; Survey</a></li>
<li><a href="/news/xtra">Xtra</a></li>
<li><a href="/news/election-2017">Election 2017</a></li>
</ul>
<div class="detail-content-box hidden-sm hidden-xs">
<div class="sub-menu-latest-stories">
<div class="row">
<div class="col-md-6">
<div class="left-section">
<div class="top-story-container">
<div class="photo">
<a href="/news/court_and_police/88460/egrant__adrian_delia_files_judicial_protest_against_attorney_general"><img src="//content.maltatoday.com.mt/ui_frontend/thumbnail/400/220/jpb_8484.jpg" /></a>
</div>
<div class="title">
<span class="category">Court & Police</span> <a href="/news/court_and_police/88460/egrant__adrian_delia_files_judicial_protest_against_attorney_general">
Egrant | Adrian Delia files judicial protest against Attorney General</a>
</div>
</div>
</div>
</div>
<div class="col-md-6">
<div class="right-section">
<ul class="stories">
<li class="story">
<div class="story-content">
<div class="image">
<a href="/news/national/88459/casa_challenges_labour_meps_on_fiau_report"><img src="//content.maltatoday.com.mt/ui_frontend/thumbnail/62/62/david_casa_1.png" /></a>
</div>
<div class="text">
<a href="/news/national/88459/casa_challenges_labour_meps_on_fiau_report">
<span class="category">National</span>
<span class="title"> Casa challenges Labour MEPs on FIAU report</span>
</a>
</div>
</div>
</li>
<li class="story">
<div class="story-content">
<div class="image">
<a href="/news/national/88445/ana_gomes_raises_ire_of_labour_mep_after_casting_doubt_on_maltese_judiciary"><img src="//content.maltatoday.com.mt/ui_frontend/thumbnail/62/62/ana_gomes.png" /></a>
</div>
<div class="text">
<a href="/news/national/88445/ana_gomes_raises_ire_of_labour_mep_after_casting_doubt_on_maltese_judiciary">
<span class="category">National</span>
<span class="title"> Ana Gomes raises ire of Labour MEP after casting doubt on Maltese judiciary</span>
</a>
</div>
</div>
</li>
<li class="story">
<div class="story-content">
<div class="image">
<a href="/news/national/88380/transport_malta_fines_bus_company_183000_for_missed_trips"><img src="//content.maltatoday.com.mt/ui_frontend/thumbnail/62/62/new_buses_1.png" /></a>
</div>
<div class="text">
<a href="/news/national/88380/transport_malta_fines_bus_company_183000_for_missed_trips">
<span class="category">National</span>
<span class="title"> Transport Malta fines bus company €183,000 for missed trips</span>
</a>
</div>
</div>
</li>
</ul>
<a href="/news">More in News <i class="fa fa-angle-right"></i></a>
</div>
</div>
</div>
</div>
</div>
</div>
</li>
<li class="menu_item business has-sub-menu">
<a href="/business">
Business </a>
<div class="menu-item-detail-box">
<ul class="sub-menu">
<li><a href="/business/business_news">Business News</a></li>
<li><a href="/business/business_comment">Business Comment</a></li>
<li><a href="/business/technology">Technology</a></li>
<li><a href="/business/law_report">Law Report</a></li>
</ul>
<div class="detail-content-box hidden-sm hidden-xs">
<div class="sub-menu-latest-stories">
<div class="row">
<div class="col-md-6">
<div class="left-section">
<div class="top-story-container">
<div class="photo">
<a href="/business/business_comment/88443/european_and_us_markets_close_higher__calamatta_cuschieri"><img src="//content.maltatoday.com.mt/ui_frontend/thumbnail/400/220/136_untitled.png" /></a>
</div>
<div class="title">
<span class="category">Business Comment</span> <a href="/business/business_comment/88443/european_and_us_markets_close_higher__calamatta_cuschieri">
European and U.S. markets close higher | Calamatta Cuschieri</a>
</div>
</div>
</div>
</div>
<div class="col-md-6">
<div class="right-section">
<ul class="stories">
<li class="story">
<div class="story-content">
<div class="image">
<a href="/business/business_comment/88441/cryptocurrencies__are_they_a_wolf_in_sheeps_clothing__pkf_malta"><img src="//content.maltatoday.com.mt/ui_frontend/thumbnail/62/62/5_13_op_mangion_pic.png" /></a>
</div>
<div class="text">
<a href="/business/business_comment/88441/cryptocurrencies__are_they_a_wolf_in_sheeps_clothing__pkf_malta">
<span class="category">Business Comment</span>
<span class="title"> Cryptocurrencies – are they a wolf in sheep’s clothing? | PKF Malta</span>
</a>
</div>
</div>
</li>
<li class="story">
<div class="story-content">
<div class="image">
<a href="/business/business_comment/88421/european_markets_performance_in_stark_contrast_to_that_of_us_markets__calamatta_cuschieri"><img src="//content.maltatoday.com.mt/ui_frontend/thumbnail/62/62/135_untitled.png" /></a>
</div>
<div class="text">
<a href="/business/business_comment/88421/european_markets_performance_in_stark_contrast_to_that_of_us_markets__calamatta_cuschieri">
<span class="category">Business Comment</span>
<span class="title"> European markets performance in stark contrast to that of U.S. markets | Calamatta Cuschieri</span>
 </a>
</div>
</div>
</li>
<li class="story">
<div class="story-content">
<div class="image">
<a href="/business/business_comment/88373/a_friday_recap_and_the_uk_earnings_season_kicks_in__calamatta_cuschieri"><img src="//content.maltatoday.com.mt/ui_frontend/thumbnail/62/62/10_calamatta.png" /></a>
</div>
<div class="text">
<a href="/business/business_comment/88373/a_friday_recap_and_the_uk_earnings_season_kicks_in__calamatta_cuschieri">
<span class="category">Business Comment</span>
<span class="title"> A Friday re-cap and the UK earnings season kicks in | Calamatta Cuschieri</span>
</a>
</div>
</div>
</li>
</ul>
<a href="/business">More in Business <i class="fa fa-angle-right"></i></a>
</div>
</div>
</div>
</div>
</div>
</div>
</li>
<li class="menu_item sports has-sub-menu">
<a href="/sports">
Sports </a>
<div class="menu-item-detail-box">
<ul class="sub-menu">
<li><a href="/worldcup2018">World Cup 2018</a></li>
<li><a href="/sports/football">Football</a></li>
<li><a href="/sports/rugby">Rugby</a></li>
<li><a href="/sports/motorsports">Motor Sports</a></li>
<li><a href="/sports/boxing">Boxing</a></li>
<li><a href="/sports/tennis">Tennis</a></li>
<li><a href="/sports/cricket">Cricket</a></li>
</ul>
<div class="detail-content-box hidden-sm hidden-xs">
<div class="sub-menu-latest-stories">
<div class="row">
<div class="col-md-6">
<div class="left-section">
<div class="top-story-container">
<div class="photo">
<a href="/sports/football/88335/balzan_make_club_history_after_passing_to_the_second_stage_of_the_europa_league_"><img src="//content.maltatoday.com.mt/ui_frontend/thumbnail/400/220/screen_shot_2018-07-20_at_13.33.06.png" /></a>
</div>
<div class="title">
<span class="category">Football</span> <a href="/sports/football/88335/balzan_make_club_history_after_passing_to_the_second_stage_of_the_europa_league_">
[WATCH] Balzan make club history after passing to the second stage of the Europa League</a>
</div>
</div>
</div>
</div>
<div class="col-md-6">
<div class="right-section">
<ul class="stories">
<li class="story">
<div class="story-content">
<div class="image">
<a href="/sports/worldcup2018/88222/live_world_cup_final__france_vs_croatia"><img src="//content.maltatoday.com.mt/ui_frontend/thumbnail/62/62/world_cup_final_2018.png" /></a>
</div>
<div class="text">
<a href="/sports/worldcup2018/88222/live_world_cup_final__france_vs_croatia">
<span class="category">World Cup 2018</span>
<span class="title"> [WATCH] France beat Croatia to claim World Cup</span>
</a>
</div>
</div>
</li>
<li class="story">
<div class="story-content">
<div class="image">
<a href="/sports/worldcup2018/88211/england_finish_fourth_as_belgium_secure_third_place_"><img src="//content.maltatoday.com.mt/ui_frontend/thumbnail/62/62/c28869bb-c5cb-48aa-a41f-0868c41b8c18.jpg" /></a>
</div>
<div class="text">
<a href="/sports/worldcup2018/88211/england_finish_fourth_as_belgium_secure_third_place_">
<span class="category">World Cup 2018</span>
<span class="title"> England finish fourth as Belgium secure third place</span>
</a>
</div>
</div>
</li>
<li class="story">
<div class="story-content">
<div class="image">
<a href="/sports/football/88202/watch_2022_world_cup_in_qatar_will_be_held_in_november_and_december"><img src="//content.maltatoday.com.mt/ui_frontend/thumbnail/62/62/2_qatar.jpg" /></a>
</div>
<div class="text">
<a href="/sports/football/88202/watch_2022_world_cup_in_qatar_will_be_held_in_november_and_december">
<span class="category">Football</span>
<span class="title"> [WATCH] 2022 World Cup in Qatar will be held in November and December</span>
</a>
</div>
</div>
</li>
</ul>
<a href="/sports">More in Sports <i class="fa fa-angle-right"></i></a>
</div>
</div>
</div>
</div>
</div>
</div>
</li>
<li class="menu_item lifestyle has-sub-menu">
<a href="/lifestyle">
Lifestyle </a>
<div class="menu-item-detail-box">
<ul class="sub-menu">
<li><a href="/lifestyle/food">Gourmet Today</a></li>
<li><a href="/lifestyle/health">Health</a></li>
<li><a href="/environment/environment">Environment</a></li>
<li><a href="/lifestyle/travel">Travel</a></li>
</ul>
<div class="detail-content-box hidden-sm hidden-xs">
<div class="sub-menu-latest-stories">
<div class="row">
<div class="col-md-6">
<div class="left-section">
<div class="top-story-container">
<div class="photo">
<a href="/lifestyle/health/88446/keep_cool_in_the_heat_who_warns_over_hot_european_summer"><img src="//content.maltatoday.com.mt/ui_frontend/thumbnail/400/220/sunshine.png" /></a>
</div>
<div class="title">
<span class="category">Health</span> <a href="/lifestyle/health/88446/keep_cool_in_the_heat_who_warns_over_hot_european_summer">
Keep cool in the heat, WHO warns over hot European summer</a>
</div>
</div>
</div>
</div>
<div class="col-md-6">
<div class="right-section">
<ul class="stories">
<li class="story">
<div class="story-content">
<div class="image">
<a href="/lifestyle/food/88419/bigilla_burger_"><img src="//content.maltatoday.com.mt/ui_frontend/thumbnail/62/62/bigilla_burger.jpg" /></a>
</div>
<div class="text">
<a href="/lifestyle/food/88419/bigilla_burger_">
<span class="category">Food</span>
<span class="title"> Bigilla burger</span>
</a>
</div>
</div>
</li>
<li class="story">
<div class="story-content">
<div class="image">
<a href="/lifestyle/question_and_answer/88390/clare_azzopardi_the_most_important_lesson_life_has_taught_me_is_not_to_expect_anything_from_anyone"><img src="//content.maltatoday.com.mt/ui_frontend/thumbnail/62/62/2-3_clare_azzopardi.jpg" /></a>
</div>
<div class="text">
<a href="/lifestyle/question_and_answer/88390/clare_azzopardi_the_most_important_lesson_life_has_taught_me_is_not_to_expect_anything_from_anyone">
<span class="category">Q & A</span>
<span class="title"> Clare Azzopardi: The most important lesson life has taught me is not to expect anything from anyone</span>
</a>
</div>
</div>
</li>
<li class="story">
<div class="story-content">
<div class="image">
<a href="/lifestyle/food/88407/mussels_in_white_wine_and_garlic"><img src="//content.maltatoday.com.mt/ui_frontend/thumbnail/62/62/mussels.jpg" /></a>
</div>
<div class="text">
<a href="/lifestyle/food/88407/mussels_in_white_wine_and_garlic">
<span class="category">Food</span>
<span class="title"> Mussels in white wine and garlic</span>
</a>
</div>
</div>
</li>
</ul>
<a href="/lifestyle">More in Lifestyle <i class="fa fa-angle-right"></i></a>
</div>
</div>
</div>
</div>
</div>
</div>
</li>
<li class="menu_item arts has-sub-menu">
<a href="/arts">
Arts </a>
<div class="menu-item-detail-box">
<ul class="sub-menu">
<li><a href="/arts/art">Art</a></li>
<li><a href="/arts/books">Books</a></li>
<li><a href="/arts/entertainment">Entertainment</a></li>
<li><a href="/arts/music">Music</a></li>
<li><a href="/arts/theatre_and_dance">Theatre &amp; Dance</a></li>
<li><a href="/arts/film">Film</a></li>
<li><a href="/arts/cultural_diary">Cultural Diary</a></li>
<li><a href="/arts/valletta_2018">Valletta 2018</a></li>
</ul>
<div class="detail-content-box hidden-sm hidden-xs">
<div class="sub-menu-latest-stories">
<div class="row">
<div class="col-md-6">
<div class="left-section">
<div class="top-story-container">
<div class="photo">
<a href="/arts/theatre_and_dance/88391/whats_going_on_here__ruth_borg"><img src="//content.maltatoday.com.mt/ui_frontend/thumbnail/400/220/tw_front_gina_ruth_borg_pix_2.jpg" /></a>
</div>
<div class="title">
<span class="category">Theatre & Dance</span> <a href="/arts/theatre_and_dance/88391/whats_going_on_here__ruth_borg">
‘What’s going on here?’ | Ruth Borg</a>
</div>
</div>
</div>
</div>
<div class="col-md-6">
<div class="right-section">
<ul class="stories">
<li class="story">
<div class="story-content">
<div class="image">
<a href="/comment/blogs/88401/creating_a_centre_for_books_in_valletta"><img src="//content.maltatoday.com.mt/ui_frontend/thumbnail/62/62/8034_books.png" /></a>
</div>
<div class="text">
<a href="/comment/blogs/88401/creating_a_centre_for_books_in_valletta">
<span class="category">Books</span>
<span class="title"> Creating a centre for books in Valletta</span>
</a>
</div>
</div>
</li>
<li class="story">
<div class="story-content">
<div class="image">
<a href="/arts/film/88392/film_review__the_happy_prince"><img src="//content.maltatoday.com.mt/ui_frontend/thumbnail/62/62/film_review_overlay_(6).png" /></a>
</div>
<div class="text">
<a href="/arts/film/88392/film_review__the_happy_prince">
<span class="category">Film</span>
<span class="title"> Film review | The Happy Prince</span>
</a>
</div>
</div>
</li>
<li class="story">
<div class="story-content">
<div class="image">
<a href="/arts/books/88378/dun_karm_psaila_arab_translation_walid_nabhan_malta"><img src="//content.maltatoday.com.mt/ui_frontend/thumbnail/62/62/walid_nabhan.jpg" /></a>
</div>
<div class="text">
<a href="/arts/books/88378/dun_karm_psaila_arab_translation_walid_nabhan_malta">
<span class="category">Books</span>
<span class="title"> Dun Karm Psaila’s opus to get Arabic translation by Walid Nabhan</span>
</a>
</div>
</div>
</li>
</ul>
<a href="/arts">More in Arts <i class="fa fa-angle-right"></i></a>
</div>
</div>
</div>
</div>
</div>
</div>
</li>
<li class="menu_item comment has-sub-menu">
<a href="/comment">
Comment </a>
<div class="menu-item-detail-box">
<ul class="sub-menu">
<li><a href="/comment/blogs">Blogs</a></li>
<li><a href="/comment/editorial">Editorial</a></li>
<li><a href="/comment/letters">Letters</a></li>
<li><a href="/comment/cartoons">Cartoons</a></li>
</ul>
<div class="detail-content-box hidden-sm hidden-xs">
<div class="sub-menu-latest-stories">
<div class="row">
<div class="col-md-6">
<div class="left-section">
<div class="top-story-container">
<div class="photo">
<a href="/comment/blogs/88457/can_you_handle_the_truth"><img src="//content.maltatoday.com.mt/ui_frontend/thumbnail/400/220/joseph_muscat_egrant_inquiry_tears.jpeg" /></a>
</div>
<div class="title">
<span class="category">Blogs</span> <a href="/comment/blogs/88457/can_you_handle_the_truth">
Can you handle the truth?</a>
</div>
</div>
</div>
</div>
<div class="col-md-6">
<div class="right-section">
<ul class="stories">
<li class="story">
<div class="story-content">
<div class="image">
<a href="/comment/blogs/88402/method_in_the_madness_evarist_bartolo"><img src="//content.maltatoday.com.mt/ui_frontend/thumbnail/62/62/trump_putin.jpg" /></a>
</div>
<div class="text">
<a href="/comment/blogs/88402/method_in_the_madness_evarist_bartolo">
<span class="category">Blogs</span>
<span class="title"> There’s method in the madness</span>
</a>
</div>
</div>
</li>
<li class="story">
<div class="story-content">
<div class="image">
<a href="/comment/blogs/88440/no_one_forges_documents_to_uncover_the_truth"><img src="//content.maltatoday.com.mt/ui_frontend/thumbnail/62/62/2_mdm.jpg" /></a>
</div>
<div class="text">
<a href="/comment/blogs/88440/no_one_forges_documents_to_uncover_the_truth">
<span class="category">Blogs</span>
<span class="title"> ‘No one forges documents to uncover the truth’</span>
</a>
</div>
</div>
</li>
<li class="story">
<div class="story-content">
<div class="image">
<a href="/comment/editorial/88431/the_big_lie"><img src="//content.maltatoday.com.mt/ui_frontend/thumbnail/62/62/kar_mw_25_lul_2018.jpg" /></a>
</div>
<div class="text">
<a href="/comment/editorial/88431/the_big_lie">
<span class="category">Editorial</span>
<span class="title"> The Big Lie</span>
</a>
</div>
</div>
</li>
</ul>
<a href="/comment">More in Comment <i class="fa fa-angle-right"></i></a>
</div>
</div>
</div>
</div>
</div>
</div>
</li>
<li class="menu_item videos">
<a href="/videos">
Video </a>
</li>
<li class="menu_item frontpages visible-xs">
<a href="http://frontpages.maltatoday.com.mt">
Frontpages </a>
</li>
<li class="menu_item gourmet-today visible-xs">
<a href="/lifestyle/food">
<img src="/ui/images/frontend/maltatoday_logo_gourmet.png" alt="GourmetToday" />
</a>
</li>
<li class="menu_item deal-today visible-xs">
<a href="/deals">
DealToday </a>
</li>
<li class="menu_item login visible-xs login-menu-item">
<a href="/maltatodaydigitaledition/">
Login to Digital Edition </a>
</li>
</ul>
<div class="menu-icons hidden-xs hidden-sm">
<div class="menu-icons-icon search-icon" onclick="$(this).addClass('active').find('input').focus()">
<span class="fa fa-search"></span>
<div class="searchbox">
<form action="/search-mt/" method="get">
<input type="text" name="q" placeholder="Search" onblur="$(this).parents('.search-icon').removeClass('active');" onkeyup="if (event.keyCode === 27) { $(this).blur(); }" />
<button type="submit">
<i class="fa fa-search search_now"></i>
</button>
</form>
</div>
</div>
<div class="menu-icons-icon login-icon">
<a href="/maltatodaydigitaledition/" class="btn btn-red">Login</a>
</div>
</div>
</div>
</div>
<div id="small-menu-placeholder" class="row visible-xs visible-sm news">
<div id="small-menu">
<a href="/">home</a>
<a href="/news">news</a>
<a class="highlight" href="/maltatodaydigitaledition">login</a>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
<div class="sub-nav">
<div class="container">
<ul class="hidden-xs outer-sub-menu sub-menu news">
<li><a href="/news/national">National</a></li>
<li><a href="/news/europe">Europe</a></li>
<li><a href="/news/world">World</a></li>
<li><a href="/news/court_and_police">Court &amp; Police</a></li>
<li><a href="/news/interview">Interview</a></li>
<li><a href="/news/data_and_surveys">Data &amp; Survey</a></li>
<li><a href="/news/xtra">Xtra</a></li>
<li><a href="/news/election-2017">Election 2017</a></li>
</ul>
</div>
</div>
</header>
<div id="content">
<section>
<div class="container">
<div class="row">
<div class="col-lg-12 col-md-12">
<div class="zone" data-zone-name="Top" data-zone-id="top"><div class='mt_module' data-module-name='article_breadcrumb' data-update-frequency='0'><ul class="breadcrumb">
<li class="breadcrumb-item news"><a href="/news/">News</a></li>
<li class="breadcrumb-item news"><a href="/news/national/">National</a></li>
</ul></div><div class='mt_module' data-module-name='article_heading' data-update-frequency='0'><div class="article-heading">
<div class="row">
<div class="col-md-12">
<h1>Casa challenges Labour MEPs on FIAU report</h1>
<h2><p>The Nationalist MEP said Marlene Mizzi and Miriam Dalli should say they do not believe the FIAU report and clarify their positions on&nbsp;Konrad Mizzi and Keith Schembri</p></h2>
</div>
</div>
</div>
</div></div> </div>
</div>
<div class="row">
<div class="col-lg-2 col-md-2">
<div class="zone" data-zone-name="Left" data-zone-id="left"><div class='mt_module' data-module-name='article_meta' data-update-frequency='0'><div class="article-meta">
<div class="author-photos"> <img src="//content.maltatoday.com.mt/ui_frontend/profile_thumbnail/300/300/maria_pace_1510227819.jpg" alt="maria_pace" />
</div>
<div class="date-text">
<span class="date">26 July 2018, 11:20am</span>
<br />by <span class="name">Maria Pace </span>
</div>
</div></div><div class='mt_module' data-module-name='addthis' data-update-frequency='0'> <script type="text/javascript" src="//s7.addthis.com/js/300/addthis_widget.js#pubid=ra-5a7023510fcc04af"></script>
</div></div> </div>
<div class="col-lg-8 col-md-8">
<div class="zone" data-zone-name="Main" data-zone-id="content"><div class='mt_module' data-module-name='article_cover' data-update-frequency='0'><div class="full-article article-cover">
<div class="photo_collection_cover article-cover-media single-cover" data-slick='{"slidesToShow": 1, "slidesToScroll": 1}'>
<div class="media-item show ">
<div class="cover-photo" title="" style="background-image: url('//content.maltatoday.com.mt/ui/images/photos/david_casa_1.png')">
<img src="//content.maltatoday.com.mt/ui_frontend/thumbnail/684/0/david_casa_1.png" alt="" />
</div>
</div>
</div>
</div></div><div class='mt_module' data-module-name='small_share_buttons' data-update-frequency='0'><div class="row">
<div class="col-md-6">
</div>
<div class="col-md-6">
<div class="small_share_buttons text-right">
<a class="addthis_button_facebook_like" fb:like:layout="button_count" style="position:relative; top: 4px; padding: 0px; right: -10px;"></a>
<script type="text/javascript">var addthis_config = {"data_track_addressbar":true};</script>
<script type="text/javascript" src="//s7.addthis.com/js/300/addthis_widget.js#pubid=seekopia"></script>
<a class="twitter" href="https://twitter.com/share?url=https://www.maltatoday.com.mt/news/national/88459/casa_challenges_labour_meps_on_fiau_report&text=Casa challenges Labour MEPs on FIAU report" target="_blank">
<i class="fa fa-twitter"></i> TWEET
</a>
<a class="facebook" href="http://www.facebook.com/sharer.php?s=100&p[url]=https://www.maltatoday.com.mt/news/national/88459/casa_challenges_labour_meps_on_fiau_report" target="_blank">
<i class="fa fa-facebook"></i> SHARE
</a>
</div>
</div>
</div></div><div class='mt_module' data-module-name='full_article' data-update-frequency='0'><div class="full-article">
<div class="content content-news"> <div class="dfp-slot" data-path="/13474545/MaltaToday_news_Inline_300x250" data-size="[[300, 250]]" style="float:right; margin:8px 0 8px 25px">
</div>
<p>Nationalist MEP David Casa has challenged Labour MEPs Marlene Mizzi and Miriam Dalli to say that they do not believe the contents of the FIAU reports.
</p><p>In a statement, Casa said the two MEPs &ldquo;should stop hiding behind vague phrases in opinion pieces and clarify their position on Konrad Mizzi, Keith Schembri, Pilatus Bank and Nexia BT,&rdquo; Casa said.
</p><p>&nbsp;&ldquo;They should state unequivocally that do not believe the contents of the FIAU reports. They should state unequivocally that they believe that Konrad Mizzi, Keith Schembri, Pilatus Bank and Nexia BT were not involved in criminal activity,&rdquo; Casa said.
</p><p>He said the two were attempting to blur the lines between the conclusions of the part-published inquiry and his work. He said the Egrant Inquiry and the FIAU report have nothing to do with each other. &ldquo;Their suggestion that there is a connection between them has disgraced the office they hold,&rdquo; he said.&nbsp;</p><p></p> </div>
</div></div><div class='mt_module' data-module-name='code' data-update-frequency='0' data-module-settings-code='PGRpdiBjbGFzcz0ic3BsaXQtYWR2ZXJ0IGRmcC1zbG90IiAKICAgICAgICAgICAgZGF0YS1wYXRoPSIvMTM0NzQ1NDUvTWFsdGFUb2RheV9bY2F0ZWdvcnldX0FydGljbGVMZWFkZXJib2FyZCIKICAgICAgICAgICAgZGF0YS1zaXplPSJbWzcyOCwgMjUwXSwgWzcyOCwgOTBdLCBbMzIwLCA1MF1dIj4KICAgICAgICA8L2Rpdj4='><div class="code_module">
<div class="split-advert dfp-slot" data-path="/13474545/MaltaToday_news_ArticleLeaderboard" data-size="[[728, 250], [728, 90], [320, 50]]">
</div></div></div><div class='mt_module' data-module-name='article_author_bios' data-update-frequency='0'> <div class="article-author-bio">
<div class="bio">
<div class="row">
<div class="col-xs-1">
<div class="image">
<img src="//content.maltatoday.com.mt/ui_frontend/profile_thumbnail/40/40/maria_pace_1510227815_zoom.jpg" />
</div>
</div>
<div class="col-xs-11">
 <div class="text">
Maria Pace joined MaltaToday in 2017. </div>
<div class="socialmedia">
<span class="link readmore"> <a href="/author/maria_pace/">More from Maria Pace</a></span>
</div>
</div>
</div>
</div>
</div>
</div><div class='mt_module' data-module-name='boxed_title' data-update-frequency='0' data-module-settings-text='More in {subcategory}'> <div class="boxed-title">
<span class="title-text">
More in National </span>
</div>
</div><div class='mt_module' data-module-name='small_article' data-update-frequency='0' data-module-settings-amount='4' data-module-settings-show_photo='1' data-module-settings-show_author='1' data-module-settings-show_category='1' data-module-settings-show_inset_category='0' data-module-settings-show_standfirst='1'><div class="responsive-articles small-articles">
<div class="article small-article open_url news-article" data-url="/news/national/88459/casa_challenges_labour_meps_on_fiau_report">
<div class="image" style="background-image: url('//content.maltatoday.com.mt/ui_frontend/thumbnail/684/0/david_casa_1.png');">
<img src="//content.maltatoday.com.mt/ui_frontend/thumbnail/684/0/david_casa_1.png" alt="Casa challenges Labour MEPs on FIAU report" />
</div>
<div class="details">
<div class="extra-info">
<span class="category news">National</span>
</div>
<div class="title">
<a href="/news/national/88459/casa_challenges_labour_meps_on_fiau_report"><h3>Casa challenges Labour MEPs on FIAU report</h3></a>
</div>
<div class="extra-info">
<span class="author news">Maria Pace </span>
</div>
</div>
</div>
<div class="article small-article open_url news-article" data-url="/news/national/88445/ana_gomes_raises_ire_of_labour_mep_after_casting_doubt_on_maltese_judiciary">
<div class="image" style="background-image: url('//content.maltatoday.com.mt/ui_frontend/thumbnail/684/0/ana_gomes.png');">
<img src="//content.maltatoday.com.mt/ui_frontend/thumbnail/684/0/ana_gomes.png" alt="Ana Gomes raises ire of Labour MEP after casting doubt on Maltese judiciary" />
</div>
<div class="details">
<div class="extra-info">
<span class="category news">National</span>
</div>
<div class="title">
<a href="/news/national/88445/ana_gomes_raises_ire_of_labour_mep_after_casting_doubt_on_maltese_judiciary"><h3>Ana Gomes raises ire of Labour MEP after casting doubt on Maltese judiciary</h3></a>
</div>
<div class="extra-info">
<span class="author news">Kurt Sansone </span>
</div>
</div>
</div>
<div class="article small-article open_url news-article" data-url="/news/national/88380/transport_malta_fines_bus_company_183000_for_missed_trips">
<div class="image" style="background-image: url('//content.maltatoday.com.mt/ui_frontend/thumbnail/684/0/new_buses_1.png');">
<img src="//content.maltatoday.com.mt/ui_frontend/thumbnail/684/0/new_buses_1.png" alt="Transport Malta fines bus company €183,000 for missed trips" />
</div>
<div class="details">
<div class="extra-info">
<span class="category news">National</span>
</div>
<div class="title">
<a href="/news/national/88380/transport_malta_fines_bus_company_183000_for_missed_trips"><h3>Transport Malta fines bus company €183,000 for missed trips</h3></a>
</div>
<div class="extra-info">
<span class="author news">James Debono </span>
</div>
</div>
</div>
<div class="article small-article open_url news-article" data-url="/news/national/88438/analysis_panama_outrage_to_egrant_deception">
<div class="image" style="background-image: url('//content.maltatoday.com.mt/ui_frontend/thumbnail/684/0/6-7_jd_simon_busuttil_1.png');">
<img src="//content.maltatoday.com.mt/ui_frontend/thumbnail/684/0/6-7_jd_simon_busuttil_1.png" alt="[ANALYSIS] From the Panama outrage to Egrant deception" />
</div>
<div class="details">
<div class="extra-info">
<span class="category news">National</span>
</div>
<div class="title">
<a href="/news/national/88438/analysis_panama_outrage_to_egrant_deception"><h3>[ANALYSIS] From the Panama outrage to Egrant deception</h3></a>
</div>
<div class="extra-info">
<span class="author news">James Debono </span>
</div>
</div>
</div>
</div></div><div class='mt_module' data-module-name='code' data-update-frequency='0' data-module-settings-code='PGRpdiBpZD0icmNqc2xvYWRfZmViZDYwIj48L2Rpdj4KPHNjcmlwdCB0eXBlPSJ0ZXh0L2phdmFzY3JpcHQiPgooZnVuY3Rpb24oKSB7CnZhciByZWZlcmVyPSIiO3RyeXtpZihyZWZlcmVyPWRvY3VtZW50LnJlZmVycmVyLCJ1bmRlZmluZWQiPT10eXBlb2YgcmVmZXJlcil0aHJvdyJ1bmRlZmluZWQifWNhdGNoKGV4Y2VwdGlvbil7cmVmZXJlcj1kb2N1bWVudC5sb2NhdGlvbi5ocmVmLCgiIj09cmVmZXJlcnx8InVuZGVmaW5lZCI9PXR5cGVvZiByZWZlcmVyKSYmKHJlZmVyZXI9ZG9jdW1lbnQuVVJMKX1yZWZlcmVyPXJlZmVyZXIuc3Vic3RyKDAsNzAwKTsKdmFyIHJjZWwgPSBkb2N1bWVudC5jcmVhdGVFbGVtZW50KCJzY3JpcHQiKTsKcmNlbC5pZCA9ICdyY18nICsgTWF0aC5mbG9vcihNYXRoLnJhbmRvbSgpICogMTAwMCk7CnJjZWwudHlwZSA9ICd0ZXh0L2phdmFzY3JpcHQnOwpyY2VsLnNyYyA9ICJodHRwczovL3RyZW5kcy5yZXZjb250ZW50LmNvbS9zZXJ2ZS5qcy5waHA/dz04MzQ1MSZ0PSIrcmNlbC5pZCsiJmM9IisobmV3IERhdGUoKSkuZ2V0VGltZSgpKyImd2lkdGg9Iisod2luZG93Lm91dGVyV2lkdGggfHwgZG9jdW1lbnQuZG9jdW1lbnRFbGVtZW50LmNsaWVudFdpZHRoKSsiJnJlZmVyZXI9IityZWZlcmVyOwpyY2VsLmFzeW5jID0gdHJ1ZTsKdmFyIHJjZHMgPSBkb2N1bWVudC5nZXRFbGVtZW50QnlJZCgicmNqc2xvYWRfZmViZDYwIik7IHJjZHMuYXBwZW5kQ2hpbGQocmNlbCk7Cn0pKCk7Cjwvc2NyaXB0Pg=='><div class="code_module">
<div id="rcjsload_febd60"></div>
<script type="text/javascript">
(function() {
var referer="";try{if(referer=document.referrer,"undefined"==typeof referer)throw"undefined"}catch(exception){referer=document.location.href,(""==referer||"undefined"==typeof referer)&&(referer=document.URL)}referer=referer.substr(0,700);
var rcel = document.createElement("script");
rcel.id = 'rc_' + Math.floor(Math.random() * 1000);
rcel.type = 'text/javascript';
rcel.src = "https://trends.revcontent.com/serve.js.php?w=83451&t="+rcel.id+"&c="+(new Date()).getTime()+"&width="+(window.outerWidth || document.documentElement.clientWidth)+"&referer="+referer;
rcel.async = true;
var rcds = document.getElementById("rcjsload_febd60"); rcds.appendChild(rcel);
})();
</script></div></div><div class='mt_module' data-module-name='comments' data-update-frequency='0'><div id="disqus_thread"></div>
<script type="text/javascript">

    var disqus_config = function () {

        
            // The generated payload which authenticates users with Disqus
            this.page.remote_auth_s3 = 'eyJpZCI6InVzZXJfIiwidXNlcm5hbWUiOiIgIiwiZW1haWwiOm51bGx9 727b27fbb025fe564dede5b8ba0b5cb0e031423b 1532605797';
            this.page.api_key = 'KKsrhxY6LSXy3nbzit54YG6MHLFaxrOJ42o6hFm3W1sUtwGMqjEzqyO5HBu9sxTW';

                this.page.identifier = 'article_88459';
        this.sso = {
            name:   "MaltaToday.com.mt",
            button:  "https://www.maltatoday.com.mt/ui/images/frontend/disqus_button.png",
            icon:     "https://www.maltatoday.com.mt/ui/images/icons/Icon-Small@2x.png",
            url:      "https://www.maltatoday.com.mt/ui_frontend/login/",
            logout:  "https://www.maltatoday.com.mt/ui_frontend/disquslogout/",
            width:   "867",
            height:  "152"
        };
    };

    var disqus_shortname = 'malta-today';

    (function() {
        var dsq = document.createElement('script'); dsq.type = 'text/javascript'; dsq.async = true;
        dsq.src = '//' + disqus_shortname + '.disqus.com/embed.js';
        (document.getElementsByTagName('head')[0] || document.getElementsByTagName('body')[0]).appendChild(dsq);
    })();
</script>
</div></div> </div>
<div class="col-lg-2 col-md-2">
<div class="zone" data-zone-name="Right" data-zone-id="right"></div> </div>
</div>
<div class="row">
<div class="col-lg-12 col-md-12">
<div class="zone" data-zone-name="Bottom" data-zone-id="bottom"></div> </div>
</div>
</div>
</section></div>
<footer class="hidden-xs">
<div class="container">
<div class="row">
<div class="col-xs-12 col-sm-6">
<div class="footer-logo">
<a href="/"> <img src="/ui/images/frontend/maltatoday_logo_white.png" /></a>
</div>
</div>
<div class="col-xs-12 col-sm-6">
<div class="social-icons">
<div class="icon facebook">
<a href="//facebook.com/maltatoday" target="_blank"><i class="fa fa-facebook"></i></a>
</div>
<div class="icon twitter">
<a href="//twitter.com/maltatoday" target="_blank"><i class="fa fa-twitter"></i></a>
</div>
<div class="icon instagram">
<a href="//www.instagram.com/maltatoday" target="_blank"><i class="fa fa-instagram"></i></a>
</div>
<div class="icon youtube">
<a href="//www.youtube.com/user/ReporterMediaToday" target="_blank"><i class="fa fa-youtube"></i></a>
</div>
<div class="icon googleplus">
<a href="//plus.google.com/113527506098764625850" target="_blank"><i class="fa fa-google-plus"></i></a>
</div>
</div>
</div>
</div>
<div class="row">
<div class="col-xs-12">
<ul class="bottom-nav">
<li><a href="/about-us/">About Us</a></li>
<li><a href="/advertising/">Advertise</a> </li>
<li><a href="/contact/">Contact</a> </li>
<li><a href="/maltatodaydigitaledition/">Digital Edition</a></li>
<li><a href="http://frontpages.maltatoday.com.mt/">Today's Newspapers</a></li>
<li><a href="/subscribe_sms/">SMS Alerts</a></li>
</ul>
<ul class="bottom-links">
<li><a href="/terms-and-conditions/">Terms and Conditions</a> </li>
<li><a href="/privacy-policy/">Privacy Policy</a> </li>
<li><a href="/privacy-policy/">Cookie Policy</a> </li>
<li><a target="_blank" href="http://archive.maltatoday.com.mt/archive.html">Archives</a></li>
</ul>
</div>
</div>
<div class="row">
<div class="col-md-12">
<div class="copyright">
MediaToday is an independent media house based in Malta. Copyright © MediaToday Co. Ltd, Vjal ir-Rihan, San Gwann SGN 9016, Malta, Europe <br />
Reproduction of material from this website without written permission is strictly prohibited.
</div>
</div>
</div>
</div>
</footer>
<div class="floating-bar" data-cookie-name="cookie_notice">
<div class="container">
<div class="message-inner">
<a href="https://www.maltatoday.com.mt/privacy-policy/" target="_blank" class="set-close">
By using this site, you agree to our Privacy Policy including the use of cookies to enhance your experience. </a>
<button class="message-close-btn set-close">
<i class="fa fa-times close"></i>
</button>
</div>
</div>
</div>
<div class="cta-modal cta-modal-subscribe" data-cookie-name="subscribe_cta">
<div class="cta-modal-content">
<div class="cta-dismiss set-close"><span class="fa fa-close"></span></div>
<p>Get access to the real stories first with the <img src="/ui/images/frontend/maltatoday_logo.png" alt="Maltatoday" class="cta-logo" /> digital edition</p>
<a href="/maltatodaydigitaledition/" class="btn btn-red btn-cta set-close">Subscribe</a>
</div>
</div>
<script type="text/javascript" src="//imasdk.googleapis.com/js/sdkloader/ima3.js"></script>
<script type="text/javascript" src="/dist/js/packages.min.js?v=2.1"></script>
<script>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</script>

<script type="text/javascript">
_atrk_opts = { atrk_acct:"io5hj1aAkN00oK", domain:"maltatoday.com.mt",dynamic: true};
(function() { var as = document.createElement('script'); as.type = 'text/javascript'; as.async = true; as.src = "https://certify-js.alexametrics.com/atrk.js"; var s = document.getElementsByTagName('script')[0];s.parentNode.insertBefore(as, s); })();
</script>
<noscript><img src="https://certify.alexametrics.com/atrk.gif?account=io5hj1aAkN00oK" style="display:none" height="1" width="1" alt="" /></noscript>

<script type="text/javascript" src="/dist/js/app.min.js?v=2.1"></script>
<script type="text/javascript">
    var currentSkin = {"backgroundImagePath":"http:\/\/content.maltatoday.com.mt\/ui\/images\/skins\/2018-04-23-15-51-13-Skin_4.jpg","backgroundColor":"","backgroundPosition":"50% 100%","backgroundAttachment":"fixed","backgroundSize":"","leftAreaLink":"https:\/\/affiliates.yobetit.com\/idevaffiliate.php?id=130&url=166","rightAreaLink":"https:\/\/affiliates.yobetit.com\/idevaffiliate.php?id=130&url=166","minWidth":"0","minHeight":"0","backgroundRepeat":"no-repeat"};
    $(function(){
        initSkin(currentSkin);
    });
    </script>
<script type="text/javascript">
    var _gaq = _gaq || [];
    _gaq.push(['_setAccount', 'UA-16977049-1']);
    _gaq.push(['_trackPageview']);

    (function () {
        var ga = document.createElement('script'); ga.type =
            'text/javascript'; ga.async = true;
        ga.src = ('https:' == document.location.protocol ? 'https://ssl' :
            'http://www') + '.google-analytics.com/ga.js';
        var s = document.getElementsByTagName('script')[0];
        s.parentNode.insertBefore(ga, s);
    })();
</script>
<script id="dsq-count-scr" src="//malta-today.disqus.com/count.js" async></script>
</body>
</html>