<!DOCTYPE html>
<html xmlns="http://www.w3.org/1999/xhtml" lang="en">
<head>
<meta http-equiv="Content-Type" content="text/html; charset=utf-8">
<meta name="viewport" content="width=device-width, initial-scale=1.0" />
<meta property="fb:pages" content="21535456940" />
<meta property="fb:app_id" content="1775326929407925" />
<link rel="shortcut icon" type="image/x-icon" href="/ui/images/icons/Icon-Small@2x.png">
<link rel="apple-touch-icon" href="/ui/images/icons/Icon-60@2x.png" />
<link rel="apple-touch-icon" sizes="58x58" href="/ui/images/icons/Icon-Small@2x.png" />
<link rel="apple-touch-icon" sizes="76x76" href="/ui/images/icons/Icon-76.png" />
<link rel="apple-touch-icon" sizes="152x152" href="/ui/images/icons/Icon-76@2x.png" />
<link rel="apple-touch-icon" sizes="180x180" href="/ui/images/icons/Icon-60@3x.png" />
<link rel="icon" sizes="192x192" href="/ui/images/icons/icon-192x192.png" />
<link rel="stylesheet" href="/dist/css/desktop.min.css?v=15.2022" />
<link rel="canonical" href="https://www.maltatoday.com.mt/comment/blogs/120046/too_little_too_late_and_too_many_unanswered_questions_">
<meta property="og:site_name" content="MaltaToday.com.mt" />
<meta property="og:url" content="http://www.maltatoday.com.mt/comment/blogs/120046/too_little_too_late_and_too_many_unanswered_questions_" />
<meta property="og:title" content="Too little, too late… and too many unanswered questions" />
<meta property="og:description" content="While murderers are continuing with their lives and running loose, Chantelle&amp;nbsp;Chetcuti, Bernice&amp;nbsp;Cassar, and all the other women who have been killed at the hands of an out-of-control man, will never be able to go on holiday again" />
<meta property="og:type" content="article" />
<meta property="article:publisher" content="https://www.facebook.com/maltatoday" />
<meta property="og:image" content="http://cdn.maltatoday.com.mt/ui_frontend/thumbnail/684/400/bernice_protest_2.jpg" />
<meta name="description" content="While murderers are continuing with their lives and running loose, Chantelle&amp;nbsp;Chetcuti, Bernice&amp;nbsp;Cassar, and all the other women who have been killed at the hands of an out-of-control man, will never be able to go on holiday again" />
<script type="text/javascript">
        var cdn_url = "//content.maltatoday.com.mt";
    </script>
<title>Too little, too late… and too many unanswered questions</title>

<script async='async' src='https://www.googletagservices.com/tag/js/gpt.js'></script>
<script>
        var googletag = googletag || {};
        googletag.cmd = googletag.cmd || [];
    </script>

<script>
    !function(f,b,e,v,n,t,s)
    {if(f.fbq)return;n=f.fbq=function(){n.callMethod?
    n.callMethod.apply(n,arguments):n.queue.push(arguments)};
    if(!f._fbq)f._fbq=n;n.push=n;n.loaded=!0;n.version='2.0';
    n.queue=[];t=b.createElement(e);t.async=!0;
    t.src=v;s=b.getElementsByTagName(e)[0];
    s.parentNode.insertBefore(t,s)}(window, document,'script',
    'https://connect.facebook.net/en_US/fbevents.js');
    fbq('init', '213704729706889');
    fbq('track', 'PageView');
    </script>
<noscript><img height="1" width="1" style="display:none"
    src="https://www.facebook.com/tr?id=213704729706889&ev=PageView&noscript=1"
    /></noscript>

</head>
<body class="page-article">
<header>
<div class="zone" data-zone-name="TOPMOST" data-zone-id="TOPMOST"><div class='mt_module' data-module-name='code' data-update-frequency='0' data-module-settings-code='PGRpdiBjbGFzcz0idG9wLXNsYXNoIGRmcC1zbG90IiAKICAgICAgICAgICAgZGF0YS1wYXRoPSIvMTM0NzQ1NDUvTWFsdGFUb2RheV9bY2F0ZWdvcnldX0xlYWRlcmJvYXJkXzcyOHg5MCIKICAgICAgICAgICAgZGF0YS1zaXplPSJbWzcyOCwgOTBdLCBbOTcwLCA5MF0sIFs5NzAsIDI1MF0sIFszMjAsIDEwMF0sIFsxMzIwLCAyNTBdLCBbMTE1MCwgMjUwXV0iPgogICAgICAgIDwvZGl2Pg=='><div class="code_module">
<div class="top-slash dfp-slot" data-path="/13474545/MaltaToday_comment_Leaderboard_728x90" data-size="[[728, 90], [970, 90], [970, 250], [320, 100], [1320, 250], [1150, 250]]">
</div></div></div></div> <div class="main-nav">
<div class="main-nav-bg">
<div class="container">
<div class="row">
<div class="col-md-12">
<div class="row">
<div class="menu-bar comment">
<div class="logo col-xs-7 col-md-2">
<a href="/"><img class="img-responsive" src="/ui/images/frontend/maltatoday_logo_comment.png" alt="maltatoday" /></a>
</div>
<div class="col-xs-5 visible-sm visible-xs text-right">
<div id="more-menu">
menu
<button type="button" class="navbar-toggle" aria-expanded="false">
<span class="sr-only">Toggle navigation</span>
<span class="icon-bar"></span>
<span class="icon-bar"></span>
<span class="icon-bar"></span>
</button>
</div>
</div>
<ul class="main-menu">
<li class="menu-inline-search visible-xs">
<form action="/search-mt/" method="get">
<div class="col-xs-12">
<input type="text" name="q" class="form-control" placeholder="Search maltatoday.." />
</div>
</form>
</li>
<li class="menu_item home has-sub-menu">
<a href="/">
Home </a>
<div class="menu-item-detail-box">
<ul class="sub-menu">
<li><a href="/vacancies">Jobs in Malta</a></li>
<li><a href="/yellow">Yellow</a></li>
<li><a href="/pharmacies">Pharmacies</a></li>
<li><a href="/sponsored">Sponsored</a></li>
<li><a href="/announcements">Announcements</a></li>
<li><a href="/advertising">Advertise</a></li>
<li><a href="/contact">Contact</a></li>
<li><a href="/maltatodaydigitaledition">Digital Edition</a></li>
<li><a href="/subscribe_sms">SMS Alerts</a></li>
</ul>
</div>
</li>
<li class="menu_item news has-sub-menu">
<a href="/news">
News </a>
<div class="menu-item-detail-box">
<ul class="sub-menu">
<li><a href="/news/national">National</a></li>
<li><a href="/news/budget-2023">Budget 2023</a></li>
<li><a href="/covid19">Covid-19</a></li>
<li><a href="/news/ewropej">#EWROPEJ</a></li>
<li><a href="/news/court_and_police">Court &amp; Police</a></li>
<li><a href="/news/interview">Interview</a></li>
<li><a href="/news/data_and_surveys">Data &amp; Survey</a></li>
<li><a href="/news/skinny">The Skinny</a></li>
<li><a href="/news/xtra">Xtra</a></li>
<li><a href="/news/election-2022">Election 2022</a></li>
</ul>
<div class="detail-content-box hidden-sm hidden-xs">
<div class="sub-menu-latest-stories">
<div class="row">
<div class="col-md-6">
<div class="left-section">
<div class="top-story-container">
<div class="photo">
<a href="/news/national/120053/pn_takes_up_antiabortion_battle_cry_calls_on_maltese_to_stop_robert_abela"><img src="//content.maltatoday.com.mt/ui_frontend/thumbnail/400/220/6_pn_hq.jpg" /></a>
</div>
<div class="title">
<span class="category">National</span> <a href="/news/national/120053/pn_takes_up_antiabortion_battle_cry_calls_on_maltese_to_stop_robert_abela">
PN takes up anti-abortion battle cry, calls on Maltese to ‘stop Robert Abela’</a>
</div>
</div>
</div>
</div>
<div class="col-md-6">
<div class="right-section">
<ul class="stories">
<li class="story">
<div class="story-content">
<div class="image">
<a href="/news/court_and_police/120052/joseph_muscat_to_testify_in_libel_case_next_january_after_noshow"><img src="//content.maltatoday.com.mt/ui_frontend/thumbnail/62/62/joseph_muscat_at_property_seminar.jpg" /></a>
</div>
<div class="text">
<a href="/news/court_and_police/120052/joseph_muscat_to_testify_in_libel_case_next_january_after_noshow">
<span class="category">Court & Police</span>
<span class="title"> Joseph Muscat to testify in libel case next January after no-show</span>
</a>
</div>
</div>
</li>
<li class="story">
<div class="story-content">
<div class="image">
<a href="/news/national/120049/domestic_violence_protection_orders_lack_of_training_were_all_concerns_brought_up_in_2020_report"><img src="//content.maltatoday.com.mt/ui_frontend/thumbnail/62/62/2_domestic_violence.jpeg" /></a>
</div>
<div class="text">
<a href="/news/national/120049/domestic_violence_protection_orders_lack_of_training_were_all_concerns_brought_up_in_2020_report">
<span class="category">National</span>
<span class="title"> Domestic violence: Protection orders, lack of training were all concerns brought up in 2020 report</span>
</a>
</div>
</div>
</li>
<li class="story">
<div class="story-content">
<div class="image">
<a href="/news/court_and_police/119974/domestic_violence_reports_dealt_on_firstcome_firstserved_basis_not_by_priority"><img src="//content.maltatoday.com.mt/ui_frontend/thumbnail/62/62/20220530120216-c-029605a4-4c0d-4314-b699-9e47efa155eb.jpeg" /></a>
</div>
<div class="text">
<a href="/news/court_and_police/119974/domestic_violence_reports_dealt_on_firstcome_firstserved_basis_not_by_priority">
<span class="category">Court & Police</span>
<span class="title"> Domestic violence reports dealt on first-come first-served basis not by priority</span>
</a>
</div>
</div>
</li>
</ul>
<a href="/news">More in News <i class="fa fa-angle-right"></i></a>
</div>
</div>
</div>
</div>
</div>
</div>
</li>
<li class="menu_item business has-sub-menu">
<a href="/business">
Business </a>
<div class="menu-item-detail-box">
<ul class="sub-menu">
<li><a href="/business/business_news">Business News</a></li>
<li><a href="/business/business_comment">Business Comment</a></li>
<li><a href="/business/tech">Tech & Gaming</a></li>
<li><a href="/business/law_report">Law Report</a></li>
<li><a href="/business/property">Property</a></li>
</ul>
<div class="detail-content-box hidden-sm hidden-xs">
<div class="sub-menu-latest-stories">
<div class="row">
<div class="col-md-6">
<div class="left-section">
<div class="top-story-container">
<div class="photo">
<a href="/business/business_comment/120050/sunset_on_q3_2022_earnings_season"><img src="//content.maltatoday.com.mt/ui_frontend/thumbnail/400/220/8_cover.jpg" /></a>
</div>
<div class="title">
<span class="category">Business Comment</span> <a href="/business/business_comment/120050/sunset_on_q3_2022_earnings_season">
Sunset on Q3 2022 earnings season</a>
</div>
</div>
</div>
</div>
<div class="col-md-6">
<div class="right-section">
<ul class="stories">
<li class="story">
<div class="story-content">
<div class="image">
<a href="/business/business_news/119996/pavi_to_become_major_commercial_hub_after_buying_adjacent_land_for_7_million_"><img src="//content.maltatoday.com.mt/ui_frontend/thumbnail/62/62/whatsapp_image_2022-11-24_at_11.12.09_am.jpeg" /></a>
</div>
<div class="text">
<a href="/business/business_news/119996/pavi_to_become_major_commercial_hub_after_buying_adjacent_land_for_7_million_">
<span class="category">Business News</span>
<span class="title"> PAVI to become major commercial hub after buying adjacent land for €7 million</span>
</a>
</div>
</div>
</li>
<li class="story">
<div class="story-content">
<div class="image">
<a href="/business/business_comment/119975/the_semiconductor_industry_woes_due_to_geopolitical_issues"><img src="//content.maltatoday.com.mt/ui_frontend/thumbnail/62/62/microchips.jpg" /></a>
</div>
<div class="text">
<a href="/business/business_comment/119975/the_semiconductor_industry_woes_due_to_geopolitical_issues">
<span class="category">Business Comment</span>
<span class="title"> The semiconductor industry woes due to geopolitical issues</span>
</a>
</div>
</div>
</li>
<li class="story">
<div class="story-content">
<div class="image">
<a href="/business/law_report/119928/a_new_lease_agreement_is_deemed_to_be_renunciation_of_the_old_lease_agreement"><img src="//content.maltatoday.com.mt/ui_frontend/thumbnail/62/62/2_law_report.png" /></a>
</div>
<div class="text">
<a href="/business/law_report/119928/a_new_lease_agreement_is_deemed_to_be_renunciation_of_the_old_lease_agreement">
<span class="category">Law Report</span>
<span class="title"> A new lease agreement is deemed to be renunciation of the old lease agreement</span>
</a>
</div>
</div>
</li>
</ul>
<a href="/business">More in Business <i class="fa fa-angle-right"></i></a>
</div>
</div>
</div>
</div>
</div>
</div>
</li>
<li class="menu_item sports has-sub-menu">
<a href="/sports">
Sports </a>
<div class="menu-item-detail-box">
<ul class="sub-menu">
<li><a href="/sports/worldcup2022">World Cup 2022</a></li>
<li><a href="/sports/football">Football</a></li>
<li><a href="/sports/rugby">Rugby</a></li>
<li><a href="/sports/motorsports">Motor Sports</a></li>
<li><a href="/sports/boxing">Boxing</a></li>
<li><a href="/sports/tennis">Tennis</a></li>
<li><a href="/sports/cricket">Cricket</a></li>
</ul>
<div class="detail-content-box hidden-sm hidden-xs">
<div class="sub-menu-latest-stories">
<div class="row">
<div class="col-md-6">
<div class="left-section">
<div class="top-story-container">
<div class="photo">
<a href="/sports/worldcup2022/120037/live_spain_vs_germany"><img src="//content.maltatoday.com.mt/ui_frontend/thumbnail/400/220/spain_vs_germany.png" /></a>
</div>
<div class="title">
<span class="category">World Cup 2022</span> <a href="/sports/worldcup2022/120037/live_spain_vs_germany">
Live! Spain vs Germany</a>
</div>
</div>
</div>
</div>
<div class="col-md-6">
<div class="right-section">
<ul class="stories">
<li class="story">
<div class="story-content">
<div class="image">
<a href="/sports/worldcup2022/120038/live_belgium_vs_morocco"><img src="//content.maltatoday.com.mt/ui_frontend/thumbnail/62/62/belgium_morocco.png" /></a>
</div>
<div class="text">
<a href="/sports/worldcup2022/120038/live_belgium_vs_morocco">
<span class="category">World Cup 2022</span>
<span class="title"> Live! Belgium vs Morocco</span>
</a>
</div>
</div>
</li>
<li class="story">
<div class="story-content">
<div class="image">
<a href="/sports/worldcup2022/120030/live_argentina_vs_mexico"><img src="//content.maltatoday.com.mt/ui_frontend/thumbnail/62/62/2_facebook_poll.png" /></a>
</div>
<div class="text">
<a href="/sports/worldcup2022/120030/live_argentina_vs_mexico">
<span class="category">World Cup 2022</span>
<span class="title"> Live! Argentina vs Mexico</span>
</a>
</div>
</div>
</li>
<li class="story">
<div class="story-content">
<div class="image">
<a href="/sports/worldcup2022/120029/live_france_vs_denmark"><img src="//content.maltatoday.com.mt/ui_frontend/thumbnail/62/62/2_facebook_poll_(2).png" /></a>
</div>
<div class="text">
<a href="/sports/worldcup2022/120029/live_france_vs_denmark">
<span class="category">World Cup 2022</span>
<span class="title"> Live! France vs Denmark</span>
</a>
</div>
</div>
</li>
</ul>
<a href="/sports">More in Sports <i class="fa fa-angle-right"></i></a>
</div>
</div>
</div>
</div>
</div>
</div>
</li>
<li class="menu_item arts has-sub-menu">
<a href="/arts">
Arts </a>
<div class="menu-item-detail-box">
<ul class="sub-menu">
<li><a href="/arts/art">Art</a></li>
<li><a href="/arts/books">Books</a></li>
<li><a href="/arts/entertainment">Entertainment</a></li>
<li><a href="/arts/music">Music</a></li>
<li><a href="/arts/theatre_and_dance">Theatre &amp; Dance</a></li>
<li><a href="/arts/film">Film</a></li>
<li><a href="/arts/cultural_diary">Cultural Diary</a></li>
<li><a href="/arts/markapagna/">Markapaġna</a></li>
<li><a href="/arts/kwartaktieb/">KwartaKtieb</a></li>
<li><a href="/arts/valletta_2018">Valletta 2018</a></li>
</ul>
<div class="detail-content-box hidden-sm hidden-xs">
<div class="sub-menu-latest-stories">
<div class="row">
<div class="col-md-6">
<div class="left-section">
<div class="top-story-container">
<div class="photo">
<a href="/arts/cultural_diary/119927/my_essentials_john_montanaros_cultural_picks"><img src="//content.maltatoday.com.mt/ui_frontend/thumbnail/400/220/screenshot_2022-11-21_at_08.57.46.png" /></a>
</div>
<div class="title">
<span class="category">Cultural Diary</span> <a href="/arts/cultural_diary/119927/my_essentials_john_montanaros_cultural_picks">
My essentials: John Montanaro’s cultural picks</a>
</div>
</div>
</div>
</div>
<div class="col-md-6">
<div class="right-section">
<ul class="stories">
<li class="story">
<div class="story-content">
<div class="image">
<a href="/arts/cultural_diary/119934/christmas_in_valletta_25_events_in_25_days"><img src="//content.maltatoday.com.mt/ui_frontend/thumbnail/62/62/owen_bonnici_and_jason_micallef.jpg" /></a>
</div>
<div class="text">
<a href="/arts/cultural_diary/119934/christmas_in_valletta_25_events_in_25_days">
<span class="category">Cultural Diary</span>
<span class="title"> Christmas in Valletta: 25 events in 25 days</span>
</a>
</div>
</div>
</li>
<li class="story">
<div class="story-content">
<div class="image">
<a href="/arts/cultural_diary/119792/my_essentials_moira_muscats_cultural_picks"><img src="//content.maltatoday.com.mt/ui_frontend/thumbnail/62/62/screenshot_2022-11-14_at_09.19.03.png" /></a>
</div>
<div class="text">
<a href="/arts/cultural_diary/119792/my_essentials_moira_muscats_cultural_picks">
<span class="category">Cultural Diary</span>
<span class="title"> My essentials: Moira Muscat’s cultural picks</span>
</a>
</div>
</div>
</li>
<li class="story">
<div class="story-content">
<div class="image">
<a href="/arts/books/119819/markapagna_john_a_bonello"><img src="//content.maltatoday.com.mt/ui_frontend/thumbnail/62/62/10_john_bonello.jpg" /></a>
</div>
<div class="text">
<a href="/arts/books/119819/markapagna_john_a_bonello">
<span class="category">Books</span>
<span class="title"> [WATCH] Markapaġna | John A. Bonello</span>
</a>
</div>
</div>
</li>
</ul>
<a href="/arts">More in Arts <i class="fa fa-angle-right"></i></a>
</div>
</div>
</div>
</div>
</div>
</div>
</li>
<li class="menu_item comment active has-sub-menu">
<a href="/comment">
Comment </a>
<div class="menu-item-detail-box">
<ul class="sub-menu">
<li><a href="/comment/blogs">Blogs</a></li>
<li><a href="/comment/editorial">Editorial</a></li>
<li><a href="/comment/letters">Letters</a></li>
<li><a href="/comment/cartoons">Cartoons</a></li>
</ul>
<div class="detail-content-box hidden-sm hidden-xs">
<div class="sub-menu-latest-stories">
<div class="row">
<div class="col-md-6">
<div class="left-section">
<div class="top-story-container">
<div class="photo">
<a href="/comment/blogs/120048/femicide_without_womens_liberation_we_all_bear_responsibility"><img src="//content.maltatoday.com.mt/ui_frontend/thumbnail/400/220/2_womens_march_435.jpg" /></a>
</div>
<div class="title">
<span class="category">Blogs</span> <a href="/comment/blogs/120048/femicide_without_womens_liberation_we_all_bear_responsibility">
Femicide: without women’s liberation, we all bear responsibility</a>
</div>
</div>
</div>
</div>
<div class="col-md-6">
 <div class="right-section">
<ul class="stories">
<li class="story">
<div class="story-content">
<div class="image">
<a href="/comment/blogs/120047/the_buck_stops_with_the_pm_meaningful_reform_must_be_taken_now"><img src="//content.maltatoday.com.mt/ui_frontend/thumbnail/62/62/law_courts_generic.jpg" /></a>
</div>
<div class="text">
<a href="/comment/blogs/120047/the_buck_stops_with_the_pm_meaningful_reform_must_be_taken_now">
<span class="category">Blogs</span>
<span class="title"> The buck stops with the PM: meaningful reform must be taken now</span>
</a>
</div>
</div>
</li>
<li class="story">
<div class="story-content">
<div class="image">
<a href="/comment/blogs/120046/too_little_too_late_and_too_many_unanswered_questions_"><img src="//content.maltatoday.com.mt/ui_frontend/thumbnail/62/62/bernice_protest_2.jpg" /></a>
</div>
<div class="text">
<a href="/comment/blogs/120046/too_little_too_late_and_too_many_unanswered_questions_">
<span class="category">Blogs</span>
<span class="title"> Too little, too late… and too many unanswered questions</span>
</a>
</div>
</div>
</li>
<li class="story">
<div class="story-content">
<div class="image">
<a href="/comment/editorial/120035/malta_has_a_crisis"><img src="//content.maltatoday.com.mt/ui_frontend/thumbnail/62/62/maltatoday_editorial.png" /></a>
</div>
<div class="text">
<a href="/comment/editorial/120035/malta_has_a_crisis">
<span class="category">Editorial</span>
<span class="title"> Malta has a crisis</span>
</a>
</div>
</div>
</li>
</ul>
<a href="/comment">More in Comment <i class="fa fa-angle-right"></i></a>
</div>
</div>
</div>
</div>
</div>
</div>
</li>
<li class="menu_item videos">
<a href="/videos/">
Video </a>
</li>
<li class="menu_item archives">
<a href="http://archive.maltatoday.com.mt" target="_blank">
Archives </a>
</li>
<li class="menu_item sponsored visible-xs visible-sm">
<a href="/sponsored">
Sponsored </a>
</li>
<li class="menu_item gourmet-today has-sub-menu">
<a href="/gourmet/">
<img src="/ui/images/frontend/maltatoday_logo_gourmet.png" alt="Gourmet" />
</a>
<div class="menu-item-detail-box">
<ul class="sub-menu">
<li><a href="/gourmet/recipes/">Recipes</a></li>
<li><a href="/gourmet/restaurants/">Restaurants</a></li>
<li><a href="/gourmet/gourmet_today/">Magazines</a></li>
<li><a href="/gourmet/gourmettv/">TV</a></li>
<li><a href="/gourmet/videos/">Videos</a></li>
</ul>
</div>
</li>
<li class="menu_item deal-today visible-xs visible-sm">
<a href="/yellow">
Yellow </a>
</li>
<li class="menu_item login visible-xs visible-sm login-menu-item">
<a href="/maltatodaydigitaledition/">
Digital Paper </a>
</li>
</ul>
<div class="menu-icons hidden-xs hidden-sm">
<div class="menu-icons-icon search-icon" onclick="$(this).addClass('active').find('input').focus()">
<span class="fa fa-search"></span>
<div class="searchbox">
<form action="/search-mt/" method="get">
<input type="text" name="q" placeholder="Search" onblur="$(this).parents('.search-icon').removeClass('active');" onkeyup="if (event.keyCode === 27) { $(this).blur(); }" />
<button type="submit">
<i class="fa fa-search search_now"></i>
</button>
</form>
</div>
</div>
<div class="menu-icons-icon login-icon digital-paper">
<a href="/maltatodaydigitaledition/" class="btn btn-red">Digital Paper</a>
<div id="login-sub-menu">
<a target="_blank" href="https://maltatoday.uberflip.com/t/73329-mediatoday-newspapers-latest-editions">My Account</a>
<a href="/maltatodaydigitaledition/">Subscribe</a>
<a href="/subscribe_sms/">SMS Alerts</a>
<a href="/maltatodaydigitaledition/#previous">Previous Editions</a>
</div>
</div>
</div>
</div>
</div>
<div id="small-menu-placeholder" class="row visible-xs visible-sm comment">
<div id="small-menu">
<a href="/">home</a>
<a href="/news">news</a>
<a class="highlight" href="/maltatodaydigitaledition">Digital Paper</a>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
<div class="sub-nav">
<div class="container">
<ul class="hidden-xs outer-sub-menu sub-menu comment">
<li><a href="/comment/blogs">Blogs</a></li>
<li><a href="/comment/editorial">Editorial</a></li>
<li><a href="/comment/letters">Letters</a></li>
<li><a href="/comment/cartoons">Cartoons</a></li>
</ul>
</div>
</div>
</header>
<div id="content">
<section>
<div class="container">
<div class="row">
<div class="col-lg-12 col-md-12">
<div class="zone" data-zone-name="Top" data-zone-id="top"><div class='mt_module' data-module-name='article_breadcrumb' data-update-frequency='0'><ul class="breadcrumb">
<li class="breadcrumb-item comment"><a href="/comment/">Comment</a></li>
<li class="breadcrumb-item comment"><a href="/comment/blogs/">Blogs</a></li>
</ul></div><div class='mt_module' data-module-name='article_heading' data-update-frequency='0'><div class="article-heading">
<div class="row">
<div class="col-md-12">
<h1>Too little, too late… and too many unanswered questions</h1>
<h2><p>While murderers are continuing with their lives and running loose, Chantelle&nbsp;Chetcuti, Bernice&nbsp;Cassar, and all the other women who have been killed at the hands of an out-of-control man, will never be able to go on holiday again</p></h2>
</div>
</div>
</div>
</div></div> </div>
</div>
<div class="row">
<div class="col-lg-2 col-md-2">
<div class="zone" data-zone-name="Left" data-zone-id="left"><div class='mt_module' data-module-name='article_meta' data-update-frequency='0'><div class="article-meta comment-meta">
<div class="author-photos"> <img src="//content.maltatoday.com.mt/ui_frontend/profile_thumbnail/300/300/josanne_cassar_1499072844.jpg" alt="josanne_cassar" />
</div>
<div class="date-text">
<span class="name">Josanne Cassar </span>
<span class="date">28 November 2022, 7:33am</span>
</div>
</div></div><div class='mt_module' data-module-name='addthis' data-update-frequency='0'> <script type="text/javascript" src="//s7.addthis.com/js/300/addthis_widget.js#pubid=ra-5a7023510fcc04af"></script>
</div></div> </div>
<div class="col-lg-8 col-md-8">
<div class="zone" data-zone-name="Main" data-zone-id="content"><div class='mt_module' data-module-name='article_cover' data-update-frequency='0'><div class="full-article article-cover">
<div class="photo_collection_cover article-cover-media single-cover" data-slick='{"slidesToShow": 1, "slidesToScroll": 1}'>
<div class="media-item show ">
<div class="cover-photo" title="Protestors gathered outside the police headquarters to protest against institutional failures that allowed Bernice Cassar to be murdered (Photo: James Bianchi/MaltaToday)" style="background-image: url('//content.maltatoday.com.mt/ui/images/photos/bernice_protest_2.jpg')">
<img src="//content.maltatoday.com.mt/ui_frontend/thumbnail/684/0/bernice_protest_2.jpg" alt="Protestors gathered outside the police headquarters to protest against institutional failures that allowed Bernice Cassar to be murdered (Photo: James Bianchi/MaltaToday)" />
</div>
<div class="caption">
<div class="inner">Protestors gathered outside the police headquarters to protest against institutional failures that allowed Bernice Cassar to be murdered (Photo: James Bianchi/MaltaToday)</div>
</div>
</div>
</div>
</div></div><div class='mt_module' data-module-name='small_share_buttons' data-update-frequency='0'><div class="row">
<div class="col-md-6">
</div>
<div class="col-md-6">
<div class="small_share_buttons text-right">
<a class="addthis_button_facebook_like" fb:like:layout="button_count" style="position:relative; top: 4px; padding: 0px; right: -10px;"></a>
<script type="text/javascript">var addthis_config = {"data_track_addressbar":true};</script>
<script type="text/javascript" src="//s7.addthis.com/js/300/addthis_widget.js#pubid=seekopia"></script>
<a class="twitter" href="https://twitter.com/share?url=https://www.maltatoday.com.mt/comment/blogs/120046/too_little_too_late_and_too_many_unanswered_questions_&text=Too little, too late… and too many unanswered questions" target="_blank">
<i class="fa fa-twitter"></i> TWEET
</a>
<a class="facebook" href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.maltatoday.com.mt%2Fcomment%2Fblogs%2F120046%2Ftoo_little_too_late_and_too_many_unanswered_questions_" target="_blank">
<i class="fa fa-facebook"></i> SHARE
</a>
</div>
</div>
</div></div><div class='mt_module' data-module-name='full_article' data-update-frequency='0'><div class="full-article">
<div class="content content-comment"> <div class="dfp-slot" data-path="/13474545/MaltaToday_comment_Inline_300x250" data-size="[[300, 250]]" style="float:right; margin:8px 0 8px 25px">
</div>
<p>How I wish it was one of those weeks when the main topic of conversation was traffic or recycling&hellip; instead of sitting here writing, once again, after another woman has been killed, joining the heartbreaking list of victims of domestic violence.
</p><p>The details of how Bernice Cassar was shot and killed by her husband on Tuesday morning as she arrived for work are well-known by now, so they don&rsquo;t need repeating. But what do bear repeating are the questions many of us have been asking:
</p><p>1. Given there was a protection order in place issued on 27 July, what stopped the Police from going to Roderick Cassar&rsquo;s home and arresting him immediately when he breached it not once, but twice? Just last week, on 13 November, her estranged husband turned up outside the Floriana health centre while Bernice was there and made a scene. A police report was filed, the Police called him for questioning on Sunday but he never showed up. On Monday, the day before she was killed, Bernice filed yet another a police report against him over defamatory comments he posted on social media. How could these comments and behaviour not have rung alarm bells in the Police officers who were following this case? It was reported that Bernice&rsquo;s lawyer was pleading with the Police to issue the arrest warrant, which never came. What is the point of a protection order if the Police are not going to swoop in swiftly and act on it?
</p><p>2. What is the Police Commissioner doing to ensure there is proper enforcement by officers?
</p><p>That the system is failing women is a fact. We have been telling women for decades not to be afraid to speak up and they have been doing just that.
</p><p>Since Tuesday&rsquo;s murder, many women have been recounting their own experiences of not getting the help they needed from the Domestic Violence Unit and Police in a timely manner. The stories are harrowing. Waiting for hours to file a report and reports not being taken seriously enough. Being told to drop the charges &ldquo;because it will make things worse&rdquo;.
</p><p>Living in perpetual fear that a violent, angry man will stalk them and eventually find them, is no way to live. Many women leave their homes but in Malta there is no way you can move and disappear like you can in larger countries.
</p><p>There is a saying that when something is repeatedly not working, you have to change what you are doing. Yet for victims and those who live in the daily dread that they will be the next statistic, it seems nothing much has changed. What are the many (many) women MPs actually doing there if they are not going to force changes to domestic violence laws so that the aggressor is locked up immediately rather than waiting for the grindingly slow judicial process to take place?
</p><p>3. Which brings us to the next question: How can one Magistrate possibly handle all the domestic violence cases in the country?
</p><p>In reply to a PQ from the Opposition it was learned that there are currently 1,429 cases pending before the Court. By the end of October this year, the domestic violence unit had registered 1,480 reports and opened 152 cases in court.&nbsp;More cases are scheduled to begin next year and more than 500 people are scheduled to be arraigned in 2024. How can you tell someone afraid for their lives, like Bernice was, that their case won&rsquo;t be heard until November of NEXT year? The case load is overwhelming, but it is only now that yet another woman has been gunned down, that the Justice Minister has informed us that more resources would be assigned to the judiciary.
</p><p>4. What is actually being done to address the anger and controlling issues which clearly exist among SOME men?
</p><p>We were told by the Police Commissioner that the DV unit receives an average of five reports daily, most of which concern psychological abuse.&nbsp;It operates around the clock with 33 police officers, five of them inspectors. This is not just a &lsquo;problem&rsquo;, but feels more like an epidemic. Yet, there is still a chasm between those who understand and have empathy for victims of domestic abuse (whether physical or psychological) and those who will keep trying to grasp at reasons why a man snaps.
</p><p>&ldquo;But maybe she provoked him?&rdquo; &ldquo;Maybe she wouldn&rsquo;t let him see the kids? &ldquo;Or maybe she was cheating on him?&rdquo; Despite all the women whose life has been snuffed out, I see little being done to bridge this chasm not only between men and women but also other women who cannot comprehend what it is to be the target of a menacing bully. If we do not address the root cause of this social malaise, we will never break through this vicious circle.
</p><p>5. And finally, the burning question many were asking on Tuesday &ndash; why did it take the Police 17 hours to enter the home of the armed murder suspect and arrest him? What were the lengthy negotiations about? The perception among the general public is that the Police were out of their depth and not trained to handle such cases. He adamantly refused to give himself up and the situation was described as dangerous and volatile but that is all we knew - no more information was forthcoming about why it took so long.
</p><p>I can understand withholding the details while the man was still in the apartment, but surely once he was in custody, we should have been given some answers? I think what the Police Commissioner fails to understand is that without proper and accurate information, the public will simply start spreading rumours, and possibly even start making things up to suit their active imagination. We need to be reassured that the Police know what they are doing in such situations, because the last thing we need is a Force which is being openly ridiculed and mocked as a murder suspect sends messages to the victim&rsquo;s grieving and traumatised family.
</p><p>The icing on this bitter cake concerns another murder victim, Chantelle Chetcuti, whose alleged killer is out on bail, awaiting trial. Photos uploaded on Justin Borg&rsquo;s Facebook page show that he was in Milan just last month to watch a Champions League football match (as soon as his photos were flagged by the media, he deleted his account). Apparently, and unbelievably, the Courts can grant someone out on bail permission to leave the country to go on holiday. Yes, even if the person is being charged with murder.
</p><p>This is a shocking, obscene punch in the gut to her family and another reason why faith and confidence in the judiciary is at an all-time low. It explains why women all over the country who want to escape the clutches of an abusive man feel abandoned by the institutions which are supposed to protect them, and are not impressed by the usual platitudes and empty political rhetoric.
</p><p>Because while murderers are continuing with their lives and running loose because of the huge backlog in our Courts, Chantelle Chetcuti, Bernice Cassar, and all the other women who have been killed at the hands of an out-of-control man, will never be able to go on holiday again.
</p><p><strong>Carers who don&rsquo;t care</strong>
</p><p>The video footage of a carer roughly manhandling an elderly man at St Vincent de Paule was sickening and horrifying to watch. All of us with elderly relatives immediately had the same thought: what if that was my parent or grandparent being treated like that?
</p><p>The carer in question along with the other carer who was in the room have both been suspended, &ldquo;for using excessive force&rdquo;. An inquiry is underway &ndash; however it should not simply be an inquiry about their behaviour but also a thorough investigation into the employment of carers at this hospital in general.
</p><p>We have a growing ageing population and the demand for carers has never been so high. But geriatric medicine is not simply a matter of plonking people into these jobs who are simply looking for work and are not properly trained for it. More importantly, if someone does not have a real vocation for working with the elderly, which requires mounds of patience, empathy and understanding, then they should be shown the door.
</p><p>Nothing can excuse the way the elderly man was forcefully shoved and pushed &ndash; after all, St Vincent de Paule is a long-time health care facility for the elderly, not a unit for dangerous prisoners. How terrible it must be to reach such a vulnerable state in one&rsquo;s life, and be at the complete mercy of people who, contrary to their title, are not &lsquo;carers&rsquo; at all.</p><p></p> </div>
</div></div><div class='mt_module' data-module-name='code' data-update-frequency='0' data-module-settings-code='PGRpdiBjbGFzcz0ic3BsaXQtYWR2ZXJ0IGRmcC1zbG90IiAKICAgICAgICAgICAgZGF0YS1wYXRoPSIvMTM0NzQ1NDUvTWFsdGFUb2RheV9bY2F0ZWdvcnldX0FydGljbGVMZWFkZXJib2FyZCIKICAgICAgICAgICAgZGF0YS1zaXplPSJbWzcyOCwgOTBdLCBbMzIwLCA1MF1dIj4KICAgICAgICA8L2Rpdj4='><div class="code_module">
<div class="split-advert dfp-slot" data-path="/13474545/MaltaToday_comment_ArticleLeaderboard" data-size="[[728, 90], [320, 50]]">
</div></div></div><div class='mt_module' data-module-name='article_author_bios' data-update-frequency='0'> <div class="article-author-bio">
<div class="bio">
<div class="row">
<div class="col-xs-1">
<div class="image">
<img src="//content.maltatoday.com.mt/ui_frontend/profile_thumbnail/40/40/josanne_cassar_1499072849_zoom.jpg" />
</div>
</div>
<div class="col-xs-11">
<div class="text">
Josanne Cassar's field is communications – and over the last 30 years she has worked in ... </div>
<div class="socialmedia">
<span class="link readmore"> <a href="/author/josanne_cassar/">More from Josanne Cassar</a></span>
<span class="link twitter"><i class="fa fa-twitter twitter"></i> <a href="http://twitter.com/josannecassar" target="_blank">Josanne on Twitter</a></span> <span class="link facebook"><i class="fa fa-facebook facebook"></i> <a href="http://www.facebook.com/profile.php?id=669525739" target="_blank">Josanne on Facebook</a></span> </div>
</div>
</div>
</div>
</div>
</div><div class='mt_module' data-module-name='comments' data-update-frequency='0'><div class="OUTBRAIN" data-widget-id="GS_5"></div>
<script type="text/javascript" async="async" src="//widgets.outbrain.com/outbrain.js"></script>
<div id="disqus_thread"></div>
<script type="text/javascript">

    var disqus_config = function () {

        
            // The generated payload which authenticates users with Disqus
            this.page.remote_auth_s3 = 'eyJpZCI6InVzZXJfIiwidXNlcm5hbWUiOiIgIiwiZW1haWwiOm51bGx9 306f6e613ad00b334eca8678d6bda3e14ff4999a 1669632222';
            this.page.api_key = 'KKsrhxY6LSXy3nbzit54YG6MHLFaxrOJ42o6hFm3W1sUtwGMqjEzqyO5HBu9sxTW';

                this.page.identifier = 'article_120046';
        this.sso = {
            name:   "MaltaToday.com.mt",
            button:  "https://www.maltatoday.com.mt/ui/images/frontend/disqus_button.png",
            icon:     "https://www.maltatoday.com.mt/ui/images/icons/Icon-Small@2x.png",
            url:      "https://www.maltatoday.com.mt/ui_frontend/login/",
            logout:  "https://www.maltatoday.com.mt/ui_frontend/disquslogout/",
            width:   "867",
            height:  "152"
        };
    };

    var disqus_shortname = 'malta-today';

    (function() {
        var dsq = document.createElement('script'); dsq.type = 'text/javascript'; dsq.async = true;
        dsq.src = '//' + disqus_shortname + '.disqus.com/embed.js';
        (document.getElementsByTagName('head')[0] || document.getElementsByTagName('body')[0]).appendChild(dsq);
    })();
</script>
</div></div> </div>
<div class="col-lg-2 col-md-2">
<div class="zone" data-zone-name="Right" data-zone-id="right"></div> </div>
</div>
<div class="row">
<div class="col-lg-12 col-md-12">
<div class="zone" data-zone-name="Bottom" data-zone-id="bottom"></div> </div>
</div>
</div>
</section></div>
<footer class="hidden-xs">
<div class="container">
<div class="row">
<div class="col-xs-12 col-sm-6">
<div class="footer-logo">
<a href="/"> <img src="/ui/images/frontend/maltatoday_logo_white.png" /></a>
</div>
</div>
<div class="col-xs-12 col-sm-6">
<div class="social-icons">
<div class="icon facebook">
<a href="//facebook.com/maltatoday" target="_blank"><i class="fa fa-facebook"></i></a>
</div>
<div class="icon twitter">
<a href="//twitter.com/maltatoday" target="_blank"><i class="fa fa-twitter"></i></a>
</div>
<div class="icon instagram">
<a href="//www.instagram.com/maltatoday" target="_blank"><i class="fa fa-instagram"></i></a>
</div>
<div class="icon youtube">
<a href="//www.youtube.com/user/ReporterMediaToday" target="_blank"><i class="fa fa-youtube"></i></a>
</div>
<div class="icon googleplus">
<a href="//plus.google.com/113527506098764625850" target="_blank"><i class="fa fa-google-plus"></i></a>
</div>
</div>
</div>
</div>
<div class="row">
<div class="col-xs-12">
<ul class="bottom-nav">
<li><a href="/about-us/">About Us</a></li>
<li><a href="/advertising/">Advertise</a> </li>
<li><a href="/contact/">Contact</a> </li>
<li><a href="/maltatodaydigitaledition/">Digital Edition</a></li>
<li><a href="/subscribe_sms/">SMS Alerts</a></li>
</ul>
<ul class="bottom-links">
<li><a href="/terms-and-conditions/">Terms and Conditions</a> </li>
<li><a href="/privacy-policy/">Privacy Policy</a> </li>
<li><a href="/privacy-policy/">Cookie Policy</a> </li>
<li><a target="_blank" href="http://archive.maltatoday.com.mt/archive.html">Archives</a></li>
</ul>
</div>
</div>
<div class="row">
<div class="col-md-12">
<div class="copyright">
MediaToday is an independent media house based in Malta. Copyright © MediaToday Co. Ltd, Vjal ir-Rihan, San Gwann SGN 9016, Malta, Europe <br />
Reproduction of material from this website without written permission is strictly prohibited.
</div>
</div>
</div>
</div>
</footer>
<div class="floating-bar" data-cookie-name="cookie_notice">
<div class="container">
<div class="message-inner">
<a href="https://www.maltatoday.com.mt/privacy-policy/" target="_blank" class="set-close">
By using this site, you agree to our Privacy Policy including the use of cookies to enhance your experience. </a>
<button class="message-close-btn set-close">
<i class="fa fa-times close"></i>
</button>
</div>
</div>
</div>
<script type="text/javascript" src="//imasdk.googleapis.com/js/sdkloader/ima3.js"></script>
<script type="text/javascript" src="/dist/js/packages.min.js?v=15.2022"></script>
<script>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</script>

<script type="text/javascript">
_atrk_opts = { atrk_acct:"io5hj1aAkN00oK", domain:"maltatoday.com.mt",dynamic: true};
(function() { var as = document.createElement('script'); as.type = 'text/javascript'; as.async = true; as.src = "https://certify-js.alexametrics.com/atrk.js"; var s = document.getElementsByTagName('script')[0];s.parentNode.insertBefore(as, s); })();
</script>
<noscript><img src="https://certify.alexametrics.com/atrk.gif?account=io5hj1aAkN00oK" style="display:none" height="1" width="1" alt="" /></noscript>

<script type="text/javascript" src="/dist/js/app.min.js?v=15.2022"></script>
<script type="text/javascript">
    var _gaq = _gaq || [];
    _gaq.push(['_setAccount', 'UA-16977049-1']);
    _gaq.push(['_trackPageview']);

    (function () {
        var ga = document.createElement('script'); ga.type =
            'text/javascript'; ga.async = true;
        ga.src = ('https:' == document.location.protocol ? 'https://ssl' :
            'http://www') + '.google-analytics.com/ga.js';
        var s = document.getElementsByTagName('script')[0];
        s.parentNode.insertBefore(ga, s);
    })();
</script>
<script id="dsq-count-scr" src="//malta-today.disqus.com/count.js" async></script>
</body>
</html>
