<!DOCTYPE html>
<html xmlns="http://www.w3.org/1999/xhtml" lang="en">
<head>
<meta http-equiv="Content-Type" content="text/html; charset=utf-8">
<meta name="viewport" content="width=device-width, initial-scale=1.0" />
<meta property="fb:pages" content="21535456940" />
<meta property="fb:app_id" content="1775326929407925" />
<link rel="shortcut icon" type="image/x-icon" href="/ui/images/icons/Icon-Small@2x.png">
<link rel="apple-touch-icon" href="/ui/images/icons/Icon-60@2x.png" />
<link rel="apple-touch-icon" sizes="58x58" href="/ui/images/icons/Icon-Small@2x.png" />
<link rel="apple-touch-icon" sizes="76x76" href="/ui/images/icons/Icon-76.png" />
<link rel="apple-touch-icon" sizes="152x152" href="/ui/images/icons/Icon-76@2x.png" />
<link rel="apple-touch-icon" sizes="180x180" href="/ui/images/icons/Icon-60@3x.png" />
<link rel="icon" sizes="192x192" href="/ui/images/icons/icon-192x192.png" />
<link rel="stylesheet" href="/dist/css/desktop.min.css?v=15.2022" />
<link rel="canonical" href="https://www.maltatoday.com.mt/news/court_and_police/118336/parish_priests_bank_deposits_raised_suspicion_when_compared_to_meagre_earnings">
<meta property="og:site_name" content="MaltaToday.com.mt" />
<meta property="og:url" content="http://www.maltatoday.com.mt/news/court_and_police/118336/parish_priests_bank_deposits_raised_suspicion_when_compared_to_meagre_earnings" />
<meta property="og:title" content="Parish priest's bank deposits raised suspicion when compared to meagre earnings" />
<meta property="og:description" content="Signatures on a number of cheques deposited to Marsaxlokk parish priest Fr Luke Seguna&amp;rsquo;s bank accounts were inconsistent, the court hears as the compilation of evidence gets underway" />
<meta property="og:type" content="article" />
<meta property="article:publisher" content="https://www.facebook.com/maltatoday" />
<meta property="og:image" content="http://cdn.maltatoday.com.mt/ui_frontend/thumbnail/684/400/2_fr_luke_seguna_on_motorcycle.jpg" />
<meta name="description" content="Signatures on a number of cheques deposited to Marsaxlokk parish priest Fr Luke Seguna&amp;rsquo;s bank accounts were inconsistent, the court hears as the compilation of evidence gets underway" />
<script type="text/javascript">
        var cdn_url = "//content.maltatoday.com.mt";
    </script>
<title>Parish priest's bank deposits raised suspicion when compared to meagre earnings</title>

<script async='async' src='https://www.googletagservices.com/tag/js/gpt.js'></script>
<script>
        var googletag = googletag || {};
        googletag.cmd = googletag.cmd || [];
    </script>

<script>
    !function(f,b,e,v,n,t,s)
    {if(f.fbq)return;n=f.fbq=function(){n.callMethod?
    n.callMethod.apply(n,arguments):n.queue.push(arguments)};
    if(!f._fbq)f._fbq=n;n.push=n;n.loaded=!0;n.version='2.0';
    n.queue=[];t=b.createElement(e);t.async=!0;
    t.src=v;s=b.getElementsByTagName(e)[0];
    s.parentNode.insertBefore(t,s)}(window, document,'script',
    'https://connect.facebook.net/en_US/fbevents.js');
    fbq('init', '213704729706889');
    fbq('track', 'PageView');
    </script>
<noscript><img height="1" width="1" style="display:none"
    src="https://www.facebook.com/tr?id=213704729706889&ev=PageView&noscript=1"
    /></noscript>

</head>
<body class="page-article">
<header>
<div class="zone" data-zone-name="TOPMOST" data-zone-id="TOPMOST"><div class='mt_module' data-module-name='code' data-update-frequency='0' data-module-settings-code='PGRpdiBjbGFzcz0idG9wLXNsYXNoIGRmcC1zbG90IiAKICAgICAgICAgICAgZGF0YS1wYXRoPSIvMTM0NzQ1NDUvTWFsdGFUb2RheV9bY2F0ZWdvcnldX0xlYWRlcmJvYXJkXzcyOHg5MCIKICAgICAgICAgICAgZGF0YS1zaXplPSJbWzcyOCwgOTBdLCBbOTcwLCA5MF0sIFs5NzAsIDI1MF0sIFszMjAsIDEwMF0sIFsxMzIwLCAyNTBdLCBbMTE1MCwgMjUwXV0iPgogICAgICAgIDwvZGl2Pg=='><div class="code_module">
<div class="top-slash dfp-slot" data-path="/13474545/MaltaToday_news_Leaderboard_728x90" data-size="[[728, 90], [970, 90], [970, 250], [320, 100], [1320, 250], [1150, 250]]">
</div></div></div></div> <div class="main-nav">
<div class="main-nav-bg">
<div class="container">
<div class="row">
<div class="col-md-12">
<div class="row">
<div class="menu-bar news">
<div class="logo col-xs-7 col-md-2">
<a href="/"><img class="img-responsive" src="/ui/images/frontend/maltatoday_logo_news.png" alt="maltatoday" /></a>
</div>
<div class="col-xs-5 visible-sm visible-xs text-right">
<div id="more-menu">
menu
<button type="button" class="navbar-toggle" aria-expanded="false">
<span class="sr-only">Toggle navigation</span>
<span class="icon-bar"></span>
<span class="icon-bar"></span>
<span class="icon-bar"></span>
</button>
</div>
</div>
<ul class="main-menu">
<li class="menu-inline-search visible-xs">
<form action="/search-mt/" method="get">
<div class="col-xs-12">
<input type="text" name="q" class="form-control" placeholder="Search maltatoday.." />
</div>
</form>
</li>
<li class="menu_item home has-sub-menu">
<a href="/">
Home </a>
<div class="menu-item-detail-box">
<ul class="sub-menu">
<li><a href="/vacancies">Jobs in Malta</a></li>
<li><a href="/yellow">Yellow</a></li>
<li><a href="/pharmacies">Pharmacies</a></li>
<li><a href="/sponsored">Sponsored</a></li>
<li><a href="/announcements">Announcements</a></li>
<li><a href="/advertising">Advertise</a></li>
<li><a href="/contact">Contact</a></li>
<li><a href="/maltatodaydigitaledition">Digital Edition</a></li>
<li><a href="/subscribe_sms">SMS Alerts</a></li>
</ul>
</div>
</li>
<li class="menu_item news active has-sub-menu">
<a href="/news">
News </a>
<div class="menu-item-detail-box">
<ul class="sub-menu">
<li><a href="/news/election-2022">Election 2022</a></li>
<li><a href="/news/national">National</a></li>
<li><a href="/covid19">Covid-19</a></li>
<li><a href="/news/ewropej">#EWROPEJ</a></li>
<li><a href="/news/court_and_police">Court &amp; Police</a></li>
<li><a href="/news/interview">Interview</a></li>
<li><a href="/news/data_and_surveys">Data &amp; Survey</a></li>
<li><a href="/news/skinny">The Skinny</a></li>
<li><a href="/news/xtra">Xtra</a></li>
<li><a href="/news/budget-2022">Budget 2022</a></li>
</ul>
<div class="detail-content-box hidden-sm hidden-xs">
<div class="sub-menu-latest-stories">
<div class="row">
<div class="col-md-6">
<div class="left-section">
<div class="top-story-container">
<div class="photo">
<a href="/news/court_and_police/118336/parish_priests_bank_deposits_raised_suspicion_when_compared_to_meagre_earnings"><img src="//content.maltatoday.com.mt/ui_frontend/thumbnail/400/220/2_fr_luke_seguna_on_motorcycle.jpg" /></a>
</div>
<div class="title">
<span class="category">Court & Police</span> <a href="/news/court_and_police/118336/parish_priests_bank_deposits_raised_suspicion_when_compared_to_meagre_earnings">
Parish priest's bank deposits raised suspicion when compared to meagre earnings</a>
</div>
</div>
</div>
</div>
<div class="col-md-6">
<div class="right-section">
<ul class="stories">
<li class="story">
<div class="story-content">
<div class="image">
<a href="/news/national/118335/pensioner_sustains_grievous_injuries_after_being_run_over_in_san_wann"><img src="//content.maltatoday.com.mt/ui_frontend/thumbnail/62/62/2_ambulance.jpg" /></a>
</div>
<div class="text">
<a href="/news/national/118335/pensioner_sustains_grievous_injuries_after_being_run_over_in_san_wann">
<span class="category">National</span>
<span class="title"> Pensioner sustains grievous injuries after being run over in San Ġwann</span>
</a>
</div>
</div>
</li>
<li class="story">
<div class="story-content">
<div class="image">
<a href="/news/national/118334/gwu_warns_employers_it_will_not_accept_changes_to_cola_mechanism"><img src="//content.maltatoday.com.mt/ui_frontend/thumbnail/62/62/money_euros_cash.jpg" /></a>
</div>
<div class="text">
<a href="/news/national/118334/gwu_warns_employers_it_will_not_accept_changes_to_cola_mechanism">
<span class="category">National</span>
<span class="title"> GWU warns employers it will not accept changes to COLA mechanism</span>
</a>
</div>
</div>
</li>
<li class="story">
<div class="story-content">
<div class="image">
<a href="/news/court_and_police/118333/rape_victim_jumped_into_the_sea_to_escape_alleged_aggressor"><img src="//content.maltatoday.com.mt/ui_frontend/thumbnail/62/62/web-rape-generic-bigstock-1552837785714.jpeg" /></a>
</div>
<div class="text">
<a href="/news/court_and_police/118333/rape_victim_jumped_into_the_sea_to_escape_alleged_aggressor">
<span class="category">Court & Police</span>
<span class="title"> Rape victim jumped into the sea to escape alleged aggressor</span>
</a>
</div>
</div>
</li>
</ul>
<a href="/news">More in News <i class="fa fa-angle-right"></i></a>
</div>
</div>
</div>
</div>
</div>
</div>
</li>
<li class="menu_item business has-sub-menu">
<a href="/business">
Business </a>
<div class="menu-item-detail-box">
<ul class="sub-menu">
<li><a href="/business/business_news">Business News</a></li>
<li><a href="/business/business_comment">Business Comment</a></li>
<li><a href="/business/tech">Tech & Gaming</a></li>
<li><a href="/business/law_report">Law Report</a></li>
<li><a href="/business/property">Property</a></li>
</ul>
<div class="detail-content-box hidden-sm hidden-xs">
<div class="sub-menu-latest-stories">
<div class="row">
<div class="col-md-6">
<div class="left-section">
<div class="top-story-container">
<div class="photo">
<a href="/business/business_news/118316/bolt_testing_new_mechanism_to_discourage_multiple_people_riding_single_scooter"><img src="//content.maltatoday.com.mt/ui_frontend/thumbnail/400/220/whatsapp_image_2022-08-12_at_12.44.37_pm.jpeg" /></a>
</div>
<div class="title">
<span class="category">Business News</span> <a href="/business/business_news/118316/bolt_testing_new_mechanism_to_discourage_multiple_people_riding_single_scooter">
Bolt testing new mechanism to discourage multiple people riding single scooter</a>
</div>
</div>
</div>
</div>
<div class="col-md-6">
<div class="right-section">
<ul class="stories">
<li class="story">
<div class="story-content">
<div class="image">
<a href="/business/law_report/118313/court_will_only_investigate_a_request_for_a_counterwarrant_on_a_prima_facie_basis"><img src="//content.maltatoday.com.mt/ui_frontend/thumbnail/62/62/2_law_report.png" /></a>
</div>
<div class="text">
<a href="/business/law_report/118313/court_will_only_investigate_a_request_for_a_counterwarrant_on_a_prima_facie_basis">
<span class="category">Law Report</span>
<span class="title"> Court will only investigate a request for a counter-warrant on a prima facie basis</span>
</a>
</div>
</div>
</li>
<li class="story">
<div class="story-content">
<div class="image">
<a href="/business/business_news/118273/fiau_fines_mobile_bank_ferratum_653000_over_2019_compliance_visit_"><img src="//content.maltatoday.com.mt/ui_frontend/thumbnail/62/62/fiau.jpeg" /></a>
</div>
<div class="text">
<a href="/business/business_news/118273/fiau_fines_mobile_bank_ferratum_653000_over_2019_compliance_visit_">
<span class="category">Business News</span>
<span class="title"> FIAU fines mobile bank Ferratum €653,000 over 2019 compliance visit</span>
</a>
</div>
</div>
</li>
<li class="story">
<div class="story-content">
<div class="image">
<a href="/business/business_news/118236/bank_of_valletta_withdraws_highbalance_fee_on_corporate_deposits"><img src="//content.maltatoday.com.mt/ui_frontend/thumbnail/62/62/4_bank_of_valletta.jpg" /></a>
</div>
<div class="text">
<a href="/business/business_news/118236/bank_of_valletta_withdraws_highbalance_fee_on_corporate_deposits">
<span class="category">Business News</span>
<span class="title"> Bank of Valletta withdraws high-balance fee on corporate deposits</span>
</a>
</div>
</div>
</li>
</ul>
<a href="/business">More in Business <i class="fa fa-angle-right"></i></a>
</div>
</div>
</div>
</div>
</div>
</div>
</li>
<li class="menu_item sports has-sub-menu">
<a href="/sports">
Sports </a>
<div class="menu-item-detail-box">
<ul class="sub-menu">
<li><a href="/worldcup2018">World Cup 2018</a></li>
<li><a href="/sports/football">Football</a></li>
<li><a href="/sports/rugby">Rugby</a></li>
<li><a href="/sports/motorsports">Motor Sports</a></li>
<li><a href="/sports/boxing">Boxing</a></li>
<li><a href="/sports/tennis">Tennis</a></li>
<li><a href="/sports/cricket">Cricket</a></li>
</ul>
<div class="detail-content-box hidden-sm hidden-xs">
<div class="sub-menu-latest-stories">
<div class="row">
<div class="col-md-6">
<div class="left-section">
<div class="top-story-container">
<div class="photo">
<a href="/sports/othersports/118294/maltese_weightlifter_tenishia_thornton_wins_three_gold_medals_at_european_junior_championships"><img src="//content.maltatoday.com.mt/ui_frontend/thumbnail/400/220/298526517_2206841809468859_187718913955837689_n.jpeg" /></a>
</div>
<div class="title">
<span class="category">Other Sports</span> <a href="/sports/othersports/118294/maltese_weightlifter_tenishia_thornton_wins_three_gold_medals_at_european_junior_championships">
Maltese weightlifter Tenishia Thornton wins three gold medals at European Junior Championships</a>
</div>
</div>
</div>
</div>
<div class="col-md-6">
<div class="right-section">
<ul class="stories">
<li class="story">
<div class="story-content">
<div class="image">
<a href="/sports/football/118274/the_english_premier_league_is_back_with_meridianbet"><img src="//content.maltatoday.com.mt/ui_frontend/thumbnail/62/62/1200_x_628_copy02.jpg" /></a>
</div>
<div class="text">
<a href="/sports/football/118274/the_english_premier_league_is_back_with_meridianbet">
<span class="category">Football</span>
<span class="title"> The English Premier League is back, with Meridianbet</span>
</a>
</div>
</div>
</li>
<li class="story">
<div class="story-content">
<div class="image">
<a href="/sports/football/118267/hamrun_spartans_make_footballing_history_after_knocking_out_levski_sofia"><img src="//content.maltatoday.com.mt/ui_frontend/thumbnail/62/62/3_hamrun.jpg" /></a>
</div>
<div class="text">
<a href="/sports/football/118267/hamrun_spartans_make_footballing_history_after_knocking_out_levski_sofia">
<span class="category">Football</span>
<span class="title"> Hamrun Spartans make footballing history after knocking out Levski Sofia</span>
</a>
</div>
</div>
</li>
<li class="story">
<div class="story-content">
<div class="image">
<a href="/sports/football/118260/joseph_muscats_first_football_move_clubs_association_rebrands_to_malta_premier_league"><img src="//content.maltatoday.com.mt/ui_frontend/thumbnail/62/62/13_1.png" /></a>
</div>
<div class="text">
<a href="/sports/football/118260/joseph_muscats_first_football_move_clubs_association_rebrands_to_malta_premier_league">
<span class="category">Football</span>
<span class="title"> Joseph Muscat's first football move: clubs' association rebrands to Malta Premier League</span>
</a>
</div>
</div>
</li>
</ul>
<a href="/sports">More in Sports <i class="fa fa-angle-right"></i></a>
</div>
</div>
</div>
</div>
</div>
</div>
</li>
<li class="menu_item arts has-sub-menu">
<a href="/arts">
Arts </a>
<div class="menu-item-detail-box">
<ul class="sub-menu">
<li><a href="/arts/art">Art</a></li>
<li><a href="/arts/books">Books</a></li>
<li><a href="/arts/entertainment">Entertainment</a></li>
<li><a href="/arts/music">Music</a></li>
<li><a href="/arts/theatre_and_dance">Theatre &amp; Dance</a></li>
<li><a href="/arts/film">Film</a></li>
<li><a href="/arts/cultural_diary">Cultural Diary</a></li>
<li><a href="/arts/kwartaktieb/">KwartaKtieb</a></li>
<li><a href="/arts/valletta_2018">Valletta 2018</a></li>
</ul>
<div class="detail-content-box hidden-sm hidden-xs">
<div class="sub-menu-latest-stories">
<div class="row">
<div class="col-md-6">
<div class="left-section">
<div class="top-story-container">
<div class="photo">
<a href="/arts/books/118302/aan_flaqwa_mien_a_caricature_of_the_muscat_era"><img src="//content.maltatoday.com.mt/ui_frontend/thumbnail/400/220/screenshot_2022-08-15_at_08.21.03.png" /></a>
</div>
<div class="title">
<span class="category">Books</span> <a href="/arts/books/118302/aan_flaqwa_mien_a_caricature_of_the_muscat_era">
Ġaħan fl-Aqwa Żmien: a caricature of the Muscat era</a>
</div>
</div>
</div>
</div>
<div class="col-md-6">
<div class="right-section">
<ul class="stories">
<li class="story">
<div class="story-content">
<div class="image">
<a href="/arts/cultural_diary/118210/my_essentials_jo_douniss_cultural_picks"><img src="//content.maltatoday.com.mt/ui_frontend/thumbnail/62/62/screenshot_2022-08-08_at_08.59.00.png" /></a>
</div>
<div class="text">
<a href="/arts/cultural_diary/118210/my_essentials_jo_douniss_cultural_picks">
<span class="category">Cultural Diary</span>
<span class="title"> My essentials: Jo Dounis’s cultural picks</span>
</a>
</div>
</div>
</li>
<li class="story">
<div class="story-content">
<div class="image">
<a href="/arts/music/118326/summerdaze_concert_sees_40000_flock_to_ta_qali"><img src="//content.maltatoday.com.mt/ui_frontend/thumbnail/62/62/summerdaze_jason_derulo.jpeg" /></a>
</div>
<div class="text">
<a href="/arts/music/118326/summerdaze_concert_sees_40000_flock_to_ta_qali">
<span class="category">Music</span>
<span class="title"> SummerDaze concert sees 40,000 flock to Ta’ Qali</span>
</a>
</div>
</div>
</li>
<li class="story">
<div class="story-content">
<div class="image">
<a href="/arts/cultural_diary/118292/the_voice_kids_now_filming_at_teatru_manoel"><img src="//content.maltatoday.com.mt/ui_frontend/thumbnail/62/62/article_covers_(32).png" /></a>
</div>
<div class="text">
<a href="/arts/cultural_diary/118292/the_voice_kids_now_filming_at_teatru_manoel">
<span class="category">Cultural Diary</span>
<span class="title"> The Voice Kids Now Filming at Teatru Manoel</span>
</a>
</div>
</div>
</li>
</ul>
<a href="/arts">More in Arts <i class="fa fa-angle-right"></i></a>
</div>
</div>
</div>
</div>
</div>
</div>
</li>
<li class="menu_item comment has-sub-menu">
<a href="/comment">
Comment </a>
<div class="menu-item-detail-box">
<ul class="sub-menu">
<li><a href="/comment/blogs">Blogs</a></li>
<li><a href="/comment/editorial">Editorial</a></li>
<li><a href="/comment/letters">Letters</a></li>
<li><a href="/comment/cartoons">Cartoons</a></li>
</ul>
<div class="detail-content-box hidden-sm hidden-xs">
<div class="sub-menu-latest-stories">
<div class="row">
<div class="col-md-6">
<div class="left-section">
<div class="top-story-container">
<div class="photo">
<a href="/comment/blogs/118304/undermining_the_rule_of_law"><img src="//content.maltatoday.com.mt/ui_frontend/thumbnail/400/220/7_robert_abela_joseph_muscat.jpg" /></a>
</div>
<div class="title">
<span class="category">Blogs</span> <a href="/comment/blogs/118304/undermining_the_rule_of_law">
Undermining the rule of law</a>
</div>
</div>
</div>
</div>
<div class="col-md-6">
<div class="right-section">
<ul class="stories">
<li class="story">
<div class="story-content">
<div class="image">
<a href="/comment/blogs/118309/a_meat_tax_is_probably_inevitable__heres_how_it_couldwork__cameron_hepburn_franziska_funke"><img src="//content.maltatoday.com.mt/ui_frontend/thumbnail/62/62/13_meat.jpg" /></a>
</div>
<div class="text">
<a href="/comment/blogs/118309/a_meat_tax_is_probably_inevitable__heres_how_it_couldwork__cameron_hepburn_franziska_funke">
<span class="category">Blogs</span>
<span class="title"> A meat tax is probably inevitable – here’s how it could work | Cameron Hepburn, Franziska Funke</span>
</a>
</div>
</div>
</li>
<li class="story">
<div class="story-content">
<div class="image">
<a href="/comment/blogs/118306/if_frank_psaila_is_a_turncoat_who_the_heck_isnt"><img src="//content.maltatoday.com.mt/ui_frontend/thumbnail/62/62/jpb_7454.jpg" /></a>
</div>
<div class="text">
<a href="/comment/blogs/118306/if_frank_psaila_is_a_turncoat_who_the_heck_isnt">
<span class="category">Blogs</span>
<span class="title"> If Frank Psaila is a ‘turncoat’… who the heck isn’t?</span>
</a>
</div>
</div>
</li>
<li class="story">
<div class="story-content">
<div class="image">
<a href="/comment/blogs/118288/there_is_hope_after_all"><img src="//content.maltatoday.com.mt/ui_frontend/thumbnail/62/62/5_saviour_pic.jpeg" /></a>
</div>
<div class="text">
<a href="/comment/blogs/118288/there_is_hope_after_all">
<span class="category">Blogs</span>
<span class="title"> There is hope after all</span>
</a>
</div>
</div>
</li>
</ul>
<a href="/comment">More in Comment <i class="fa fa-angle-right"></i></a>
</div>
</div>
</div>
</div>
</div>
</div>
</li>
<li class="menu_item videos">
<a href="/videos/">
Video </a>
</li>
<li class="menu_item archives">
<a href="http://archive.maltatoday.com.mt" target="_blank">
Archives </a>
</li>
<li class="menu_item sponsored visible-xs visible-sm">
<a href="/sponsored">
Sponsored </a>
</li>
<li class="menu_item gourmet-today has-sub-menu">
<a href="/gourmet/">
<img src="/ui/images/frontend/maltatoday_logo_gourmet.png" alt="Gourmet" />
</a>
<div class="menu-item-detail-box">
<ul class="sub-menu">
<li><a href="/gourmet/recipes/">Recipes</a></li>
<li><a href="/gourmet/restaurants/">Restaurants</a></li>
<li><a href="/gourmet/gourmet_today/">Magazines</a></li>
<li><a href="/gourmet/gourmettv/">TV</a></li>
<li><a href="/gourmet/videos/">Videos</a></li>
</ul>
</div>
</li>
<li class="menu_item deal-today visible-xs visible-sm">
<a href="/yellow">
Yellow </a>
</li>
<li class="menu_item login visible-xs visible-sm login-menu-item">
<a href="/maltatodaydigitaledition/">
Digital Paper </a>
</li>
</ul>
<div class="menu-icons hidden-xs hidden-sm">
<div class="menu-icons-icon search-icon" onclick="$(this).addClass('active').find('input').focus()">
<span class="fa fa-search"></span>
<div class="searchbox">
<form action="/search-mt/" method="get">
<input type="text" name="q" placeholder="Search" onblur="$(this).parents('.search-icon').removeClass('active');" onkeyup="if (event.keyCode === 27) { $(this).blur(); }" />
<button type="submit">
<i class="fa fa-search search_now"></i>
</button>
</form>
</div>
</div>
<div class="menu-icons-icon login-icon digital-paper">
<a href="/maltatodaydigitaledition/" class="btn btn-red">Digital Paper</a>
<div id="login-sub-menu">
<a target="_blank" href="https://maltatoday.uberflip.com/t/73329-mediatoday-newspapers-latest-editions">My Account</a>
<a href="/maltatodaydigitaledition/">Subscribe</a>
<a href="/subscribe_sms/">SMS Alerts</a>
<a href="/maltatodaydigitaledition/#previous">Previous Editions</a>
</div>
</div>
</div>
</div>
</div>
<div id="small-menu-placeholder" class="row visible-xs visible-sm news">
<div id="small-menu">
<a href="/">home</a>
<a href="/news">news</a>
<a class="highlight" href="/maltatodaydigitaledition">Digital Paper</a>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
<div class="sub-nav">
<div class="container">
<ul class="hidden-xs outer-sub-menu sub-menu news">
<li><a href="/news/election-2022">Election 2022</a></li>
<li><a href="/news/national">National</a></li>
<li><a href="/covid19">Covid-19</a></li>
<li><a href="/news/ewropej">#EWROPEJ</a></li>
<li><a href="/news/court_and_police">Court &amp; Police</a></li>
<li><a href="/news/interview">Interview</a></li>
<li><a href="/news/data_and_surveys">Data &amp; Survey</a></li>
<li><a href="/news/skinny">The Skinny</a></li>
<li><a href="/news/xtra">Xtra</a></li>
<li><a href="/news/budget-2022">Budget 2022</a></li>
</ul>
</div>
</div>
</header>
<div id="content">
<section>
<div class="container">
<div class="row">
<div class="col-lg-12 col-md-12">
<div class="zone" data-zone-name="Top" data-zone-id="top"><div class='mt_module' data-module-name='article_breadcrumb' data-update-frequency='0'><ul class="breadcrumb">
<li class="breadcrumb-item news"><a href="/news/">News</a></li>
<li class="breadcrumb-item news"><a href="/news/court_and_police/">Court & Police</a></li>
</ul></div><div class='mt_module' data-module-name='article_heading' data-update-frequency='0'><div class="article-heading">
<div class="row">
<div class="col-md-12">
<h1>Parish priest's bank deposits raised suspicion when compared to meagre earnings</h1>
<h2><p>Signatures on a number of cheques deposited to Marsaxlokk parish priest Fr Luke Seguna&rsquo;s bank accounts were inconsistent, the court hears as the compilation of evidence gets underway</p></h2>
</div>
</div>
</div>
</div></div> </div>
</div>
<div class="row">
<div class="col-lg-2 col-md-2">
<div class="zone" data-zone-name="Left" data-zone-id="left"><div class='mt_module' data-module-name='article_meta' data-update-frequency='0'><div class="article-meta">
<div class="author-photos"> <img src="//content.maltatoday.com.mt/ui_frontend/profile_thumbnail/300/300/luke_vella_1645462338.jpg" alt="luke_vella" />
</div>
<div class="date-text">
<span class="date">17 August 2022, 6:13pm</span>
<br />by <span class="name">Luke Vella </span>
</div>
</div></div><div class='mt_module' data-module-name='addthis' data-update-frequency='0'> <script type="text/javascript" src="//s7.addthis.com/js/300/addthis_widget.js#pubid=ra-5a7023510fcc04af"></script>
</div></div> </div>
<div class="col-lg-8 col-md-8">
<div class="zone" data-zone-name="Main" data-zone-id="content"><div class='mt_module' data-module-name='article_cover' data-update-frequency='0'><div class="full-article article-cover">
<div class="photo_collection_cover article-cover-media single-cover" data-slick='{"slidesToShow": 1, "slidesToScroll": 1}'>

<div class="media-item show ">
<div class="cover-photo" title="Fr Luke Seguna's personal wealth includes five motorcycles, a Land Rover and a Fiat 500 (Photo: Facebook)" style="background-image: url('//content.maltatoday.com.mt/ui/images/photos/2_fr_luke_seguna_on_motorcycle.jpg')">
<img src="//content.maltatoday.com.mt/ui_frontend/thumbnail/684/0/2_fr_luke_seguna_on_motorcycle.jpg" alt="Fr Luke Seguna's personal wealth includes five motorcycles, a Land Rover and a Fiat 500 (Photo: Facebook)" />
</div>
<div class="caption">
<div class="inner">Fr Luke Seguna's personal wealth includes five motorcycles, a Land Rover and a Fiat 500 (Photo: Facebook)</div>
</div>
</div>
</div>
</div></div><div class='mt_module' data-module-name='small_share_buttons' data-update-frequency='0'><div class="row">
<div class="col-md-6">
</div>
<div class="col-md-6">
<div class="small_share_buttons text-right">
<a class="addthis_button_facebook_like" fb:like:layout="button_count" style="position:relative; top: 4px; padding: 0px; right: -10px;"></a>
<script type="text/javascript">var addthis_config = {"data_track_addressbar":true};</script>
<script type="text/javascript" src="//s7.addthis.com/js/300/addthis_widget.js#pubid=seekopia"></script>
<a class="twitter" href="https://twitter.com/share?url=https://www.maltatoday.com.mt/news/court_and_police/118336/parish_priests_bank_deposits_raised_suspicion_when_compared_to_meagre_earnings&text=Parish priest's bank deposits raised suspicion when compared to meagre earnings" target="_blank">
<i class="fa fa-twitter"></i> TWEET
</a>
<a class="facebook" href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.maltatoday.com.mt%2Fnews%2Fcourt_and_police%2F118336%2Fparish_priests_bank_deposits_raised_suspicion_when_compared_to_meagre_earnings" target="_blank">
<i class="fa fa-facebook"></i> SHARE
</a>
</div>
</div>
</div></div><div class='mt_module' data-module-name='full_article' data-update-frequency='0'><div class="full-article">
<div class="content content-news"> <div class="dfp-slot" data-path="/13474545/MaltaToday_news_Inline_300x250" data-size="[[300, 250]]" style="float:right; margin:8px 0 8px 25px">
</div>
<p>Marsaxlokk parish priest Fr Luke Seguna had bank deposits amounting to &euro;450,000 over seven years, when his salary amounted to only &euro;75,000 over the same period.
</p><p>The information emerged in the first sitting of the compilation of evidence against Seguna, 39, accused of misappropriation of funds and money laundering.
</p><p>Seguna was charged last week and the Curia placed him on administrative leave pending the criminal investigations. Seguna&rsquo;s arraignment last week was cut short after he complained of chest pains and had to be rushed to hospital for treatment.
</p><p>Seguna remains in prison since bail was denied at the end of today&rsquo;s sitting.
</p><p>Inspector Christopher Ellul from the police&rsquo;s Financial Crimes Investigation Department testified how in March 2022 the police received intelligence that in the bank accounts of the accused, a number of transactions were not congruent with the financial status of someone holding the occupation of a parish priest.
</p><p><strong>Bikes, a Land Rover and a garage</strong>
</p><p>The inspector said that in 2016, the year he became a parish priest, the salary of Seguna amounted to &euro;16,204 and increased gradually each year until it reached &euro;20,613. According to the prosecution his salary from the Archdiocese was his sole income and he received no inheritance.
</p><p>The inspector said that on 28 December 2021, the accused purchased a garage in Paola at a value of &euro;34,000. Seguna was in possession of five motorcycles, a Land Rover and a Fiat 500. These were all acquired between 2014 and 2021.
</p><p>Seguna held 10 bank accounts in his name and as the parish priest he was the signatory of the bank account of the Marsaxlokk parish.
</p><p>During the period between 2015 and 2022, Seguna&rsquo;s bank accounts showed a total income of &euro;449,000, with the prosecution noting that his salary only amounted to &euro;75,000 before tax during the same period.
</p><p>Police established that more than &euro;200,000 in cash deposits were made to his bank accounts between 2015 and 2021.
</p><p><strong>Parish account,&nbsp;dubious cheques and dementia</strong>
</p><p>In the period between 2017 and 2020, &euro;24,000 were transferred from the Marsaxlokk parish bank account to the HSBC account belonging to Seguna in the form of cheques.
</p><p>Two cheques from a certain Joseph Attard to Seguna had inconsistent signatures and six cheques from a certain Louis Caruana to the accused amounting to &euro;15,000 were also found to have inconsistent signatures.
</p><p>In one HSBC account, Seguna received &euro;75,000 in cheques ranging from &euro;300 to &euro;5,000. Inspector Ellul said that HSBC spoke to the accused in 2020 about the deposited cheques. The accused told the bank that Caruana was a parish attendee who used to ask him for money to distribute it among various charities.
</p><p>Seguna had informed the bank that he had given &euro;10,000 to Caruana, but had then asked for the money back. The cheques from Caruana, were ostensibly, the money that the parishioner paid back.
</p><p>According to the prosecution, Caruana died in 2021 and during the period in which the cheques were issued, he was suffering from dementia, as per a declaration from the health authorities.
</p><p>Asked by the bank for the reason why the money was deposited to his personal bank account, Seguna said it was his personal money, adding that &euro;4,000 was donated to him during an event celebrating his 10-year anniversary since being ordained a priest.
</p><p><strong>Tombola, arbular and Revolut</strong>
</p><p>The prosecution said that a number of transactions were marked as tombola, masses and &lsquo;arbular&rsquo;. Ellul said that on the official Facebook page of the Marsaxlokk parish, an &lsquo;arbular&rsquo; system was in place were parishioners could donate &euro;10 per month for the needs of the parish.
</p><p>In his Revolut account, between 2019 and 2020, Seguna received donations from 47 individuals, amounting to around &euro;120 each. &ldquo;The amount was consistent with the &lsquo;arbular&rsquo; and reached a total of around &euro;6,000,&rdquo; Ellul told the court.
</p><p>Between 2016 and 2022, &euro;107,000 were withdrawn from Seguna&rsquo;s bank accounts, with &euro;52,000 being cash withdrawals and the rest being spent in restaurants and establishments.
</p> <div class="photo_collection photo_collection_size_1">
<div class="media-item  show">
<div class="photo-item" title="Fr Luke Seguna was denied bail since witnesses still need to testify (Photo: Facebook)" style="background-image: url(//content.maltatoday.com.mt/ui/images/photos/fr_luke_seguna_2.jpg)">
<img src="//content.maltatoday.com.mt/ui_frontend/thumbnail/684/0/fr_luke_seguna_2.jpg" alt="Fr Luke Seguna was denied bail since witnesses still need to testify (Photo: Facebook)" />
</div>
<div class="caption">
<div class="inner">Fr Luke Seguna was denied bail since witnesses still need to testify (Photo: Facebook)</div>
</div>
</div>
</div>
<p><strong>Marsaxlokk parish income drops</strong>
</p><p>The books of the Marsaxlokk parish showed that during the period between 2014 and 2016, the yearly income was always over &euro;90,000. Seguna became the parish priest in October 2016.
</p><p>In 2017 and 2018, the income was &euro;75,000, in 2019 it amounted to &euro;65,000, dropping further to &euro;25,000 in 2020 and &euro;37,000 in 2021.
</p><p>Ellul noted that one had to take into account the effect of the pandemic for the years 2020 and 2021.
</p><p>When interrogated, Seguna said that he made additional income through weddings and other ceremonies, and from personal donations.
</p><p>&ldquo;When asked how he distinguished between donations to the parish and personal ones, the accused said that he always asked the donators to specify,&rdquo; Elul said.
</p><p>Seguna told police that the majority of donations came from parishioners, and apart from cash he also received vouchers and clothes. He also stated that he made &ldquo;tens of thousands of euros&rdquo; from attendees of his 10-year priesthood anniversary.
</p><p><strong>Defence brands prosecution a &lsquo;disgrace&rsquo;</strong>
</p><p>The accused told police that the garage was financed through a loan scheme with the Curia, that had to be paid over six years. Seguna also stated that he took two loans in order to finance the &euro;27,000 second-hand Land Rover.
</p><p>During the deposition, defence lawyer Matthew Xuereb started shouting &lsquo;għarukaża&rsquo; (disgrace) at the prosecution. &ldquo;So, this is a case of money laundering? Are you accusing this priest of money laundering?&rdquo;
</p><p>The prosecution told Xuereb to allow them to carry on with their duties.
</p><p>Asked about the expenses that he had, Seguna told police that they were mainly related to the upkeep of his vehicles.
</p><p>According to the prosecution, Seguna refused to comment about the cheques from Louis Caruana and Joseph Attard, and about most details in relation to the deposits and transfer of funds.
</p><p>At the end of the sitting, Magistrate Natasha Galea Sciberras denied Seguna bail since witnesses were still to be summoned.
</p><p>The court was adjourned to Thursday 25 August at 9:30am.
</p><p>The defence was led by lawyers Matthew Xuereb and Jose Herrera.</p><p></p> </div>
</div></div><div class='mt_module' data-module-name='code' data-update-frequency='0' data-module-settings-code='PGRpdiBjbGFzcz0ic3BsaXQtYWR2ZXJ0IGRmcC1zbG90IiAKICAgICAgICAgICAgZGF0YS1wYXRoPSIvMTM0NzQ1NDUvTWFsdGFUb2RheV9bY2F0ZWdvcnldX0FydGljbGVMZWFkZXJib2FyZCIKICAgICAgICAgICAgZGF0YS1zaXplPSJbWzcyOCwgOTBdLCBbMzIwLCA1MF1dIj4KICAgICAgICA8L2Rpdj4='><div class="code_module">
<div class="split-advert dfp-slot" data-path="/13474545/MaltaToday_news_ArticleLeaderboard" data-size="[[728, 90], [320, 50]]">
</div></div></div><div class='mt_module' data-module-name='article_author_bios' data-update-frequency='0'> <div class="article-author-bio">
<div class="bio">
<div class="row">
<div class="col-xs-1">
<div class="image">
<img src="//content.maltatoday.com.mt/ui_frontend/profile_thumbnail/40/40/luke_vella_1645462344_zoom.jpg" />
</div>
</div>
<div class="col-xs-11">
<div class="text">
Luke Vella joined MaltaToday as a reporter in 2021 </div>
<div class="socialmedia">
<span class="link readmore"> <a href="/author/luke_vella/">More from Luke Vella</a></span>
</div>
</div>
</div>
</div>
</div>
</div><div class='mt_module' data-module-name='comments' data-update-frequency='0'><div class="OUTBRAIN" data-widget-id="GS_5"></div>
<script type="text/javascript" async="async" src="//widgets.outbrain.com/outbrain.js"></script>
<div id="disqus_thread"></div>
<script type="text/javascript">

    var disqus_config = function () {

        
            // The generated payload which authenticates users with Disqus
            this.page.remote_auth_s3 = 'eyJpZCI6InVzZXJfIiwidXNlcm5hbWUiOiIgIiwiZW1haWwiOm51bGx9 8d5876a357e08082b4b38402bf883f4928ef18f6 1660759377';
            this.page.api_key = 'KKsrhxY6LSXy3nbzit54YG6MHLFaxrOJ42o6hFm3W1sUtwGMqjEzqyO5HBu9sxTW';

                this.page.identifier = 'article_118336';
        this.sso = {
            name:   "MaltaToday.com.mt",
            button:  "https://www.maltatoday.com.mt/ui/images/frontend/disqus_button.png",
            icon:     "https://www.maltatoday.com.mt/ui/images/icons/Icon-Small@2x.png",
            url:      "https://www.maltatoday.com.mt/ui_frontend/login/",
            logout:  "https://www.maltatoday.com.mt/ui_frontend/disquslogout/",
            width:   "867",
            height:  "152"
        };
    };

    var disqus_shortname = 'malta-today';

    (function() {
        var dsq = document.createElement('script'); dsq.type = 'text/javascript'; dsq.async = true;
        dsq.src = '//' + disqus_shortname + '.disqus.com/embed.js';
        (document.getElementsByTagName('head')[0] || document.getElementsByTagName('body')[0]).appendChild(dsq);
    })();
</script>
</div></div> </div>
<div class="col-lg-2 col-md-2">
<div class="zone" data-zone-name="Right" data-zone-id="right"></div> </div>
</div>
<div class="row">
<div class="col-lg-12 col-md-12">
<div class="zone" data-zone-name="Bottom" data-zone-id="bottom"></div> </div>
</div>
</div>
</section></div>
<footer class="hidden-xs">
<div class="container">
<div class="row">
<div class="col-xs-12 col-sm-6">
<div class="footer-logo">
<a href="/"> <img src="/ui/images/frontend/maltatoday_logo_white.png" /></a>
</div>
</div>
<div class="col-xs-12 col-sm-6">
<div class="social-icons">
<div class="icon facebook">
<a href="//facebook.com/maltatoday" target="_blank"><i class="fa fa-facebook"></i></a>
</div>
<div class="icon twitter">
<a href="//twitter.com/maltatoday" target="_blank"><i class="fa fa-twitter"></i></a>
</div>
<div class="icon instagram">
<a href="//www.instagram.com/maltatoday" target="_blank"><i class="fa fa-instagram"></i></a>
</div>
<div class="icon youtube">
<a href="//www.youtube.com/user/ReporterMediaToday" target="_blank"><i class="fa fa-youtube"></i></a>
</div>
<div class="icon googleplus">
<a href="//plus.google.com/113527506098764625850" target="_blank"><i class="fa fa-google-plus"></i></a>
</div>
</div>
</div>
</div>
<div class="row">
<div class="col-xs-12">
<ul class="bottom-nav">
<li><a href="/about-us/">About Us</a></li>
<li><a href="/advertising/">Advertise</a> </li>
<li><a href="/contact/">Contact</a> </li>
<li><a href="/maltatodaydigitaledition/">Digital Edition</a></li>
<li><a href="/subscribe_sms/">SMS Alerts</a></li>
</ul>
<ul class="bottom-links">
<li><a href="/terms-and-conditions/">Terms and Conditions</a> </li>
<li><a href="/privacy-policy/">Privacy Policy</a> </li>
<li><a href="/privacy-policy/">Cookie Policy</a> </li>
<li><a target="_blank" href="http://archive.maltatoday.com.mt/archive.html">Archives</a></li>
</ul>
</div>
</div>
<div class="row">
<div class="col-md-12">
<div class="copyright">
MediaToday is an independent media house based in Malta. Copyright © MediaToday Co. Ltd, Vjal ir-Rihan, San Gwann SGN 9016, Malta, Europe <br />
Reproduction of material from this website without written permission is strictly prohibited.
</div>
</div>
</div>
</div>
</footer>
<div class="floating-bar" data-cookie-name="cookie_notice">
<div class="container">
<div class="message-inner">
<a href="https://www.maltatoday.com.mt/privacy-policy/" target="_blank" class="set-close">
By using this site, you agree to our Privacy Policy including the use of cookies to enhance your experience. </a>
<button class="message-close-btn set-close">
<i class="fa fa-times close"></i>
</button>
</div>
</div>
</div>
<script type="text/javascript" src="//imasdk.googleapis.com/js/sdkloader/ima3.js"></script>
<script type="text/javascript" src="/dist/js/packages.min.js?v=15.2022"></script>
<script>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</script>

<script type="text/javascript">
_atrk_opts = { atrk_acct:"io5hj1aAkN00oK", domain:"maltatoday.com.mt",dynamic: true};
(function() { var as = document.createElement('script'); as.type = 'text/javascript'; as.async = true; as.src = "https://certify-js.alexametrics.com/atrk.js"; var s = document.getElementsByTagName('script')[0];s.parentNode.insertBefore(as, s); })();
</script>
<noscript><img src="https://certify.alexametrics.com/atrk.gif?account=io5hj1aAkN00oK" style="display:none" height="1" width="1" alt="" /></noscript>

<script type="text/javascript" src="/dist/js/app.min.js?v=15.2022"></script>
<script type="text/javascript">
    var _gaq = _gaq || [];
    _gaq.push(['_setAccount', 'UA-16977049-1']);
    _gaq.push(['_trackPageview']);

    (function () {
        var ga = document.createElement('script'); ga.type =
            'text/javascript'; ga.async = true;
        ga.src = ('https:' == document.location.protocol ? 'https://ssl' :
            'http://www') + '.google-analytics.com/ga.js';
        var s = document.getElementsByTagName('script')[0];
        s.parentNode.insertBefore(ga, s);
    })();
</script>
<script id="dsq-count-scr" src="//malta-today.disqus.com/count.js" async></script>
</body>
</html>
