<!DOCTYPE html>
<html xmlns="http://www.w3.org/1999/xhtml" lang="en">
<head>
<meta http-equiv="Content-Type" content="text/html; charset=utf-8">
<meta name="viewport" content="width=device-width, initial-scale=1.0" />
<meta property="fb:pages" content="21535456940" />
<meta property="fb:app_id" content="1775326929407925" />
<link rel="shortcut icon" type="image/x-icon" href="/ui/images/icons/Icon-Small@2x.png">
<link rel="apple-touch-icon" href="/ui/images/icons/Icon-60@2x.png" />
<link rel="apple-touch-icon" sizes="58x58" href="/ui/images/icons/Icon-Small@2x.png" />
<link rel="apple-touch-icon" sizes="76x76" href="/ui/images/icons/Icon-76.png" />
<link rel="apple-touch-icon" sizes="152x152" href="/ui/images/icons/Icon-76@2x.png" />
<link rel="apple-touch-icon" sizes="180x180" href="/ui/images/icons/Icon-60@3x.png" />
<link rel="icon" sizes="192x192" href="/ui/images/icons/icon-192x192.png" />
<link rel="stylesheet" href="/dist/css/desktop.min.css?v=1.2021" />
<link rel="canonical" href="https://www.maltatoday.com.mt/business/business_news/108095/economic_recovery_from_covid19_slower_than_anticipated_business_survey_shows">
<meta property="og:site_name" content="MaltaToday.com.mt" />
<meta property="og:url" content="http://www.maltatoday.com.mt/business/business_news/108095/economic_recovery_from_covid19_slower_than_anticipated_business_survey_shows" />
<meta property="og:title" content="Economic recovery from COVID-19 'slower than anticipated', business survey shows" />
<meta property="og:description" content="A survey by the&amp;nbsp;Malta Employers&amp;rsquo; Association finds that job retention remains strong but economic recovery will be &amp;#39;slower than anticipated&amp;#39;" />
<meta property="og:type" content="article" />
<meta property="article:publisher" content="https://www.facebook.com/maltatoday" />
<meta property="og:image" content="http://cdn.maltatoday.com.mt/ui_frontend/thumbnail/684/400/image-from-rawpixel-id-2617356-jpeg.jpg" />
<meta name="description" content="A survey by the&amp;nbsp;Malta Employers&amp;rsquo; Association finds that job retention remains strong but economic recovery will be &amp;#39;slower than anticipated&amp;#39;" />
<script type="text/javascript">
        var cdn_url = "//content.maltatoday.com.mt";
    </script>
<title>Economic recovery from COVID-19 'slower than anticipated', business survey shows</title>

<script async='async' src='https://www.googletagservices.com/tag/js/gpt.js'></script>
<script>
        var googletag = googletag || {};
        googletag.cmd = googletag.cmd || [];
    </script>

<script>
    !function(f,b,e,v,n,t,s)
    {if(f.fbq)return;n=f.fbq=function(){n.callMethod?
    n.callMethod.apply(n,arguments):n.queue.push(arguments)};
    if(!f._fbq)f._fbq=n;n.push=n;n.loaded=!0;n.version='2.0';
    n.queue=[];t=b.createElement(e);t.async=!0;
    t.src=v;s=b.getElementsByTagName(e)[0];
    s.parentNode.insertBefore(t,s)}(window, document,'script',
    'https://connect.facebook.net/en_US/fbevents.js');
    fbq('init', '213704729706889');
    fbq('track', 'PageView');
    </script>
<noscript><img height="1" width="1" style="display:none"
    src="https://www.facebook.com/tr?id=213704729706889&ev=PageView&noscript=1"
    /></noscript>

<script type="text/javascript">
    window._taboola = window._taboola || [];
    _taboola.push({article:'auto'});
    !function (e, f, u, i) {
    if (!document.getElementById(i)){
    e.async = 1;
    e.src = u;
    e.id = i;
    f.parentNode.insertBefore(e, f);
    }
    }(document.createElement('script'),
    document.getElementsByTagName('script')[0],
    '//cdn.taboola.com/libtrc/maltatoday/loader.js',
    'tb_loader_script');
    if(window.performance && typeof window.performance.mark == 'function')
    {window.performance.mark('tbl_ic');}
</script>
</head>
<body class="page-article">
<header>
<div class="zone" data-zone-name="TOPMOST" data-zone-id="TOPMOST"><div class='mt_module' data-module-name='code' data-update-frequency='0' data-module-settings-code='PGRpdiBjbGFzcz0idG9wLXNsYXNoIGRmcC1zbG90IiAKICAgICAgICAgICAgZGF0YS1wYXRoPSIvMTM0NzQ1NDUvTWFsdGFUb2RheV9bY2F0ZWdvcnldX0xlYWRlcmJvYXJkXzcyOHg5MCIKICAgICAgICAgICAgZGF0YS1zaXplPSJbWzcyOCwgOTBdLCBbOTcwLCA5MF0sIFs5NzAsIDI1MF0sIFszMjAsIDEwMF0sIFsxMzIwLCAyNTBdLCBbMTE1MCwgMjUwXV0iPgogICAgICAgIDwvZGl2Pg=='><div class="code_module">
<div class="top-slash dfp-slot" data-path="/13474545/MaltaToday_business_Leaderboard_728x90" data-size="[[728, 90], [970, 90], [970, 250], [320, 100], [1320, 250], [1150, 250]]">
</div></div></div></div> <div class="main-nav">
<div class="main-nav-bg">
<div class="container">
<div class="row">
<div class="col-md-12">
<div class="row">
<div class="menu-bar business">
<div class="logo col-xs-7 col-md-2">
<a href="/"><img class="img-responsive" src="/ui/images/frontend/maltatoday_logo_business.png" alt="maltatoday" /></a>
</div>
<div class="col-xs-5 visible-sm visible-xs text-right">
<div id="more-menu">
menu
<button type="button" class="navbar-toggle" aria-expanded="false">
<span class="sr-only">Toggle navigation</span>
<span class="icon-bar"></span>
<span class="icon-bar"></span>
<span class="icon-bar"></span>
</button>
</div>
</div>
<ul class="main-menu">
<li class="menu-inline-search visible-xs">
<form action="/search-mt/" method="get">
<div class="col-xs-12">
<input type="text" name="q" class="form-control" placeholder="Search maltatoday.." />
</div>
</form>
</li>
<li class="menu_item home has-sub-menu">
<a href="/">
Home </a>
<div class="menu-item-detail-box">
<ul class="sub-menu">
<li><a href="/vacancies">Jobs in Malta</a></li>
<li><a href="/yellow">Yellow</a></li>
<li><a href="/pharmacies">Pharmacies</a></li>
<li><a href="/sponsored">Sponsored</a></li>
<li><a href="/announcements">Announcements</a></li>
<li><a href="/advertising">Advertise</a></li>
<li><a href="/contact">Contact</a></li>
<li><a href="/maltatodaydigitaledition">Digital Edition</a></li>
<li><a href="/subscribe_sms">SMS Alerts</a></li>
</ul>
</div>
</li>
<li class="menu_item news has-sub-menu">
<a href="/news">
News </a>
<div class="menu-item-detail-box">
<ul class="sub-menu">
<li><a href="/news/national">National</a></li>
<li><a href="/covid19">Covid-19</a></li>
<li><a href="/news/ewropej">#EWROPEJ</a></li>
<li><a href="/news/court_and_police">Court &amp; Police</a></li>
<li><a href="/news/interview">Interview</a></li>
<li><a href="/news/data_and_surveys">Data &amp; Survey</a></li>
<li><a href="/news/skinny">The Skinny</a></li>
<li><a href="/news/xtra">Xtra</a></li>
<li><a href="/news/budget-2021">Budget 2021</a></li>
</ul>
<div class="detail-content-box hidden-sm hidden-xs">
<div class="sub-menu-latest-stories">
<div class="row">
<div class="col-md-6">
<div class="left-section">
<div class="top-story-container">
<div class="photo">
<a href="/news/national/108105/chris_fearne_wont_tell_house_who_pn_mps_asking_to_jump_vaccine_queue_were"><img src="//content.maltatoday.com.mt/ui_frontend/thumbnail/400/220/4_chris_fearne.png" /></a>
</div>
<div class="title">
<span class="category">National</span> <a href="/news/national/108105/chris_fearne_wont_tell_house_who_pn_mps_asking_to_jump_vaccine_queue_were">
Chris Fearne won’t tell House who PN MPs asking to jump vaccine queue were</a>
</div>
</div>
</div>
</div>
<div class="col-md-6">
<div class="right-section">
<ul class="stories">
<li class="story">
<div class="story-content">
<div class="image">
<a href="/news/national/108103/robert_abela_threatens_jason_azzopardi_with_serious_story_in_wake_of_frameup_allegation"><img src="//content.maltatoday.com.mt/ui_frontend/thumbnail/62/62/untitled_design_(22).jpg" /></a>
</div>
<div class="text">
<a href="/news/national/108103/robert_abela_threatens_jason_azzopardi_with_serious_story_in_wake_of_frameup_allegation">
<span class="category">National</span>
<span class="title"> Robert Abela threatens Jason Azzopardi with ‘serious story’ in wake of frame-up allegation</span>
</a>
</div>
</div>
</li>
<li class="story">
<div class="story-content">
<div class="image">
<a href="/news/court_and_police/108104/adrian_delia_stipped_bare_vella_de_fremeaux_inlaws_paid_mps_120000_tax_bill"><img src="//content.maltatoday.com.mt/ui_frontend/thumbnail/62/62/adrian_delia_nickie_vella_de_fremeaux.jpg" /></a>
</div>
<div class="text">
<a href="/news/court_and_police/108104/adrian_delia_stipped_bare_vella_de_fremeaux_inlaws_paid_mps_120000_tax_bill">
<span class="category">Court & Police</span>
<span class="title"> Adrian Delia stripped bare: Vella de Fremeaux in-laws paid MP’s €120,000 tax bill</span>
</a>
</div>
</div>
</li>
<li class="story">
<div class="story-content">
<div class="image">
<a href="/news/court_and_police/108102/court_staff_threaten_industrial_action_over_covid19_vaccine_availability"><img src="//content.maltatoday.com.mt/ui_frontend/thumbnail/62/62/6_courts.jpg" /></a>
</div>
<div class="text">
<a href="/news/court_and_police/108102/court_staff_threaten_industrial_action_over_covid19_vaccine_availability">
<span class="category">Court & Police</span>
<span class="title"> Court staff threaten industrial action over COVID-19 vaccine availability</span>
</a>
</div>
</div>
</li>
</ul>
<a href="/news">More in News <i class="fa fa-angle-right"></i></a>
</div>
</div>
</div>
</div>
</div>
</div>
</li>
<li class="menu_item business active has-sub-menu">
<a href="/business">
Business </a>
 <div class="menu-item-detail-box">
<ul class="sub-menu">
<li><a href="/business/business_news">Business News</a></li>
<li><a href="/business/business_comment">Business Comment</a></li>
<li><a href="/business/technology">Technology</a></li>
<li><a href="/business/law_report">Law Report</a></li>
</ul>
<div class="detail-content-box hidden-sm hidden-xs">
<div class="sub-menu-latest-stories">
<div class="row">
<div class="col-md-6">
<div class="left-section">
<div class="top-story-container">
<div class="photo">
<a href="/business/business_comment/108093/why_rs2s_expansion_strategy_is_considered_as_a_growth_story__calamatta_cuschieri"><img src="//content.maltatoday.com.mt/ui_frontend/thumbnail/400/220/rs2-malta-office-.jpg" /></a>
</div>
<div class="title">
<span class="category">Business Comment</span> <a href="/business/business_comment/108093/why_rs2s_expansion_strategy_is_considered_as_a_growth_story__calamatta_cuschieri">
Why RS2’s expansion strategy is considered as a growth story | Calamatta Cuschieri</a>
</div>
</div>
</div>
</div>
<div class="col-md-6">
<div class="right-section">
<ul class="stories">
<li class="story">
<div class="story-content">
<div class="image">
<a href="/business/business_news/108095/economic_recovery_from_covid19_slower_than_anticipated_business_survey_shows"><img src="//content.maltatoday.com.mt/ui_frontend/thumbnail/62/62/image-from-rawpixel-id-2617356-jpeg.jpg" /></a>
</div>
<div class="text">
<a href="/business/business_news/108095/economic_recovery_from_covid19_slower_than_anticipated_business_survey_shows">
<span class="category">Business News</span>
<span class="title"> Economic recovery from COVID-19 'slower than anticipated', business survey shows</span>
</a>
</div>
</div>
</li>
<li class="story">
<div class="story-content">
<div class="image">
<a href="/business/business_news/108069/pilatus_bank_loses_eu_court_appeal_over_ecb_appeal"><img src="//content.maltatoday.com.mt/ui_frontend/thumbnail/62/62/european_court_of_justice_1.png" /></a>
</div>
<div class="text">
<a href="/business/business_news/108069/pilatus_bank_loses_eu_court_appeal_over_ecb_appeal">
<span class="category">Business News</span>
<span class="title"> Pilatus Bank loses EU Court appeal over ECB appeal</span>
</a>
</div>
</div>
</li>
<li class="story">
<div class="story-content">
<div class="image">
<a href="/business/business_comment/108082/markets_surge_higher__calamatta_cuschieri"><img src="//content.maltatoday.com.mt/ui_frontend/thumbnail/62/62/532_untitled.png" /></a>
</div>
<div class="text">
<a href="/business/business_comment/108082/markets_surge_higher__calamatta_cuschieri">
<span class="category">Business Comment</span>
<span class="title"> Markets surge higher | Calamatta Cuschieri</span>
</a>
</div>
</div>
</li>
</ul>
<a href="/business">More in Business <i class="fa fa-angle-right"></i></a>
</div>
</div>
</div>
</div>
</div>
</div>
</li>
<li class="menu_item sports has-sub-menu">
<a href="/sports">
Sports </a>
<div class="menu-item-detail-box">
<ul class="sub-menu">
<li><a href="/worldcup2018">World Cup 2018</a></li>
<li><a href="/sports/football">Football</a></li>
<li><a href="/sports/rugby">Rugby</a></li>
<li><a href="/sports/motorsports">Motor Sports</a></li>
<li><a href="/sports/boxing">Boxing</a></li>
<li><a href="/sports/tennis">Tennis</a></li>
<li><a href="/sports/cricket">Cricket</a></li>
</ul>
<div class="detail-content-box hidden-sm hidden-xs">
<div class="sub-menu-latest-stories">
<div class="row">
<div class="col-md-6">
<div class="left-section">
<div class="top-story-container">
<div class="photo">
<a href="/sports/football/107839/sliema_sponsor_offended_by_dar_talprovidenza_due_diligence"><img src="//content.maltatoday.com.mt/ui_frontend/thumbnail/400/220/jeffrey_farrugia_and_catco.jpeg" /></a>
</div>
<div class="title">
<span class="category">Football</span> <a href="/sports/football/107839/sliema_sponsor_offended_by_dar_talprovidenza_due_diligence">
Sliema sponsor ‘offended’ by Dar tal-Providenza due diligence</a>
</div>
</div>
</div>
</div>
<div class="col-md-6">
<div class="right-section">
<ul class="stories">
<li class="story">
<div class="story-content">
<div class="image">
<a href="/sports/football/107702/malta_fa_to_stop_revolving_doors_for_football_club_presidents"><img src="//content.maltatoday.com.mt/ui_frontend/thumbnail/62/62/valletta_fined.png" /></a>
</div>
<div class="text">
<a href="/sports/football/107702/malta_fa_to_stop_revolving_doors_for_football_club_presidents">
<span class="category">Football</span>
<span class="title"> Malta FA to stop revolving doors for football club presidents</span>
</a>
</div>
</div>
</li>
<li class="story">
<div class="story-content">
<div class="image">
<a href="/sports/football/107646/premier_league_nailbiter_this_weekend_as_liverpool_faces_leicester"><img src="//content.maltatoday.com.mt/ui_frontend/thumbnail/62/62/leicester-liverpool-684x455.jpg" /></a>
</div>
<div class="text">
<a href="/sports/football/107646/premier_league_nailbiter_this_weekend_as_liverpool_faces_leicester">
<span class="category">Football</span>
<span class="title"> Premier League nail-biter this weekend as Liverpool faces Leicester</span>
</a>
</div>
</div>
</li>
<li class="story">
<div class="story-content">
<div class="image">
<a href="/sports/football/107589/mfa_submits_bid_to_host_european_football_under19_championship_in_2024"><img src="//content.maltatoday.com.mt/ui_frontend/thumbnail/62/62/millennium_stand_-_exterior_2.jpeg" /></a>
</div>
<div class="text">
<a href="/sports/football/107589/mfa_submits_bid_to_host_european_football_under19_championship_in_2024">
<span class="category">Football</span>
<span class="title"> MFA submits bid to host European football Under-19 championship in 2024</span>
</a>
</div>
</div>
</li>
</ul>
<a href="/sports">More in Sports <i class="fa fa-angle-right"></i></a>
</div>
</div>
</div>
</div>
</div>
</div>
</li>
<li class="menu_item arts has-sub-menu">
<a href="/arts">
Arts </a>
<div class="menu-item-detail-box">
<ul class="sub-menu">
<li><a href="/arts/art">Art</a></li>
<li><a href="/arts/books">Books</a></li>
<li><a href="/arts/entertainment">Entertainment</a></li>
<li><a href="/arts/music">Music</a></li>
<li><a href="/arts/theatre_and_dance">Theatre &amp; Dance</a></li>
<li><a href="/arts/film">Film</a></li>
<li><a href="/arts/cultural_diary">Cultural Diary</a></li>
<li><a href="/arts/kwartaktieb/">KwartaKtieb</a></li>
<li><a href="/arts/valletta_2018">Valletta 2018</a></li>
</ul>
<div class="detail-content-box hidden-sm hidden-xs">
<div class="sub-menu-latest-stories">
<div class="row">
<div class="col-md-6">
<div class="left-section">
<div class="top-story-container">
<div class="photo">
<a href="/arts/music/108061/watch_the_new_victorians_release_maltese_debut_min_jaf_featuring_lapes"><img src="//content.maltatoday.com.mt/ui_frontend/thumbnail/400/220/screen_shot_2021-03-02_at_14.43.43.png" /></a>
</div>
<div class="title">
<span class="category">Music</span> <a href="/arts/music/108061/watch_the_new_victorians_release_maltese_debut_min_jaf_featuring_lapes">
[WATCH] The New Victorians release Maltese debut ‘Min Jaf’, featuring Lapes</a>
</div>
</div>
</div>
</div>
<div class="col-md-6">
<div class="right-section">
<ul class="stories">
<li class="story">
<div class="story-content">
<div class="image">
<a href="/arts/music/108043/the_road_less_travelled_a_profile_of_composer_alexey_shor"><img src="//content.maltatoday.com.mt/ui_frontend/thumbnail/62/62/composer_alexey_shor.jpg" /></a>
</div>
<div class="text">
<a href="/arts/music/108043/the_road_less_travelled_a_profile_of_composer_alexey_shor">
<span class="category">Music</span>
<span class="title"> The road less travelled: a profile of composer Alexey Shor</span>
</a>
</div>
</div>
</li>
<li class="story">
<div class="story-content">
<div class="image">
<a href="/arts/theatre_and_dance/107869/bulgarianmaltese_soprano_andriana_fenech_yordanova_to_perform_at_operatic_concert_in_march"><img src="//content.maltatoday.com.mt/ui_frontend/thumbnail/62/62/screen_shot_2021-02-22_at_10.33.28.png" /></a>
</div>
<div class="text">
<a href="/arts/theatre_and_dance/107869/bulgarianmaltese_soprano_andriana_fenech_yordanova_to_perform_at_operatic_concert_in_march">
<span class="category">Theatre & Dance</span>
<span class="title"> Bulgarian-Maltese soprano Andriana Fenech Yordanova to perform at operatic Concert in March</span>
</a>
</div>
</div>
</li>
<li class="story">
<div class="story-content">
<div class="image">
<a href="/arts/film/107791/german_tv_series_das_boot_films_in_malta_for_a_third_time"><img src="//content.maltatoday.com.mt/ui_frontend/thumbnail/62/62/thumbnail_das_boot_2.jpg" /></a>
</div>
<div class="text">
<a href="/arts/film/107791/german_tv_series_das_boot_films_in_malta_for_a_third_time">
<span class="category">Film</span>
<span class="title"> German TV Series ‘Das Boot’ films in Malta for a third time</span>
</a>
</div>
</div>
</li>
</ul>
<a href="/arts">More in Arts <i class="fa fa-angle-right"></i></a>
</div>
</div>
</div>
</div>
</div>
</div>
</li>
<li class="menu_item comment has-sub-menu">
<a href="/comment">
Comment </a>
<div class="menu-item-detail-box">
<ul class="sub-menu">
<li><a href="/comment/blogs">Blogs</a></li>
<li><a href="/comment/editorial">Editorial</a></li>
<li><a href="/comment/letters">Letters</a></li>
<li><a href="/comment/cartoons">Cartoons</a></li>
</ul>
<div class="detail-content-box hidden-sm hidden-xs">
<div class="sub-menu-latest-stories">
<div class="row">
<div class="col-md-6">
<div class="left-section">
<div class="top-story-container">
<div class="photo">
<a href="/comment/editorial/108070/time_to_consider_a_soft_lockdown"><img src="//content.maltatoday.com.mt/ui_frontend/thumbnail/400/220/maltatoday_editorial.png" /></a>
</div>
<div class="title">
<span class="category">Editorial</span> <a href="/comment/editorial/108070/time_to_consider_a_soft_lockdown">
Time to consider a soft lockdown</a>
</div>
</div>
</div>
</div>
<div class="col-md-6">
<div class="right-section">
<ul class="stories">
<li class="story">
<div class="story-content">
<div class="image">
<a href="/comment/blogs/108016/a_criminal_network_indicted"><img src="//content.maltatoday.com.mt/ui_frontend/thumbnail/62/62/vincemuscat.jpeg" /></a>
</div>
<div class="text">
<a href="/comment/blogs/108016/a_criminal_network_indicted">
<span class="category">Blogs</span>
<span class="title"> A criminal network indicted</span>
</a>
</div>
</div>
</li>
<li class="story">
<div class="story-content">
<div class="image">
<a href="/comment/blogs/108018/everything_neatly_wrapped_up_except_the_motive"><img src="//content.maltatoday.com.mt/ui_frontend/thumbnail/62/62/opinion_raphael_vassallo.png" /></a>
</div>
<div class="text">
<a href="/comment/blogs/108018/everything_neatly_wrapped_up_except_the_motive">
<span class="category">Blogs</span>
<span class="title"> Everything neatly wrapped up... except the motive</span>
</a>
</div>
</div>
</li>
<li class="story">
<div class="story-content">
<div class="image">
<a href="/comment/blogs/108004/the_writing_was_on_the_wall"><img src="//content.maltatoday.com.mt/ui_frontend/thumbnail/62/62/open_arms_(11).jpg" /></a>
</div>
<div class="text">
<a href="/comment/blogs/108004/the_writing_was_on_the_wall">
<span class="category">Blogs</span>
<span class="title"> The writing was on the wall</span>
</a>
</div>
</div>
</li>
</ul>
<a href="/comment">More in Comment <i class="fa fa-angle-right"></i></a>
</div>
</div>
</div>
</div>
</div>
</div>
</li>
<li class="menu_item videos">
<a href="/videos/">
Video </a>
</li>
<li class="menu_item archives">
<a href="http://archive.maltatoday.com.mt" target="_blank">
Archives </a>
</li>
<li class="menu_item sponsored visible-xs visible-sm">
<a href="/sponsored">
Sponsored </a>
</li>
<li class="menu_item gourmet-today has-sub-menu">
<a href="/gourmet/">
<img src="/ui/images/frontend/maltatoday_logo_gourmet.png" alt="Gourmet" />
</a>
<div class="menu-item-detail-box">
<ul class="sub-menu">
<li><a href="/gourmet/recipes/">Recipes</a></li>
<li><a href="/gourmet/restaurants/">Restaurants</a></li>
<li><a href="/gourmet/gourmet_today/">Magazines</a></li>
<li><a href="/gourmet/gourmettv/">TV</a></li>
<li><a href="/gourmet/videos/">Videos</a></li>
</ul>
</div>
</li>
<li class="menu_item deal-today visible-xs visible-sm">
<a href="/yellow">
Yellow </a>
</li>
<li class="menu_item login visible-xs visible-sm login-menu-item">
<a href="/maltatodaydigitaledition/">
Login to Digital Edition </a>
</li>
</ul>
<div class="menu-icons hidden-xs hidden-sm">
<div class="menu-icons-icon search-icon" onclick="$(this).addClass('active').find('input').focus()">
<span class="fa fa-search"></span>
<div class="searchbox">
<form action="/search-mt/" method="get">
<input type="text" name="q" placeholder="Search" onblur="$(this).parents('.search-icon').removeClass('active');" onkeyup="if (event.keyCode === 27) { $(this).blur(); }" />
<button type="submit">
<i class="fa fa-search search_now"></i>
</button>
</form>
</div>
</div>
<div class="menu-icons-icon login-icon">
<a href="/maltatodaydigitaledition/" class="btn btn-red">Login</a>
</div>
</div>
</div>
</div>
<div id="small-menu-placeholder" class="row visible-xs visible-sm business">
<div id="small-menu">
<a href="/">home</a>
<a href="/news">news</a>
<a class="highlight" href="/maltatodaydigitaledition">login</a>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
<div class="sub-nav">
<div class="container">
<ul class="hidden-xs outer-sub-menu sub-menu business">
<li><a href="/business/business_news">Business News</a></li>
<li><a href="/business/business_comment">Business Comment</a></li>
<li><a href="/business/technology">Technology</a></li>
<li><a href="/business/law_report">Law Report</a></li>
</ul>
</div>
</div>
</header>
<div id="content">
<section>
<div class="container">
<div class="row">
<div class="col-lg-12 col-md-12">
<div class="zone" data-zone-name="Top" data-zone-id="top"><div class='mt_module' data-module-name='article_breadcrumb' data-update-frequency='0'><ul class="breadcrumb">
<li class="breadcrumb-item business"><a href="/business/">Business</a></li>
<li class="breadcrumb-item business"><a href="/business/business_news/">Business News</a></li>
</ul></div><div class='mt_module' data-module-name='article_heading' data-update-frequency='0'><div class="article-heading">
<div class="row">
<div class="col-md-12">
<h1>Economic recovery from COVID-19 'slower than anticipated', business survey shows</h1>
<h2><p>A survey by the&nbsp;Malta Employers&rsquo; Association finds that job retention remains strong but economic recovery will be &#39;slower than anticipated&#39;</p></h2>
</div>
</div>
</div>
</div></div> </div>
</div>
<div class="row">
<div class="col-lg-2 col-md-2">
<div class="zone" data-zone-name="Left" data-zone-id="left"><div class='mt_module' data-module-name='article_meta' data-update-frequency='0'><div class="article-meta">
<div class="author-photos"> <img src="//content.maltatoday.com.mt/ui_frontend/profile_thumbnail/300/300/laura_calleja_1537350066.jpg" alt="laura_calleja" />
</div>
<div class="date-text">
<span class="date">3 March 2021, 1:56pm</span>
<br />by <span class="name">Laura Calleja </span>
</div>
</div></div><div class='mt_module' data-module-name='addthis' data-update-frequency='0'> <script type="text/javascript" src="//s7.addthis.com/js/300/addthis_widget.js#pubid=ra-5a7023510fcc04af"></script>
</div></div> </div>
<div class="col-lg-8 col-md-8">
<div class="zone" data-zone-name="Main" data-zone-id="content"><div class='mt_module' data-module-name='article_cover' data-update-frequency='0'><div class="full-article article-cover">
<div class="photo_collection_cover article-cover-media single-cover" data-slick='{"slidesToShow": 1, "slidesToScroll": 1}'>
<div class="media-item show ">
<div class="cover-photo" title="" style="background-image: url('//content.maltatoday.com.mt/ui/images/photos/image-from-rawpixel-id-2617356-jpeg.jpg')">
<img src="//content.maltatoday.com.mt/ui_frontend/thumbnail/684/0/image-from-rawpixel-id-2617356-jpeg.jpg" alt="" />
</div>
</div>
</div>
</div></div><div class='mt_module' data-module-name='small_share_buttons' data-update-frequency='0'><div class="row">
<div class="col-md-6">
</div>
<div class="col-md-6">
<div class="small_share_buttons text-right">
<a class="addthis_button_facebook_like" fb:like:layout="button_count" style="position:relative; top: 4px; padding: 0px; right: -10px;"></a>
<script type="text/javascript">var addthis_config = {"data_track_addressbar":true};</script>
<script type="text/javascript" src="//s7.addthis.com/js/300/addthis_widget.js#pubid=seekopia"></script>
<a class="twitter" href="https://twitter.com/share?url=https://www.maltatoday.com.mt/business/business_news/108095/economic_recovery_from_covid19_slower_than_anticipated_business_survey_shows&text=Economic recovery from COVID-19 'slower than anticipated', business survey shows" target="_blank">
<i class="fa fa-twitter"></i> TWEET
</a>
<a class="facebook" href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.maltatoday.com.mt%2Fbusiness%2Fbusiness_news%2F108095%2Feconomic_recovery_from_covid19_slower_than_anticipated_business_survey_shows" target="_blank">
<i class="fa fa-facebook"></i> SHARE
</a>
</div>
</div>
</div></div><div class='mt_module' data-module-name='full_article' data-update-frequency='0'><div class="full-article">
<div class="content content-business"> <div class="dfp-slot" data-path="/13474545/MaltaToday_business_Inline_300x250" data-size="[[300, 250]]" style="float:right; margin:8px 0 8px 25px">
</div>
<p>Recovery from the economic effects of the COVID-19 pandemic will be &quot;slower than anticipated&quot;, a business survey released today shows.
</p><p>The&nbsp;survey commissioned by the Malta Employers&#39; Association&nbsp;covered more than 200 companies and found that the pandemic hit some sectors more severely than others.
</p><p>&ldquo;Many operators in the tourism industry may not survive another dry season unless they are kept on life support by fiscal incentives,&rdquo; the association said.
</p><p>The MEA said job retention remained strong with 79% of companies plan to keep their labour force stable in the coming three months, while 10% said they planned to reduce their workforce and 14% said they&nbsp;might increase employment but not necessarily to pre-COVID levels.
</p><p>&ldquo;However, government fiscal package will likely have to be extended throughout 2021, creating a strain on public finances, as, besides the enhanced expenditure, it is likely that government revenues will fall short of what was projected for 2021,&rdquo; the association said.
</p><p>The MEA said that 15% of companies reported activity similar to pre-COVID levels, and a further 16% said they were expecting a recovery within eight months. 24% of respondents said that it would take up to a year to recover, and a further 45% said that recovery would take more than one year.
</p><p>32% of companies also told the association that investment projects had been postponed. The remaining 925 said that they do not foresee a reactivation of such projections in the coming six months.
</p><p><strong>Recommendations from the MEA</strong>
<ul>
<li>Strict enforcement of measures to reduce the spread of Covid &ndash; the current laissez-faire attitude is endangering jobs and lives.</li>
<li>Faster roll-out of the vaccine.</li>
<li>Persons who, without a valid reason, refuse to take the vaccine should not be entitled to quarantine leave.</li>
<li>Introduce a &lsquo;green passport&rsquo;. Employers should know who has been vaccinated or not in the interest of the welfare of all employees.</li>
<li>MEA supports measures for remote working where possible to reduce physical contact between persons at work. Work flexibility measures should be left up to open discussion between employers, individual employees and employee representatives and not legislated.</li>
<li>There should be no measures that create additional burdens to employers in such sensitive times. The public holiday measure is ill-timed and populist.</li>
<li>Despite the crisis, companies are still experiencing a shortage of labour in many areas. Identity Malta needs to expedite TCN applications. The government should address the drain of nurses in times when they are most needed.</li>
<li>Together with social partners and other stakeholders, the government needs to stimulate a constructive discussion about economic restructuring in the coming years.</li>
<li>There should be tax reliefs to reduce transportation costs and ease, introducing new barriers to trade due to BREXIT and COVID-19.</li>
<li>A less restrictive approach from banks towards provisions of loans, a deluge of controls and paperwork</li>
</ul></p><p></p> </div>
</div></div><div class='mt_module' data-module-name='code' data-update-frequency='0' data-module-settings-code='PGRpdiBjbGFzcz0ic3BsaXQtYWR2ZXJ0IGRmcC1zbG90IiAKICAgICAgICAgICAgZGF0YS1wYXRoPSIvMTM0NzQ1NDUvTWFsdGFUb2RheV9bY2F0ZWdvcnldX0FydGljbGVMZWFkZXJib2FyZCIKICAgICAgICAgICAgZGF0YS1zaXplPSJbWzcyOCwgOTBdLCBbMzIwLCA1MF1dIj4KICAgICAgICA8L2Rpdj4='><div class="code_module">
<div class="split-advert dfp-slot" data-path="/13474545/MaltaToday_business_ArticleLeaderboard" data-size="[[728, 90], [320, 50]]">
</div></div></div><div class='mt_module' data-module-name='article_author_bios' data-update-frequency='0'> <div class="article-author-bio">
<div class="bio">
<div class="row">
<div class="col-xs-1">
<div class="image">
<img src="//content.maltatoday.com.mt/ui_frontend/profile_thumbnail/40/40/laura_calleja_1537350071_zoom.jpg" />
</div>
</div>
<div class="col-xs-11">
<div class="socialmedia">
<span class="link readmore"> <a href="/author/laura_calleja/">More from Laura Calleja</a></span>
</div>
</div>
</div>
</div>
</div>
</div><div class='mt_module' data-module-name='boxed_title' data-update-frequency='0' data-module-settings-text='More in {subcategory}'> <div class="boxed-title">
<span class="title-text">
More in Business News </span>
</div>
</div><div class='mt_module' data-module-name='small_article' data-update-frequency='0' data-module-settings-amount='4' data-module-settings-show_photo='1' data-module-settings-show_author='1' data-module-settings-show_category='1' data-module-settings-show_inset_category='0' data-module-settings-show_standfirst='1'><div class="responsive-articles small-articles">
<div class="article small-article open_url business-article" data-url="/business/business_news/108095/economic_recovery_from_covid19_slower_than_anticipated_business_survey_shows">
<div class="image" style="background-image: url('//content.maltatoday.com.mt/ui_frontend/thumbnail/684/0/image-from-rawpixel-id-2617356-jpeg.jpg');">
<img src="//content.maltatoday.com.mt/ui_frontend/thumbnail/684/0/image-from-rawpixel-id-2617356-jpeg.jpg" alt="Economic recovery from COVID-19 'slower than anticipated', business survey shows" />
</div>
<div class="details" style="padding-right: 25px;">
<div class="extra-info">
<span class="category business">Business News</span>
</div>
<div class="title">
<a href="/business/business_news/108095/economic_recovery_from_covid19_slower_than_anticipated_business_survey_shows"><h3>Economic recovery from COVID-19 'slower than anticipated', business survey shows</h3></a>
</div>
<div class="extra-info">
<span class="author business">Laura Calleja </span>
</div>
</div>
</div>
<div class="article small-article open_url business-article" data-url="/business/business_news/108069/pilatus_bank_loses_eu_court_appeal_over_ecb_appeal">
<div class="image" style="background-image: url('//content.maltatoday.com.mt/ui_frontend/thumbnail/684/0/european_court_of_justice_1.png');">
<img src="//content.maltatoday.com.mt/ui_frontend/thumbnail/684/0/european_court_of_justice_1.png" alt="Pilatus Bank loses EU Court appeal over ECB appeal" />
</div>
<div class="details" style="padding-right: 25px;">
<div class="extra-info">
<span class="category business">Business News</span>
</div>
<div class="title">
<a href="/business/business_news/108069/pilatus_bank_loses_eu_court_appeal_over_ecb_appeal"><h3>Pilatus Bank loses EU Court appeal over ECB appeal</h3></a>
</div>
<div class="extra-info">
<span class="author business">Matthew Vella </span>
</div>
</div>
</div>
<div class="article small-article open_url business-article" data-url="/business/business_news/107933/covid19_wipes_off_70_million_in_revenue_for_malta_international_airport">
<div class="image" style="background-image: url('//content.maltatoday.com.mt/ui_frontend/thumbnail/684/0/malta-international-airport.jpg');">
<img src="//content.maltatoday.com.mt/ui_frontend/thumbnail/684/0/malta-international-airport.jpg" alt="COVID-19 wipes off nearly €70 million in revenue for Malta International Airport" />
</div>
<div class="details" style="padding-right: 25px;">
<div class="extra-info">
<span class="category business">Business News</span>
</div>
<div class="title">
<a href="/business/business_news/107933/covid19_wipes_off_70_million_in_revenue_for_malta_international_airport"><h3>COVID-19 wipes off nearly €70 million in revenue for Malta International Airport</h3></a>
</div>
<div class="extra-info">
<span class="author business">Matthew Vella </span>
</div>
</div>
</div>
<div class="article small-article open_url business-article" data-url="/business/business_news/107917/noneu_workers_get_sixmonth_travel_extension_for_malta_jobs">
<div class="image" style="background-image: url('//content.maltatoday.com.mt/ui_frontend/thumbnail/684/0/14_travel.jpg');">
<img src="//content.maltatoday.com.mt/ui_frontend/thumbnail/684/0/14_travel.jpg" alt="Non-EU workers get six-month travel extension for Malta jobs" />
</div>
<div class="details" style="padding-right: 25px;">
<div class="extra-info">
<span class="category business">Business News</span>
</div>
<div class="title">
<a href="/business/business_news/107917/noneu_workers_get_sixmonth_travel_extension_for_malta_jobs"><h3>Non-EU workers get six-month travel extension for Malta jobs</h3></a>
</div>
<div class="extra-info">
<span class="author business">Matthew Vella </span>
</div>
</div>
</div>
</div>
</div><div class='mt_module' data-module-name='comments' data-update-frequency='0'><div id="taboola-below-article-thumbnails"></div>
<script type="text/javascript">window._taboola = window._taboola || [];_taboola.push({mode: 'thumbnails-a',container: 'taboola-below-article-thumbnails',placement: 'Below Article Thumbnails',target_type: 'mix'});</script>
<div id="disqus_thread"></div>
<script type="text/javascript">

    var disqus_config = function () {

        
            // The generated payload which authenticates users with Disqus
            this.page.remote_auth_s3 = 'eyJpZCI6InVzZXJfIiwidXNlcm5hbWUiOiIgIiwiZW1haWwiOm51bGx9 4c47b37c859bab57e2148095dd8b000f8fa5974f 1614788252';
            this.page.api_key = 'KKsrhxY6LSXy3nbzit54YG6MHLFaxrOJ42o6hFm3W1sUtwGMqjEzqyO5HBu9sxTW';

                this.page.identifier = 'article_108095';
        this.sso = {
            name:   "MaltaToday.com.mt",
            button:  "https://www.maltatoday.com.mt/ui/images/frontend/disqus_button.png",
            icon:     "https://www.maltatoday.com.mt/ui/images/icons/Icon-Small@2x.png",
            url:      "https://www.maltatoday.com.mt/ui_frontend/login/",
            logout:  "https://www.maltatoday.com.mt/ui_frontend/disquslogout/",
            width:   "867",
            height:  "152"
        };
    };

    var disqus_shortname = 'malta-today';

    (function() {
        var dsq = document.createElement('script'); dsq.type = 'text/javascript'; dsq.async = true;
        dsq.src = '//' + disqus_shortname + '.disqus.com/embed.js';
        (document.getElementsByTagName('head')[0] || document.getElementsByTagName('body')[0]).appendChild(dsq);
    })();
</script>
<div id="taboola-below-article-thumbnails1"></div>
<script type="text/javascript">window._taboola = window._taboola || [];_taboola.push({mode: 'thumbnails-a1',container: 'taboola-below-article-thumbnails1',placement: 'Below Article Thumbnails1',target_type: 'mix'});</script></div></div> </div>
<div class="col-lg-2 col-md-2">
<div class="zone" data-zone-name="Right" data-zone-id="right"></div> </div>
</div>
<div class="row">
<div class="col-lg-12 col-md-12">
<div class="zone" data-zone-name="Bottom" data-zone-id="bottom"></div> </div>
</div>
</div>
</section></div>
<footer class="hidden-xs">
<div class="container">
<div class="row">
<div class="col-xs-12 col-sm-6">
<div class="footer-logo">
<a href="/"> <img src="/ui/images/frontend/maltatoday_logo_white.png" /></a>
</div>
</div>
<div class="col-xs-12 col-sm-6">
<div class="social-icons">
<div class="icon facebook">
<a href="//facebook.com/maltatoday" target="_blank"><i class="fa fa-facebook"></i></a>
</div>
<div class="icon twitter">
<a href="//twitter.com/maltatoday" target="_blank"><i class="fa fa-twitter"></i></a>
</div>
<div class="icon instagram">
<a href="//www.instagram.com/maltatoday" target="_blank"><i class="fa fa-instagram"></i></a>
</div>
<div class="icon youtube">
<a href="//www.youtube.com/user/ReporterMediaToday" target="_blank"><i class="fa fa-youtube"></i></a>
</div>
<div class="icon googleplus">
<a href="//plus.google.com/113527506098764625850" target="_blank"><i class="fa fa-google-plus"></i></a>
</div>
</div>
</div>
</div>
<div class="row">
<div class="col-xs-12">
<ul class="bottom-nav">
<li><a href="/about-us/">About Us</a></li>
<li><a href="/advertising/">Advertise</a> </li>
<li><a href="/contact/">Contact</a> </li>
<li><a href="/maltatodaydigitaledition/">Digital Edition</a></li>
<li><a href="/subscribe_sms/">SMS Alerts</a></li>
</ul>
<ul class="bottom-links">
<li><a href="/terms-and-conditions/">Terms and Conditions</a> </li>
<li><a href="/privacy-policy/">Privacy Policy</a> </li>
<li><a href="/privacy-policy/">Cookie Policy</a> </li>
<li><a target="_blank" href="http://archive.maltatoday.com.mt/archive.html">Archives</a></li>
</ul>
</div>
</div>
<div class="row">
<div class="col-md-12">
<div class="copyright">
MediaToday is an independent media house based in Malta. Copyright © MediaToday Co. Ltd, Vjal ir-Rihan, San Gwann SGN 9016, Malta, Europe <br />
Reproduction of material from this website without written permission is strictly prohibited.
</div>
</div>
</div>
</div>
</footer>
<div class="floating-bar" data-cookie-name="cookie_notice">
<div class="container">
<div class="message-inner">
<a href="https://www.maltatoday.com.mt/privacy-policy/" target="_blank" class="set-close">
By using this site, you agree to our Privacy Policy including the use of cookies to enhance your experience. </a>
<button class="message-close-btn set-close">
<i class="fa fa-times close"></i>
</button>
</div>
</div>
</div>
<script type="text/javascript" src="//imasdk.googleapis.com/js/sdkloader/ima3.js"></script>
<script type="text/javascript" src="/dist/js/packages.min.js?v=1.2021"></script>
<script>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</script>

<script type="text/javascript">
_atrk_opts = { atrk_acct:"io5hj1aAkN00oK", domain:"maltatoday.com.mt",dynamic: true};
(function() { var as = document.createElement('script'); as.type = 'text/javascript'; as.async = true; as.src = "https://certify-js.alexametrics.com/atrk.js"; var s = document.getElementsByTagName('script')[0];s.parentNode.insertBefore(as, s); })();
</script>
<noscript><img src="https://certify.alexametrics.com/atrk.gif?account=io5hj1aAkN00oK" style="display:none" height="1" width="1" alt="" /></noscript>

<script type="text/javascript" src="/dist/js/app.min.js?v=1.2021"></script>
<script type="text/javascript">
    var _gaq = _gaq || [];
    _gaq.push(['_setAccount', 'UA-16977049-1']);
    _gaq.push(['_trackPageview']);

    (function () {
        var ga = document.createElement('script'); ga.type =
            'text/javascript'; ga.async = true;
        ga.src = ('https:' == document.location.protocol ? 'https://ssl' :
            'http://www') + '.google-analytics.com/ga.js';
        var s = document.getElementsByTagName('script')[0];
        s.parentNode.insertBefore(ga, s);
    })();
</script>
<script id="dsq-count-scr" src="//malta-today.disqus.com/count.js" async></script>
<script type="text/javascript">
    window._taboola = window._taboola || [];
    _taboola.push({flush: true});
</script>
</body>
</html>
