<!DOCTYPE html>
<html xmlns="http://www.w3.org/1999/xhtml" lang="en">
<head>
<meta http-equiv="Content-Type" content="text/html; charset=utf-8">
<meta name="viewport" content="width=device-width, initial-scale=1.0" />
<meta property="fb:pages" content="21535456940" />
<meta property="fb:app_id" content="1775326929407925" />
<link rel="shortcut icon" type="image/x-icon" href="/ui/images/icons/Icon-Small@2x.png">
<link rel="apple-touch-icon" href="/ui/images/icons/Icon-60@2x.png" />
<link rel="apple-touch-icon" sizes="58x58" href="/ui/images/icons/Icon-Small@2x.png" />
<link rel="apple-touch-icon" sizes="76x76" href="/ui/images/icons/Icon-76.png" />
<link rel="apple-touch-icon" sizes="152x152" href="/ui/images/icons/Icon-76@2x.png" />
<link rel="apple-touch-icon" sizes="180x180" href="/ui/images/icons/Icon-60@3x.png" />
<link rel="icon" sizes="192x192" href="/ui/images/icons/icon-192x192.png" />
<link rel="stylesheet" href="/dist/css/desktop.min.css?v=1.95" />
<link rel="canonical" href="https://www.maltatoday.com.mt/news/national/103639/public_invited_to_physically_attend_pa_meetings_">
<meta property="og:site_name" content="MaltaToday.com.mt" />
<meta property="og:url" content="http://www.maltatoday.com.mt/news/national/103639/public_invited_to_physically_attend_pa_meetings_" />
<meta property="og:title" content="Public invited to physically attend PA meetings" />
<meta property="og:description" content="As part of the relaxation of&amp;nbsp;Covid 19 prevention measures, the public is being allowed to follow PA meetings in person and not just online, but will have to adhere to measures aimed at curbing the spread of the coronavirus." />
<meta property="og:type" content="article" />
<meta property="article:publisher" content="https://www.facebook.com/maltatoday" />
<meta property="og:image" content="http://cdn.maltatoday.com.mt/ui_frontend/thumbnail/684/400/7.2_planning_authority_11.jpg" />
<meta name="description" content="As part of the relaxation of&amp;nbsp;Covid 19 prevention measures, the public is being allowed to follow PA meetings in person and not just online, but will have to adhere to measures aimed at curbing the spread of the coronavirus." />
<script type="text/javascript">
        var cdn_url = "//content.maltatoday.com.mt";
    </script>
<title>Public invited to physically attend PA meetings</title>

<script async='async' src='https://www.googletagservices.com/tag/js/gpt.js'></script>
<script>
        var googletag = googletag || {};
        googletag.cmd = googletag.cmd || [];
    </script>

<script>
    !function(f,b,e,v,n,t,s)
    {if(f.fbq)return;n=f.fbq=function(){n.callMethod?
    n.callMethod.apply(n,arguments):n.queue.push(arguments)};
    if(!f._fbq)f._fbq=n;n.push=n;n.loaded=!0;n.version='2.0';
    n.queue=[];t=b.createElement(e);t.async=!0;
    t.src=v;s=b.getElementsByTagName(e)[0];
    s.parentNode.insertBefore(t,s)}(window, document,'script',
    'https://connect.facebook.net/en_US/fbevents.js');
    fbq('init', '213704729706889');
    fbq('track', 'PageView');
    </script>
<noscript><img height="1" width="1" style="display:none"
    src="https://www.facebook.com/tr?id=213704729706889&ev=PageView&noscript=1"
    /></noscript>

</head>
<body class="page-article">
<header>
<div class="zone" data-zone-name="TOPMOST" data-zone-id="TOPMOST"><div class='mt_module' data-module-name='code' data-update-frequency='0' data-module-settings-code='PGRpdiBjbGFzcz0idG9wLXNsYXNoIGRmcC1zbG90IiAKICAgICAgICAgICAgZGF0YS1wYXRoPSIvMTM0NzQ1NDUvTWFsdGFUb2RheV9bY2F0ZWdvcnldX0xlYWRlcmJvYXJkXzcyOHg5MCIKICAgICAgICAgICAgZGF0YS1zaXplPSJbWzcyOCwgOTBdLCBbOTcwLCA5MF0sIFs5NzAsIDI1MF0sIFszMjAsIDEwMF0sIFsxMzIwLCAyNTBdLCBbMTE1MCwgMjUwXV0iPgogICAgICAgIDwvZGl2Pg=='><div class="code_module">
<div class="top-slash dfp-slot" data-path="/13474545/MaltaToday_news_Leaderboard_728x90" data-size="[[728, 90], [970, 90], [970, 250], [320, 100], [1320, 250], [1150, 250]]">
</div></div></div></div> <div class="main-nav">
<div class="main-nav-bg">
<div class="container">
<div class="row">
<div class="col-md-12">
<div class="row">
<div class="menu-bar news">
<div class="logo col-xs-7 col-md-2">
<a href="/"><img class="img-responsive" src="/ui/images/frontend/maltatoday_logo_news.png" alt="maltatoday" /></a>
</div>
<div class="col-xs-5 visible-sm visible-xs text-right">
<div id="more-menu">
menu
<button type="button" class="navbar-toggle" aria-expanded="false">
<span class="sr-only">Toggle navigation</span>
<span class="icon-bar"></span>
<span class="icon-bar"></span>
<span class="icon-bar"></span>
</button>
</div>
</div>
<ul class="main-menu">
<li class="menu-inline-search visible-xs">
<form action="/search-mt/" method="get">
<div class="col-xs-12">
<input type="text" name="q" class="form-control" placeholder="Search maltatoday.." />
</div>
</form>
</li>
<li class="menu_item home has-sub-menu">
<a href="/">
Home </a>
<div class="menu-item-detail-box">
<ul class="sub-menu">
<li><a href="http://frontpages.maltatoday.com.mt/">Today's Newspapers</a></li>
<li><a href="/vacancies">Jobs in Malta</a></li>
<li><a href="/yellow">Yellow</a></li>
<li><a href="/pharmacies">Pharmacies</a></li>
<li><a href="/sponsored">Sponsored</a></li>
<li><a href="/announcements">Announcements</a></li>
<li><a href="/advertising">Advertise</a></li>
<li><a href="/contact">Contact</a></li>
<li><a href="/maltatodaydigitaledition">Digital Edition</a></li>
<li><a href="/subscribe_sms">SMS Alerts</a></li>
</ul>
</div>
</li>
<li class="menu_item news active has-sub-menu">
<a href="/news">
News </a>
<div class="menu-item-detail-box">
<ul class="sub-menu">
<li><a href="/news/national">National</a></li>
<li><a href="/news/europe">Europe</a></li>
<li><a href="/news/world">World</a></li>
<li><a href="/news/court_and_police">Court &amp; Police</a></li>
<li><a href="/news/interview">Interview</a></li>
<li><a href="/news/data_and_surveys">Data &amp; Survey</a></li>
<li><a href="/news/skinny">The Skinny</a></li>
<li><a href="/news/xtra">Xtra</a></li>
<li><a href="/news/budget-2020">Budget 2020</a></li>
</ul>
<div class="detail-content-box hidden-sm hidden-xs">
<div class="sub-menu-latest-stories">
<div class="row">
<div class="col-md-6">
<div class="left-section">
<div class="top-story-container">
<div class="photo">
<a href="/news/national/103640/imported_coronavirus_case_brings_8_day_lull_to_an_end"><img src="//content.maltatoday.com.mt/ui_frontend/thumbnail/400/220/maltatoday_survey_coronavirus_may_2020.png" /></a>
</div>
<div class="title">
<span class="category">National</span> <a href="/news/national/103640/imported_coronavirus_case_brings_8_day_lull_to_an_end">
Imported coronavirus case brings 8 day lull to an end</a>
</div>
</div>
</div>
</div>
<div class="col-md-6">
<div class="right-section">
<ul class="stories">
<li class="story">
<div class="story-content">
<div class="image">
<a href="/news/national/103639/public_invited_to_physically_attend_pa_meetings_"><img src="//content.maltatoday.com.mt/ui_frontend/thumbnail/62/62/7.2_planning_authority_11.jpg" /></a>
</div>
<div class="text">
<a href="/news/national/103639/public_invited_to_physically_attend_pa_meetings_">
<span class="category">National</span>
<span class="title"> Public invited to physically attend PA meetings</span>
</a>
</div>
</div>
</li>
<li class="story">
<div class="story-content">
<div class="image">
<a href="/news/europe/103635/eu_discussions_on_covid19_recovery_package_continue"><img src="//content.maltatoday.com.mt/ui_frontend/thumbnail/62/62/abela_and_eu_leaders.jpg" /></a>
</div>
<div class="text">
<a href="/news/europe/103635/eu_discussions_on_covid19_recovery_package_continue">
<span class="category">Europe</span>
<span class="title"> Tough slog for EU leaders to agree on multi billion euro recovery package</span>
</a>
</div>
</div>
</li>
<li class="story">
<div class="story-content">
<div class="image">
<a href="/news/national/103634/muscats_21000_dubai_weekend_during_crisis_paid_by_third_parties"><img src="//content.maltatoday.com.mt/ui_frontend/thumbnail/62/62/2_jm_dubai.jpg" /></a>
</div>
<div class="text">
<a href="/news/national/103634/muscats_21000_dubai_weekend_during_crisis_paid_by_third_parties">
<span class="category">National</span>
<span class="title"> Muscat’s €21,000 Dubai weekend during crisis paid by third parties</span>
</a>
</div>
</div>
</li>
</ul>
<a href="/news">More in News <i class="fa fa-angle-right"></i></a>
</div>
</div>
</div>
</div>
</div>
</div>
</li>
<li class="menu_item business has-sub-menu">
<a href="/business">
Business </a>
<div class="menu-item-detail-box">
<ul class="sub-menu">
<li><a href="/business/business_news">Business News</a></li>
<li><a href="/business/business_comment">Business Comment</a></li>
<li><a href="/business/technology">Technology</a></li>
<li><a href="/business/law_report">Law Report</a></li>
</ul>
<div class="detail-content-box hidden-sm hidden-xs">
<div class="sub-menu-latest-stories">
<div class="row">
<div class="col-md-6">
<div class="left-section">
<div class="top-story-container">
<div class="photo">
<a href="/business/business_comment/103625/markets_drop_on_mixed_data__calamatta_cuschieri"><img src="//content.maltatoday.com.mt/ui_frontend/thumbnail/400/220/477_untitled.png" /></a>
</div>
<div class="title">
<span class="category">Business Comment</span> <a href="/business/business_comment/103625/markets_drop_on_mixed_data__calamatta_cuschieri">
Markets drop on mixed data | Calamatta Cuschieri</a>
</div>
</div>
</div>
</div>
<div class="col-md-6">
<div class="right-section">
<ul class="stories">
<li class="story">
<div class="story-content">
<div class="image">
<a href="/business/business_news/103622/home_insurance_policy_not_having_it_could_mean_losing_everything"><img src="//content.maltatoday.com.mt/ui_frontend/thumbnail/62/62/thumbnail_mfsa_-__house1.jpg" /></a>
</div>
<div class="text">
<a href="/business/business_news/103622/home_insurance_policy_not_having_it_could_mean_losing_everything">
<span class="category">Business News</span>
<span class="title"> Home insurance policy: not having it could mean losing everything</span>
</a>
</div>
</div>
</li>
<li class="story">
<div class="story-content">
<div class="image">
<a href="/business/law_report/103548/cruelty_in_marriage_has_its_consequences"><img src="//content.maltatoday.com.mt/ui_frontend/thumbnail/62/62/2_law_report.png" /></a>
</div>
<div class="text">
<a href="/business/law_report/103548/cruelty_in_marriage_has_its_consequences">
<span class="category">Law Report</span>
<span class="title"> Cruelty in marriage has its consequences</span>
</a>
</div>
</div>
</li>
<li class="story">
<div class="story-content">
<div class="image">
<a href="/business/business_comment/103611/markets_climb_on_vaccine_hopes__calamatta_cuschieri"><img src="//content.maltatoday.com.mt/ui_frontend/thumbnail/62/62/476_untitled.png" /></a>
</div>
<div class="text">
<a href="/business/business_comment/103611/markets_climb_on_vaccine_hopes__calamatta_cuschieri">
<span class="category">Business Comment</span>
<span class="title"> Markets climb on vaccine hopes | Calamatta Cuschieri</span>
</a>
</div>
</div>
</li>
</ul>
<a href="/business">More in Business <i class="fa fa-angle-right"></i></a>
</div>
</div>
</div>
</div>
</div>
</div>
</li>
<li class="menu_item sports has-sub-menu">
<a href="/sports">
Sports </a>
<div class="menu-item-detail-box">
<ul class="sub-menu">
<li><a href="/worldcup2018">World Cup 2018</a></li>
<li><a href="/sports/football">Football</a></li>
<li><a href="/sports/rugby">Rugby</a></li>
<li><a href="/sports/motorsports">Motor Sports</a></li>
<li><a href="/sports/boxing">Boxing</a></li>
<li><a href="/sports/tennis">Tennis</a></li>
<li><a href="/sports/cricket">Cricket</a></li>
</ul>
<div class="detail-content-box hidden-sm hidden-xs">
<div class="sub-menu-latest-stories">
<div class="row">
<div class="col-md-6">
<div class="left-section">
<div class="top-story-container">
<div class="photo">
<a href="/sports/football/103603/2022_world_cup_schedule_announced_by_fifa_"><img src="//content.maltatoday.com.mt/ui_frontend/thumbnail/400/220/qatar-world-cup-2022.jpg" /></a>
</div>
<div class="title">
<span class="category">Football</span> <a href="/sports/football/103603/2022_world_cup_schedule_announced_by_fifa_">
2022 World Cup schedule announced by FIFA</a>
</div>
</div>
</div>
</div>
<div class="col-md-6">
<div class="right-section">
<ul class="stories">
<li class="story">
<div class="story-content">
<div class="image">
<a href="/sports/olympics/103576/maltese_deaf_athletes_national_record_went_unrecognised_for_16_years"><img src="//content.maltatoday.com.mt/ui_frontend/thumbnail/62/62/george_vella_deaflympian_running.jpg" /></a>
</div>
<div class="text">
<a href="/sports/olympics/103576/maltese_deaf_athletes_national_record_went_unrecognised_for_16_years">
<span class="category">Olympics</span>
<span class="title"> Maltese deaf athlete’s national record went unrecognised for 16 years</span>
</a>
</div>
</div>
</li>
<li class="story">
<div class="story-content">
<div class="image">
<a href="/sports/othersports/103352/watch_72_million_football_and_rugby_kordin_project_approved_"><img src="//content.maltatoday.com.mt/ui_frontend/thumbnail/62/62/thumbnail_pr201265a.jpg" /></a>
</div>
<div class="text">
<a href="/sports/othersports/103352/watch_72_million_football_and_rugby_kordin_project_approved_">
<span class="category">Other Sports</span>
<span class="title"> [WATCH] €7.2 million football and rugby Kordin project approved</span>
</a>
</div>
</div>
</li>
<li class="story">
<div class="story-content">
<div class="image">
<a href="/sports/othersports/103220/watch_malta_failed_miserably_in_teaching_young_people_importance_of_sport__delia"><img src="//content.maltatoday.com.mt/ui_frontend/thumbnail/62/62/sport.jpg" /></a>
</div>
<div class="text">
<a href="/sports/othersports/103220/watch_malta_failed_miserably_in_teaching_young_people_importance_of_sport__delia">
<span class="category">Other Sports</span>
<span class="title"> [WATCH] Malta 'failed miserably' in teaching young people importance of sport - Delia</span>
</a>
</div>
</div>
</li>
</ul>
<a href="/sports">More in Sports <i class="fa fa-angle-right"></i></a>
</div>
</div>
</div>
</div>
</div>
</div>
</li>
<li class="menu_item arts has-sub-menu">
<a href="/arts">
Arts </a>
<div class="menu-item-detail-box">
<ul class="sub-menu">
<li><a href="/arts/art">Art</a></li>
<li><a href="/arts/books">Books</a></li>
<li><a href="/arts/entertainment">Entertainment</a></li>
<li><a href="/arts/music">Music</a></li>
<li><a href="/arts/theatre_and_dance">Theatre &amp; Dance</a></li>
<li><a href="/arts/film">Film</a></li>
<li><a href="/arts/cultural_diary">Cultural Diary</a></li>
<li><a href="/arts/kwartaktieb/">KwartaKtieb</a></li>
<li><a href="/arts/valletta_2018">Valletta 2018</a></li>
</ul>
<div class="detail-content-box hidden-sm hidden-xs">
<div class="sub-menu-latest-stories">
<div class="row">
<div class="col-md-6">
<div class="left-section">
<div class="top-story-container">
<div class="photo">
<a href="/arts/theatre_and_dance/103547/giving_farce_the_respect_it_deserves_chris_gatt"><img src="//content.maltatoday.com.mt/ui_frontend/thumbnail/400/220/tw_front_comedy_of_errors_main_pix_2.jpg" /></a>
</div>
<div class="title">
<span class="category">Theatre & Dance</span> <a href="/arts/theatre_and_dance/103547/giving_farce_the_respect_it_deserves_chris_gatt">
Giving farce the respect it deserves | Chris Gatt</a>
</div>
</div>
</div>
</div>
<div class="col-md-6">
<div class="right-section">
<ul class="stories">
<li class="story">
<div class="story-content">
<div class="image">
<a href="/arts/art/103602/what_would_liz_say_artist_sends_buckingham_palace_postcard_on_queen_vic_statue"><img src="//content.maltatoday.com.mt/ui_frontend/thumbnail/62/62/keit_bonnici_postcard_queen_elizabeth_2.jpg" /></a>
</div>
<div class="text">
<a href="/arts/art/103602/what_would_liz_say_artist_sends_buckingham_palace_postcard_on_queen_vic_statue">
<span class="category">Art</span>
<span class="title"> What would Liz say? Artist sends Buckingham Palace postcard on Queen Vic statue</span>
</a>
</div>
</div>
</li>
<li class="story">
<div class="story-content">
<div class="image">
<a href="/arts/cultural_diary/103556/watch_virtual_museum_to_showcase_maltese_history_in_realtime"><img src="//content.maltatoday.com.mt/ui_frontend/thumbnail/62/62/dsc08784.jpg" /></a>
</div>
<div class="text">
<a href="/arts/cultural_diary/103556/watch_virtual_museum_to_showcase_maltese_history_in_realtime">
<span class="category">Cultural Diary</span>
<span class="title"> [WATCH] Virtual museum to showcase Maltese history in real-time</span>
</a>
</div>
</div>
</li>
<li class="story">
<div class="story-content">
<div class="image">
<a href="/comment/blogs/103397/the_road_to_recovery_for_the_arts_in_malta_toni_attard"><img src="//content.maltatoday.com.mt/ui_frontend/thumbnail/62/62/10-11_op_toni_attard_main.jpg" /></a>
</div>
<div class="text">
<a href="/comment/blogs/103397/the_road_to_recovery_for_the_arts_in_malta_toni_attard">
<span class="category">Theatre & Dance</span>
<span class="title"> The road to recovery for the arts in Malta | Toni Attard</span>
</a>
</div>
</div>
</li>
</ul>
<a href="/arts">More in Arts <i class="fa fa-angle-right"></i></a>
</div>
</div>
</div>
</div>
</div>
</div>
</li>
<li class="menu_item comment has-sub-menu">
<a href="/comment">
Comment </a>
<div class="menu-item-detail-box">
<ul class="sub-menu">
<li><a href="/comment/blogs">Blogs</a></li>
<li><a href="/comment/editorial">Editorial</a></li>
<li><a href="/comment/letters">Letters</a></li>
<li><a href="/comment/cartoons">Cartoons</a></li>
</ul>
<div class="detail-content-box hidden-sm hidden-xs">
<div class="sub-menu-latest-stories">
<div class="row">
<div class="col-md-6">
<div class="left-section">
<div class="top-story-container">
<div class="photo">
<a href="/comment/blogs/103587/when_you_point_your_finger_cos_your_plan_fell_through"><img src="//content.maltatoday.com.mt/ui_frontend/thumbnail/400/220/opinion_raphael_vassallo.png" /></a>
</div>
<div class="title">
<span class="category">Blogs</span> <a href="/comment/blogs/103587/when_you_point_your_finger_cos_your_plan_fell_through">
‘When you point your finger cos your plan fell through...’</a>
</div>
</div>
</div>
</div>
<div class="col-md-6">
<div class="right-section">
<ul class="stories">
<li class="story">
<div class="story-content">
<div class="image">
<a href="/comment/blogs/103607/adrian_delia_has_to_make_way_for_a_new_pn_leader"><img src="//content.maltatoday.com.mt/ui_frontend/thumbnail/62/62/3_opinion_saviour_balzan.png" /></a>
</div>
<div class="text">
<a href="/comment/blogs/103607/adrian_delia_has_to_make_way_for_a_new_pn_leader">
<span class="category">Blogs</span>
<span class="title"> [WATCH] Adrian Delia has to make way for a new PN leader</span>
</a>
</div>
</div>
</li>
<li class="story">
<div class="story-content">
<div class="image">
<a href="/comment/editorial/103584/a_verdict_that_doesnt_resolve_the_impasse"><img src="//content.maltatoday.com.mt/ui_frontend/thumbnail/62/62/maltatoday_editorial.png" /></a>
</div>
<div class="text">
<a href="/comment/editorial/103584/a_verdict_that_doesnt_resolve_the_impasse">
<span class="category">Editorial</span>
<span class="title"> A verdict that doesn’t resolve the impasse</span>
</a>
</div>
</div>
</li>
<li class="story">
<div class="story-content">
<div class="image">
<a href="/comment/blogs/103545/so_much_for_the_postdelia_plan"><img src="//content.maltatoday.com.mt/ui_frontend/thumbnail/62/62/10-11_op_raphael.jpg" /></a>
</div>
<div class="text">
<a href="/comment/blogs/103545/so_much_for_the_postdelia_plan">
<span class="category">Blogs</span>
<span class="title"> So much for the ‘post-Delia plan’...</span>
</a>
</div>
</div>
</li>
</ul>
<a href="/comment">More in Comment <i class="fa fa-angle-right"></i></a>
</div>
</div>
</div>
</div>
</div>
</div>
</li>
<li class="menu_item videos">
<a href="/videos/">
Video </a>
</li>
<li class="menu_item archives">
<a href="http://archive.maltatoday.com.mt" target="_blank">
Archives </a>
</li>
<li class="menu_item sponsored visible-xs visible-sm">
<a href="/sponsored">
Sponsored </a>
</li>
<li class="menu_item gourmet-today has-sub-menu">
<a href="/gourmet/">
<img src="/ui/images/frontend/maltatoday_logo_gourmet.png" alt="Gourmet" />
</a>
<div class="menu-item-detail-box">
<ul class="sub-menu">
<li><a href="/gourmet/recipes/">Recipes</a></li>
<li><a href="/gourmet/restaurants/">Restaurants</a></li>
<li><a href="/gourmet/gourmet_today/">Magazines</a></li>
<li><a href="/gourmet/gourmettv/">TV</a></li>
<li><a href="/gourmet/videos/">Videos</a></li>
</ul>
</div>
</li>
<li class="menu_item frontpages visible-xs">
<a href="http://frontpages.maltatoday.com.mt">
Frontpages </a>
</li>
<li class="menu_item deal-today visible-xs visible-sm">
<a href="/yellow">
Yellow </a>
</li>
<li class="menu_item login visible-xs visible-sm login-menu-item">
<a href="/maltatodaydigitaledition/">
Login to Digital Edition </a>
</li>
</ul>
<div class="menu-icons hidden-xs hidden-sm">
<div class="menu-icons-icon search-icon" onclick="$(this).addClass('active').find('input').focus()">
<span class="fa fa-search"></span>
<div class="searchbox">
<form action="/search-mt/" method="get">
<input type="text" name="q" placeholder="Search" onblur="$(this).parents('.search-icon').removeClass('active');" onkeyup="if (event.keyCode === 27) { $(this).blur(); }" />
<button type="submit">
<i class="fa fa-search search_now"></i>
</button>
</form>
</div>
</div>
<div class="menu-icons-icon login-icon">
<a href="/maltatodaydigitaledition/" class="btn btn-red">Login</a>
</div>
</div>
</div>
</div>
<div id="small-menu-placeholder" class="row visible-xs visible-sm news">
<div id="small-menu">
<a href="/">home</a>
<a href="/news">news</a>
<a class="highlight" href="/maltatodaydigitaledition">login</a>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
<div class="sub-nav">
<div class="container">
<ul class="hidden-xs outer-sub-menu sub-menu news">
<li><a href="/news/national">National</a></li>
<li><a href="/news/europe">Europe</a></li>
<li><a href="/news/world">World</a></li>
<li><a href="/news/court_and_police">Court &amp; Police</a></li>
<li><a href="/news/interview">Interview</a></li>
<li><a href="/news/data_and_surveys">Data &amp; Survey</a></li>
<li><a href="/news/skinny">The Skinny</a></li>
<li><a href="/news/xtra">Xtra</a></li>
<li><a href="/news/budget-2020">Budget 2020</a></li>
</ul>
</div>
</div>
</header>
<div id="content">
<section>
<div class="container">
<div class="row">
<div class="col-lg-12 col-md-12">
<div class="zone" data-zone-name="Top" data-zone-id="top"><div class='mt_module' data-module-name='article_breadcrumb' data-update-frequency='0'><ul class="breadcrumb">
<li class="breadcrumb-item news"><a href="/news/">News</a></li>
<li class="breadcrumb-item news"><a href="/news/national/">National</a></li>
</ul></div><div class='mt_module' data-module-name='article_heading' data-update-frequency='0'><div class="article-heading">
<div class="row">
<div class="col-md-12">
<h1>Public invited to physically attend PA meetings</h1>
<h2><p>As part of the relaxation of&nbsp;Covid 19 prevention measures, the public is being allowed to follow PA meetings in person and not just online, but will have to adhere to measures aimed at curbing the spread of the coronavirus.</p></h2>
</div>
</div>
</div>
</div></div> </div>
</div>
<div class="row">
<div class="col-lg-2 col-md-2">
<div class="zone" data-zone-name="Left" data-zone-id="left"><div class='mt_module' data-module-name='article_meta' data-update-frequency='0'><div class="article-meta">
<div class="author-photos"> <img src="//content.maltatoday.com.mt/ui_frontend/profile_thumbnail/300/300/matthew_agius_1519462042.jpg" alt="matthew_agius" />
</div>
<div class="date-text">
<span class="date">18 July 2020, 12:04pm</span>
<br />by <span class="name">Matthew Agius </span>
</div>
</div></div><div class='mt_module' data-module-name='addthis' data-update-frequency='0'> <script type="text/javascript" src="//s7.addthis.com/js/300/addthis_widget.js#pubid=ra-5a7023510fcc04af"></script>
</div></div> </div>
<div class="col-lg-8 col-md-8">
<div class="zone" data-zone-name="Main" data-zone-id="content"><div class='mt_module' data-module-name='article_cover' data-update-frequency='0'><div class="full-article article-cover">
<div class="photo_collection_cover article-cover-media single-cover" data-slick='{"slidesToShow": 1, "slidesToScroll": 1}'>
<div class="media-item show ">
<div class="cover-photo" title="The Planning Authority building" style="background-image: url('//content.maltatoday.com.mt/ui/images/photos/7.2_planning_authority_11.jpg')">
<img src="//content.maltatoday.com.mt/ui_frontend/thumbnail/684/0/7.2_planning_authority_11.jpg" alt="The Planning Authority building" />
 </div>
<div class="caption">
<div class="inner">The Planning Authority building</div>
</div>
</div>
</div>
</div></div><div class='mt_module' data-module-name='small_share_buttons' data-update-frequency='0'><div class="row">
<div class="col-md-6">
</div>
<div class="col-md-6">
<div class="small_share_buttons text-right">
<a class="addthis_button_facebook_like" fb:like:layout="button_count" style="position:relative; top: 4px; padding: 0px; right: -10px;"></a>
<script type="text/javascript">var addthis_config = {"data_track_addressbar":true};</script>
<script type="text/javascript" src="//s7.addthis.com/js/300/addthis_widget.js#pubid=seekopia"></script>
<a class="twitter" href="https://twitter.com/share?url=https://www.maltatoday.com.mt/news/national/103639/public_invited_to_physically_attend_pa_meetings_&text=Public invited to physically attend PA meetings" target="_blank">
<i class="fa fa-twitter"></i> TWEET
</a>
<a class="facebook" href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.maltatoday.com.mt%2Fnews%2Fnational%2F103639%2Fpublic_invited_to_physically_attend_pa_meetings_" target="_blank">
<i class="fa fa-facebook"></i> SHARE
</a>
</div>
</div>
</div></div><div class='mt_module' data-module-name='full_article' data-update-frequency='0'><div class="full-article">
<div class="content content-news"> <div class="dfp-slot" data-path="/13474545/MaltaToday_news_Inline_300x250" data-size="[[300, 250]]" style="float:right; margin:8px 0 8px 25px">
</div>
<p>The Planning Authority has announced that representees and the public may attend the Planning Commission&rsquo;s Meeting in Public next Wednesday, 4 months after moving to online-only meetings because of the Covid-19 pandemic.
</p><p>Back in March, the PA had introduced &ldquo;Webmeeting&rdquo; an online meeting platform through which it would conduct its public meetings.<br />
In a statement issued this morning, the PA confirmed that in the correspondence sent to all representees and objectors informing them that the Planning Commission will be discussing and deciding planning application PA04037/19 &ndash; about a controversial building project in St. Julians village core - it specifically mentioned that &ldquo;if interested parties were unable to join the Webmeeting, they were invited to attend the meeting physically at the Planning Boardroom, St. Francis Ravelin, Floriana.&rdquo;
</p><p>Any member of the public who chooses to physically attend the public meeting &quot;will have to adhere to COVID measures&quot;, the statement said.
</p><p>The Planning Commission, which decides ODZ and UCA applications, is currently carrying out trial hybrid board hearings, where proceedings are still conducted through video conferencing but still allowing for the public and interested parties to physically attend hearings, since the Commission is conducting its sittings at the Planning Authority&rsquo;s board room.
</p><p>The PA said it had received positive feedback from stakeholders who frequently participate in Planning Board or Commission through online facilities.</p><p></p> </div>
</div></div><div class='mt_module' data-module-name='code' data-update-frequency='0' data-module-settings-code='PGRpdiBjbGFzcz0ic3BsaXQtYWR2ZXJ0IGRmcC1zbG90IiAKICAgICAgICAgICAgZGF0YS1wYXRoPSIvMTM0NzQ1NDUvTWFsdGFUb2RheV9bY2F0ZWdvcnldX0FydGljbGVMZWFkZXJib2FyZCIKICAgICAgICAgICAgZGF0YS1zaXplPSJbWzcyOCwgOTBdLCBbMzIwLCA1MF1dIj4KICAgICAgICA8L2Rpdj4='><div class="code_module">
<div class="split-advert dfp-slot" data-path="/13474545/MaltaToday_news_ArticleLeaderboard" data-size="[[728, 90], [320, 50]]">
</div></div></div><div class='mt_module' data-module-name='article_author_bios' data-update-frequency='0'> <div class="article-author-bio">
<div class="bio">
<div class="row">
<div class="col-xs-1">
<div class="image">
<img src="//content.maltatoday.com.mt/ui_frontend/profile_thumbnail/40/40/matthew_agius_1517918791_zoom.jpg" />
</div>
</div>
<div class="col-xs-11">
<div class="text">
Matthew Agius is a court reporter as well as a Legal Procurator and Commissioner for Oaths... </div>
<div class="socialmedia">
<span class="link readmore"> <a href="/author/matthew_agius/">More from Matthew Agius</a></span>
<span class="link twitter"><i class="fa fa-twitter twitter"></i> <a href="https://twitter.com/mattagius" target="_blank">Matthew on Twitter</a></span> </div>
</div>
</div>
</div>
</div>
</div><div class='mt_module' data-module-name='boxed_title' data-update-frequency='0' data-module-settings-text='More in {subcategory}'> <div class="boxed-title">
<span class="title-text">
More in National </span>
</div>
</div><div class='mt_module' data-module-name='small_article' data-update-frequency='0' data-module-settings-amount='4' data-module-settings-show_photo='1' data-module-settings-show_author='1' data-module-settings-show_category='1' data-module-settings-show_inset_category='0' data-module-settings-show_standfirst='1'><div class="responsive-articles small-articles">
<div class="article small-article open_url news-article" data-url="/news/national/103640/imported_coronavirus_case_brings_8_day_lull_to_an_end">
<div class="image" style="background-image: url('//content.maltatoday.com.mt/ui_frontend/thumbnail/684/0/maltatoday_survey_coronavirus_may_2020.png');">
<img src="//content.maltatoday.com.mt/ui_frontend/thumbnail/684/0/maltatoday_survey_coronavirus_may_2020.png" alt="Imported coronavirus case brings 8 day lull to an end" />
</div>
<div class="details" style="padding-right: 25px;">
<div class="extra-info">
<span class="category news">National</span>
</div>
<div class="title">
<a href="/news/national/103640/imported_coronavirus_case_brings_8_day_lull_to_an_end"><h3>Imported coronavirus case brings 8 day lull to an end</h3></a>
</div>
<div class="extra-info">
<span class="author news">Matthew Agius </span>
</div>
</div>
</div>
<div class="article small-article open_url news-article" data-url="/news/national/103639/public_invited_to_physically_attend_pa_meetings_">
<div class="image" style="background-image: url('//content.maltatoday.com.mt/ui_frontend/thumbnail/684/0/7.2_planning_authority_11.jpg');">
<img src="//content.maltatoday.com.mt/ui_frontend/thumbnail/684/0/7.2_planning_authority_11.jpg" alt="Public invited to physically attend PA meetings" />
</div>
<div class="details" style="padding-right: 25px;">
<div class="extra-info">
<span class="category news">National</span>
</div>
<div class="title">
<a href="/news/national/103639/public_invited_to_physically_attend_pa_meetings_"><h3>Public invited to physically attend PA meetings</h3></a>
</div>
<div class="extra-info">
<span class="author news">Matthew Agius </span>
</div>
</div>
</div>
<div class="article small-article open_url news-article" data-url="/news/national/103634/muscats_21000_dubai_weekend_during_crisis_paid_by_third_parties">
<div class="image" style="background-image: url('//content.maltatoday.com.mt/ui_frontend/thumbnail/684/0/2_jm_dubai.jpg');">
<img src="//content.maltatoday.com.mt/ui_frontend/thumbnail/684/0/2_jm_dubai.jpg" alt="Muscat’s €21,000 Dubai weekend during crisis paid by third parties" />
</div>
<div class="details" style="padding-right: 25px;">
<div class="extra-info">
<span class="category news">National</span>
</div>
<div class="title">
<a href="/news/national/103634/muscats_21000_dubai_weekend_during_crisis_paid_by_third_parties"><h3>Muscat’s €21,000 Dubai weekend during crisis paid by third parties</h3></a>
</div>
<div class="extra-info">
<span class="author news">Karl Azzopardi </span>
</div>
</div>
</div>
<div class="article small-article open_url news-article" data-url="/news/national/103630/group_of_63_rescued_migrants_to_be_brought_to_malta">
<div class="image" style="background-image: url('//content.maltatoday.com.mt/ui_frontend/thumbnail/684/0/eddkibjwsaakud1.jpeg');">
<img src="//content.maltatoday.com.mt/ui_frontend/thumbnail/684/0/eddkibjwsaakud1.jpeg" alt="Group of 63 rescued migrants to be brought to Malta" />
</div>
<div class="details" style="padding-right: 25px;">
<div class="extra-info">
<span class="category news">National</span>
</div>
<div class="title">
<a href="/news/national/103630/group_of_63_rescued_migrants_to_be_brought_to_malta"><h3>Group of 63 rescued migrants to be brought to Malta</h3></a>
</div>
<div class="extra-info">
<span class="author news">Karl Azzopardi </span>
</div>
</div>
</div>
</div>
</div><div class='mt_module' data-module-name='comments' data-update-frequency='0'><div id="disqus_thread"></div>
<script type="text/javascript">

    var disqus_config = function () {

        
            // The generated payload which authenticates users with Disqus
            this.page.remote_auth_s3 = 'eyJpZCI6InVzZXJfIiwidXNlcm5hbWUiOiIgIiwiZW1haWwiOm51bGx9 9f7fbf0c8eb2c1039314c172de1e2810520a076a 1595076032';
            this.page.api_key = 'KKsrhxY6LSXy3nbzit54YG6MHLFaxrOJ42o6hFm3W1sUtwGMqjEzqyO5HBu9sxTW';

                this.page.identifier = 'article_103639';
        this.sso = {
            name:   "MaltaToday.com.mt",
            button:  "https://www.maltatoday.com.mt/ui/images/frontend/disqus_button.png",
            icon:     "https://www.maltatoday.com.mt/ui/images/icons/Icon-Small@2x.png",
            url:      "https://www.maltatoday.com.mt/ui_frontend/login/",
            logout:  "https://www.maltatoday.com.mt/ui_frontend/disquslogout/",
            width:   "867",
            height:  "152"
        };
    };

    var disqus_shortname = 'malta-today';

    (function() {
        var dsq = document.createElement('script'); dsq.type = 'text/javascript'; dsq.async = true;
        dsq.src = '//' + disqus_shortname + '.disqus.com/embed.js';
        (document.getElementsByTagName('head')[0] || document.getElementsByTagName('body')[0]).appendChild(dsq);
    })();
</script>
</div></div> </div>
<div class="col-lg-2 col-md-2">
<div class="zone" data-zone-name="Right" data-zone-id="right"></div> </div>
</div>
<div class="row">
<div class="col-lg-12 col-md-12">
<div class="zone" data-zone-name="Bottom" data-zone-id="bottom"></div> </div>
</div>
</div>
</section></div>
<footer class="hidden-xs">
<div class="container">
<div class="row">
<div class="col-xs-12 col-sm-6">
<div class="footer-logo">
<a href="/"> <img src="/ui/images/frontend/maltatoday_logo_white.png" /></a>
</div>
</div>
<div class="col-xs-12 col-sm-6">
<div class="social-icons">
<div class="icon facebook">
<a href="//facebook.com/maltatoday" target="_blank"><i class="fa fa-facebook"></i></a>
</div>
<div class="icon twitter">
<a href="//twitter.com/maltatoday" target="_blank"><i class="fa fa-twitter"></i></a>
</div>
<div class="icon instagram">
<a href="//www.instagram.com/maltatoday" target="_blank"><i class="fa fa-instagram"></i></a>
</div>
<div class="icon youtube">
<a href="//www.youtube.com/user/ReporterMediaToday" target="_blank"><i class="fa fa-youtube"></i></a>
</div>
<div class="icon googleplus">
<a href="//plus.google.com/113527506098764625850" target="_blank"><i class="fa fa-google-plus"></i></a>
</div>
</div>
</div>
</div>
<div class="row">
<div class="col-xs-12">
<ul class="bottom-nav">
<li><a href="/about-us/">About Us</a></li>
<li><a href="/advertising/">Advertise</a> </li>
<li><a href="/contact/">Contact</a> </li>
<li><a href="/maltatodaydigitaledition/">Digital Edition</a></li>
<li><a href="http://frontpages.maltatoday.com.mt/">Today's Newspapers</a></li>
<li><a href="/subscribe_sms/">SMS Alerts</a></li>
</ul>
<ul class="bottom-links">
<li><a href="/terms-and-conditions/">Terms and Conditions</a> </li>
<li><a href="/privacy-policy/">Privacy Policy</a> </li>
<li><a href="/privacy-policy/">Cookie Policy</a> </li>
<li><a target="_blank" href="http://archive.maltatoday.com.mt/archive.html">Archives</a></li>
</ul>
</div>
</div>
<div class="row">
<div class="col-md-12">
<div class="copyright">
MediaToday is an independent media house based in Malta. Copyright © MediaToday Co. Ltd, Vjal ir-Rihan, San Gwann SGN 9016, Malta, Europe <br />
Reproduction of material from this website without written permission is strictly prohibited.
</div>
</div>
</div>
</div>
</footer>
<div class="floating-bar" data-cookie-name="cookie_notice">
<div class="container">
<div class="message-inner">
<a href="https://www.maltatoday.com.mt/privacy-policy/" target="_blank" class="set-close">
By using this site, you agree to our Privacy Policy including the use of cookies to enhance your experience. </a>
<button class="message-close-btn set-close">
<i class="fa fa-times close"></i>
</button>
</div>
</div>
</div>
<script type="text/javascript" src="//imasdk.googleapis.com/js/sdkloader/ima3.js"></script>
<script type="text/javascript" src="/dist/js/packages.min.js?v=1.95"></script>
<script>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</script>

<script type="text/javascript">
_atrk_opts = { atrk_acct:"io5hj1aAkN00oK", domain:"maltatoday.com.mt",dynamic: true};
(function() { var as = document.createElement('script'); as.type = 'text/javascript'; as.async = true; as.src = "https://certify-js.alexametrics.com/atrk.js"; var s = document.getElementsByTagName('script')[0];s.parentNode.insertBefore(as, s); })();
</script>
<noscript><img src="https://certify.alexametrics.com/atrk.gif?account=io5hj1aAkN00oK" style="display:none" height="1" width="1" alt="" /></noscript>

<script type="text/javascript" src="/dist/js/app.min.js?v=1.95"></script>
<script type="text/javascript">
    var _gaq = _gaq || [];
    _gaq.push(['_setAccount', 'UA-16977049-1']);
    _gaq.push(['_trackPageview']);

    (function () {
        var ga = document.createElement('script'); ga.type =
            'text/javascript'; ga.async = true;
        ga.src = ('https:' == document.location.protocol ? 'https://ssl' :
            'http://www') + '.google-analytics.com/ga.js';
        var s = document.getElementsByTagName('script')[0];
        s.parentNode.insertBefore(ga, s);
    })();
</script>
<script id="dsq-count-scr" src="//malta-today.disqus.com/count.js" async></script>
</body>
</html>
